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Ansoft Maxwell Fundamentals
What is Maxwell?
Maxwell is a high-performance interactive software package that uses finite
element analysis (FEA) to solve three-dimensional (3D) electric, magnetostatic,
eddy current, and transient problems.
Electric 3D fields:
Electrostatic 3D fields in dielectrics caused by a user-specified distribution
of voltages and charges. Additional computed quantities you can specify
include torque, force, and capacitances.
Electric 3D fields in conductors, characterized by a spatial distribution of
voltage, electric field, and DC current density. The main additional quantity
in this case is power loss.
A combination of the first two with conduction solutions being used as
boundary conditions for an electrostatic problem.
Magnetostatic:
Magnetostatic:
Linear and nonlinear 3D magnetostatic fields caused by a user-specified
distribution of DC current density, voltage, permanent magnets, or
externally applied magnetic fields. Additional computed quantities you can
specify include torque, force, and inductances (self and mutual).
Eddy current:
Harmonic (sinusoidal variation in time) steady state 3D magnetic fields with
pulsation-induced eddy currents in massive (solid) conductors caused by
one of the following: by a user-specified distribution of AC currents (all with
the same frequency but with possibly different initial phase angles), or by
externally applied magnetic fields. The eddy solution is a full wave solution
that includes electromagnetic wave radiation effects.
Transient:
Time domain 3D magnetic fields caused by permanent magnets and
windings supplied by voltage and/or current sources with arbitrary variation
as functions of time; electrical circuits will be connected with the windings.
Rotational or translational motion effects can also be included in the
simulation.
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Installing the Ansoft Maxwell Software
System Requirements (Windows)
Supported Platforms:
Windows 2000 Professional
Windows XP Professional
Windows XP Professional x64 Edition
Windows Server 2003
3232-Bit System Requirements
Minimum System Requirements:
Processor: All fully compatible 686 (or later) instruction set
processors, 500 MHz
Hard Drive Space (for Maxwell software): 200 MB
RAM: 512 MB
Recommended Minimum Configuration (for Optimal Performance):
Processor: All fully compatible 786 (or later) instruction set
processors, 1 GHz
Hard Drive Space (for Maxwell software and temporary files): 500 MB
RAM: 2 GB
6464-bit System Requirements
Minimum System Requirements:
Supported processors: AMD Athlon 64, AMD Opteron, Intel Xeon with
Intel EM64T support, Intel Pentium 4 with Intel EM64T support
Hard Drive Space (for Maxwell software): 200 MB
RAM: 2 MB
Recommended Minimum Configuration (for Optimal Performance):
Supported processors: AMD Athlon 64, AMD Opteron, Intel Xeon with
Intel EM64T support, Intel Pentium 4 with Intel EM64T support Video
card: 128-bit SVGA or PCI Express video card
Hard Drive Space (for Maxwell software and temporary files): 700 MB
RAM: 8 GBPentium –based computer
512 MB RAM minimum
8MB Video Card minimum
Mouse or other pointing device
CD-ROM drive
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Installing the Ansoft Maxwell Software
System Requirements (Sun Solaris)
Supported Platforms:
Solaris 8
Solaris 9
Minimum System Requirements:
Processor: UltraSparc v9 processor, 450 MHz
Hard Drive Space (for Maxwell software): 550 MB
RAM: 1 GB
Recommended Minimum Configuration:
Processor: UltraSparc v9 dual processor or better, 900 MHz
Hard Drive Space (for Maxwell software and temporary files): 800 MB
RAM: 4 GB
Note: You must install Sun OpenGL libraries before installing and running
Maxwell. This is available for free download at the following location:
http://wwws.sun.com/software/graphics/opengl/download.html
Note: Some older graphics cards may have minor display issues (such as check
marks or a “t” appearing in a report title).
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Installing the Ansoft Maxwell Software
System Requirements (Red Hat Enterprise Linux v3)
3232-Bit System Requirements
Minimum System Requirements:
Processor: All fully compatible 686 (or later) instruction set
processors, 500 MHz
Hard Drive Space (for Maxwell software): 200 MB
RAM: 512 MB
Recommended Minimum Configuration (for Optimal Performance):
Processor: All fully compatible 786 (or later) instruction set
processors, 2GHz
Hard Drive Space (for Maxwell software and temporary files): 700 MB
RAM: 2 GB
6464-bit System Requirements
Minimum System Requirements:
Supported processors: AMD Athlon 64, AMD Opteron, Intel Xeon with
Intel EM64T support, Intel Pentium 4 with Intel EM64T support
Hard Drive Space (for Maxwell software): 200 MB
RAM: 2 MB
Recommended Minimum Configuration (for Optimal Performance):
Supported processors: AMD Athlon 64, AMD Opteron, Intel Xeon with
Intel EM64T support, Intel Pentium 4 with Intel EM64T support Video
card: 128-bit SVGA or PCI Express video card
Hard Drive Space (for Maxwell software and temporary files): 700 MB
RAM: 8 GB

Ansoft Maxwell 3D Field Simulator v11 User’s Guide

6

Installing the Ansoft Maxwell Software

Installing the Ansoft Maxwell Software
For up-to-date information, refer to the Maxwell Installation Guide

Starting Ansoft Maxwell
1.

2.

Click the Microsoft Start button, select Programs,
Programs and select the Ansoft, Maxwell
11 program group. Click Maxwell 11.
11
Or Double click on the Maxwell 11 icon on the Windows Desktop
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Converting Older Files
Converting Older Maxwell file to Maxwell v11
NOTE:
NOTE You should make backup copies of all Maxwell projects created with
a previous version of the software before opening them in Maxwell v11.
Because of changes to the Maxwell files with the development of Maxwell v11,
opening a Maxwell document from an earlier release may take more time than
you are used to experiencing. However, once the file has been opened and
saved, subsequent opening time will return to normal
Ansoft Maxwell v11 provides a way for you to automatically convert your Maxwell
projects from an earlier version to the Maxwell v11 format.
To access Maxwell projects in an earlier version.
From Maxwell v11,
v11
1. Select the menu item File > Open
2. Open dialog
1. Files of Type: Ansoft Legacy EM Projects (.cls
(.cls)
cls)
2. Browse to the existing project and select the .cls file
3. Click the Open button
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Getting Help
Getting Help
If you have any questions while you are using Ansoft Maxwell you can find
answers in several ways:
Ansoft Maxwell Online Help provides assistance while you are working.
To get help about a specific, active dialog box, click the Help button
in the dialog box or press the F1 key.
Select the menu item Help > Contents to access the online help
system.
Tooltips
Tooltip are available to provide information about tools on the
toolbars or dialog boxes. When you hold the pointer over a tool for a
brief time, a tooltip appears to display the name of the tool.
As you move the pointer over a tool or click a menu item, the Status
Bar at the bottom of the Ansoft Maxwell window provides a brief
description of the function of the tool or menu item.
The Ansoft Maxwell Getting Started guide provides detailed
information about using Maxwell to create and solve 3D EM projects.
Ansoft Technical Support
To contact Ansoft technical support staff in your geographical area,
please log on to the Ansoft corporate website, www.ansoft.com and
select Contact.
Contact
Your Ansoft sales engineer may also be contacted in order to
obtain this information.

Visiting the Ansoft Web Site
If your computer is connected to the Internet, you can visit the Ansoft Web site to
learn more about the Ansoft company and products.
From the Ansoft Desktop
Select the menu item Help > Ansoft Corporate Website to access
the Online Technical Support (OTS) system.
From your Internet browser
Visit www.ansoft.com
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Getting Help
For Technical Support
The following link will direct you to the Ansoft Support Page. The Ansoft Support
Pages provide additional documentation, training, and application notes.
Web Site: http://www.ansoft.com/support.cfm
Technical Support:
9-4 EST:
Pittsburgh, PA
(412) 261-3200 x0 – Ask for Technical Support
Burlington, MA
(781) 229-8900 x0 – Ask for Technical Support
9-4 PST:
San Jose, CA
(408) 261-9095 x0 – Ask for Technical Support
Portland, OR
(503) 906-7944 or (503) 906-7947
El Segundo, CA
(310) 426-2287 – Ask for Technical Support
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WebUpdate
WebUpdate
This new feature allows you to update any existing Ansoft software from the
WebUpdate window. This feature automatically scans your system to find any
Ansoft software, and then allows you to download any updates if they are
available.
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Ansoft Terms
Ansoft Terms
The Ansoft Maxwell window has several optional panels:
A Project Manager which contains a design tree which lists the structure of
the project.
A Message Manager that allows you to view any errors or warnings that
occur before you begin a simulation.
A Property Window that displays and allows you to change model
parameters or attributes.
A Progress Window that displays solution progress.
A 3D Modeler Window which contains the model and model tree for the
active design. For more information about the3D Modeler Window, see
chapter 1.
Menu
bar
Toolbars

3D Modeler
Window
Project
Manager
with project
tree

Progress
Window

Message
Manager

Status
bar
Coordinate Entry Fields
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Ansoft Terms
Project Manager

Project Manager Window

Project
Design

Design Setup

Design Automation
•Parametric
•Optimization
•Sensitivity
•Statistical
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Ansoft Terms
Property Window
Property Window

Property
buttons

Property
table

Property tabs
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Ansoft Terms
Ansoft 3D Modeler
3D Modeler Window

Graphics
area

Model

3D Modeler
design tree

Context menu

Edge

Vertex

Coordinate System (CS)
Plane
Origin

Face
Model
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Ansoft Terms
3D Modeler Design Tree
Material
Object

Object Command History

Grouped by Material

Object View
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Design Windows
Design Windows
In the Ansoft Maxwell Desktop, each project can have multiple designs and each
design is displayed in a separate window.
You can have multiple projects and design windows open at the same time.
Also, you can have multiple views of the same design visible at the same time.
To arrange the windows, you can drag them by the title bar, and resize them by
dragging a corner or border. Also, you can select one of the following menu
options: Window >Cascade, Window >Tile Vertically, or Window > Tile

Horizontally.
To organize your Ansoft Maxwell window, you can iconize open designs. Click
the Iconize ** symbol in the upper right corner of the document border. An icon
appears in the lower part of the Ansoft Maxwell window. If the icon is not visible,
it may be behind another open document. Resize any open documents as
necessary. Select the menu item Window > Arrange Icons to arrange them at
the bottom of the Ansoft Maxwell window.
Select the menu item Window > Close All to close all open design. You are
prompted to Save unsaved designs.

Iconize
Symbol

Design icons
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Toolbars
Toolbars
The toolbar buttons are shortcuts for frequently used commands. Most of the
available toolbars are displayed in this illustration of the Ansoft Maxwell initial
screen, but your Ansoft Maxwell window probably will not be arranged this way.
You can customize your toolbar display in a way that is convenient for you.
Some toolbars are always displayed; other toolbars display automatically when
you select a document of the related type. For example, when you select a 2D
report from the project tree, the 2D report toolbar displays.

To display or hide individual toolbars:
Right-click the Ansoft Maxwell window frame.
A list of all the toolbars is displayed. The toolbars with a check mark
beside them are visible; the toolbars without a check mark are hidden.
Click the toolbar name to turn its display on or off
To make changes to the toolbars, select the menu item Tools > Customize. See
Customize and Arrange Toolbars on the
Ansoft
next page.
Maxwell
panels

Toolbars

Ansoft Maxwell 3D Field Simulator v11 User’s Guide

18

Toolbars
Customize and Arrange Toolbars
To customize toolbars:
Select the menu item Tools > Customize, or right-click the Ansoft Maxwell
window frame and click Customize at the bottom of the toolbar list.
In the Customize dialog, you can do the following:
View a Description of the toolbar commands
1. Select an item from the Component pull-down list
2. Select an item from the Category list
3. Using the mouse click on the Buttons to display the
Description
4. Click the Close button when you are finished
Toggle the visibility of toolbars
1. From the Toolbar list, toggle the check boxes to control the
visibility of the toolbars
2. Click the Close button when you are finished
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Overview
Ansoft Maxwell Desktop
The complex functionality built into the Maxwell 3D solvers is accessed through
the main user interface (called the desktop). With the version 11 interface and
later, you can model the problem in a fairly arbitrary order (rather than following
the steps in a precise order as was required in previous versions of Maxwell).
This flexibility allows experienced users to develop a modeling style that suits
their preferences. Once the model is created, the automated Maxwell solution
sequence takes over and fully controls the solution process without any
interaction from the user. When the solution becomes available, the user can
perform a variety of post-processing tasks as required by the design application.

Modeling Process
For users new to electromagnetic field simulation, Ansoft recommends the
following sequence of modeling steps:
1. Based on your application, choose the type of electromagnetic analysis
to be performed.
2. Draw the geometry of the model using the drawing space provided by
the 3D Modeler menu and Draw menu commands available through the
Maxwell desktop interface.
3. Assign the material properties to all solid objects in the model, and
define new material properties if materials in the default library do not
provide the needed material.
Note:
Note Always make sure the material properties assigned to an object correspond
to the real properties of the materials in the electromagnetic device that is being
simulated. Material properties supplied in the default library are generic properties
and may not always be substituted for actual properties.

4. Specify the field sources (excitations) and boundary conditions for your
unique solution.
5. Define additional global parameters that you want to calculate (such as
force, torque, inductance/capacitance, etc.).
6. Define mesh operations for special applications (such as seeding in
areas/objects of interest).
7. Specify solution options.
8. Start the solution process.
9. When the solution becomes available, perform post processing, such as
plotting field quantities and calculating expressions.
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Overview
Parametric Adaptive Analysis
1.
2.
3.
4.

Parametric Model Generation – creating the geometry, boundaries and excitations
Analysis Setup – defining solution setup and frequency sweeps
Results – creating 2D reports and field plots
Solve Loop - the solution process is fully automated
To understand how these processes co-exist, examine the illustration shown
below (shown specifically for a Magnetostatic setup).

Design
Solution Type
2. Boundaries

1. Parametric Model
Geometry/Materials
2. Excitations
3 Mesh
Operations

2. Analysis
Solution Setup
Mesh
Refinement

Analyze

Solve

4. Results
2D Reports
Fields

NO

Converged

2. Solve Loop
YES
Update
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Opening a Design
Opening a Maxwell project
The basic modeling entity in Maxwell is the design (model). The next level up is
the project. A project is a collection of one or more designs (models) that is saved
in a single *.mxwl file. A new project is automatically created when Maxwell is
launched. As many Maxwell designs as needed can be added to a single
Maxwell project.
Opening a New project
To open a new project:
1. In an Ansoft Maxwell window, select the menu item File > New.
To insert a Maxwell design:
1. In an Ansoft Maxwell window, select the menu item Project > Insert
MaxwellDesign.
Opening an Existing Maxwell project
To open an existing project:
1. In an Ansoft Maxwell window, select the menu File > Open. Use the
Open dialog to select the project.
2. Click Open to open the project
Opening an Existing Project from Explorer
You can open a project directly from the Microsoft Windows Explorer.
following::
To open a project from Windows Explorer, do one of the following
Double-click on the name of the project in Windows Explorer.
Right-click the name of the project in Windows Explorer and select
Open from the shortcut menu.
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Set Solution Type
Set Solution Type
To set the solution type:
1. Select the menu item Maxwell > Solution Type
2. Solution Type Window:
1. Choose one of the following:
1. Magnetostatic
2. Eddy Current
3. Transient
4. Electric (Electrostatic, DC Conduction)
2. Click the OK button
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2.1
Magnetostatic Analysis
Magnetostatic Analysis
Magnetostatic Analysis is performed by choosing the Magnetostatic solution type.
Applications that use Magnetostatic Analysis can be solenoids, inductors,
motors, actuators, permanent magnets, stray field calculations and many others.

Overview
The magnetostatic solver computes static (DC) magnetic fields.
All objects are stationary.
The source of the static magnetic field can be:
DC current in conductors
Permanent magnets
Static magnetic fields represented by external boundary conditions.
The quantity solved is the magnetic field (H).
Current density (J) and magnetic flux density (B) are automatically calculated
from the magnetic field (H).
Derived quantities such as forces, torques, energy, and inductances may be
calculated from these basic field quantities.
Material permeabilities can be nonlinear and/or anisotropic.
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2.1
Magnetostatic Analysis
Setup
The options in the project tree for a magnetostatic simulation control all the
simulation setup parameters.
Notice that right-clicking on any of the options will open a menu with
important options for each step of the simulation setup.
The Model definition refers to the geometry
and material definition.
Boundaries and Excitations refer to the
specific boundaries and excitations available
in a magnetostatic simulation.
Parameters are values that the solver will
automatically calculate after finding the field
solution.
Mesh Operations are discussed in a separate
section.
Analysis defines the solution setup.
Optimetrics defines any automatic variational
analyses.
Results and Field overlays are discussed in a
separate section.
These options are displayed in an order that can be followed in creating a new
Magnetostatic simulation. This is a general purpose order that goes linearly
through simulation setup, analysis, and post-processing.
However, in some cases it is acceptable to work out of the defined order. This is
particularly true when defining results, field overlays, or calculated quantities. It
is important to think of results when defining the problem setup so that the
desired quantities may be obtained in a sufficient manner. Notice, however, that
the field calculator is not available until a solution setup is defined.

Ansoft Maxwell 3D Field Simulator v11 User’s Guide

2.1-2

2.1
Magnetostatic Analysis
Magnetostatic Material Definition
In a Magnetostatic simulation, the following parameters may be defined for a
material:
Relative Permeability (can be Anisotropic and/or Nonlinear, or Simple)
Relative permeability along with the Magnetic Coercivity determine
the magnetic properties of the material.
Bulk Conductivity (can be Anisotropic or Simple)
Bulk Conductivity is used in determining the current distribution in
current carrying conductors – it has no influence in the magnetic part
of the solution process.
Magnetic Coercivity (defined as a vector magnitude and direction)
Magnetic Coercivity is used to define the permanent magnetization
of magnetic materials. When a non-zero magnitude is entered, the
directional entries are visible. The direction (like all directional
material properties) are determined by the coordinate system type
and the object orientation.
Composition (can be Solid or Lamination)
Setting Composition to Lamination creates an anisotropic
magnetization effect. This is discussed in the Anisotropic Material
example.
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2.1
Magnetostatic Analysis
Magnetostatic Boundary Conditions
Default – The default boundary conditions for the Magnetostatic solver are:
Natural boundaries on the interface between objects.
- This means that the H Field is continuous across the boundary.
Neumann boundaries on the outer boundaries.
- This means that the H Field is tangential to the boundary and flux cannot
cross it.
Zero Tangential H Field – This boundary is often used to model an applied
uniform, external field. This would model outer boundaries of the Region that are
perpendicular to the applied field. In this case, the boundary should be placed far
from the structure so that the simulation is not over-defined. This is equivalent to
the even symmetry boundary definition.
Tangential H Field – This boundary is used primarily to model an applied uniform,
external field. This would model outer boundaries of the Region that have a
defined tangential magnetic field. This boundary should always be placed far
from the structure so that the simulation is not over-defined. Faces must be
planar and must be defined one at a time, due to the U-V field definition on each
face.
To apply a uniform field along any orthogonal axis of a bounding box, first,
apply a Zero Tangential H Field on the top and bottom faces (with respect
to the direction of the desired axis) of the box. Then apply a Tangential H
Field to each side face – define each U vector to be parallel to the selected
axis (the V vector does not matter because no field will exist in that
direction), and assign the value of U with a constant value. The field will be
in the direction of the selected axis (perpendicular to the top and bottom
faces), and will have a constant value at the boundaries of the solution
region.
Note that it is very easy to create impossible field assignments with these
boundary conditions. If your simulation does not converge when using
these boundaries, try the boundary conditions without any objects included
to see if the boundaries are assigned correctly (the simulation will have
difficulties converging if boundaries are incorrect).
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2.1
Magnetostatic Analysis
Magnetostatic Boundary Conditions (Continued)
Insulating – This boundary defines a thin, perfectly insulating sheet between
touching conductors. This is particularly useful to separate coils from magnetic
steel (defined on surfaces between the two objects), but there are many other
applications.
Symmetry – There are two magnetic symmetries – odd symmetry (flux tangential)
and even symmetry (flux normal). Odd symmetry defines H to be tangential to
the boundary (this is equivalent to the default boundary condition on the outer
boundary). Even symmetry defines H to be normal to the boundary (this is
equivalent to the Zero Tangential H Field boundary condition). Remember that
geometric symmetry may not mean magnetic symmetry in all cases. Symmetry
boundaries enable you to model only part of a structure, which reduces the size
or complexity of your design, thereby shortening the solution time. Other
considerations for a Symmetry boundary condition:
A plane of symmetry must be exposed to the background.
A plane of symmetry must not cut through an object drawn in the 3D
Modeler window.
A plane of symmetry must be defined on a planar surface.
Only three orthogonal symmetry planes can be defined in a problem
Master/Slave – This boundary condition is also known as a matching boundary
condition because it matches the magnetic field at the slave boundary to the field
at the master boundary. The geometry must be identical on each face (the mesh
needs to be identical, but the solver takes care of this requirement for matched
geometries) and the faces need to be planar. It is required to define a U-V
coordinate system along each face to properly map the matched boundary as
desired. Master and Slave boundaries enable you to model only one period of a
periodic structure, which will reduce the size of a design. Example applications
are periodic rotational machines or infinite arrays.
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2.1
Magnetostatic Analysis
Magnetostatic Excitations
Typical sources for magnetostatic field problems include voltage, current, and
current density. When applying the sources for the magnetic field problems, the
applied current distribution must be divergence free in the entire space of the
solution as it is physical for quasi-stationary conduction current density
distributions. Thus, the conduction path(s) for the applied current distributions
must be closed when totally contained within the solution space for the problem,
or must begin and end at the boundaries.
Permanent Magnets and externally applied magnetic fields can also act as
sources for a magnetostatic analysis, however, those are defined elsewhere.
Voltage Excitations - These are used in conjunction with the material conductivity
to define the current through a solid conductor. Either multiple Voltage
excitations can be used to define a voltage difference across two faces of a
conductor (creating a current) or a Voltage Drop can be defined on a 2D sheet
object to signify the voltage drop around a conductive loop.
Current Excitations - This excitation can be assigned on any conductor to define
the total current (amp-turns) through the cross-section of a loop or to define the
current into and out of the opposing, external faces of a conducting object. This
is a very general purpose excitation that comes in two flavors – Solid or Stranded.
More information about Stranded Magnetostatic Current excitations (along with
an example and explanation) can be found in the Magnetostatic Switched
Reluctance Motor example.
Current Density - These excitations are used to define a known current density
throughout an object and must be used with a Current Density Terminal. The
Current Density is defined on the 3D object, and the Terminal is defined on either
an internal cross-sectional sheet, or on all external cross-sectional faces.
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2.1
Magnetostatic Analysis
Parameters
There are three parameters that can be
automatically calculated in a
Magnetostatic simulation – Force,
Force
Torque,
Torque and Inductance Matrix.
Matrix
All three quantities are computed
directly from the magnetic field solution.
Force and torque can be calculated with
two different methods - Virtual or Lorentz
(Lorentz cannot be used on magnetic
materials).
Inductance Matrix has many post-processing options available – this is discussed
in detail in the Magnetostatic Inductance Matrix example.
The results of any parameters can be found by selecting Maxwell > Results >
Solution Data…
icon.
Data… or by clicking on the
Further results can be obtained manually through the field calculator.

Mesh Operations
Mesh operations are described in detail in the Mesh operations section.
Remember that the Magnetostatic solver has an adaptive mesh solution, so
excessive mesh operations are not usually required. It can often be worse to
over-define the mesh than to not define mesh operations at all (it will take longer
to solve, and it will be more difficult to adapt correctly).
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2.1
Magnetostatic Analysis
Solution Setup
The solution setup defines the parameters used for solving the simulation.
Add a solution setup by selecting Maxwell > Analysis Setup > Add Solution
Setup…
icon.
Setup… or click on the
The following window appears with the General Setup parameters.

You can Name the setup, and you can create multiple setups if you desire (by
repeating this procedure).
Maximum Number of Passes defines a limit to the number of adaptively refined
passes that the solver performs (the default value is 10).
Percent Error is the error goal for both the Error Energy and Delta Energy.
Solve Fields Only ignores any defined parameters if checked.
Solve Matrix has the options of calculating the matrix after the last solved pass or
calculating the matrix only if the solution converges.
An option is included to display one Force or Torque parameter in the
Convergence table.
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2.1
Magnetostatic Analysis
Solution Setup (Continued)
The second tab of the Solution Setup contains information about Convergence.

Refinement Per Pass defines the number of tetrahedral elements added during
mesh refinement as a percentage of the previous pass (30% is the default).
Minimum Number of Passes defines the minimum number of adaptive passes
before the solution stops - if there is a conflict, this value is over-ridden by
Maximum Number of Passes (the default value is 2).
Minimum Converged Passes defines the minimum number of adaptive passes
that have been converged (with respect to the Percent error) before the solution
stops (the default value is 1).
Use Output Variable Convergence is an option to include a defined output
variable as an additional convergence criterion with a specified maximum percent
change per pass (an output variable must be defined for this option to be
available).
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2.1
Magnetostatic Analysis
Solution Setup (Continued)
The third tab of the Solution Setup contains information about the Solver.

Nonlinear Residual defines how precisely the nonlinear solution must define the
B-H nonlinear operating points (the default value is 0.01).
Solver Type has options for the Direct or ICCG solvers (Direct is the default).
Permeability Option allows the nonlinear B-H operating points either to be
calculated by the solver from the Nonlinear BB-H curve or to use frozen
permeabilities From Link – the linked solution must have the exact same
geometry as the current simulation (Nonlinear B-H curve is the default).
Magnetization Option allows the permanent magnetization to be determined from
the Nonlinear BB-H curve or to use demagnetized values From Link - where the
linked solution selected Compute demagnetized operating points - the linked
solution must have the exact same geometry (Nonlinear B-H curve is the default).
Import Mesh allows the initial mesh to be imported from another solution – the
linked solution must have the exact same geometry as the current simulation.
Setup Link must be defined when selecting From Link or Import Mesh.
Mesh
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2.1
Magnetostatic Analysis
Magnetostatic Solution Process
Unlike pre-processing, the solution process is very automated. Once the
problem has been defined properly, Maxwell will take over and step through
several stages of the solution process. To start the solution process, right-click
on Analysis in the Maxwell Project Tree and select Analyze.

Initial Setup

Adaptive Solution

Nonlinear Convergence
(Changing permeability)

Force/Torque Calculation

Solution Convergence ?

Refine Mesh

Converged or Number of Passes

Stop Field Solution

Calculate Parameters
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Eddy Current Analysis
Eddy Current Analysis is performed by choosing the Eddy Current solution type.
Applications that use Eddy Current Analysis can be solenoids, inductors, motors,
stray field calculations and many others.

Overview
The eddy current solver computes steady-state, time-varying (AC) magnetic
fields at a given frequency – this is a frequency domain solution.
All objects are stationary.
The source of the static magnetic field can be:
Sinusoidal AC current (peak) in conductors.
Time-varying external magnetic fields represented by external boundary
conditions.
The quantities solved are the magnetic field (H) and the magnetic scalar potential
(Ω).
Current density (J) and magnetic flux density (B) are automatically calculated
from the magnetic field (H).
Derived quantities such as forces, torques, energy, and inductances may be
calculated from these basic field quantities.
Material permeabilities and conductivities can be anisotropic, but must be linear.
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Setup
The options in the project tree for a eddy current simulation control all the
simulation setup parameters.
Notice that right-clicking on any of the options will open a menu with
important options for each step of the simulation setup.
The Model definition refers to the geometry
and material definition.
Boundaries and Excitations refer to the
specific boundaries and excitations available
in a eddy current simulation.
Parameters are values that the solver will
automatically calculate after finding the field
solution.
Mesh Operations are discussed in a separate
section.
Analysis defines the solution setup.
Optimetrics defines any automatic variational
analyses.
Results and Field overlays are discussed in a
separate section.
These options are displayed in an order that can be followed in creating a new
Eddy Current simulation. This is a general purpose order that goes linearly
through simulation setup, analysis, and post-processing.
However, in some cases it is acceptable to work out of the defined order. This is
particularly true when defining results, field overlays, or calculated quantities. It
is important to think of results when defining the problem setup so that the
desired quantities may be obtained in a sufficient manner. Notice, however, that
the field calculator is not available until a solution setup is defined.
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Eddy Current Material Definition
In an Eddy Current simulation, the following parameters may be defined for a
material:
Relative Permittivity (can be Anisotropic or Simple)
Relative Permittivity effects the solution when displacement currents
are considered in an object.
Relative Permeability (can be Anisotropic or Simple)
Relative Permeability along with the Bulk Conductivity determine the
time-varying magnetic properties of the material.
Bulk Conductivity (can be Anisotropic or Simple)
Bulk Conductivity is used both in determining the current distribution
in current carrying conductors and in calculating eddy currents and
the resulting magnetic field solution.
Dielectric Loss Tangent (can be Anisotropic or Simple)
Dielectric Loss Tangent controls the ratio of imaginary and real
permittivities.
Magnetic Loss Tangent (can be Anisotropic or Simple)
Magnetic Loss Tangent controls the ratio of imaginary and real
permeabilities.
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Eddy Current Boundary Conditions
Default – The default boundary conditions for the Eddy Current solver are:
Natural boundaries on the interface between objects.
- This means that the H Field is continuous across the boundary.
Neumann boundaries on the outer boundaries.
- This means that the H Field is tangential to the boundary and flux cannot
cross it.
Zero Tangential H Field – This boundary (similar to the Magnetostatic version) is
often used to model an applied uniform, external field. This would model outer
boundaries of the Region that are perpendicular to the applied field. In this case,
the boundary should be placed far from the structure so that the simulation is not
over-defined. This is equivalent to the even symmetry boundary definition.
Tangential H Field – This boundary (similar to the Magnetostatic version) is used
primarily to model an applied uniform, external field. This would model outer
boundaries of the Region that have a defined tangential magnetic field. This
boundary should always be placed far from the structure so that the simulation is
not over-defined. Faces must be planar and must be defined one at a time, due
to the U-V field definition on each face.
To apply a uniform field along any orthogonal axis of a bounding box, first,
apply a Zero Tangential H Field on the top and bottom faces (with respect
to the direction of the axis) of the box. Then apply a Tangential H Field to
each side face – define each U vector to be parallel to the selected axis (the
V vector does not matter because no field will exist in that direction), and
assign the real and imaginary values of U with constant values. The field
will be in the direction of the selected axis (perpendicular to the top and
bottom faces), and will have a constant value away from the defined
objects in the simulation.
Note that it is very easy to create impossible field assignments with these
boundary conditions. If your simulation does not converge when using
these boundaries, try the boundary conditions without any objects included
to see if the boundaries are assigned correctly (the simulation will have
difficulties converging if boundaries are incorrect).
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Eddy Current Boundary Conditions (Continued)
Insulating – This boundary defines a thin, perfectly insulating sheet between
touching conductors. This is particularly useful to separate coils from magnetic
steel (defined on surfaces between the two objects), but there are many other
applications.
Symmetry – There are two magnetic symmetries – odd symmetry (flux tangential)
and even symmetry (flux normal). Odd symmetry defines H to be tangential to
the boundary (this is equivalent to the default boundary condition on the outer
boundary). Even symmetry defines H to be normal to the boundary (this is
equivalent to the Zero Tangential H Field boundary condition). Remember that
geometric symmetry may not mean magnetic symmetry in all cases. Symmetry
boundaries enable you to model only part of a structure, which reduces the size
or complexity of your design, thereby shortening the solution time. Other
considerations for a Symmetry boundary condition are the same as for a
Magnetostatic symmetry boundary.
Master/Slave – This boundary condition is also known as a matching boundary
condition because it matches the magnetic field at the slave boundary to the field
at the master boundary. The geometry must be identical on each face (the mesh
needs to be identical, but the solver takes care of this requirement for matched
geometries) and the faces need to be planar. It is required to define a U-V
coordinate system along each face to properly map the matched boundary as
desired. Master and Slave boundaries enable you to model only one period of a
periodic structure, which will reduce the size of a design. Example applications
are periodic rotational machines or infinite arrays.
Radiation – This boundary condition is specific to the Eddy Current solver. See
the discussion of the Radiation boundary in the Radiation Boundary example.
Impedance – This boundary can model induced currents within excluded objects
without explicitly solving within the objects. This can decrease simulation time
because the difficult to mesh areas near the surface of objects can be ignored
and approximated with this boundary. By excluding the object (accomplished by
deselecting Solve Inside in the object properties), there will be no solution inside
the object. This approximation is good for good conductors (where the skin depth
is less than half the width of the excluded conductor).
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Eddy Current Excitations
Typical sources for eddy current problems include current and current density. In
applying the sources for the magnetic field problems, keep in mind that the
applied current distribution must be divergence free in the entire space of the
solution as it is physical for (quasi) stationary conduction current density
distributions. Thus, the conduction paths(s) for the applied current distributions
must be closed when totally contained within the solution space for the problem
or must begin and end at the boundaries. The total current applied to conductors
that touch the boundaries doesn't require the existence of terminals at the ends
where the current is applied, the respective planar surfaces of the conductors in
the plane of the region (background) can be used to apply the excitations.
Current Excitations - This excitation can be assigned on any conductor to define
the total peak current (amp-turns) through the cross-section of a loop or to define
the current into and out of the opposing, external faces of a conducting object.
This is a very general purpose excitation that comes in two flavors – Solid or
Stranded. More information about Stranded Current excitations (along with a
Magnetostatic example and explanation) can be found in the Magnetostatic
Switched Reluctance Motor example. The only difference between the use of
stranded and solid conductors between the magnetostatic solver and the eddy
current solver, is that in the eddy current solver eddy effects are not considered in
stranded conductors, but not in solid conductors.
Current Density - These excitations are used to define a known current density
throughout an object and must be used with a Current Density Terminal. The
peak Current Density (magnitude and phase) is defined on the 3D object, and the
Terminal is defined on either an internal cross-sectional sheet, or on all external
cross-sectional faces.
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Parameters
There are three parameters that can be
automatically calculated in an
Eddy Current simulation – Force,
Force
Torque,
Torque and Inductance Matrix.
Matrix
All three quantities are computed
directly from the magnetic field solution.
Force and torque can be calculated with
two different methods - Virtual or Lorentz
(Lorentz cannot be used on magnetic
materials).
The results of any parameters can be found by selecting Maxwell > Results >
Solution Data…
Data… or by clicking on the
icon.
Further results can be obtained manually through the field calculator.

Mesh Operations
Mesh operations are described in detail in the Mesh operations section.
Remember that the Eddy Current solver has an adaptive mesh solution, so
excessive mesh operations are not always required. It can often be worse to
over-define the mesh than to not define mesh operations at all (it will take longer
to solve, and it will be more difficult to adapt correctly).
However, it is very important to mesh properly to account for currents with small
skin depths – this is important on solid conducting objects.
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Solution Setup
The solution setup defines the parameters used for solving the simulation.
Add a solution setup by selecting Maxwell > Analysis Setup > Add Solution
Setup…
icon.
Setup… or click on the
The following window appears with the General Setup parameters.

You can Name the setup, and you can create multiple setups if you desire (by
repeating this procedure).
Maximum Number of Passes defines a limit to the number of adaptively refined
passes that the solver performs (the default value is 10).
Percent Error is the error goal for both the Error Energy and Delta Energy.
Solve Fields Only ignores any defined parameters if checked.
Solve Matrix has the options of calculating the matrix after the last solved pass or
calculating the matrix only if the solution converges.
An option is included to display one Force or Torque parameter in the
Convergence table.
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Eddy Current Analysis
Solution Setup (Continued)
The second tab of the Solution Setup contains information about Convergence.

Refinement Per Pass defines the number of tetrahedral elements added during
mesh refinement as a percentage of the previous pass (30% is the default).
Minimum Number of Passes defines the minimum number of adaptive passes
before the solution stops - if there is a conflict, this value is over-ridden by
Maximum Number of Passes (the default value is 2).
Minimum Converged Passes defines the minimum number of adaptive passes
that have been converged (with respect to the Percent error) before the solution
stops (the default value is 1).
Use Output Variable Convergence is an option to include a defined output
variable as an additional convergence criterion with a specified maximum percent
change per pass (an output variable must be defined for this option to be
available).

Ansoft Maxwell 3D Field Simulator v11 User’s Guide

2.2-9

2.2
Eddy Current Analysis
Solution Setup (Continued)
The third tab of the Solution Setup contains information about the Solver.

Linear Residual defines the residual limit of an iterative solver that is
automatically used if necessary, but the default solver for eddy current
simulations is the direct solver where this limit has no significance (the default
value is 1e-8).
Adaptive Frequency defines the frequency at which the mesh is constructed and
adapted, and at which solution is obtained (the default value is 60 Hz).
Import Mesh allows the initial mesh to be imported from another solution – the
linked solution must have the exact same geometry as the current simulation.
Setup Link must be defined when selecting Import Mesh.
Mesh
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Solution Setup (Continued)
The fourth tab of the Solution Setup contains information about an optional
Frequency Sweep.

Define the sweep (Type,
Type, Start, Stop, Step)
Step in the left panel.
Check Save Fields (All Frequencies) to save the fields for all frequencies in this
sweep definition.
Select Add to List >> to place this sweep definition in the Sweep List (the Sweep
List is displayed in the right panel).
Edit any entries in the Sweep List to adjust solution frequencies or whether to
save fields at specific frequencies in the list.
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Eddy Current Solution Process
Unlike pre-processing, the solution process is very automated. Once the
problem has been defined properly, Maxwell will take over and step through
several stages of the solution process. To start the solution process, right-click
on Analysis in the Maxwell Project Tree and select Analyze.

Initial Setup

Adaptive Solution

Solution Convergence ?

Refine Mesh

Converged or Number of Passes

Stop Field Solution

Calculate Parameters

Frequency Sweep ?

Next Frequency

Done
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Transient Analysis
Transient Analysis
Transient Analysis is performed by choosing the Transient solution type.
Applications that use Transient Analysis can be solenoids, inductors, motors,
actuators, permanent magnets and many others.

Overview
The Transient solver computes magnetic fields in the time domain
(instantaneously at each time step).
The solver formulation is based on a current vector potential in solid conductors,
and a scalar potential over the entire field domain.
The source of the static magnetic field can be:
Arbitrary time-varying current in conductors.
Permanent magnets.
Field Quantities are strongly coupled with circuit equations to allow voltage
sources and/or external driving circuits.
The quantity solved is the magnetic field (H) and the current density (J) while
magnetic flux density (B) is automatically calculated from the H-field.
Derived quantities such as forces, torques, flux linkage and core loss may be
calculated from these basic field quantities.
Material permeabilities can be nonlinear and/or anisotropic.
Permanent magnets are considered.
Excitations can be sinusoidal or non-sinusoidal including:
Voltages and currents applied to windings.
External circuits attached to windings.
Permanent magnets.
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Setup
The options in the project tree for a transient simulation control all the simulation
setup parameters.
Notice that right-clicking on any of the options will open a menu with
important options for each step of the simulation setup.
The Model definition refers to the geometry
and material, as well as motion definitions.
Boundaries and Excitations refer to the
specific boundaries and excitations available
in a transient simulation.
Parameters are values that the solver will
automatically calculate after finding the field
solution.
Mesh Operations are discussed in a separate
section.
Analysis defines the solution setup.
Optimetrics defines any automatic variational
analyses.
Results and Field overlays are discussed in a
separate section.
These options are displayed in an order that can be followed in creating a new
Transient simulation. This is a general purpose order that goes linearly through
simulation setup, analysis, and post-processing.
However, in some cases it is acceptable to work out of the defined order. This is
particularly true when defining results, field overlays, or calculated quantities. It
is important to think of results when defining the problem setup so that the
desired quantities may be obtained in a sufficient manner. Notice, however, that
the field calculator is not available until a solution setup is defined.
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Transient Material Definition
In a Transient simulation, the following parameters may be defined for a material:
Relative Permeability (can be Anisotropic and/or Nonlinear, or Simple)
Relative Permeability plays a large role in determining the magnetic
field solution.
Bulk Conductivity (can be Anisotropic or Simple)
Bulk Conductivity is used both in determining the current distribution
in current carrying conductors and in finding the eddy currents in
solid conductors, which affect the magnetic solution.
Magnetic Coercivity (defined as a vector magnitude and direction)
Magnetic Coercivity is used to define the permanent magnetization
of magnetic materials. When a non-zero magnitude is entered, the
directional entries are visible. The direction (like all directional
material properties) are determined by the coordinate system type
and the object orientation.
Core Loss Type (can be Electrical Steel, Power Ferrite, or None)
Mass Density
Composition (can be Solid or Lamination)
Setting Composition to Lamination creates an anisotropic
magnetization effect. This is discussed in the Magnetostatic
Anisotropic Material example.
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Transient Boundary Conditions
Default – The default boundary conditions for the Transient solver are:
Natural boundaries on the interface between objects.
- This means that the H Field is continuous across the boundary.
Neumann boundaries on the outer boundaries.
- This means that the H Field is tangential to the boundary and flux cannot
cross it.
Zero Tangential H Field – This boundary acts equivalently on the field as the even
symmetry boundary, but is used in special cases only. Use the even symmetry
boundary to model symmetries with normal H fields to the symmetry plane.
Insulating – This boundary defines a thin, perfectly insulating sheet between
touching conductors. This is particularly useful to separate coils from magnetic
steel (defined on surfaces between the two objects), but there are many other
applications.
Symmetry – There are two magnetic symmetries – odd symmetry (flux tangential)
and even symmetry (flux normal). Odd symmetry defines H to be tangential to
the boundary (this is equivalent to the default boundary condition on the outer
boundary). Even symmetry defines H to be normal to the boundary (this is
equivalent Zero Tangential H Field boundary condition). Remember that
geometric symmetry may not mean magnetic symmetry in all cases. Symmetry
boundaries enable you to model only part of a structure, which reduces the size
or complexity of your design, thereby shortening the solution time. Other
considerations for a Symmetry boundary condition are the same as for a
Magnetostatic symmetry boundary.
Master/Slave – This boundary condition is also known as a matching boundary
condition because it matches the magnetic field at the slave boundary to the field
at the master boundary. The geometry must be identical on each face (the mesh
needs to be identical, but the solver takes care of this requirement for matched
geometries) and the faces need to be planar. It is required to define a U-V
coordinate system along each face to properly map the matched boundary as
desired. Master and Slave boundaries enable you to model only one period of a
periodic structure, which will reduce the size of a design. Example applications
are periodic rotational machines or infinite arrays.
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Transient Excitations
Typical sources for transient field problems include coil terminals of type voltage,
current or external circuit. When applying the sources for the magnetic field
problems, the applied current distribution must be divergence free in the entire
space of the solution as it is physical for quasi-stationary conduction current
density distributions. Thus, the conduction path(s) for the applied current
distributions must be closed when totally contained within the solution space for
the problem, or must begin and end at the boundaries.
Permanent Magnets can also act as sources for a transient analysis, however,
those are defined elsewhere.
Coil Terminals – Coil terminals are defined to designate the cross sectional faces
of the 3D conductors. These can either be located internally to a closed loop, or
on the external faces of a conduction path. The coil terminals are grouped into a
Winding that controls the current in one or multiple conduction paths. The only
things that are defined by the Coil Terminals are as follows:
Number of conductors (solid windings require 1 conductor)
Direction of the current
A cross section of the conductor
Windings – Windings control the current flowing through the conductors and are
therefore crucial to the magnetic solution. There are three different types of
winding:
Current – defines a specified functional current through the conducting
paths.
Voltage – defines a specified functional voltage across the coil terminals
(and a series resistance and inductance).
External – defines that an external circuit will control the current and voltage
associated with the conducting path.
Coil terminals must be added to a Winding to complete the excitation setup.
Coil terminals will automatically report flux linkage and induced voltage vs. time
in the 2D reporter.
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Winding Setup
Assign a coil terminal to a winding by either:
Right-clicking on the winding and choosing Add Terminals…
Terminals…
or
Right-clicking on the terminal and choosing Add to Winding…
Winding…
Group coil terminals by adding them to the same winding.
Grouped conductors are considered in series – the defined current goes through
each conductor, voltage is defined across all conductors plus additional
resistance and/or inductance – total winding inductance is treated as the sum of
each coil’s inductance.
In the Winding setup:
Define the Winding to be the desired Type and Solid vs. Stranded.
Then, define the necessary parameters – current or voltage can be a
function of time in their respective source types. Resistance and
inductance are available for voltage sources (to determine the current), and
are considered in series with winding.
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External Circuits
Step1: Open Maxwell Circuit Editor
(Windows Start Menu > Programs > Ansoft >
Maxwell 11 > Maxwell Circuit Editor)
Step 2: Create Circuit in Maxwell Circuit Editor Schematic
In the editor, each winding should appear as a Winding element, with a
matching name for each winding – i.e. Winding1 in the transient simulation
would require Winding1 in the schematic (displayed as LWinding1 on the
schematic sheet).

Step 3: Export netlist from the circuit editor (Maxwell Circuit > Export Netlist).
Save the Circuit Editor project so that you can edit your circuit later.
Step 4: Import the netlist into Maxwell (Maxwell > Excitations > External Circuit >
Edit External Circuit…
Circuit…)
Choose Import Circuit…
Circuit… to import the netlist.
You must re-import the netlist every time that you make a change to the
circuit, otherwise the change will not take effect.
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Parameters
There are two parameters that can be
automatically calculated in a Transient
simulation – Force and Torque.
Torque
Both quantities are computed
directly from the magnetic field solution.
Force and torque are calculated with the
Virtual work method.
With the motion setup, a force or torque
associated with the translational or
rotational motion is automatically
calculated – this force or torque (from the
motion setup) may or may not be exactly equal to a similar parameter assigned
on the same set of moving objects.
The results of the parameters are not located in the solution results for a transient
simulation – however, they can be obtained by creating a 2D report to find the
parameter values as a function of time.
Further results can be obtained manually through the field calculator.

Mesh Operations
Mesh operations are described in detail in the Mesh operations section.
Remember that the Transient solver does not have an adaptive mesh solution, so
significant, intelligent mesh operations are required. There are techniques to
obtain a more defined mesh, such as linking a transient simulation to the mesh
from a Magnetostatic simulation. Also, skin-depth meshing can be very important
if solid conductors have significant eddy effects.
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Solution Setup
The solution setup defines the parameters used for solving the simulation.
Add a solution setup by selecting Maxwell > Analysis Setup > Add Solution
Setup…
icon.
Setup… or click on the
The following window appears with the General Setup parameters.

You can Name the setup, and you can create multiple setups if you desire (by
repeating this procedure).
Stop time indicates the transient simulation time at which the simulation will stop.
Time step indicates the discrete lengths of time used in the transient simulation.
Notice that the general information is related to the transient nature of this
simulation – there is no information about convergence, because there is no
adaptive solution to converge with.
Choose the time steps appropriately for the physical time-constants of the
simulation (about 20 timesteps per cycle).
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Solution Setup (Continued)
The second tab of the Solution Setup contains information about Saving Fields.

Define the sweep (Type,
Type, Start, Stop, Step)
Step in the left panel.
Select Add to List >> to place this sweep definition in the Sweep List (the Sweep
List is displayed in the right panel).
Edit any entries in the Sweep List to adjust saved fields times.
The times that are included in this list will have a full field solution available for
post-processing. All other time-steps that are solved will not keep their field
solutions after solving and moving on to the next time step.
The last time step in a simulation will retain its fields automatically.
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Solution Setup (Continued)
The third tab of the Solution Setup contains Advanced options.

Control Programs are used to dynamically adjust parameters and control the
simulation – information can be found in the Maxwell Help.
Permeability Option allows the nonlinear B-H operating points either to be
calculated by the solver from the Nonlinear BB-H curve or to use frozen
permeabilities From Link – the linked solution must have the exact same
geometry as the current simulation (Nonlinear B-H curve is the default).
Magnetization Option allows the permanent magnetization to be determined from
the Nonlinear BB-H curve or to use demagnetized values From Link - where the
linked solution selected Compute demagnetized operating points - the linked
solution must have the exact same geometry (Nonlinear B-H curve is the default).
Import Mesh allows the initial mesh to be imported from another solution – the
linked solution must have the exact same geometry as the current simulation.
Setup Link must be defined when selecting From Link or Import Mesh.
Mesh
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Solution Setup (Continued)
The fourth tab of the Solution Setup contains information about the Solver.

Nonlinear Residual defines how precisely the nonlinear solution must define the
B-H nonlinear operating points (the default value is 0.005).
Solver Type has options for the Direct or ICCG solvers (Direct is the default).
Output Error will calculate the percent energy error (as described in the Solver
section). This provides some measure of convergence of the total field solution
at each time step. Remember however, that this does not guarantee that the
field solution is converged at all points. Also, the calculation of this quantity
requires a moderate increase in solution time (because the calculation is
evaluated at every time step).
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Solution Setup (Continued)
The fifth tab of the Solution Setup contains Output Variable options.

Output Variables are added to the list by selecting Add then selecting the
available output variables from the pull down list.
This output variable option requires that you first define an output variable before
adding it (however, you often need to define the analysis setup before you can
define an output variable – so do not be disoriented if you need to return to these
settings after defining the analysis setup).
There are two options for defining the time steps at which these output variables
are calculated.
The first option is to evaluate the output variables at evenly spaced
increments of time by using a constant time step.
The second option is to evaluate the output variables every Nth step, where
N is some integer. The output variable will then be computed at 0s, and
then at step N, step 2*N and so on.
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Motion Setup
Choose Assign Band to specify the band object (Maxwell > Model > Motion Setup

> Assign Band…
Band…).
The Motion Setup window appears when the band is assigned.

Specify Rotational or Translational
Set the Moving Vector (this vector can be defined along one of the axis of any
coordinate system – you may need to construct a new coordinate system to
properly assign the proper direction of motion or rotational axis.
Set Positive or Negative to define the direction with respect to the direction of the
positive axis of the Moving Vector.
Then define the Initial Position and translational or rotational limits.
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Motion Setup (Continued)
In the Mechanical tab of the motion setup, there are two fundamental options:
Velocity Definition
or
Consider Mechanical Transient
Velocity Definition is useful when the velocity is constant or follows a known
trajectory that can be expressed as a velocity as a function of time. Use this
option by de-selecting Consider Mechanical Transient.
Consider Mechanical Transient is useful for situations when the velocity varies
dynamically or is unknown. Requires the following inputs:
Initial Velocity or Initial Angular Velocity
Mass or Moment of Inertia
Damping
Load Force
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Motion Setup - Suggestions
Read the Maxwell Help note called Meshing Aspects for 3D Transient

Applications With Motion
When performing translational or non-cylindrical rotational motion, always include
a vacuum container object within the band that contains all the moving parts.
This container object should be spaced slightly away from all the objects that it
contains and should provide clearance when the objects and container move
within the band. This container object is necessary for both meshing purposes
with multiple objects and to produce a better force calculation surface. A vacuum
container object is often useful in cylindrical motion too, but not necessary due to
meshing considerations. The objects within the vacuum container are assumed
to move as one rigid body (all moving objects are assumed to move as one rigid
body by definition of the transient motion solution).
When conceptualizing translational or non-cylindrical rotational motion,
remember that the moving parts within the vacuum container move as one solid
body and the remeshing occurs between the surface of the band object and the
moving objects (generally a container object).
When conceptualizing cylindrical rotational motion, remember that the band
object and all moving parts rotate without remeshing between.
The conceptual difference between the two is that the band is more solid in the
cylindrical case (in that it does not change position with respect to the moving
parts), and the band is more fluid in the translational and non-cylindrical case (in
that the moving parts change position with respect to the band).
In the translational and non-cylindrical cases, the mesh the is created within the
band is created so that the edge length is not larger than the average edge length
for the elements on the surface of the band and the moving parts. If you wish to
better define the mesh within the band, you should apply a length-based mesh
operation on the surfaces of the band and moving parts (simply on the surface of
the vacuum container if used).
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2.3
Transient Analysis
Transient Solution Process
Unlike pre-processing, the solution process is very automated. Once the
problem has been defined properly, Maxwell will take over and step through
several stages of the solution process. To start the solution process, right-click
on Analysis in the Maxwell Project Tree and select Analyze.

Make Initial Mesh

Initial Setup

Conduction Solution

Nonlinear Convergence
(Changing permeability)

Field Solution (concurrent with
external circuit solution)

Force/Torque Calculation

Adjust for Motion

Next Time Step
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2.4
Electrostatic Analysis
Electrostatic Analysis
Electrostatic Analysis is performed by choosing the Electric solution type and
selecting the Electrostatic option.
Applications that use Electrostatic Analysis can be capacitors, high voltage lines,
breakdown voltage calculations and many others.

Overview
The electrostatic solver computes static (DC) electric fields.
All objects are stationary.
The source of the static magnetic field can be:
Applied potentials.
Charge distributions.
The quantity solved is the electric scalar potential (ø).
Electric Field (E) and Electric Flux Density (D) are automatically calculated from
the scalar potential (ø).
Derived quantities such as forces, torques, energy, and capacitances may be
calculated from these basic field quantities.
Material permittivities and conductivities can be anisotropic.
All fields inside conductors are assumed to be perfect and equipotential in an
electrostatic equilibrium (no current flow), therefore Joule losses are zero
everywhere.
Conductivity is irrelevant except to define conductors from insulators.
Can be coupled with a DC conduction simulation, where the electric potential
from the DC conduction solution is used as a voltage boundary condition for the
electric field solution in the insulators in an electrostatic simulation.
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2.4
Electrostatic Analysis
Setup
The options in the project tree for an electrostatic simulation control all the
simulation setup parameters.
Notice that right-clicking on any of the options will open a menu with
important options for each step of the simulation setup.
The Model definition refers to the geometry
and material definition.
Boundaries and Excitations refer to the
specific boundaries and excitations available
in an electrostatic simulation.
Parameters are values that the solver will
automatically calculate after finding the field
solution.
Mesh Operations are discussed in a separate
section.
Analysis defines the solution setup.
Optimetrics defines any automatic variational
analyses.
Results and Field overlays are discussed in a
separate section.
These options are displayed in an order that can be followed in creating a new
Electrostatic simulation. This is a general purpose order that goes linearly
through simulation setup, analysis, and post-processing.
However, in some cases it is acceptable to work out of the defined order. This is
particularly true when defining results, field overlays, or calculated quantities. It
is important to think of results when defining the problem setup so that the
desired quantities may be obtained in a sufficient manner. Notice, however, that
the field calculator is not available until a solution setup is defined.
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Electrostatic Analysis
Electrostatic Material Definition
In an Electrostatic simulation, the following parameters may be defined for a
material:
Relative Permittivity (can be Anisotropic or Simple)
Relative permittivity determines the electric field solution in the
insulators.
Bulk Conductivity (can be Anisotropic or Simple)
Bulk Conductivity defines whether an object is a conductor (treated
as a perfect conductor in the Electrostatic solver) or an insulator.
This separation is determined by the insulator/conductor material
threshold setting.
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2.4
Electrostatic Analysis
Electrostatic Boundary Conditions
Default – The default boundary conditions for the Electrostatic solver are:
Natural boundaries on the interface between objects.
- This means that the normal component of the D Field at the boundary
changes by the amount of surface charge density on the boundary.
Neumann boundaries on the outer boundaries.
- This means that the E Field is tangential to the boundary and flux cannot
cross it.
Symmetry – There are two Electric symmetries – even symmetry (flux tangential)
and odd symmetry (flux normal). Even symmetry defines E to be tangential to
the boundary (this is equivalent to the default boundary condition on the outer
boundary). Odd symmetry defines E to be normal to the boundary. Remember
that geometric symmetry may not mean electric symmetry in all cases.
Symmetry boundaries enable you to model only part of a structure, which
reduces the size or complexity of your design, thereby shortening the solution
time. Other considerations for a Symmetry boundary condition:
A plane of symmetry must be exposed to the background.
A plane of symmetry must not cut through an object drawn in the 3D
Modeler window.
A plane of symmetry must be defined on a planar surface.
Only three orthogonal symmetry planes can be defined in a problem
Master/Slave – This boundary condition is also known as a matching boundary
condition because it matches the electric field at the slave boundary to the field at
the master boundary. The geometry must be identical on each face (the mesh
needs to be identical, but the solver takes care of this requirement for matched
geometries) and the faces need to be planar. It is required to define a U-V
coordinate system along each face to properly map the matched boundary as
desired. Master and Slave boundaries enable you to model only one period of a
periodic structure, which will reduce the size of a design. Example applications
are periodic rotational machines or infinite arrays.
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2.4
Electrostatic Analysis
Electrostatic Excitations
Typical sources for electrostatic problems are net charges (assumed to have a
uniform distribution) applied to perfect insulator model objects or on surfaces that
cannot touch conductors and voltages (electric potential applied to perfect
conductor model objects or on surfaces, also called a Dirichlet boundary
condition). Additionally, a floating boundary condition can be applied to perfect
conductors (surrounded by insulators) or to surfaces surrounded by perfect
insulators.
Voltage Excitations – surface or object is at a constant, known potential – E field is
normal to the boundary.
Charge – The total charge on a surface or object (either a conductor or dielectric).
Floating – used to model conductors at unknown potentials
Volume Charge Density – The charge density in an object.
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2.4
Electrostatic Analysis
Parameters
There are three parameters that can be
automatically calculated in an
Electrostatic simulation – Force,
Force
Torque,
Torque and Capacitance Matrix.
Matrix
All three quantities are computed
directly from the electric field solution.
Force and torque can be calculated with
two different methods - Virtual or Lorentz
(Lorentz cannot be used on magnetic
materials).
The results of any parameters can be found by selecting Maxwell > Results >
Solution Data…
Data… or by clicking on the
icon.
Further results can be obtained manually through the field calculator.

Mesh Operations
Mesh operations are described in detail in the Mesh operations section.
Remember that the Electrostatic solver has an adaptive mesh solution, so
excessive mesh operations are not usually required. It can often be worse to
over-define the mesh than to not define mesh operations at all (it will take longer
to solve, and it will be more difficult to adapt correctly).
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2.4
Electrostatic Analysis
Solution Setup
The solution setup defines the parameters used for solving the simulation.
Add a solution setup by selecting Maxwell > Analysis Setup > Add Solution
Setup…
icon.
Setup… or click on the
The following window appears with the General Setup parameters.

You can Name the setup, and you can create multiple setups if you desire (by
repeating this procedure).
Maximum Number of Passes defines a limit to the number of adaptively refined
passes that the solver performs (the default value is 10).
Percent Error is the error goal for both the Error Energy and Delta Energy.
Solve Fields Only ignores any defined parameters if checked.
Solve Matrix has the options of calculating the matrix after the last solved pass or
calculating the matrix only if the solution converges.
An option is included to display one Force or Torque parameter in the
Convergence table.
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2.4
Electrostatic Analysis
Solution Setup (Continued)
The second tab of the Solution Setup contains information about Convergence.

Refinement Per Pass defines the number of tetrahedral elements added during
mesh refinement as a percentage of the previous pass (30% is the default).
Minimum Number of Passes defines the minimum number of adaptive passes
before the solution stops - if there is a conflict, this value is over-ridden by
Maximum Number of Passes (the default value is 2).
Minimum Converged Passes defines the minimum number of adaptive passes
that have been converged (with respect to the Percent error) before the solution
stops (the default value is 1).
Use Output Variable Convergence is an option to include a defined output
variable as an additional convergence criterion with a specified maximum percent
change per pass (an output variable must be defined for this option to be
available).
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2.4
Electrostatic Analysis
Solution Setup (Continued)
The third tab of the Solution Setup contains information about the Solver.

Solver Type has options for the Direct or ICCG solvers (Direct is the default).
Import Mesh allows the initial mesh to be imported from another solution – the
linked solution must have the exact same geometry as the current simulation.
Setup Link must be defined when selecting Import Mesh.
Mesh
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2.4
Electrostatic Analysis
Electrostatic Solution Process
Unlike pre-processing, the solution process is very automated. Once the
problem has been defined properly, Maxwell will take over and step through
several stages of the solution process. To start the solution process, right-click
on Analysis in the Maxwell Project Tree and select Analyze.

Initial Setup

Adaptive Solution

Field Solution

Force/Torque Calculation

Solution Convergence ?

Refine Mesh

Converged or Number of Passes

Stop Field Solution

Calculate Parameters
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2.5
DC Conduction Analysis
DC Conduction Analysis
DC Conduction Analysis is performed by choosing the Electrostatic solution type
and selecting the DC conduction option.
Applications that use DC Conduction Analysis can be bus bars, power supplies,
and many others.

Overview
The DC Conduction solver computes static (DC) currents in conductors.
All objects are stationary.
The source of the static magnetic field can be:
Voltages at different ends of solid conductors.
Currents applied on surfaces of conductors.
The quantity solved is the electric scalar potential (ø).
Current density (J) and Electric Field (E) are automatically calculated from the
electric scalar potential (ø).
Material conductivities can be anisotropic.
All fields outside of the conductors are not calculated and totally decoupled from
the electric field distribution in the conductors – permittivity is irrelevant in this
calculation.
There is non-zero Joule loss (ohmic power loss) in the conductors.
Can be coupled with an electrostatic simulation, where the electric potentials
found in the conductors are used as a voltage boundary condition for the electric
field solution in the insulators in an electrostatic simulation.
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2.5
DC Conduction Analysis
Setup
The options in the project tree for a DC conduction simulation control all the
simulation setup parameters.
Notice that right-clicking on any of the options will open a menu with
important options for each step of the simulation setup.
The Model definition refers to the geometry
and material definition.
Boundaries and Excitations refer to the
specific boundaries and excitations available
in a DC Conduction simulation.
There are no parameters for a DC conduction
simulation.
Mesh Operations are discussed in a separate
section.
Analysis defines the solution setup.
Optimetrics defines any automatic variational
analyses.
Results and Field overlays are discussed in a
separate section.
These options are displayed in an order that can be followed in creating a new
DC Conduction simulation. This is a general purpose order that goes linearly
through simulation setup, analysis, and post-processing.
However, in some cases it is acceptable to work out of the defined order. This is
particularly true when defining results, field overlays, or calculated quantities. It
is important to think of results when defining the problem setup so that the
desired quantities may be obtained in a sufficient manner. Notice, however, that
the field calculator is not available until a solution setup is defined.
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2.5
DC Conduction Analysis
DC Conduction Material Definition
In a DC Conduction simulation, the following parameters may be defined for a
material:
Relative Permittivity (can be Anisotropic or Simple)
Relative permittivity does not affect the DC conduction calculation,
but will be important in insulators if this is coupled with an
electrostatic simulation.
Bulk Conductivity (can be Anisotropic or Simple)
Bulk Conductivity defines whether an object is a conductor (treated
as a perfect conductor in the Electrostatic solver) or an insulator.
This separation is determined by the insulator/conductor material
threshold setting.
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2.5
DC Conduction Analysis
DC Conduction Boundary Conditions
Default – The default boundary conditions for the DC Conduction solver are:
Natural boundaries on the interface between objects.
- This means that the normal component of the current density at the
boundary is continuous.
Neumann boundaries on the outer boundaries.
- This means that the E Field is tangential to the boundary and flux cannot
cross it (current cannot leave conductors).
Insulating – This boundary defines a thin, perfectly insulating sheet between
touching conductors. This is particularly useful to separate distinct conductors
(defined on surfaces between the objects).
Symmetry – There are two Electric symmetries – even symmetry (flux tangential)
and odd symmetry (flux normal). Even symmetry defines E to be tangential to
the boundary (this is equivalent to the default boundary condition on the outer
boundary). Odd symmetry defines E to be normal to the boundary. Remember
that geometric symmetry may not mean electric symmetry in all cases.
Symmetry boundaries enable you to model only part of a structure, which
reduces the size or complexity of your design, thereby shortening the solution
time. Other considerations for a Symmetry boundary condition:
A plane of symmetry must be exposed to the background.
A plane of symmetry must not cut through an object drawn in the 3D
Modeler window.
A plane of symmetry must be defined on a planar surface.
Only three orthogonal symmetry planes can be defined in a problem
Master/Slave – This boundary condition is also known as a matching boundary
condition because it matches the electric field at the slave boundary to the field at
the master boundary. The geometry must be identical on each face (the mesh
needs to be identical, but the solver takes care of this requirement for matched
geometries) and the faces need to be planar. It is required to define a U-V
coordinate system along each face to properly map the matched boundary as
desired. Master and Slave boundaries enable you to model only one period of a
periodic structure, which will reduce the size of a design. Example applications
are periodic rotational machines or infinite arrays.
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2.5
DC Conduction Analysis
DC Conduction Excitations
Typical sources for DC current flow problems are currents applied on surfaces of
conductors and voltages (electric potential applied to surfaces of conductors).
The direction of the applied current is either “in” or “out”, always normal to the
respective surfaces. Multiple conduction paths are allowed. Each conduction
path that has a current excitation must also have either a voltage excitation
applied or a sink to ensure a unique solution.
Voltage Excitations - These are used in conjunction with the material conductivity
to define the current through a solid conductor. Either multiple Voltage
excitations can be used to define a voltage difference across two faces of a
conductor (creating a current) or a Voltage can be defined along with a current
excitation to define a voltage reference for the electric field solution.
Current Excitations - This excitation can be assigned on any conductor to define
the total current (amp-turns) through the cross-sectional face of a conductor.
Sink – This excitation is used when only current excitations are defined in a
conduction path and there is no voltage excitation. This excitation ensures that
the total current flowing through the outside surface of a conduction path is
exactly zero.

Mesh Operations
Mesh operations are described in detail in the Mesh operations section.
Remember that the Magnetostatic solver has an adaptive mesh solution, so
excessive mesh operations are not usually required. It can often be worse to
over-define the mesh than to not define mesh operations at all (it will take longer
to solve, and it will be more difficult to adapt correctly).
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2.5
DC Conduction Analysis
Solution Setup
The solution setup defines the parameters used for solving the simulation.
Add a solution setup by selecting Maxwell > Analysis Setup > Add Solution
Setup…
icon.
Setup… or click on the
The following window appears with the General Setup parameters.

You can Name the setup, and you can create multiple setups if you desire (by
repeating this procedure).
Maximum Number of Passes defines a limit to the number of adaptively refined
passes that the solver performs (the default value is 10).
Percent Error is the error goal for both the Error Energy and Delta Energy.
Solve Fields Only ignores any defined parameters if checked.
Solve Matrix has the options of calculating the matrix after the last solved pass or
calculating the matrix only if the solution converges.
An option is included to display one Force or Torque parameter in the
Convergence table.
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2.5
DC Conduction Analysis
Solution Setup (Continued)
The second tab of the Solution Setup contains information about Convergence.

Refinement Per Pass defines the number of tetrahedral elements added during
mesh refinement as a percentage of the previous pass (30% is the default).
Minimum Number of Passes defines the minimum number of adaptive passes
before the solution stops - if there is a conflict, this value is over-ridden by
Maximum Number of Passes (the default value is 2).
Minimum Converged Passes defines the minimum number of adaptive passes
that have been converged (with respect to the Percent error) before the solution
stops (the default value is 1).
Use Output Variable Convergence is an option to include a defined output
variable as an additional convergence criterion with a specified maximum percent
change per pass (an output variable must be defined for this option to be
available).
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2.5
DC Conduction Analysis
Solution Setup (Continued)
The third tab of the Solution Setup contains information about the Solver.

Solver Type has options for the Direct or ICCG solvers (Direct is the default).
Import Mesh allows the initial mesh to be imported from another solution – the
linked solution must have the exact same geometry as the current simulation.
Setup Link must be defined when selecting Import Mesh.
Mesh
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2.5
DC Conduction Analysis
DC Conduction Solution Process
Unlike pre-processing, the solution process is very automated. Once the
problem has been defined properly, Maxwell will take over and step through
several stages of the solution process. To start the solution process, right-click
on Analysis in the Maxwell Project Tree and select Analyze.

Initial Setup

Adaptive Solution

Field Solution

Solution Convergence ?

Refine Mesh

Converged or Number of Passes

Stop Field Solution

Ansoft Maxwell 3D Field Simulator v11 User’s Guide

2.5-9

2.5
DC Conduction Analysis
Electrostatic and DC Conduction Combination
The combination of the DC current flow and electrostatic solution is based on the
division of the arrangement into conductors and insulators (determined by the
object’s conductivity and the insulator/conductor material threshold). The
solution of such problems is performed in two steps: first the DC conduction
problem in the conductors is computed, then the electrostatic solution is
calculated using the electric scalar potential of the conductors as a voltage
boundary condition.
Select the Electrostatic and DC Conduction combination by choosing the
Electrostatic solution type and selecting both the electrostatic and the DC
conduction options.

The setup for a ElectroDCConduction simulation is the same as if setting up a
DC Conduction simulation in the conducting objects, and setting up an
Electrostatic simulation in the insulators. All boundary conditions and excitations
for both setups are available when both options are selected. It is up to the user
to set up the simulation appropriately in each domain.

Ansoft Maxwell 3D Field Simulator v11 User’s Guide

2.5-10

3
Mesh Operations
Mesh Operations
This chapter provides details on meshing in the Ansoft Maxwell v11 software. It
discusses the default process of creating a mesh, meshing of curvature, user
control of meshing, and intermediate methods of manual mesh refinement. The
following topics are discussed:
Initial Mesh Process
Adaptive Mesh Process
Mesh Considerations and Impact on Solutions
Applying Mesh Operations
Surface Approximations
Curved Geometry Mesh Adaptation
Model Resolution
Length Based Mesh Operations
Skin Depth Based Mesh Operations
Mesh Reduction Techniques
Dummy Objects
Linking Mesh
Transient
Non-transient
Mesh failures and suggestions
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Mesh Operations
Initial Mesh Process
When you first analyze a problem, there must be an initial mesh in place to
perform a field calculation. The initial mesh is automatically constructed without
any instructions from the user (besides for the geometry definition) when the
analysis is first performed. The initial mesh is only constructed if no current mesh
exists – if a current mesh exists Maxwell will solve without creating a new initial
mesh. The automatic mesh process goes something like the following:

Click Analyze

Check model for errors and
intersections.

Create basic mesh point information from
geometry vertices and model resolution data.

Create mesh on the surface of curved
objects using surface approximations
(this is called surface triangulation).

Match up surface mesh between
objects and insert points.

Length and Skin Based Refinements.

Smooth mesh.

Pass mesh information to the
field solver.
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Adaptive Mesh Process
The adaptive mesh process takes numerous factors into consideration when
deciding where to refine the mesh at each pass. There are geometry factors,
field solution factors, and everything is based on the percent refinement number
defined in the analysis setup dialog.
If the percent refinement is set to 30%, and there are 1000 elements at pass 1,
then 300 points will be added for pass 2. This increase may not be exactly 30%
due to smoothing and other factors that will adjust the actual percent refinement.
The refined mesh points are calculated by the field solver and placed at points
where there are strong fields, large errors, large field gradients, or areas that
generally have a large impact on the field solution. This list of refined points is
then passed on to the meshing procedure which places the points and creates an
optimal refined mesh for the next adaptive pass.
Field solver finds field solution.

Solver creates a list of points to
add for next pass.

Next adaptive pass.

Add points determined from
previous adaptive pass.

Smooth mesh.

Pass mesh information to the
field solver
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Mesh Considerations and Impact on Solutions
The mesh is important for two separate, yet related reasons – first, the mesh is
used to directly determine the numerical field solution, second, the mesh is used
to produce all secondary results such as volume integrations or other field
calculations.
There is a trade-off among the size of the mesh, the desired level of accuracy
and the amount of available computing resources.
The accuracy of the solution depends on the size of each of the individual
elements (tetrahedra). Generally speaking, solutions based on meshes using
thousands of elements are more accurate than solutions based on coarse
meshes using relatively few elements. To generate a precise description of a
field quantity, each element must occupy a region that is small enough for the
field to be adequately interpolated from the nodal values.
However, generating a field solution involves inverting a matrix with
approximately as many elements as there are tetrahedra nodes. For meshes
with a large number of elements, such an inversion requires a significant amount
of computing power and memory. Therefore, it is desirable to use a mesh fine
enough to obtain an accurate field solution but not so fine that it overwhelms the
available computer memory and processing power.
Generally, uniform mesh elements with equilateral triangular faces are best
suited for second order interpolated field solutions. However, these triangles are
not easy to produce with complex geometries. The important thing to remember
is not to over-define the mesh in any region (this is especially true for nontransient simulations). It is often necessary to define the mesh on specific
surfaces or volumes for further calculations, however there are efficient and
inefficient methods to achieve good results.
Inefficient meshes pick up all the details of every curve and joint, even in
unimportant areas for the field solution. There are methods that we will discuss
that can decrease the mesh in areas of low importance and promote overall
convergence of the field solution.
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The Initial Mesh and Why Mesh Operations are Often Necessary
The initial mesh is created only by taking into account the design’s geometry.
For example, if only one box is included in the simulation, there will be 5
elements generated inside the box in the initial mesh. Only the corners of the
geometry are used to create the initial mesh – this is constructed by an initial
mesh-maker that only looks at the geometry and knows nothing about the field
structure (there is no solution yet, so there can be no knowledge of the field
solution).
It is often the case that the initial mesh is too coarse in the regions of interest to
produce an efficient, accurate field solution (this is certainly true in transient
simulations). Mesh operations are able to define a manual refinement to the
initial mesh that can improve simulation time and provide enhanced solutions in
some cases.
It is sometimes the case that the initial mesh is overly defined in some places,
due to joints in the geometry or difficult to mesh areas. Mesh operations can
better define the initial mesh in the entire solution region so that the mesh is most
efficient and improvements are possible for both simulation time and solution
accuracy. This can even allow the simulation of geometries that would be
impossible without mesh operations.
Sometimes the initial mesh has difficulties that can be fixed by assigning mesh
operations. This means that problems that are not solvable with the default initial
mesh can sometimes be solved with the addition of a few mesh operations (or
with mesh considerations in mind during geometry creation).
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Applying Mesh Operations
If you want to refine the mesh on a face or volume you do not necessarily have to
generate a solution. Do either of the following after defining mesh operations to
apply mesh operations:
Select Maxwell > Analysis Setup > Apply Mesh Operations, or right-click on
the setup name in the project tree and choose Apply Mesh Operations.
Analyze the design – the mesh operations will take effect when creating the
mesh for the current adaptive pass.
For non-transient simulations, the following behaviors can be expected when
applying mesh operations using either of the above methods:
If a current mesh has been generated, Maxwell will refine it using the
defined mesh operations.
If a current mesh has not been generated, Maxwell will apply the mesh
operations to the initial mesh.
If an initial mesh has not been generated, Maxwell will generate it and
apply the mesh operations to the initial mesh.
For transient simulations, the mesh must be the same from one time step to the
next, therefore, adjusting mesh operations of a transient simulation will force the
simulation to start from time zero.
Select Maxwell > Analysis Setup > Revert to Initial Mesh to clear the mesh
information (as well as any solution information) and revert to the initial mesh.
This can also be accessed by right-clicking on the setup name and choosing
Revert to Initial Mesh.
Mesh
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Mesh Operations
Applying Mesh Operations (Continued)
Note the following:
If the defined mesh operations have been applied to the selected face or
object, the current mesh will not be altered.
Define a new mesh operation rather than modify an existing mesh
operation. Maxwell will not re-apply a modified mesh operation.
Applying mesh operations without solving enables you to experiment with
mesh refinement in specific problem regions without losing design
solutions. You cannot undo the applied mesh operations, but you can
discard them by closing the project without saving them.
Model Resolutions adjust the effective geometry used for the initial mesh
(and the mesh maker used in solving the problem), so, applying a model
resolution will invalidate any solutions and revert to the initial mesh.
Surface approximations only work on the initial mesh. If a surface
approximation is applied with an existing current mesh, it will not take effect
until the mesh has been cleared.
You can look at the mesh by selecting Maxwell > Fields > Plot Mesh…
Mesh… or by rightclicking on Field Overlays in the project tree and choosing Plot Mesh.
Mesh A setup
must be created to define the plot. An object or surface must be selected to
create the mesh plot. Read the section on Data Reporting to find out more about
field plotting on 3D geometries.
You can view mesh statistics by right-clicking on the setup name and choosing
Mesh Statistics (except for Transient simulations), or by going to the Solution
Data or Analysis Profile and choosing the Mesh Statistics tab. This mesh
statistic information represents information about element length (the length of
the sides of each element), the tet volume (the volume of the tetrahedral mesh
elements), and the total number of elements in each object.
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Surface Approximations
Object surfaces in Maxwell may be planar, cylindrical or conical, toroidal,
spherical or splines. The original model surfaces are called true surfaces. To
create a finite element mesh, Maxwell first divides all true surfaces into triangles.
These triangulated surfaces are called faceted surfaces because a series of
straight line segments represents each curved or planar surface.
For planar surfaces, the triangles lie exactly on the model faces; there is no
difference in the location or the normal of the true surface and the meshed
surface. When an object’s surface is non-planar, the faceted triangle faces lie a
small distance from the object’s true surface. This distance is called the surface
deviation, and it is measured in the model’s units. The surface deviation is
greater near the triangle centers and less near the triangle vertices.
The normal of a curved surface is different depending on its location, but it is
constant for each triangle. (In this context, “normal” is defined as a line
perpendicular to the surface.) The angular difference between the normal of the
curved surface and the corresponding mesh surface is called the normal
deviation and is measured in degrees (15deg is the default).
The aspect ratio of triangles used in planar surfaces is based on the ratio of
circumscribed radius to the in radius of the triangle. It is unity for an equilateral
triangle and approaches infinity as the triangle becomes thinner (see the aspect
ratio comments after the usage suggestions for a detailed explanation).
You can modify the surface deviation, the maximum permitted normal deviation,
and the maximum aspect ratio of triangles settings on one or more faces at a
time in the Surface Approximation dialog box. (Click Maxwell > Mesh Operations
> Assign > Surface Approximation.)
The surface approximation settings are applied to the initial mesh.
Below is a diagram that illustrates the surface deviation, “d
d”, and the normal
deviation, “θ”.
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Surface Approximations (Continued)
Since refining curved surfaces is not always enough to produce an efficient
solution, users can control the fidelity to which the initial mesh faceting conforms
to geometric curvature by assigning Surface Approximations to appropriate
objects and/or object faces
Mesh Operations can be assigned from the Maxwell menu, from the Project Tree,
Tree
or from the geometry interface’s context-sensitive menu.

The Surface Approximation options are shown below right. Definitions follow:
Surface Deviation is the maximum spacing,
in drawing units, that the tetrahedral surfaces
may be from the true-curved geometry’s
surface.
Normal Deviation is the maximum angular
difference, in degrees, that a tetrahedral
face’s normal can have from the surface
normal for the true geometry which it is
meant to represent.
Aspect Ratio refers to the maximum allowed
aspect ratio of all faces of all tetrahedra of
the selected object or face. This setting
influences mesh quality rather than actual
meshed volume or surface locations.
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Mesh Operations
Surface Approximations - Usage Suggestions
Do not overspecify.
overspecify.
It is always easier to ‘add’ than subtract mesh, by running more adaptive
passes or by adding supplemental mesh instructions
Too stringent a setting (e.g. Normal Deviation of 1 degree) can result in
poor mesh qualities due to aspect ratios, poor mesh gradients to
surrounding objects, etc.
Use Aspect Ratio settings along with Normal or Surface Deviation settings
For cylindrical type objects where curved and planar faces meet, the
normal and surface deviation settings apply to the curved faces only.
Setting an aspect ratio limit as well (e.g. 4:1) will force a few additional
triangles on the planar faces and help preserve a cleaner overall mesh
Consider using Polyhedrons or Polygons instead if using to ‘reduce’ mesh
If your design has many curved objects which you want only very coarsely
meshed (e.g. individual current-carrying wires with no eddy or proximity
effects, for which 15 degree default normal deviation is unnecessary), and
the geometry is not imported, consider drawing the objects as hexagonal or
even square solids instead.
Surface approximations can be applied to either entire objects or faces (in groups
or individually) or sheets. The surface approximations take effect during the
surface meshing, so it does not matter if an object is selected whole, or if all
faces of an object are selected to apply these operations – either way, the volume
of the object will be meshed after the surface approximation is considered.

Surface Approximations – Aspect ratio comments
There is a different definition of aspect ratio on curved and planar surfaces, but in
either case, the aspect ratio is defined by the triangles on the selected surfaces.
On curved surfaces, the aspect ratio is essentially defined by the height to
width ratio of the triangles. The default minimum aspect ratio is around 1.2
and will tend to form nearly isosceles right triangles on the faceted faces.
The default aspect ratio on curved surfaces is 10.
On planar surfaces, the aspect ratio is equal to the circumscribed radius
over twice the inner radius of each triangle – this produces 1 for an
equilateral triangle. (See the diagram at left to see what is meant by
circumscribed circle and inner circle of a triangle.) The default minimum
aspect ratio is around 2. The default aspect ratio on planar surfaces is 200.
Specifying an aspect ratio of 1 will not produce perfectly equilateral triangles.
Ansoft Maxwell 3D Field Simulator v11 User’s Guide
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Mesh Operations
Curved Geometry Mesh Adaptation
The new graphical drawing interface encourages the use of true-curved drawing
by removing the option to assign a facet count to the construction of primitives
such as circles, cylinders, spheres, and ellipses.
Faceted primitives are available however as polyhedrons and polyhedral
solids, if desired.
Initial meshing is constrained by faceting decisions made by the first pass of the
meshing algorithms. However, adaptive mesh points can be placed ‘anywhere’
on the true-surface of the curved object(s), as shown in the before and after
images below. (Initial mesh left, partly adapted in middle, fully adapted at right.)
Note that regular faceting is not maintained after adaptive mesh alteration.

This example documents a cylindrical, linear magnet oriented in the Z-direction,
with a 200% padded region. The pictures correspond to the initial pass, the 10th
pass, and the 18th pass, with total mesh sizes of 401, 4969, and 14135 mesh
elements for each respective pass.
The increase in mesh size due to the refinement of the cylinder may increase
model fidelity, but it may also increase the solution time.
Note that if you wish to maintain the initial faceting, you can use faceted
primitives during geometry creation.

Ansoft Maxwell 3D Field Simulator v11 User’s Guide

3-11

3
Mesh Operations
Model Resolution
In many models (especially imported models), there are small geometric details
that are present, yet do not affect the field solution to a large extent.
Small features in the geometry can lead to a mesh that is unnecessarily large and
contains long and thin tetrahedra that make the simulation converge slower.
For these reasons and more, Model resolution allows the initial mesh to generate
without including all the little details that can slow down simulations and do not
add to the quality of the solution.
Model resolution improves model convergence and reduces solve times. If in
previous versions the tetrahedron count got too large, the solver could run out of
memory. It would be trying to add meshing elements to areas of the model that
are not important. Now with model resolution, we are able to crank down the
mesh size in order to actually get convergence before memory becomes an
issue.
Model resolution is a length based value that modifies the initial mesh. This
meshing operation allows the user to specify a minimum edge length of any
tetrahedron used for the mesh. By specifying a minimum edge length for a
tetrahedron, the mesher will have to coarsely mesh geometric detail that may not
be important for the field solution. This saves the solver a tremendous amount of
solution time since the initial mesh is smaller, and the mesher does not have to
add mesh elements to areas that are not important for the field solution.
Model resolution can be assigned from the Maxwell menu, from the Project Tree,
Tree
or from the geometry interface’s context-sensitive menu, and is found
immediately below Surface Approximation in the Mesh Operations list.
The Model Resolution dialog is presented below. The suggested value for the
resolution length is determined by the smallest edge length on the selected
objects. This may not be the best value to use, but it might be a good place to
start or, at least, a good reference.
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Mesh Operations
Model Resolution (Continued)
Model resolution capabilities are an expanded capability of the ACIS engine and
are incorporated into the new fault tolerant meshing features. By default, ACIS
uses 1.0e-6 model units as the smallest possibly resolved length. Any two
geometry points that are closer than this absolute resolution length (ResAbs) will
not be resolved by ACIS (so choose the model units appropriately).
By default, if there are difficulties creating an initial mesh, a second initial mesh
will be attempted with a model resolution automatically applied to all model
objects with 100 times the absolute resolution length (ResAbs). If continued
difficulties are experienced, a third initial mesh will be attempted with an
automatic model resolution of 1000 times ResAbs on all model objects. After the
third attempt a mesh failure is reported (you will be able to see three distinct
“mesh_init” lines in the analysis profile).
If the user specifies the model resolution length so that the mesh grossly
misinterprets the model or changes the contacts between the objects, Maxwell
will detect this and report this as an error (“MRL too large or object_name lost all
surface triangles”).
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Mesh Operations
Model Resolution (Continued)
Practical Example
This is part of a complex design that benefited from model resolution. The
grey outline is the reduced model. The pink lines were the original model
details that were removed due to the mesh operation. The original model
had an initial mesh of 184,675 tets. After model resolution, the initial mesh
was 24,691 tets.
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Model Resolution – Usage Suggestions
Apply model resolution to one specific object or a group of objects. Be aware of
what the size of important details are when assigning a new model resolution to
an object or group of objects. Measure various lengths (3D Modeler > Measure)
to survey some nominal lengths for the specific objects. Then, when applying the
model resolution, look at the number suggested in the model resolution
assignment dialog – this number is the smallest edge found on the selected
objects. If this edge is very much smaller than some of the measured and
expected lengths, apply a model resolution that is larger than the suggested
value, yet significantly smaller than the expected length (for example, if you have
an object that is cube-like with 10in sides, yet the smallest length is returned as
1e-6in, you should apply a model resolution of about 0.1in to the object).
If the mesh fails with a vague error, occasionally, applying a model resolution to a
complicated object will assist the initial mesh generation.
Model resolution is very useful when dealing with imported geometries.
When dealing with models that have very high aspect ratios due to small
geometric detail, use a model resolution of 1/10 to 1/20 of the thinnest conductor
to start with. Then adjust the value accordingly.
It is often good to be conservative with model resolutions as a large model
resolution can cause mesh errors.
Model resolution is often most useful when fillets, chamfers, and other small
features are included at joints and corners – these can often be ignored for
electromagnetic simulations and are often small enough to use an appropriate
model resolution.
Always create the initial mesh and look at the surface mesh on objects before
solving the problem. If too aggressive of a model resolution is used, then
important features can be skipped with a model resolution – it is important to
know that the mesh is appropriate for the simulation.
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Length Based Mesh Operations
Length based mesh operations are perhaps the most basic conceptual mesh
refinement option. The assignment of a length based mesh operation limits the
edge length of all tetrahedral elements inside an object or on an object’s surface.
There are two types of length based mesh operations:
On Selection
Inside Selection
The Length-based On-selection refinement will limit the edge length of all
triangles formed on the surface of a selected object (or group of objects), or any
selected faces.
The Length-based Inside-selection refinement will limit the edge length of all
tetrahedral elements inside the selected object (or group of objects).
The assignment of these two types are similar – simply choose either:

Maxwell > Mesh Operations > Assign > On Selection > Length Based … or
Maxwell > Mesh Operations > Assign > Inside Selection > Length Based
Based …
The same dialog appears for both types of assignment - the only difference is
whether it affects all edges within an object or all edges on a face (or surface).

The default value for Maximum Length of Elements is 20% of the largest edgelength of the bounding boxes of each selected face.
For a cube, the default length-based on-selection refinement will produce
about 7 triangles along an edge for a total of about 100 triangles per face.
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Mesh Operations
Length Based Mesh Operations (Continued)
There is one other option that is
provided when assigning a length
based mesh operation that will limit
the number of elements that are
added into the simulation with that
particular mesh refinement.
Restrict the Number of Elements is
a hard limit and no more than the
specified number of elements will be
added to the simulation for the
particular mesh operation than are
specified here (unless the box is
un-checked).
For example: if the restriction to the
length of elements requires 3000
additional elements, yet the number
of elements is restricted to 1000, then only 1000 elements will be added, and the
elements will not meet the Length of Elements requirement (they will be larger
than specified).
This second restriction brings another possible method of adding elements to
objects without regard to the dimension of the object – you may uncheck the
Length of Elements restriction and enter a value for the Number of Elements
restriction, thereby adding a defined number of elements to the simulation.
This second method of adding elements is good and bad, because it allows
control over the number of elements that are inserted into the defined objects for
the particular mesh operation, however, it does not necessarily need to meet any
length requirements (so the elements could still be too large).
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Mesh Operations
Length Based Mesh Operations - Example
This example uses a cube inside a Region with 100% padding. An initial mesh
was created for four different cases of applying length-based mesh operations.
First, a default initial mesh was created without defining any mesh operations.
Second, an initial mesh was created by defining a length-based mesh operation
on the surface of the box at the default maximum length setting (20% edge
length).
Third, an initial mesh was created by defining a length-based mesh operation
inside the box at the default maximum length setting (20% edge length).
Fourth, an initial mesh was created with a length-based mesh operation defined
both on and inside the box at the default maximum length settings – 2 mesh
operations were used.

Default Initial mesh
42 elements

Initial mesh with Length-Based
On-Selection set to 20%
6467 elements

Initial mesh with Length-Based
Inside-Selection set to 20%
6698 elements
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Mesh Operations
Skin Depth Based Mesh Operations
Skin depth based mesh operations
are similar to On-selection lengthbased mesh operations. These
operations are defined by both the
triangles on the surface and a
seeding inside the selected faces.
This refinement method creates
layers of mesh within the
selected surfaces of objects – this
is useful for modeling induced
currents near the surface of a
conducting object.
Skin Depth defines the classical
skin depth value (discussed on
the next page).
Number of Layers defines the
number of layers of points that
are placed at distances according
to the skin depth value.
The Surface Triangle Length is equivalent to the surface length restriction for
length-based refinement.
The Number of Elements is equivalent to the surface element restriction for
length-based refinement. The total number of elements added may exceed this
number by a factor of the Number of Layers.
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Mesh Operations
Skin Depth Based Mesh Operations (Continued)
Instead of inserting a value straight into the skin depth box you can use the
automatic skin depth calculator. Simply fill in the relative permeability and
conductivity of the material, and the measurement frequency to calculate and
insert the skin depth in the skin depth box.

The skin depth of an object is calculated as:

δ=

2

ωσµ 0 µ r

=

1

πfσµ 0 µ r

Currents are concentrated near the surface of the conductor, decaying rapidly
past the skin depth. As the formula above indicates, the skin depth gets smaller
as the frequency increases.
The skin depth based mesh operation is most important in eddy current and
transient simulations where eddy currents and proximity effects are important to
the solution of the simulation.
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Mesh Reduction Techniques
Because the mesh size affects the simulation time, it is often desired to decrease
the total number of elements in a simulation to also decrease total simulation
time. This can be done either at the expense of accuracy or not depending on
the efficiency of the mesh construction. There are several ways to reduce the
mesh size – here are a few examples.
1.

Mitigate large aspect ratios with intelligent geometry construction.
If you have a thin conductor that is far from other objects, this conductor
should not be drawn with curved surfaces. Draw a square or regular
polygon and sweep the square along the path of the conductor. This will
limit the number of triangles necessary in a large aspect ratio object and
will decrease the total number of mesh elements in the simulation.

2.

Add a vacuum container object (dummy object) around all objects in simulation.
This can be a good method to limit the aspect ratios of triangles in the
region. The region needs to be defined a certain distance away from the
components (due to fringing fields) – so this vacuum container can assist
the mesh construction and reduce aspect ratios in the region near to the
structure.

3.

Use a model resolution when it will reduce the size of the mesh but not affect the
solution of the simulation.
Look at the Model Resolution usage suggestions for more information.

4.

Use faceted objects instead of curved surfaces when the surface is not in an area
of high fields.
Faceted objects are easier to mesh and do not add more surface elements
in the same manner as curved objects. This can reduce the mesh
significantly in many cases. Curved surfaces may provide a more true
representation of objects, especially important in areas with large fields.
However, using faceted surfaces even with large fields may be appropriate
and may reduce the mesh in many cases.

5.

Add small mesh operations on conductors and inside magnetic materials.
These will intelligently assist the initial mesh formation, so that less
adaptive passes are necessary.
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Dummy Objects
Placing an object of the same material inside another object does not affect the
field solution for the field solver. However, this additional object defines another
set of surfaces on which the initial mesh will form. This object can also have
additional mesh operations defined on it. For these reasons and more, adding
additional objects may assist the mesh formation process, and, moreover,
increase the amount of control with which you can define the initial mesh. These
objects are called dummy or virtual objects.
Some example places to use dummy objects are the following:
In the gap of a magnetic core.
As a container object for subgroups of objects (such as the inner rotor of an
rotational machine).
As a container object for all objects.
Around a sensor.
Around a surface that will be integrated on.
Around a line that will be used for plotting or calculations.
These dummy object examples serve different purposes – the first three
examples in the above list are intended to improve the general convergence of
the solution, while the last three examples are intended to improve the postprocessing results due to the local mesh in the vicinity of the measurement.
When placing dummy objects, use simple objects (such as rectangles, or regular
polyhedrons) when possible. The size of the dummy objects should be
comparable to the objects around it. The placement is sometimes best to be
placed slightly away from model objects (such as a container object for a
rotational machine – which should have its radius in the middle of the gap, or
equally spaced in the gap with the band object) where the placement creates an
extra layer of mesh elements that allow for better calculation of changing fields.
Other times the placement is best when the dummy object touches the model
objects (such as in the gap of a magnetic core) where the dummy object helps to
both reduce the aspect ratio in the surroundings and to provide an object to apply
mesh operations if desired.
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Linking Mesh - Transient
Every solution type has a mesh linking capability. It is sometimes necessary to
have a simulation linked (when using demagnetization options, or otherwise).
However, it can be beneficial for mesh purposes to link a mesh from another
simulation. This is nowhere as powerful as in a transient simulation.
Because a transient simulation does not adaptively refine its mesh, the mesh that
it uses is constrained the initial mesh. Mesh operations can assist in manually
refining the mesh, but this can be insufficient sometimes. What is provided with
mesh linking, is the power of an adaptively refined mesh used in a transient
simulation.
A transient simulation can be linked to any other simulation with the exact same
geometry. This means that a magnetostatic or eddy current simulation can be
adaptively solved to any accuracy, then the design can be copied and converted
to a transient simulation that uses the same adaptively refined mesh.
In the transient simulation Analysis Setup, simply check Import Mesh.
Mesh When this
box is initially checked on, a dialog appears that sets up the mesh link.

Either select This Project or browse to the desired project file. Then choose the
design name within the selected project and the desired setup name within the
design. Adjust any parameters if necessary and then select OK.
OK The mesh in
the transient simulation will now be identical to the mesh in the selected
project/design/setup.
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Linking Mesh – Non-Transient
There are several important reasons why mesh linking capabilities are important
in non-transient simulations. One example is if DC power flow calculations are
performed, both an electrostatic and a magnetostatic solution are required, and
the mesh must be identical to perform the necessary calculations (see the Field
Calculator topic for an example). Another example is if the exact same mesh is
required in a parametric sweep (especially important with distributed analysis).
Note that if mesh operations are included in a linking simulation, the model
resolution and surface approximations are ignored – however, the length-based
and skin-depth based resolutions are performed. If identical meshes are desired,
delete mesh operations from the linking simulation.
You cannot link two analysis setups within the same design.
Any simulation can be linked to any other simulation with the exact same
geometry (regardless of solution type).
In the Analysis Setup, simply check Import Mesh.
Mesh When this box is initially
checked on, a dialog appears that sets up the mesh link. In the dialog, either
select This Project or browse to the desired project file. Then choose the design
name within the selected project and the desired setup name within the design.
Adjust any parameters if necessary and then select OK.
OK The mesh in the linking
simulation will now be identical to the mesh in the selected project/design/setup.
To guarantee identical meshes in a parametric sweep (with no geometry
variations) do the following:
1. Create a nominal design and solve it.
2. Copy the design and delete mesh operations.
3. Set up the mesh link in the copied design.
4. Create a parametric sweep in the linking design.
This will guarantee that every row of the parametric sweep (assuming no
geometry variations) will use an identical mesh.
To re-initialize the linked data, select Maxwell > Analysis Setup > Clear Linked
Data or right-click on Analysis and choose Clear Linked Data.
Data
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Mesh Failures and Suggestions
There are several different points at which the mesh can fail even if the design
passes all model verifications (no ACIS errors, no non-manifold objects, no
partial intersections).
If an ACIS error or other geometry error occurs, please see the section on
geometry import/healing.
Information about a mesh failure will appear in 3D Modeler > Model Analysis >
Show Analysis Dialog > Last Simulation Mesh…
Mesh….
Generally, the mesh will fail at the point where it tries to match the surface mesh
between objects. The error for this failure will state “Volume Meshing Failed –
Stitching flag <#> failure mode <#>”. This is often the case if surfaces are not
perfectly coincident – if there is a small gap between two objects, the mesh will
have difficulties filling the gap yet retaining a reasonable aspect ratio and form.
Another semi-frequent mesh error is “Incompatible Faceting”. This error is
almost exclusively related to coincident true surfaces. There is some information
on coincident true surfaces in the geometry import/healing section.
You can determine which part of the model is causing problems for the mesh by
making an object non-model (double-click on the object to bring up the Properties
dialog – then deselect the Model check-box). If it meshes, then that object is the
problem.
Can you move the faces of the object or move the object so that it is not
coincident (or is fully coincident)? Try to change the geometry a little bit without
changing the solution.
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Mesh Failures and Suggestions (Continued)
Look in 3D Modeler / Model Analysis > Show Analysis Dialog > Last Simulation Mesh.

Follow up on what the dialog says

Consider eliminating tiny details through healing

Consider aligning faces through healing

Determine which object or part of object is the trouble maker

Vary Model Resolution and Surface Deviation

Try miscellaneous modifications

Redraw as much as is needed to get the geometry to mesh
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3.1
Geometry Import/Healing
Importing a geometry into the 3D modeler and Healing of
geometries
Geometries can be imported from many sources in numerous formats. The
importing of geometry allows complicated structures from CAD type tools to
be used within an electromagnetic simulation. Several points must be kept
in mind when importing geometries, as important details in a CAD tool may
not be important to (or may even be detrimental to) an electromagnetic
simulation. However, with some general guidelines and knowledge of what
to look for, most geometries can be imported from many of the standard
modeling tools.
When geometries are imported, conversions may be necessary to allow the
file format to be read by the 3D Modeler. There may be very small errors in
this conversion process which require healing. Also, the geometry of your
model will determine the meshing characteristics of the simulation, so proper
consideration for meshing should be given when creating, importing, and
healing objects. Several different methods of healing imported objects and
objects created in the 3D Modeler exist and will be discussed.
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3.1
Geometry Import/Healing
Ansoft Maxwell Design Environment
The following features of the Ansoft Maxwell Design Environment are used to
create the models covered in this topic
Edit
Duplicate: Around Axis
3D Solid Modeling
Import
Purge History
Model Analysis: Analyze Objects
Heal
Align Faces
Surface Operations: Move Faces
Boolean Operations: Unite
Subtract
Intersect
Separate Bodies
Mesh Operations
Surface Approximation
Model Resolution
Analysis
Validation Check
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3.1
Geometry Import/Healing

Importing
1.

To import a model, select 3D Modeler > Import … .
1. An Import File dialog pops up, allowing you to browse to the desired
file.
On the left is a list of import files that we support. For some of these
import options you will need an add-on translator feature in your
license file.

1.

On the right is the first available option for healing an imported model.
This will be discussed in detail later.
Select the desired model and then Open.
Open
1. The model should appear in the window with any defined healing
applied to it.
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3.1
Geometry Import/Healing
Characteristics of Imported Objects
The imported objects will appear with the same units and dimensions as exported
(a 1in rod will appear as a 2.54cm rod when imported in those units).
The imported parts will arrive separately if defined separately within the import
file.
The imported parts will retain the names assigned in the import file.
The imported file will be added to the existing model; it will not replace it.
The location of the imported file will be relative to the current coordinate system.
The material assigned to the imported parts will be Not Assigned.
Assigned
The imported model will not have any history defined (the history tree will simply
say Import),
Import so it requires special operations to alter the model.
If the object can not be classified as either solid, sheet or wire (e.g. it is some
combination of the three), the object will be placed in an Unclassified folder in the
history tree.

Suggestions for Exporting Geometries from Drawing Tools
De-feature the model to get rid of details that are not important for EM
simulations (e.g. small rounds, chamfers, fillets, and mechanical connectors).
Small features will result in a large and inefficient mesh.
Use caution when exporting parts with touching (coincident) parts. Overlapping
objects will need adjusting in the imported model.
All parts should fit exactly when you create the assembly (materials should be in
contact where required for electrical connections).
Thin parts may also be successfully removed and replaced later with appropriate
2D objects (e.g. an insulating boundary in place of a thin insulating material).
Do not use the interference fit for your exported assemblies – use the slide fit so
that parts contact exactly as desired in the EM simulation.
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Geometry Import/Healing
Adjusting Imported Geometries
Several methods can be used to adjust an imported geometry – two methods are
described below. Creativity can expand the following basic strategies to adjust
most imported geometries and even allow parametric manipulation of these static
imports.
The first method is to use a combination of the geometry primitives (cylinders,
cubes, etc.) and Boolean expressions to add, subtract, and manipulate the
geometries and therefore allow access to many dimensional variables.
The second method is to use surface commands on the faces of imported objects
as described below.
Select the desired face to adjust (type f while in the 3D Modeler to switch to
face select mode – type o to switch back to object select).
Select 3D Modeler > Surface > Move Faces > Along Normal and type in the
distance the face should move along the normal. This will contract
(negative distance) or expand (positive distance) the object along the
normal of the face. This offset is now a parameterizable distance that is
accessible in the history tree.
The following is an example of how to manipulate an imported object to
adjust the size and position of a hole by selecting the walls of the hole.
Along Normal ->

Original

Caution!
This Move produces errors

Along Vector ->
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3.1
Geometry Import/Healing
Common Model Errors
The following are common model errors that can be encountered during
validation checks and when creating a mesh.
1. api_check_entity() errors. These are errors detected by ACIS and are
geometry and topology errors.
2. non-manifold topology. This detects non-manifold edges and vertices that
are present in the model (non-manifold means that a 3D object has no
thickness at some point – i.e. two faces meet and produce a 2D sheet,
edge, or vertex in a 3D object).
3. Body pair intersection. This detects if pairs of bodies intersect.
4. Small feature detection. This detects small edge length, small face area
and sliver faces.
5. Mis-aligned entities detection. This detects pairs of faces from bodies that
can be aligned to remove interbody intersections. This improves the odds
of mesh success.
6. Mesh failure error display. This is available for single body, body pairs and
last simulation run (all bodies in model). Errors reported by the meshing
module are reported to the user.
Errors of type 1, 2, and 3 must be resolved before the mesh can be applied to the
model.

Imported Geometry Errors
There are two types of errors related most specifically to Imported Parts:
Geometry errors
Topology errors
Geometry errors are errors in definition of the underlying geometry.
Topology errors are errors in how the underlying components like faces, edges,
and vertices are connected.
These errors must be fixed before mesh analysis can be performed.

Ansoft Maxwell 3D Field Simulator v11 User’s Guide

3.1-6

3.1
Geometry Import/Healing
Healing during Geometry Import

In the Import File dialog there is a check box “Heal
Heal Imported Objects”
Objects
This will heal small errors that occur when converting the imported file from its
original format to the format of the 3D Modeler (ACIS SAT v14.0).
There are two modes for healing the imported object – “auto” and “manual”.
Auto healing will try to address ACIS errors and non-manifold errors, the
first two classes of potential errors listed earlier.
Manual healing adds small-feature removal to the auto-healing. You can
remove small features at this stage if you wish. However, the usual
approach is to apply auto-healing at this stage and leave small-feature
removal until later.
After you import a part, you should perform a Validation Check as described in
the next section. This allows you to target problems before the model is altered
or becomes too complex.
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3.1
Geometry Import/Healing
Healing after Geometry Import
Healing can only be performed on objects that have no drawing history other than
“Import
Import”.
Import
If necessary, object history can be deleted through 3D Modeler > Purge History.
If this causes a warning that another object will be deleted, you may need to
purge the history of that other object first, or purge the histories of several objects
simultaneously.
After you import an object, you should perform a validation check Maxwell >
Validation Check. This lets you focus on objects and object pairs that prevent the
mesh from being invoked.

Fixing api_check_entity() errors

3.

The objects that fail api_check_entity() should be analyzed via the Analyize
Objects menu item.
Select the objects that have ACIS errors.
Select 3D Modeler > Model Analysis > Analyze Objects.
The Analysis Options dialog box appears with options for small feature detection.

4.

Select OK to proceed.

1.
2.
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3.1
Geometry Import/Healing
Fixing api_check_entity() errors (Continued)
5.

The Model Analysis dialog box appears.

This dialog produces a list of problems affecting faces, edges, and vertices.
There is also the option to auto zoom to regions where problems exist.
6.

7.
8.

Select the objects marked with “Invalid Entities Found” and click Perform > Heal
Objects. The Healing Options dialog box appears. Adjust parameters as
necessary. Click OK.
OK The Model Analysis dialog box reappears.
In most cases, the objects are healed, and the errors are fixed.
If errors persist, select the edges and faces still containing errors and click
Delete.
Delete This replaces each selected face/edge object by a tolerant edge/vertex,
respectively. In some cases, the replacement of face/edge by edge/vertex fails.
Objects in the Model Analysis can have the following statuses: Good, Null Body,
Analysis not performed, Invalid entities found, Small-entity errors.
Invalid-entity errors are ACIS and non-manifold errors.
Invalid-entity errors must be fixed before a mesh can be generated.
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3.1
Geometry Import/Healing
Fixing non-manifold errors
The main strategy for fixing non-manifold errors is to slightly adjust the geometry
to either add thickness to the object or delete the non-manifold edge.
Find the non-manifold face/edge/vertex either visually or with the Analyze
Objects menu item.
Create a small box to contain the non-manifold edge.
Either unite or subtract the non-manifold object with the small box.
A unite operation will add thickness to the object at the required place.
A subtract operation will delete the non-manifold edge (and a small portion of the
model).
This example shows a non-manifold edge along the z-axis
Create a small box
along edge
Original

Subtract the two objects
to delete the edge

Use engineering judgment to decide whether this edge is in an area of high fields,
and is therefore important. The importance of this area can decide the size of the
box and whether to add or subtract the box.
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3.1
Geometry Import/Healing
Fixing Object Pair intersection
This type of error is easily seen in a Validation Check, where the intersecting
objects are designated with an error notification in the message window.
There are several reasons why objects could be intersecting when they are
imported. If care is taken with drawing and exporting the model from the desired
CAD tool (i.e. no interference fit and no overlap in the model), then the problem is
most likely in the translation.
You can identify which parts of the objects are intersecting by performing an
Intersection of the two objects (in the case where one object is supposed to be
entirely inside the other you should perform a Subtraction to see what part of the
inner object is not within the outer object).
There are several ways to fix this issue. They are as follows:
The easiest circumstance for intersecting objects is if the objects are of the same
material with no need for any distinction between the objects.
To fix intersecting objects of the same material:
1. Select the intersecting objects.
2. Select 3D Modeler > Boolean > Unite.
This will group all the selected objects and there will be no intersection.

In circumstances requiring separate objects the following techniques apply.
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3.1
Geometry Import/Healing
Fixing Object Pair intersection (Continued)
In the circumstance that two adjacent objects are supposed to be coincident
along their respective faces, yet the objects intersect, you can Align Faces.
Faces
Aligning faces will take two different object faces that are very close together and
make them coincident (more on mis-aligned objects will be discussed later).
To align the faces you can use the Analyze Objects tool similar to the process in
fixing api_check_entity() errors.
1. Make sure the histories for intersecting objects are purged.
2. Select the intersecting objects.
3. Select 3D Modeler > Model Analysis > Analyze InterObject Misalignment.
4. Select the individual Object Sets to find which faces are mis-aligned at a
possibly intersecting area.

Select Align Faces to make the faces coincident.
6. Proceed with any other intersecting, mis-aligned faces.
7. Select Close.
Close
This set of operations should fix the intersecting errors.
Run a Validation Check to determine that the aligned objects do not intersect.
5.
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3.1
Geometry Import/Healing
Fixing Object Pair intersection (Continued)
Other circumstances for intersecting objects require manual Boolean
manipulation.
One Boolean method of fixing intersecting objects is to subtract a copy of one
object from the other. In the subtract dialog, the tool object should be the object
of which you want to keep the material definition in the overlapping area.
For example, Box1 and Box2 intersect (picture (a) below).
Box1 is vacuum.
Box2 is copper.
Subtraction with Box1 as the Blank Part and Box2 as the Tool Part will
define the intersecting area as the copper part (picture (b) below).
Subtraction with Box2 as the Blank Part and Box1 as the Tool Part will
define the intersecting area as the vacuum part (picture (c) below).

(a)
(b)
Box2

Box1

(c)

Note: Either Select Clone tool objects before subtracting while subtracting or
Duplicate the object (Select the tool object, then Edit > Duplicate > Around Axis
with an Angle of 0 and a Total number of 2, or use Ctrl+C,
Ctrl+C Ctrl+V if you are in the
original object’s coordinate system) before subtracting to retain both objects after
the subtraction is performed.
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3.1
Geometry Import/Healing
Fixing Object Pair intersection (Continued)
The final method for fixing intersecting objects is a general method that is very
robust, but more advanced.
Take for example a copper wire passing through a box that is defined as vacuum
(pictured below).
To solve this intersection easily, you would just subtract the wire from the box as
described in the last method. However, this creates a situation known as
Coincident True Surfaces, which is difficult for the 3D Modeler to mesh correctly.
One way to get around this difficulty is to create three sections to the wire (one
section within the box and two sections on either side).
The process is as follows:
1. Select the wire and the box.
2. Select Edit > Duplicate > Around Axis with an Angle of 0 and a Total
number of 2 (or Type Ctrl+C,
Ctrl+C then Ctrl+V if you are in the original object’s
coordinate system).
3. Select the copies of both the wire and the box.
4. Select 3D Modeler > Boolean > Intersect to create the middle section.
5. Select the original wire and box.
6. Select 3D Modeler > Boolean > Subtract.
Make sure the wire is in the Blank Parts and the box is in the Tool
Parts, and the Clone tool objects before subtracting box is checked.
7. This creates the outer sections as one part.
8. To separate the outer sections, select the outer-section wire, then Select
3D Modeler > Boolean > Separate Bodies.
The wire is now either completely inside the box or completely outside the box.
There are still coincident surfaces, but these are not true surfaces.
Repeat this process for any other objects that may be intersecting.
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3.1
Geometry Import/Healing
Meshing difficulties
When there are no ACIS errors in the model, no non-manifold objects, and no
partial object intersections, the mesh generator can be invoked to create a valid
mesh for the electromagnetic analysis.
Even if the geometry is valid, mesh generation can still fail.
Possible causes of mesh failure are the presence of very short edges, very small
faces, long and thin sliver faces, and slight misalignments between faces that are
supposed to be coincident.

Small features
Small features in the geometry can lead to a mesh that is unnecessarily large and
contains long and thin tetrahedra that make the simulation converge slower.
Small features may even cause the mesh generation to fail.
By small, we mean details on an object that are thousands of times smaller than
the main features of the object, and that, in most cases, are unintended
consequences of the drawing history in another CAD tool.
Therefore, it is advantageous to remove small features.
This step is entirely optional, and although it could have been accomplished
when an object is imported (by selecting the Manual radio button instead of
Auto),
Auto we present this information here because the previous steps were
necessary to invoke mesh generation, while this one is optional.
To start the small-feature analysis:
1. Select the objects (their histories must be purged) and invoke Object
Analysis through 3D Modeler > Model Analysis > Analyze Objects.
2. In the Model Analysis Window,
Window select Perform > Analyze Objects.
Objects
3. The software will report the smallest edge length and the smallest face
area, and enable you to set thresholds for the detection of short edges,
small faces, and sliver faces.
4. Click OK,
OK and the analysis is performed.
This will report small features in the analyzed objects that can be Deleted
automatically or repaired with Boolean operations in the 3D Modeler.

Ansoft Maxwell 3D Field Simulator v11 User’s Guide

3.1-15

3.1
Geometry Import/Healing
Mis-aligned entities
Objects that touch each other in imported geometries don’t always have wellaligned faces. Often, this is a consequence of the limited level of precision in the
imported file.
Misaligned faces can cause tiny object intersections or tiny gaps between
objects, which in turn can lead to an inefficient mesh or even a failure to create
the mesh.
To repair such misalignments in an automated way take the following steps:
1. Select groups of objects.
2. Select 3D Modeler > Model Analysis > Analyze Interobject Misalignment.
Misalignment
3. This will produce face pairs from different bodies that are slightly
misaligned with respect to eachother.
4. In the window that shows this list, check the box AutoAuto-Zoom to Selection.
Selection
5. Select face pairs from the list to visualize which face pairs are misaligned.
6. When it appears that the faces should be aligned (either they should be
coincident or on the same plane), click Align Faces.
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Geometry Import/Healing
Coincident True Surfaces
True Surfaces are curved surfaces in the 3D Modeler (e.g. spheres have a true
surface, while boxes do not).
Due to the finite nature of the mesh, these true surfaces are approximated with
facets and tetrahedra (as explained in the section on Mesh Operations).
When two true surfaces are coincident the mesh that is constructed for each
object must align on the coincident face. This is difficult for the mesher.
A mesh failure can occur simply because of coincident true surfaces.
A mesh failure does not have to occur while constructing the first mesh –
coincident surface mesh errors can occur on any adaptive pass.
There are different schools of thought to avoiding mesh problems with coincident
true surfaces. Here are a few examples:
1) Avoid true surfaces (e.g. use a regular polyhedron in place of a cylinder –
this is usually not the preferred method).
2) Avoid coincident true surfaces (see the last example in Fixing Object Pair
Intersection for one method to achieve this).
3) Accept the geometry you have imported (or constructed) and try to improve
the chances of producing a usable mesh.
One method of improving the chances of a usable mesh involves increasing the
number of facets on the true surfaces to make it easier for the mesh on each
object to line up. After the mesher reconciles the meshes of the two coincident
faces, the initial mesh size can be reduced to a more manageable size by using
the model resolution. The procedure for this method is outlined in the following.
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3.1
Geometry Import/Healing
Coincident True Surfaces (Continued)
1.

Select the coincident surface (type f in the 3D Modeler to switch to face selection
– type o in the 3D Modeler to switch back to object selection).
1. Select Maxwell > Mesh Operations > Assign > Surface Approximation…
Approximation…

Choose Set maximum normal deviation (angle) and enter a small number
(sometimes 5 deg works well, other times a smaller angle is necessary).
3. Select OK.
OK
4. Proceed assigning surface approximations to other coincident faces.
Select objects (either as a group or sequentially) that have surface
approximations.
1. Select Maxwell > Mesh Operations > Assign > Model Resolution…
Resolution…
2. Enter a number that is half the size of the smallest necessary feature.
3. Select OK.
OK
4. Repeat this assignment for any other objects with too fine a mesh.
2.

2.
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3.2
Mesh Operations Examples
Mesh Operations
This chapter provides details on meshing in the Ansoft Maxwell v.11.0 software.
The following topics are discussed:
Curved Geometry Mesh Adaptation
Faceting Default Settings
Volume Perturbation in FEM Solutions
User-Defining Surface Approximations
Application Recommendations
Model Resolution
Applying Mesh Operations
Examples
The following examples are provided to demonstrate the topics discussed
in the chapter:
Skin effect and adjacent effect for two bars (Eddy Current)
LR Matrix of a bar of PCB (Eddy Current)
3 Phase Linear PM Motor (Transient)
1.5kw 4p24s IPM Synchronous Motor (Transient)
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3.2
Mesh Operations Examples
Curve Mesh Adaptation in Maxwell v11
Maxwell v11 meshes handles curved surfaces differently than prior versions of
Maxwell. Proper understanding of the differences in curved mesh handling and
the advantages of new capabilities in the Maxwell v11 solver are essential to
obtaining accurate results.
The new graphical drawing interface offers the use of true-curved drawing,
by removing the option to assign a facet count to the construction of
primitives such as circles, cylinders, spheres, and ellipses.
Faceted primitives are still suggested as polyhedrons and polyhedral solids
for basic needs. For examples, in rotating motion analysis with Transient
solver, band have to be made as a faceted solid for Transient data
mapping. It Is also required for inner-region in translate motion.
Initial meshing is constrained by faceting decisions made by the first pass
of the meshing algorithms as shown below.

For Maxwell v11 in order to provide more robust meshing with respect to
more complex geometries, the initial faceting selections made for curved
objects are respected throughout the adaptation process, so that the
adapted mesh is a subdivided variation of the same meshed volume as the
initial mesh. An adapted mesh from Maxwell v11 is shown below.
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3.2
Mesh Operations Examples
Faceter Default Settings
In order to keep initial meshes at reasonable sizes, the initial faceting default
setting is to constrain the mesh surface normals to fall within 22.5 degrees of the
true-curved surface normals.
This means that a cylindrical surface would be ‘faceted’ into 16 segments
about its circumference, as illustrated below.
The normal for each flat segment cannot be off by more than 22.5 degrees
from the normal for the curved true surface which that segment’s face is
approximating.

Although aided by the Volume Perturbation technique now used in Maxwell
v11, it is not anticipated that this default faceting will be ‘enough’ for highaccuracy analysis of motors, actuators, sensors etc.
The faceting default does not include a stringent aspect ratio default (note
long triangles on top and bottom cylindrical faces).
The default however is sufficient for many applications in which the curved
geometry is not itself highly critical to the simulation result, yet where more
faceting would result in an unnecessary large initial mesh.
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3.2
Mesh Operations Examples
Introduction of Volume Perturbation to Maxwell Solutions
Despite lower faceting ‘compliance’ to the true-curved geometry as the
adaptation process adds mesh points, Maxwell v11 introduces a new solution
technology that should result in a more accurate solution from far smaller mesh
counts than in prior versions. This technology is referred to as Volume
Perturbation or Volume Correction.
Correction.
In a faceted mesh of a cylindrical solid, small arc-section volumes are ‘lost’
to the cylinder volume and become part of the volume of the cylinder’s
surroundings.
Since the true geometry definition is known before faceting, the deltavolumes represented by each of these sliver regions is computable
The meshing algorithm in Maxwell v11 can provide ‘adjustment factors’ to
both the tetrahedral center-edge node locations and to the appropriate
volumes of the tetrahedra on either side of the curved boundary, so that the
FEM solution proceeds with the right terms even for a loosely-discretized
mesh
The end result is higher accuracy from the same mesh, even before the
benefits of adaptive mesh refinement are taken into account.
Volume Perturbation solutions are always on. No user setting is required to
active them.

Sliver Region (only top surface
mesh outline shown)
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3.2
Mesh Operations Examples
Mesh Operations
Mesh Operations can be assigned from the Maxwell menu, from the Design Tree,
Tree
or from the geometry interface’s context-sensitive menu.

Maxwell v11 can offer user 5 types of Mesh Operations:
On Selection/ Length Based;
On Selection / Skin Depth Based
Inside Selection / Length Based
Surface Approximation
Model Resolution
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3.2
Mesh Operations Examples
On Selection / Length Based
After user selected one or some Objects, this mesh operation can be setup
as a maximum length of the edges of the mesh for it.
The Cylinder with initial mesh below was created
by Draw regular Polyhedron with R = 1 mm, H =
1 mm, Number of segments = 24. The left two fig.
are the meshes on surface and the center crosssection. The right fig. of them are the results after
using the mesh option On Selection / Length
Based 0.1mm.
0.1mm User can see the surface of it
was meshed with small ones on it.
The Default of Maximum Length equals 20% of
the maximum length of the edge of it.

Without Mesh Operation
After Mesh Operation
Meshes on the surfaces

Without Mesh Operation

After Mesh Operation

Meshes on the center cross-section of them
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3.2
Mesh Operations Examples
On Selection / Skin Depth Based
The mesh will be created with the skin depth
effect in the object.
The Cylinder with initial mesh left below was
created by Draw regular Polyhedron with
R = 1 mm, H = 1 mm, No. of segments = 24.
The right one was the results with the setting
in On Selection / Skin Depth Based:
Skin Depth 0.25mm
Number of Layer of Element 4;
Surface Triangle Length 0.4mm.
The inner mesh will be 4 layers where the skin
depth effects will be considered.
if user select Calculate Skin Depth,
Depth the skin
depth will be automaticly calculated due to the
frequency, permeability and conductivity set
by user.

Without Mesh Operation

With Mesh Operation

Forth layer

Third Layer
Second layer
First layer
Cross-section of the mesh
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Mesh Operations Examples
Inside Selection / Length Based
Model Object of any shape can be meshed with this command for
inner mesh creating. It s the most frequently used for manual
mesh. It also can be used for Non Model Objects (Boxes only).
Below is the 2x2x1 mm box with initial
mesh. The right below is result with the
command of Inside Selection / Length
Based 0.25mm

Note:
For some special points or lines where user
have the measured data for comparison,
the Non Model Boxes can be created to
cover all these places and set small lengths
in Inside Selection / Length Based for
enough accuracy.

Without Mesh Operation

With Mesh Operation

Cross-section of the mesh
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3.2
Mesh Operations Examples
Surface Approximation
The Surface Approximation options are shown right Below.
Definitions follow:
Surface Deviation is the maximum
spacing, in drawing units, that the
tetrahedral surfaces may be from the
true-curved geometry’s surface.
Normal Deviation is the maximum
angular difference, in degrees, that a
tetrahedral face’s normal can have from
the surface normal for the true geometry
which it is meant to represent.
Aspect Ratio refers to the maximum
allowed aspect ratio of all faces of all
tetrahedral ofthe selected object or face.
This setting influences mesh quality rather
than actual meshed volume or surface
locations.

The Cylinder with initial mesh on the right is
created by Draw regular Polyhedron with
R = 1 mm, H = 1 mm, No. of segments = 24.

Without Mesh Operation
The right is the result with Maximum Surface
Deviation 0.000125mm

Maximum Surface Deviation
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3.2
Mesh Operations Examples

Here in right Is the result with Maximum
Surface Normal Deviation 5deg

Maximum Surface Normal Deviation
The last in the right is the surface result with
Maximum Aspect Ratio 2

Maximum Aspect Ratio
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3.2
Mesh Operations Examples
Model Resolution
Model resolution is a length based value that modifies the initial mesh. This
meshing operation allows the user to specify a minimum edge length of any
tetrahedron used for the mesh. By specifying a minimum edge length for a
tetrahedron, the mesher will have to coarsely mesh geometric detail that may not
be electrically important. This will save the solver the amount of solution time
since the initial mesh is smaller, and the mesher does not have to add mesh
elements to areas that are not electrically important.
When dealing with models that have very high aspect ratios due to small
geometric detail, use a model resolution of 1/10 to 1/20 of the thinnest conductor
to start with. Then adjust the value accordingly.
Simple example:
There is a small stub (0.2x0.2x0.2mm) on a
cylinder (R=1mm, H=1mm). Below is the initial
mesh without Model Resolution.
Then with Model Resolution 0.3mm,
0.3mm the

mesh of it will be as below right, the stub
will be neglected.

With Mesh Resolution

Without Mesh Operation

Mesh on the surface
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3.2
Mesh Operations Examples
Mesh Operation Examples
EX1. Skin effect and adjacent effect for two bars (Eddy Current)
Model:
Two parallel copper bars (named coil1 &
coil2) are created by Draw regular Polyhedron
with R = 0.15 mm, H = 3 mm, No. of segments
= 12. The distance between their axes is
0.4mm (Gap is 0.1mm)
The air box (3x3x3mm) Is created for analysis
region
Excitations
For each end terminal of bars is set as 1A
current in same Y direction (Design named same )
or Y direction for bar1, -Y direction for bar2 (Design named opposite )
Mesh Operation
Select all surface of bars except their end terminals
as in right,

Then with On Selection / Skin Depth Based;

get in Calculate skin Depth…
Depth… and get the
skin depth = 0.066mm for copper in 1MHz.

Then set Skin Depth Based Refinement
as below:
Skin Depth 0.066mm
Number of Layer of Element 3;
Surface Triangle Length 0.3mm.
and without Number Restriction
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Mesh Operations Examples
EX1. Skin effect and adjacent effect for two bars (Con’t)
Solve Setup
Solve Setup is set as below:

Results
The B & J distribution on the XZ cross-section of two bars will be as below:

B distribution for opposite

J distribution for opposite
With mesh plot
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3.2
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EX2. LR Matrix for print bar (Eddy Current)
Model:
One copper bar (part from PCB, with Length
= 24.5mm, Height = 0.5mm) on the right is
imported. This model will calculate its LR from
1Mhz to 5MHz
An air box (50x24.5x40 mm) Is created as the
analysis region
Mesh Operation
This time we will try using dummy Sheets to mesh the bar with skin depth
meshes.
1. First we make the copy of the bar, and name it as Unnamed_2
2. Using Calculate skin Depth to get the skin depth = 0.029 mm as copper at
5 MHz.
3. Select the Unnamed_2 and do /Edit/Arrange/Offset with -0.029mm.
4. Select all surfaces of the new Unnamed_2 and do /Edit/Surface/Create Objects
form Surfaces. (16 Sheets will be created) All the Sheets will help automesh to
create skin depth meshes at the surface of the copper bar.

Mesh in cross-section of bar
Excitations
For each end terminal of bar is set as 1A current in Y direction
Matrix setup
Select the copper bar and do /Assign Parameters/Matrix with Current1 as
Include
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EX2. LR Matrix for print bar (Eddy Current) (Con’t)
Solve Setup
Solve Setup is set as below: (Set Default In General & Convergence)

Results
The L & R vs. Frequency will be as below:

L vs. Frequency

R vs. Frequency
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EX3. 3ph Linear PM Motor (Transient)
Model:
The basic parts of it are as below:

Band
Permanent Magnets
3 Phase windings

Moving core

Stator core
Mesh Operation
Using Inside Selection / Length
Based to set the length of the maximum
of element edge for each parts as below:
windings: 4 mm;
magnets: 2 mm;
cores : 4 mm:
Band : 3 mm
Please note for each time step the mesh
of the air part in band will be recreated
due to the Inside Selection /
Length Based = 3 mm.

Mesh

Band mesh in XZ cut-plane
at some time step
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EX3. Linear Motor (Transient) (con t)

dsA(A)

Exciation
The current exciation is set as a time function:
U Phase:
Phase: if((Speed>0&&Position<=41.5),
if((Speed>0&&Position<=41.5), 4*pwl_periodic(dsA,Position
4*pwl_periodic(dsA,Position),
pwl_periodic(dsA,Position),
-4*pwl_periodic(dsA,Position
4*pwl_periodic(dsA,Position))
pwl_periodic(dsA,Position))

Position
.
Results

Transient current of 3 phase winding

Force in X direction (|fx|>2N)
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3.2
Mesh Operations Examples
EX3. Linear Motor (Transient) (con t)
Results

Position vs. Time

Speed vs. Time
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EX4. 1.5KW 4p24s IPM Synchronous Motor (Transient)
Model:
Please see the model as below:
3 Phase windings

Permanent
Magnets

5 sheets (dummy)
Rotor core

Circuit model of 3 Phase Y connection
Stator core

Mesh Operation
For making the mesh as 6 levels in motor, 5 dummy circular sheets are created.
Using Inside Selection / Length Based to set the length of the maximum
of element edge for windings: 5 mm;
For rotor and stator, we only do mesh operation for the surfaces along the gap
and set Surface Approximation as below:
Set maximum surface deviation
(length): 2.5 mm;
Set maximum surface deviation
(angle): 3 deg
The mesh of the main parts will
be shown in the right.

Mesh
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3.2
Mesh Operations Examples
EX4. 1.5KW 4p24s IPM Synchronous Motor (Transient) (con t)
Results at Speed = 1800 rpm

Current of 3 phase

Input node voltages

Induced Voltages

Output Torque
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4
Data Reporting
Overview
Ansoft Maxwell has very powerful and flexible data management and plotting
capabilities. Once understood, it will make the whole solution process much
easier, and will help craft the entire problem setup.

Topics of Discussion
2D Plotting
3D Plotting
Field Plotting
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Data Reporting
Data Plotting
Data plotting can take a variety of forms. The most often used format is 2D
Cartesian plotting, but we also have the capability to plot in 3D as well. Below is a
list of all the quantities that can be plotted on various graphs. For definitions of
each of these quantities, see the online help or the respective solution type
chapter.
Magnetostatic,
Magnetostatic, Eddy Current, Electric
Force
Torque
Matrix
Transient
Motion
Position
Force/Torque
Velocity
Winding
Flux Linkage
Induced Voltage
Core Loss
Power Loss
Branch Current (external meter required)
Node Voltage (external meter required)
Fields
Mag_H
Mag_B
Mag_J
Energy Density
Coenergy Density
Apparent Energy Density
Ohmic Loss Density
Named Expressions
NOTE:
NOTE For all data plots of Fields data, a Line must be defined before
creating the plot.
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Data Reporting
Data Plotting (Continued)
Types of Plots:
Rectangular Plot
Data Table
3D Rectangular Plot
To Create a Plot:
1. Select Maxwell > Results > Create Report
2. Select Report Type and Display Type from the selections above
3. Click OK and the Traces Dialog will be displayed – we will go over the
options in this dialog on the next page.
OR
1. Select Maxwell > Results > Create Quick Report (when available)
2. Choose Quick Report type and click OK.
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Data Reporting
Data Plotting (Continued)
Creating a Plot (continued)
4. Context
Design – choose from available designs within a project
Solution – choose from available setups or solution types
Geometry – if plotting Fields data, select an available Line from the
list.
5. Sweep / X / Y Tabs
Sweep – controls the source of the independent variable in the plot.
NOTE: By default, the Report editor selects Use Current
Design and Project variable values.
values This will select the
primary sweep of distance for a field data plot, or an
undefined variable X for other plot types, and the current
simulated values of the project variables
To display a plot with multiple traces for different variable
values, change this setting to Sweep Design and Project
variable values You can then change the primary sweep from
X to a variable if desired. This is useful for looking at
variations and families of curves. Simply select the value in
the Name column next to primary sweep,
sweep and change the
value to whatever you desire.
You can also uncheck the All Points block to select which
values of a variable are to be plotted.
After adjusting the sweeps tab, select Apply To All Selected
Traces.
Traces
X – controls any functional operator on the independent variable (this
is usually set to Use Primary Sweep and defined in the Sweep tab).
Y – select the value to be plotted and any operator.
6. Select Add Trace for as many values as you would like to plot
7. Select Done when finished
An example of a multi-trace plot of the sweep tab shown on the previous page is
shown next
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Data Reporting
Data Plotting (Continued)
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4.1
Field Calculator
Examples of the Field Calculator in Maxwell3D v11
The Field Calculator can be used for a variety of tasks, however its primary
use is to extend the post-processing capabilities within Maxwell beyond the
calculation / plotting of the main field quantities. The Field Calculator makes
it possible to operate with primary vector fields (such as H, B, J, etc) using
vector algebra and calculus operations in a way that is both mathematically
correct and meaningful from a Maxwell’s equations perspective.
The Field Calculator can also operate with geometry quantities for three
basic purposes:
- plot field quantities (or derived quantities) onto geometric entities;
- perform integration (line, surface, volume) of quantities over specified
geometric entities;
- export field results in a user specified box or at a user specified set of
locations (points).
Another important feature of the (field) calculator is that it can be fully script
driven. All operations that can be performed in the calculator have a
corresponding “image” in one or more lines of VBscript code. Scripts are
widely used for repetitive post-processing operations, for support purposes
and in cases where Optimetrics is used and post-processing scripts provide
some quantity required in the optimization / parameterization process.
This document describes the mechanics of the tools as well as the “softer”
side of it as well. So, apart from describing the structure of the interface this
document will show examples of how to use the calculator to perform many
of the post-processing operations encountered in practical, day to day
engineering activity using Maxwell. Examples are grouped according to the
type of solution. Keep in mind that most of the examples can be easily
transposed into similar operations performed with solutions of different
physical nature.
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Ansoft Maxwell Design Environment
The following features of the Ansoft Maxwell Design Environment are used to
interact with the calculator as covered in this topic
Analysis
Electrostatic
DC Conduction
Magnetostatic
Eddy Current
Transient
Results
Output Variables
Field Calculator
Field Overlays:
Named Expressions
Animate
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Description of the interface
The interface is shown in Fig. I1. It is structured such that it contains a stack
which holds the quantity of interest in stack registers. A number of operations
are intended to allow the user to manipulate the contents of the stack or
change the order of quantities being hold in stack registers. The description of
the functionality of the stack manipulation buttons (and of the corresponding
stack commands) is presented below:
- Push repeats the contents of the top stack register so that after the
operation the two top lines contain identical information;
- Pop deletes the last entry from the stack (deletes the top of the stack);
- RlDn (roll down) is a “circular” move that makes the contents of the stacks
slide down one line with the bottom of the stack advancing to the top;
- RlUp (roll up) is a “circular” move that makes the contents of the stacks
slide up one line with the top of the stack dropping to the bottom;
- Exch (exchange) produces an exchange between the contents of the two
top stack registers;
- Clear clears the entire contents of all stack registers;
- Undo reverses the result of the most recent operation.
The user should note that Undo operations could be nested up to the level
where a basic quantity is obtained.
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Solution
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Stack
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Buttons

Fig. I1 Field Calculator Interface
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The calculator buttons are organized in five categories as follows:
-

-

-

-

Input contains calculator buttons that allow the user to enter data in the stack;
sub-categories contain solution vector fields (B, H, J, etc.), geometry(point, line,
surface, volume, coordinate system), scalar, vector or complex constants
(depending on application) or even entire f.e.m. solutions.
General contains general calculator operations that can be performed with
“general” data (scalar, vector or complex), if the operation makes sense; for
example if the top two entries on the stack are two vectors, one can perform the
addition (+) but not multiplication (*);indeed, with vectors one can perform a dot
product or a cross product but not a multiplication as it is possible with scalars.
Scalar contains operations that can be performed on scalars; example of scalars
are scalar constants, scalar fields, mathematical operations performed on vector
which result in a scalar, components of vector fields (such as the X component of
a vector field), etc.
Vector contains operations that can be performed on vectors only; example of
such operations are cross product (of two vectors), div, curl, etc.
Output contains operations resulting in plots (2D / 3D), graphs, data export, data
evaluation, etc.

As a rule, calculator operations are allowed if they make sense from a mathematical
point of view. There are situations however where the contents of the top stack
registers should be in a certain order for the operation to produce the expected result.
The examples that follow will indicate the steps to be followed in order to obtain the
desired result in a number of frequently encountered operations. The examples are
grouped according to the type of solution (solver) used. They are typical medium/higher
level post-processing task that can be encountered in current engineering practice.
Throughout this manual it is assumed that the user has the basic skills of using the
Field Calculator for basic operations as explained in the on-line technical
documentation and/or during Ansoft basic training.
Note: The f.e.m. solution is always performed in the global (fixed) coordinate system.
The plots of vector quantities are therefore related to the global coordinate system and
will not change if a local coordinate system is defined with a different orientation from
the global coordinate system.
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Electrostatic Examples
Example ES1: Calculate the charge density distribution and total
electric charge on the surface of an object
Description: Assume an electrostatic (3D) application with separate metallic
objects having applied voltages or floating voltages. The task is to calculate the
total electric charge on any of the objects.
Calculate/plot the charge density distribution on the object; the sequence of
calculator operations is described below:
Quantity -> D (load D vector into the calculator);
Geometry…
Geometry… -> Surface…
Surface… (select the surface of interest) -> OK
Unit Vec -> Normal (creates the normal unit vector corresponding to the surface
of interest)
Dot (creates the dot product between D and the unit normal vector to the surface
of interest, equal to the surface charge density)
Add … (input “charge_density” as the name) -> OK (creates a named expression
and adds it to the list)
Done (leaves calculator)

(select the surface of interest from the model)
Maxwell -> Fields -> Fields -> Named Expressions (a Selecting calculated
expression window appears)
(select “charge_density” from the list) -> OK (A Create Field Plot window
appears)
Done
Calculate the total electric charge on the surface of an object
Quantity -> D (load D vector into the calculator);
Geometry…
Geometry… -> Surface…
Surface… (select the surface of interest) -> OK
Normal

∫

Eval
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Example ES2: Calculate the Maxwell stress distribution on the
surface of an object
Description: Assume an electrostatic application (for ex. a parallel plate capacitor
structure). The surface of interest and adjacent region should have a fine finite
element mesh since the Maxwell stress method for calculation the force is quite
sensitive to mesh.
The Maxwell electric stress vector has the following expression for objects
without electrostrictive effects:
r r r 1r
TnE = D ⋅ n E − n εE 2
2
where the unit vector n is the normal vector to the surface of interest. The
sequence of calculator commands necessary to implement the above formula is
given below.

(

)

Quantity -> D
Geometry…
Geometry… -> Surface…
Surface… (select the surface of interest) -> OK
Unit Vec -> Normal (creates the normal unit vector corresponding to the surface
of interest)
Dot
Quantity -> E
* (multiply)
Geometry…
Geometry… -> Surface…
Surface… (select the surface of interest) -> OK
Unit Vec -> Normal (creates the normal unit vector corresponding to the surface
of interest)
Number…
Number… ->Scalar (0.5) OK
*
Constant -> Epsi0
*
Quantity -> E
Push
Dot
*
- (minus)
Continued on next page.
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Example ES2: Continued
Add … (input “stress” as the name) -> OK (creates a named expression and adds
it to the list)
Done (leaves calculator)

(select the surface of interest from the model)
Maxwell -> Fields -> Fields -> Named Expressions (a Selecting calculated
expression window appears)
(select “stress” from the list) -> OK (A Create Field Plot window appears)
Done
If an integration of the Maxwell stress is to be performed over the surface of
interest, then use the Named Expression in the following calculator sequence:

(select “stress” from the Named Expressions list)
Copy to stack (inserts the named expression to the stack)
Geometry…
Geometry… -> Surface…
Surface… (select surface of interest) -> OK
Normal

∫
Eval

Note: The surface in all the above calculator commands should lie in free space
or should coincide with the surface of an object surrounded by free space
(vacuum, air). It should also be noted that the above calculations hold true in
general for any instance where a volume distribution of force density is equivalent
to a surface distribution of stress (tension):
r
r
r
F = ∫ fdv = ∫ Tn dS
vΣ

Σ

where Tn is the local tension force acting along the normal direction to the
surface and F is the total force acting on object(s) inside Σ.
The above results for the electrostatic case hold for magnetostatic applications if
the electric field quantities are replaced with corresponding magnetic quantities.
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Current flow Examples
Example CF1: Calculate the resistance of a conduction path between
between
two terminals
Description: Assume a given conductor geometry that extends between two
terminals with applied DC currents.
In DC applications (static current flow) one frequent question is related to the
calculation of the resistance when one has the field solution to the conduction
(current flow) problem. The formula for the analytical calculation of the DC
resistance is:
ds
RDC = ∫
σ (s ) ⋅ A(s )
C
where the integral is calculated along curve C (between the terminals) coinciding
with the “axis” of the conductor. Note that both conductivity and cross section
area are in general function of point (location along C). The above formula is not
easily implementable in the general case in the field calculator so that alternative
methods to calculate the resistance must be found.
One possible way is to calculate the resistance using the power loss in the
respective conductor due to a known conduction current passing through the
conductor.
r
r r
r
P
J
R DC = 2
where power loss is given by P = ∫ E ⋅ J dV = ∫ ⋅ J dV
V
I DC
σ
V
The sequence of calculator commands to compute the power loss P is given
below:
Quantity -> J
Push
Number…
Number… -> Scalar (1e7) OK (conductivity assumed to be 1e7 S/m)
/ (divide)
Dot
Geometry…
Geometry… -> Volume…
Volume… (select the volume of interest) -> OK

∫

Eval
The resistance can now be easily calculated from power and the square of the
current.
Continued on next page.
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There is another way to calculate the resistance which makes use of the well
known Ohm’s law.
U
R DC =
I
Assuming that the conductor is bounded by two terminals, T1 and T2 (current
through T1 and T2 must be the same), the resistance of the conductor (between
T1 and T2) is given the ratio of the voltage differential U between T1 and T2 and
the respective current, I . So it is necessary to define two points on the
respective terminals and then calculate the voltage at the two locations (voltage
is called Phi in the field calculator). The rest is simple as described above.

Example CF2: Export the field solution to a uniform grid
Description: Assume a conduction problem solved. It is desired to export the
field solution at locations belonging to a uniform grid to an ASCII file.
The field calculator allows the field solutions to be exported regardless of the
nature of the solution or the type of solver used to obtain the solution. It is
possible to export any quantity that can be evaluated in the field calculator.
Depending on the nature of the data being exported (scalar, vector, complex),
the structure of each line in the output file is going to be different. However,
regardless of what data is being exported, each line in the data section of the
output file contains the coordinates of the point (x, y, z) followed by the data
being exported (1 value for a scalar quantity, 2 values for a complex quantity, 3
values for a vector in 3D, 6 values for a complex vector in 3D)
Continued on next page.
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To export the current density vector to a grid the field calculator steps are:
Quantity J
Export…
Export… -> On Grid (then fill in the data as appropriate, see Fig. CF2)
OK

Fig. CF2 Define the size of the export region (box) and spacing within
Select Calculate grid points and define minimum, maximum & spacing in all 3
directions X, Y, Z as the size of the rectangular export region (box) and the
spacing between locations. By default the location of the ASCII file containing
the export data is in the project directory. Clicking on the browse symbol one
can also choose another location for the exported file.
Note: One can export the quantity calculated with the field calculator at user
specified locations by selecting Input grid points from file. In that case the ASCII
file containing on each line the x, y and z coordinates of the locations must exist
prior to initiating the export-to-file command.
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Example CF3: Calculate the conduction current in a branch of a
complex conduction path
Description: There are situations where the current splits along the conduction
path. If the nature of the problem is such that symmetry considerations cannot
be applied, it may be necessary to evaluate total current in 2 or more parallel
branches after the split point. To be able to perform the calculation described
above, it is necessary to have each parallel branch (where the current is to be
calculated) modeled as a separate solid.
Before the calculation process is started, make sure that the (local) coordinate
system is placed somewhere along the branch where the current is calculated,
preferably in a median location along that branch. In more general terms, that
location is where the integration is performed and it is advisable to choose it far
from areas where the current splits or changes direction, if possible.
Here is the process to be followed to perform the calculation using the field
calculator.
Quantity -> J
Geometry…
Geometry… -> Volume…
Volume… (choose the volume of the branch of interest) OK
Domain (this is to limit the subsequent calculations to the branch of interest
only)
Geometry…
Geometry… -> Surface…
Surface… yz (choose axis plane that cuts perpendicular to the
branch) OK
Normal

∫
Eval
The result of the evaluation is positive or negative depending on the general
orientation of the J vector versus the normal of the integration surface (S). In
mathematical terms the operation performed above can be expressed as:
r r
I = ∫ J ⋅ n dS
S

Note: The integration surface (yz, in the example above) extends through the
whole region, however because of the “domain” command used previously, the
calculation is restricted only to the specified solid (that is the S surface is the
intersection between the specified solid and the integration plane).
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Magnetostatic examples
Example MS1: Calculate (check) the current in a conductor using
Ampere’
Ampere’s theorem
Description: Assume a magnetostatic problem where the magnetic field is
produced by a given distribution of currents in conductors. To calculate the
current in the conductor using Ampere’s theorem, a closed polyline (of arbitrary
shape) should be drawn around the respective conductor. In a mathematical
form the Ampere’s theorem is given by:
r r
I SΓ = ∫ H ⋅ ds
Γ

where Γ is the closed contour (polyline) and SΓ is an open surface bounded by
Γ but otherwise of arbitrary shape. ISΓ is the total current intercepting the surface
S Γ.
To calculate the (closed) line integral of H, the sequence of field calculator
commands is:
Quantity -> H
Geometry…
Geometry… -> Line (choose the closed polygonal line around the conductor) OK
Tangent

∫
Eval
The value should be reasonably close to the value of the corresponding current.
The match between the two can be used as a measure of the global accuracy of
the calculation in the general region where the closed line was placed.
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Example MS2: Calculate the magnetic flux through a surface
Description: Assume the case of a magnetostatic application. To calculate the
magnetic flux through an already existing surface the sequence of calculator
commands is:
Quantity -> B
Geometry…
Geometry… -> Surface…
Surface… (specify the integration surface) OK
Normal

∫
Eval
The result is positive or negative depending on the orientation of the B vector
with respect to the normal to the surface of integration.
The above operation corresponds to the following mathematical formula for the
magnetic flux:
r r
Φ S = ∫ B ⋅ n dA
S

Example MS3: Calculate components of the Lorentz force
Description: Assume a distribution of magnetic field surrounding conductors with
applied DC currents. The calculation of the components of the Lorentz force has
the following steps in the field calculator.
Quantity -> J
Quantity -> B
Cross
Scalar -> ScalarX
Geom -> Volume … (specify the volume of interest)

OK

∫
Eval
The above example shows the process for calculating the X component of the
Lorentz force. Similar steps should be performed for all components of interest.
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Example MS4: Calculate the distribution of relative permeability in
nonlinear material
Description: Assume a non-linear magnetostatic problem. To plot the relative
permeability distribution inside a non-linear material the following steps should
be taken:
Quantity -> B
Scal?
Scal? -> ScalarX
Quantity -> H
Scal?
Scal? -> ScalarX
Constant -> Mu0
* (multiply)
/ (divide)
Smooth
Add … (input “rel_perm” as the name)
OK (creates a named expression
and adds it to the list)
Done (leaves calculator)

(select the surface of interest from the model)
Maxwell -> Fields -> Fields -> Named Expressions (a Selecting calculated
expression window appears)
(select “rel_perm” from the list) -> OK (a Create Field Plot window appears)
Done

Note: The above sequence of commands makes use of one single field
component (X component). Please note that any spatial component can be used
for the purpose of calculating relative permeability in isotropic, non-linear soft
magnetic materials. The result would still be the same if we used the Y
component or the Z component. However, this does not apply for anisotropic
materials. The “smoothing” also used in the sequence is also recommended
particularly in cases where the mesh density is not very high.
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Frequency domain (AC) Examples
Example AC1: Calculate the radiation resistance of a circular loop
loop
Description: Assume a circular loop of radius 0.02 m with an applied current
excitation at 1.5 GHz;
The radiation resistance is given by the following formula:
Rr =

Pav
2
I rms

Pav =

(

)

(

)

r r*
r
r *
 1
1
1
Re
×
=
Re
∇
×
×
E
H
dS
H
H

dS
2 ∫∫
2 ∫∫
 jωε 0

S
S

where S is the outer surface of the region (preferably spherical), placed
conveniently far away from the source of radiation.
Assuming that a half symmetry model is used, no ½ is needed in the above
formula. The sequence of calculator commands necessary for the calculation of
the average power is as follows:
Quantity -> H
Curl
Number…
Number… -> Complex (0 , -12) OK
*
Quantity -> H
Complex -> Conj
Cross
Complex -> Real
Geometry…
Geometry… -> Surface…
Surface… (select the surface of interest) -> OK
Normal

∫
Eval

Note: The integration surface above must be an open surface (radiation surface)
if a symmetry model is used. Surfaces of existing objects cannot be used since
they are always closed. Therefore the necessary integration surface must be
created in the example above using 3DModeler > Surface > Create Object From
Face command.
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Example AC2: Calculate/Plot the Poynting vector
Description: Same as in Example AC1.
To obtain the Poynting vector the following sequence of calculator commands is
necessary:
Quantity -> H
Curl
Number…
Number… -> Complex (0 , -12) OK
*
Quantity -> H
Complex -> Conj
Cross

To plot the real part of the Poynting vector the following commands
should be added to the above sequence:
Complex -> Real
Number…
Number… -> Scalar (0.5) OK
*
Add … (input “Poynting” as the name) -> OK (creates a named expression and
adds it to the list)
Done (leaves calculator)

(select the surface of interest from the model)
Maxwell -> Fields -> Fields -> Named Expressions (a Selecting calculated
expression window appears)
(select “Poynting” from the list) -> OK (a Create Field Plot window appears)
Done
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Example AC3: Calculate total induced current in a solid
Description: Consider (as example) the device in Fig. AC3.

a) full model
b) quarter model
Fig. AC3 Geometry of inductor model
Assume that the induced current through the surface marked with an arrow in
the quarter model is to be calculated. Please note that there is an expected net
current flow through the market surface, due to the symmetry of the problem. As
a general recommendation, the surface that is going to be used in the process
of integrating the current density should exist prior to solving the problem. In
some cases this also means that the geometry needs to be created in such a
way so that the particular post-processing task is made possible. Once the
object containing the integration surface exists, use the 3DModeler > Surface >
Create Object From Face command to create the integration surface necessary
for the calculation. Make sure that the object with expected induced currents
has non-zero conductivity and that the eddy-effect calculation was turned on.
Assuming now that all of the above was taken care of, the sequence of
calculator commands necessary to obtain separately the real part and the
imaginary part of the induced current is described on the next page:
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For the real part of the induced current:
Quantity -> J
Complex -> Real
Geometry…
Geometry… -> Surface -> (select the previously defined integration surface) OK
Normal

∫

Eval
For the imaginary part of the induced current:
Quantity -> J
Complex -> Imag
Geometry…
Geometry… -> Surface -> (select the previously defined integration surface) OK
Normal

∫
Eval
If instead of getting the real and imaginary part of the current , one desires to do
an “at phase” calculation, the sequence of commands is:
Quantity -> J
Number…
Number… -> Scalar (45) OK (assuming a calculation at 45 degrees phase
angle)
Complex -> AtPhase
Geometry…
Geometry… -> Surface -> (select the previously defined integration surface) OK
Normal

∫

Eval
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Example AC4: Calculate (ohmic
(ohmic)
ohmic) voltage drop along a conductive
path
Description: Assume the existence of a conductive path (a previously defined
open line totally contained inside a conductor). To calculate the real and
imaginary components of the ohmic voltage drop inside the conductor the
following steps should be followed:
For the real part of the voltage:
Quantity -> J
Matl…
Matl… -> Conductivity -> Divide OK
Complex -> Real
Geometry…
Geometry… -> Line -> (select the applicable line) OK
Tangent

∫
Eval
For the imaginary part of the voltage:
Quantity -> J
Matl…
Matl… -> Conductivity -> Divide OK
Complex -> Imag
Geometry…
Geometry… -> Line -> (select the applicable line) OK
Tangent

∫

Eval
To calculate the phase of the voltage manipulate the contents of the stack so
that the top register contains the real part of the voltage and the second register
of the stack contains the imaginary part. To calculate phase enter the following
command:
Trig -> Atan2
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Example AC5: Calculate the AC resistance of a conductor
Description: Consider the existence of an AC application containing conductors
with significant skin effect. Assume also that the mesh density is appropriate for
the task, i.e. mesh has a layered structure with 1-2 layers per skin depth for 3-4
skin depths if the conductor allows it. Here is the sequence to follow in order to
calculate the total power dissipated in the conductor of interest.
Quantity -> OhmicLoss
Geometry…
Geometry… -> Volume -> (specify volume of interest) OK
Eval

∫
Note: To obtain the AC resistance the power obtained above must be divided by
the squared rms value of the current applied to the conductor. Note that in the
Boundary/Source Manager peak values are entered for sources, not rms values.
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Time Domain Examples
Example TD1: Plotting Transient Data
Description: Assume a time domain (transient application) requiring the display
of induced current as a function of time. Do this before solving if fields are not
saved at every step, or any time if fields are available.
Quantity -> J
Geometry…
Geometry… -> Surface -> (enter the surface of interest) OK
Normal

∫
Add … (input “Induced_Current” as the name) -> OK (creates a named
expression and adds it to the list)
Done (leaves calculator)
Maxwell -> Results -> Output Variables…
Variables… (an Output Variables Dialogue
appears)

(select Fields from the Report Type pull down menu)
(select Calculator Expressions as the Category and “Induced_Current” as the
Quantity)
Insert Quantity Into Expression

(name your expression by writing “Ind_Cur” in the Name textbox)
Add (adds an output variable and its expression to the list)
Done
This Output Variable can be accessed two ways. First, it can be accessed
directly in the reports - make sure that the Reports Type is set to Fields (not
Transient). Second, it can be included in the Solve setup under the Output
Variables tab (which also makes it available in the reports with the Reports Type
set to Transient).
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Example TD2: Find the maximum/minimum field value/location
Description: Consider a solved transient application. To find extreme field
values in a given volume and/or the respective locations follow these steps.
To get the value of the maximum magnetic flux density in a given volume:
Quantity -> B
Mag
Geometry…
Geometry… -> Volume -> (enter volume of interest) OK
Max -> Value…
Value…
Eval
To get the location of the maximum:
Quantity -> B
Mag
Geometry…
Geometry… -> Volume -> (enter volume of interest) OK
Max -> Position…
Position…
Eval
The process is very similar when searching for the minimum. Just replace the
Max with Min in the above sequences.
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Example TD3: Combine (by summation) the solutions from two time
steps
Description: Assume a linear model transient application. It is possible to add
the solution from different time steps if you follow these steps:
First, set the solution context to a certain time step, say t1 by selecting View >
Set Solution Context…
Context… and choosing an appropriate time from the list.
Then in the calculator:
Quantity -> B
Write (enter the name of the file) OK
Exit the calculator and choose a different time step, say t2.
Then, in the calculator:
Quantity -> B
Read (specify the name of the .reg file to be read in) OK
+ (add)
Mag
Geometry…
Geometry… -> Surface -> (enter surface of interest) OK

Note 1: For this operation to succeed it is necessary that the respective meshes
are identical. This condition is of course satisfied in transient applications
without motion since they do not have adaptive meshing. It should be noted that
this capability can be used in other solutions sequences –say static- if the
meshes in the two models are identical.
The whole operation is numeric entirely, therefore the nature of the quantities
being “combined” is not checked from a physical significance point of view. It is
possible to add for example an H vector solution to a B vector solution. This
doesn’t have of course any physical significance, so the user is responsible for
the physical significance of the operation.
For the particular case of time domain applications it is possible to study the
“displacement” of the (vector) solution from one time step to another, study the
spatial orthogonality of two solution, etc. It is a very powerful capability that can
be used in many interesting ways.
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Example TD3: Continued
Note 2: As another example of using this capability please consider another
typical application: power flow in a given device.
As example one can consider the case of a cylindrical conductor above the
ground plane with 1 Amp current, the voltage with respect to the ground being
1000 V. As well known, one can solve separately the magnetostatic problem (in
which case the voltage is of no consequence, and only magnetic fields are
calculated) and the electrostatic problem (in which case only the electric fields
are calculated). With Maxwell it is possible to “combine” the two results in the
post-processing phase if the assumption that the electric and magnetic fields
are totally separated and do not influence each other. One possible reason that
such an operation is meaningful from a physical point of view might be the need
for an analysis of power flow.
Assume that a magnetostatic and electrostatic problem are created with
identical geometries. Link the mesh from one simulation to the mesh of the
other, so that they will be identical – this can be accomplished in the Setup tab of
the Analysis Setup properties. Select the Import mesh box, and clicking on the
Setup Link … button. Then specify the target Design and Solution in the Setup
Link dialog. To assure that the mesh is identical in both the linked solution and
the target solution, make sure to set the Maximum Number of Passes to one (1)
in the linked solution.
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Example TD3: Continued
Solve both these models and access the electrostatic results. Export the
electric field solution as follows:
Quantity -> E
Write…
Write… (enter the name of the .reg file to contain the solution) OK
Access now the solution of the magnetostatic problem and perform the following
operations with the calculator after placing the coordinate system in the median
plane of the conductor (yz plane if the conductor is oriented along x axis):
Read…
Read… (specify the name of the file containing the electrostatic E field) OK
Quantity -> H
Cross
Geometry…
Geometry… -> Volume -> background OK
Domain
Geometry…
Geometry… -> Surface -> yz
Normal

∫
Eval
A result around 1000 W should be obtained, corresponding to 1000 W of power
being transferred along the wire but NOT THROUGH THE WIRE! Indeed the
power is transmitted through the air around the wire (the Poynting vector has
higher values closer to the wire and decays in a radial direction). The wire here
only has the role of GUIDING the power transfer! The wire absorbs from the
electromagnetic field only the power corresponding to the conduction losses in
the wire.
When the integration of the Poynting vector was performed above, a domain
operation was also performed limiting the result to the background only. This
shows clearly that the distribution of the Poynting vector in the background is
responsible for the power transfer. Displaying the Poynting vector in different
transversal planes to the wire shows also the direction of the power transfer.
This type of analysis can be very useful in studying the power transfer in
complex devices.
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Example TD4: Create an animation from saved field solutions
Description: Assume a solved time domain application. To create an animation
file of a certain field quantity extracted from the saved field solution (say
magnitude of conduction current density J) proceed as described below.

(select surface of interest)
Maxwell -> Fields -> Fields -> J -> Mag_J
Done
Maxwell -> Fields -> Animate … (a Setup Animation dialogue appears)

(select desired time steps from those available in the list)
Done
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Miscellaneous Examples
Example M1: Calculation of volumes and areas
To calculate the volume of an object here is the sequence of calculator
commands:
Number…
Number… -> Scalar (1) OK (enters the scalar value of 1)
Geometry…
Geometry… -> Volume…
Volume… (enter the volume of interest) OK

∫

Eval
The result is expressed in m3.

To calculate the area of a surface here is the sequence of calculator commands:
- Number…
Number… -> Scalar (1) OK (enters the scalar value of 1)
- Geometry…
Geometry… -> Surface…
Surface… (enter the surface of interest) OK

∫
Eval
The result is expressed in m2.
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Chapter 5.0
Chapter 5.0 – Magnetostatic Examples
5.1 – Magnetic Force
5.2 – Inductance Calculation
5.3 –Stranded Conductors
5.4 – Equivalent Circuit Extraction (ECE) Linear Movement
5.5 – Anisotropic Materials
5.6 – Symmetry Boundaries
5.7 – Permanent Magnet Magnetization
5.8 – Master/Slave boundaries
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5.1
Example (Magnetostatic) – Magnetic Force
Magnetic Force
This example is intended to show you how to create and analyze a
magnetostatic problem with a permanent magnet to determine the force
exerted on a steel bar using the Magnetostatic solver in the Ansoft Maxwell
3D Design Environment.
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Example (Magnetostatic) – Magnetic Force
Ansoft Maxwell Design Environment
The following features of the Ansoft Maxwell Design Environment are used to
create the models covered in this topic
3D Solid Modeling
Primitives:: Box
Surface Operations: Section
Boolean Operations: Subtract, Unite, Separate Bodies
Boundaries/Excitations
Current: Stranded
Analysis
Magnetostatic
Results
Force
Field Overlays:
Vector B
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Example (Magnetostatic) – Magnetic Force
Getting Started
Launching Maxwell
1.

To access Maxwell, click the Microsoft Start button, select Programs,
Programs and select
Ansoft and then Maxwell 11.

Setting Tool Options
To set the tool options:
Note: In order to follow the steps outlined in this example, verify that the
following tool options are set :
1. Select the menu item Tools > Options > Maxwell Options
2. Maxwell Options Window:
1. Click the General Options tab
Use Wizards for data entry when creating new boundaries:: 
Checked
Duplicate boundaries with geometry::  Checked
2. Click the OK button
3. Select the menu item Tools > Options > 3D Modeler Options.
Options
4. 3D Modeler Options Window:
1. Click the Operation tab
Automatically cover closed polylines::  Checked
2. Click the Drawing tab
Edit property of new primitives::  Checked
3. Click the OK button
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Opening a New Project
To open a new project:
In an Ansoft Maxwell window, click the  On the Standard toolbar, or
select the menu item File > New.
From the Project menu, select Insert Maxwell Design.

Set Solution Type
To set the solution type:
Select the menu item Maxwell > Solution Type
Solution Type Window:
Choose Magnetostatic
Click the OK button

Ansoft Maxwell 3D Field Simulator v11 User’s Guide

5.1-4

5.1
Example (Magnetostatic) – Magnetic Force
Creating the 3D Model
Set Model Units
To set the units:
1. Select the menu item 3D Modeler > Units
2. Set Model Units:
1. Select Units: mm
2. Click the OK button

Set Default Material
To set the default material:
1. Using the 3D Modeler Materials toolbar, choose Select
2. Select Definition Window:
1. Type steel_1008 in the Search by Name field
2. Click the OK button
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Create Core
To create a box:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
X: 0.0,
0.0 Y: 0.0,
0.0 Z: -5.0,
5.0 Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the box:
dX: 10.0,
10.0 dY: -30.0,
30.0 dZ: 10.0,
10.0 Press the Enter key
To fit the view:
1. Select the menu item View > Fit All > Active View.
Duplicate Box:
1. Select the menu item Edit > Duplicate Along Line
2. Using the coordinate entry fields, enter the first point
X: 0.0,
0.0 Y: 0.0,
0.0 Z: 0.0,
0.0 Press the Enter key
3. Using the coordinate entry fields, enter the second point
dX: 30.0,
30.0 dY: 0.0,
0.0 dZ: 0, Press the Enter key
4. Duplicate Along Line Window
1. Total Number: 2
2. Click the OK button
To create the core:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
X: 0.0,
0.0 Y: -30.0,
30.0 Z: -5.0,
5.0 Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the box:
dX: 50.0,
50.0 dY: -10.0,
10.0 dZ: 10.0,
10.0 Press the Enter key
To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Core
3. Click the OK button
To fit the view:
1. Select the menu item View > Fit All > Active View.
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Group the Core
To select the objects
1. Select the menu item Edit > Select All
2. Select the menu item, 3D Modeler > Boolean > Unite
To fit the view:
1. Select the menu item View > Fit All > Active View.

Duplicate the Core
To select the objects
1. Select the menu item, Edit > Duplicate Mirror
2. Using the coordinate entry fields, enter the first point
X: 0.0,
0.0 Y: 0.0,
0.0 Z: 0.0,
0.0 Press the Enter key
3. Using the coordinate entry fields, enter the normal point
dX: 0.0,
0.0 dY: 1.0,
1.0 dZ: 0.0,
0.0 Press the Enter key
To fit the view:
1. Select the menu item View > Fit All > Active View.

Group the Core
To select the objects
1. Select the menu item Edit > Select All
2. Select the menu item, 3D Modeler > Boolean > Unite
To fit the view:
1. Select the menu item View > Fit All > Active View.
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Create Bar
To create the bar:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
X: 51.0,
51.0 Y: -40.0,
40.0 Z: -5.0,
5.0 Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the box:
dX: 10.0,
10.0 dY: 80.0,
80.0 dZ: 10.0,
10.0 Press the Enter key
To parameterize the object:
1. Select the Command tab from the Properties window
2. For Position,
Position type: 50mm+mx, -40.0, -5.0,
5.0 Click the Tab key to accept
Add Variable mx:
mx 1mm,
1mm Click the OK button
To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Bar
3. Click the OK button
To fit the view:
1. Select the menu item View > Fit All > Active View.

Set Default Material
1.
2.

Using the 3D Modeler Materials toolbar, choose Select
Select Definition Window:
1. Type copper in the Search by Name field
2. Click the OK button
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Create Coil
To create the coil:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
X: 45.0,
45.0 Y: 30.0,
30.0 Z: 10.0,
10.0 Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the box:
dX: -20.0,
20.0 dY: -60.0,
60.0 dZ: -20.0,
20.0 Press the Enter key
To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: coil
3. Click the OK button
To select the object for subtract
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
1. Select the objects named: Coil, Core
2. Click the OK button
To complete the coil:
1. Select the menu item 3D Modeler > Boolean > Subtract
2. Subtract Window
1. Blank Parts: Coil
2. Tool Parts: Core
3. Clone tool objects before subtracting::  Checked
4. Click the OK button
To fit the view:
1. Select the menu item View > Fit All > Active View.

Insulate Coil
To assign an insulating boundary to prevent current leakage out of the coil:
1. Select the coil Edit > Select > By Name > Coil
2. Click the OK button
3. Select the menu item Maxwell > Boundaries > Assign > Insulating
4. Insulating Boundary
1. Name: Insulating1
2. Click the OK button

Ansoft Maxwell 3D Field Simulator v11 User’s Guide

5.1-9

5.1
Example (Magnetostatic) – Magnetic Force
Create Excitation
Section Object to create a 2D sheet object for assigning current
1. Select the coil Edit > Select > By Name > Coil
2. Click the OK button
3. Select the menu item 3D Modeler > Surface > Section
1. Section Plane: XY
2. Click the OK button
Separate Bodies
1. Select the menu item 3D Modeler > Boolean > Separate Bodies
2. Delete the extra sheet located closest to the bar.
3. Rename the remaining sheet to terminal and select it.
Assign Excitation
1. Select the menu item Maxwell > Excitations > Assign > Current
2. Current Excitation : General
1. Name: Current1
2. Value: c1
3. Type: Stranded
4. Current Direction: positive Z direction.
direction (Use Swap Direction button)
3. Click the OK button
4. Add Variable Window
1. Value: 100A
2. Click the OK button

Calculate Force
To select the object
Select the menu item Edit > Select > By Name
Select Object Dialog,
Select the objects named: Bar
Click the OK button
Calculate Force
Select the menu item Maxwell > Parameters > Assign > Force > Virtual
Click the OK button
Note: Virtual forces are useful on any object while Lorentz forces are only
applicable on current carrying objects which have permeability = 1.
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Set Default Material
1.
2.

Using the 3D Modeler Materials toolbar, choose Select
Select Definition Window:
1. Type NdFe35 in the Search by Name field
2. Click the OK button

Create Magnet
To create the magnet:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
X: 0.0,
0.0 Y: -10.0,
10.0 Z: -5.0,
5.0 Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the box:
dX: 10.0,
10.0 dY: 20.0,
20.0 dZ: 10.0,
10.0 Press the Enter key
To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Magnet
3. Click the OK button
To select the object for subtract
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
1. Select the objects named: Magnet, Core
2. Click the OK button
To complete the magnet:
1. Select the menu item 3D Modeler > Boolean > Subtract
2. Subtract Window
1. Blank Parts: Core
2. Tool Parts: Magnet
3. Clone tool objects before subtracting::  Checked
4. Click the OK button
To fit the view:
1. Select the menu item View > Fit All > Active View.
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Orient Magnet
Note: By default all of the magentic material in the material libaray are oriented in
the x-direction. Using a local coordinate system (CS) we can correct the orientation
of the geometry to align with the material definition.
To create rotated CS:
1. Select the menu item Edit > Select > Faces
2. Using the mouse, graphically select the top face of the Magnet
3. Select the menu item 3D Modeler > Coordinate System > Create > Face CS
4. Using the coordinate entry fields, enter the origin
X: 10.0,
10.0 Y: 10.0,
10.0 Z: 5.0,
5.0 Press the Enter key
5. Using the coordinate entry fields, enter the axis:
dX: 0.0,
0.0 dY: -20.0,
20.0 dZ: 0.0,
0.0 Press the Enter key
Change Properties
1. Select the menu item Maxwell > List
2. Design List Window
1. From the list, select row: Magnet
2. Click the Properties button
3. Properties Window
1. Orientation: FaceCS1
2. Click the OK button
4. Click the Done button
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Set Default Material
To set the default material:
1. Using the 3D Modeler Materials toolbar, choose vacuum

Define a Region
model:
el:
To define a Region that is 50% larger than the object in the mod
1. Select the menu item Draw > Region
1. Padding Date: One
2. Padding Percentage: 50
3. Click the OK button
Note: For all Maxwell 3D projects a solution space must be defined. Unless a
partial model (like a motor wedge) is used, a region is usually created as
described above.

Ansoft Maxwell 3D Field Simulator v11 User’s Guide

5.1-13

5.1
Example (Magnetostatic) – Magnetic Force
Analysis Setup
Creating an Analysis Setup
To create an analysis setup:
1. Select the menu item Maxwell > Analysis Setup > Add Solution Setup
2. Solution Setup Window:
1. Click the OK button to accept all default settings.

Save Project
To save the project:
1. In an Ansoft Maxwell window, select the menu item File > Save As.
2. From the Save As window, type the Filename: maxwell_ms_
maxwell_ms_magforce
_ms_magforce
3. Click the Save button

Analyze
Model Validation
To validate the model:
1. Select the menu item Maxwell > Validation Check
2. Click the Close button
Note: To view any errors or warning messages, use the Message
Manager.

Analyze
To start the solution process:
1. Select the menu item Maxwell > Analyze All
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Solution Data
To view the Solution Data:
1. Select the menu item Maxwell > Results > Solution Data
To view the Profile:
1. Click the Profile Tab.
To view the Convergence:
1. Click the Convergence Tab
Note: The default view is for convergence is Table.
Table Select
the Plot radio button to view a graphical representations of
the convergence data.
To view the Solutions:
1. Click the Solutions Tab
2. Click the Close button
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Plot Flux Density on Core Cross section
To ensure that the current direction and magnetization are correct, create a plot
the flux density vector on the core cross section, a new coordinate system is
needed. Here are the steps to create this plot:
Create an object list including the core, bar and magnet:
Select the menu item Edit > Select > By Name
Select Object Dialog,
Select the objects named: Bar, Core, Magnet
Click the OK button
Select 3D Modeler > List > Create > Object List > Objectlist1
In the history tree, expand Planes and select the geometry on which to create the
plot: Global:XY
Create the plot:
Right mouse click: Field Overlays > Fields > B > B_vector.
Choose Quantity: B_vector and In Volume: Objectlist1.
Objectlist1
Click the Done button

Note: This field plot is for the nominal design case with: mx = 1mm and c1 = 100A.
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Optimetrics Setup – Parametric Sweep
During the design of a device, it is common practice to develop design trends
based on swept parameters. Ansoft Maxwell 3D with Optimetrics Parametric
Sweep can automatically create these design curves.

Add a Parametric Sweep
1.
2.

Select the menu item Maxwell > Optimetrics Analysis > Add Parametric
The Setup Sweep Analysis window appears:
1. On the Sweep Definitions tab::
1. Click the Add button
2. Add/Edit Sweep Dialog
1. Select Variable: c1 (pull down menu to to change from “mx” if
necessary)
2. Select Linear Step
3. Start: 0A
4. Stop: 500A
5. Step: 100
6. Click the Add button
7. Click the OK button
2. Click the Options tab::
1. Save Fields and Mesh:  Checked
3. Click the OK button

Analyze Parametric Sweep
To start the solution process:
1. Expand the Project Tree to display the items listed under Optimetrics
2. Right-click the mouse on ParametricSetup1 and choose Analyze
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Optimetrics Results
To view the Optimetrics Results:
1. Select the menu item Maxwell> Optimetrics Analysis > Optimetrics Results
2. Select the Profile Tab to view the solution progress for each setup.
3. Click the Close button when you are finished viewing the results
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Create Plot of Force at each Current
To create a report:
1. Select the menu item Maxwell > Results > Create Report
2. Create Report Window::
1. Report Type: Magnetostatic
2. Display Type: Rectangular Plot
3. Click the OK button
3. Traces Window::
1. Solution: Setup1: Force
2. Click the Sweeps tab
1. Select Sweep Design and Project variable values
2. Make sure that c1 is selected as the primary sweep
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3.

4.

Click the Y tab
1. Category: Force
2. Quantity: Force_x
3. Function: <none>
4. Click the Add Trace button
Click the Done button
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Plot Flux Density on Core Cross section at a different current
Finally, create a plot of B_vector in the core corresponding to the last row in
the parametric table with c1 = 500A.
Switch to the solution for the last row in the parametric table:
Select Maxwell > Design Properties > Local Variables. Change the
value for c1 = 500 and click on OK.
OK

The previous B_vector plot automatically updates to show the fields for
c1 = 100A. The flux density is higher as expected
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The implementation and application of a 3-phase Inductor using
the Magnetostatic Solver to calculate the nonlinear inductance
The inductance calculation is an important part of a magnetostatic simulation.
The inductive properties will, of course, change with the nonlinearities of the
problem. The properties and concepts of the inductance calculation are
described in this example.
This example uses a 3-phase, 3-coil-per-phase inductor to demonstrate how
the inductance calculation produces meaningful results. The setup is
scrutinized and the results are examined. Then a half-symmetry model is
examined to familiarize the user with a half-symmetry setup.
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Ansoft Maxwell Design Environment
The following features of the Ansoft Maxwell Design Environment are used to
create the models covered in this topic
3D Solid Modeling
Primitives:: Box, Rectangle, Region
Surface Operations: Section
Boolean Operations: Subtract, Separate Bodies, Split
3D Modeler: Delete Last Operation
Sweep: Along Path
Duplicate: Along Line
Boundaries/Excitations
Current: Stranded
Analysis
Magnetostatic
Results
Inductance Matrix
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Getting Started
Launching Maxwell
1.

To access Maxwell, click the Microsoft Start button, select Programs,
Programs and select
Ansoft and then Maxwell 11.

Setting Tool Options
To set the tool options:
Note: In order to follow the steps outlined in this example, verify that the
following tool options are set :
1. Select the menu item Tools > Options > Maxwell Options
2. Maxwell Options Window:
1. Click the General Options tab
Use Wizards for data entry when creating new boundaries:: 
Checked
Duplicate boundaries with geometry::  Checked
2. Click the OK button
3. Select the menu item Tools > Options > 3D Modeler Options.
Options
4. 3D Modeler Options Window:
1. Click the Operation tab
Automatically cover closed polylines::  Checked
2. Click the Drawing tab
Edit property of new primitives::  Checked
3. Click the OK button
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Opening a New Project
To open a new project:
1. In an Maxwell window, click the  On the Standard toolbar, or select
the menu item File > New.
2. Select the menu item Project > Insert Maxwell Design, or click on the
icon

Set Solution Type
Select the menu item: Maxwell > Solution Type > Magnetostatic, or right
mouse click on MaxwellDesign1 and select Solution Type …

Creating the 3D Model of a Nonlinear Inductor
The example that will be used to demonstrate the inductance calculation is
that of a 3-phase transformer with multiple windings in series for each
phase.

Set Model Units
Select the menu item 3D Modeler > Units > Select Units: in (inches)
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Create the Core
1.

Select Draw > Box to start the drawing procedure:
1. Enter -1, -6, 0 as the starting point of the box
2. Enter 2, 12, 10 to define the dimensions of the box
3. A Properties dialog appears:
1. Select OK
4. Hold down Ctrl+D or click the
button to view the entire geometry.

2.

Select Draw > Box to start drawing the window.
1. Enter -1, 1, 2 as the starting point of the box
2. Enter 2, 3, 6 to define the dimensions of the box
3. A Properties dialog appears:
1. Select OK

3.

Select Box2 from the object tree (selected by default after creating it in step 2).
Select Edit > Duplicate > Around Axis to create a second window.
1. Axis: Z
2. Angle: 180 deg
3. Total number: 2
4. Select OK
Select OK

4.

5.

6.

Select Box1,
Box1 and then select Box2 and Box2_1 from the object tree.
Use Ctrl or Shift to select multiple items throughout this example.

7.

Select 3D Modeler > Boolean > Subtract
1. Make sure that Box1 is in the Blank
Parts box and that Box2 and Box2_1
are in the Tool Parts box (this is true
if Box1 is selected first).
2. Make sure that Clone tool objects
before subtracting is deselected.
3. Select OK
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Create the Core (continued)
8.

Select Draw > Box to start drawing the gap:
1. Enter -1, -6, 2 as the starting point of the box
2. Enter 2, 12, 0.05 to define the dimensions of the box
3. A Properties dialog appears:
1. In the value box of Zsize, enter gap and type Enter to accept this
value.
1. In the Add Variable box that appears, enter 0.05in for the
value.
2. Select OK
2. Select OK

9.

Select Box1 and then Box3 from the Object Tree.
(Use Ctrl or Shift to select multiple items.)
Select 3D Modeler > Boolean > Subtract.
Subtract
1. Make sure that Box1 is in the Blank
Parts box and that Box2 and Box2_1
are in the Tool Parts box (this is true
if Box1 is selected first).
2. Make sure that Clone tool objects
before subtracting is deselected.
3. Select OK

10.
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Create the Core (continued)
11.
12.

13.

14.

Select Box1.
Select 3D Modeler > Boolean > Separate Bodies (the E and I parts of the core
are now separate).
Double-click on Box1 in the object tree (a Properties window pops up).
1. Change the name from Box1 to Core_E.
Core_E
2. Select OK.
OK
Double-click on Box1_1 in the object tree (a Properties window pops up).
1. Change the name from Box1_1 to Core_I.
Core_I
2. Select OK.
OK

15.

Select both Core_E and Core_I from the object tree.
1. Find the Attribute window (on the left side, under the project tree by
default).
2. Click on the Material Value vacuum (a Materials list appears).
1. Find steel_1008 and double-click on this material to accept it (or
single-click and select OK).
OK

16.

The cores are now completely defined.
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Create the Coils
1.
2.

3.
4.

5.
6.

7.
8.

Select 3D Modeler > Grid Plane > YZ
Select Draw > Rectangle.
1. Enter 0, -3.6, 3.5 as the starting point of the rectangle
2. Enter 0, 0.3, -0.8 to define the dimensions of the rectangle
3. A Properties dialog appears:
1. Select OK
Select 3D Modeler > Grid Plane > XY
Select Draw Rectangle.
1. Enter 1.5, -6.5, 3 as the starting point of the rectangle
2. Enter -3, 3, 0 to define the dimensions of the rectangle
3. A Properties dialog appears:
1. Select OK
Select Rectangle2 from the object tree.
Select 3D Modeler > Delete Last Operation to produce a line.
Select Rectangle1 and Rectangle2 from the object tree.
Select Draw > Sweep > Along Path
1. A Sweep along path window pops up:
1. Angle of twist: 0deg
2. Draft Angle: 0deg
3. Draft type: Round
4. Select OK
2. Select OK
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Create the Coils (continued)
9.
10.

11.

12.

13.
14.

15.
16.

17.
18.

19.
20.

Select Rectangle1 from the object tree.
Select Edit > Duplicate > Along Line
1. Enter 0, 0, 0.
2. Enter 0, 0, 1.925.
1. Total Number: 3
2. Select OK.
OK
3. Select OK.
Select Rectangle1,
Rectangle1 Rectangle1_1,
Rectangle1_1
and Rectangle1_2 from the object tree.
(Use Ctrl or Shift to select multiple items.)
Select Edit > Duplicate > Along Line
1. Enter 0, 0, 0.
2. Enter 0, 5, 0.
1. Total Number: 3
2. Select OK.
OK
3. Select OK.
Select Rectangle1,
Rectangle1 Rectangle1_1,
Rectangle1_1 and Rectangle1_2 from the object tree.
In the Attribute window, type Coil_left in the Name Value.
Select Rectangle1_3,
Rectangle1_3 Rectangle1_1_1,
Rectangle1_1_1 and Rectangle1_2_1 from the object tree.
In the Attribute window, type Coil_mid in the Name Value.
Select Rectangle1_4,
Rectangle1_4 Rectangle1_1_2,
Rectangle1_1_2 and Rectangle1_2_2 from the object tree.
In the Attribute window, type Coil_right in the Name Value.
Select all Coil objects from the object tree.
In the Attribute window, click on the Material Value vacuum (a Materials list
appears).
1. Find copper and double-click on this material to accept it (or single-click
and select OK).
OK

Ansoft Maxwell 3D Field Simulator v11 User’s Guide

5.2-9

5.2
Example (Magnetostatic) – Inductance Calculation
Create the Terminals and Define the Sources:
1.
2.

3.
4.

Select all the Coil objects from the object tree.
Select 3D Modeler > Surface > Section…
Section…
1. Select YZ
2. Select OK
Select all the Section sheets (selected by default after the last operation).
Select 3D Modeler > Boolean > Separate Bodies

5.

Select the extra Sections (1_1 through 9_1) and delete them (by using Delete on
the keyboard or Edit > Delete from the command menu).

6.

Select the sheets Section1,
Section1 Section2,
Section2 Section3 from the object tree.
Select Maxwell > Excitations > Assign > Current…
Current…
The Current Excitation dialog appears.
1. Base Name: PhaseA
2. Value: -0.5*Mag
0.5*Mag
3. Type: Stranded
Select OK
An Add Variable dialog appears
1. For the Variable Mag:
Mag:
Value: 30A
Select OK

7.
8.

9.
10.

11.

12.

13.

Select the sheets Section4,
Section5, Section6 from the
object tree.
Select Maxwell > Excitations >

Assign > Current…
Current…
Base Name: PhaseB
2. Value: Mag
3. Type: Stranded
Select OK
1.

14.
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Example (Magnetostatic) – Inductance Calculation
Create the Terminals and Define the Sources (continued):
15.
16.
17.

18.

Select the sheets Section7,
Section7 Section8,
Section8 Section9 from the object tree.
Select Maxwell > Excitations > Assign > Current…
Current…
The Current Excitation dialog appears.
1. Base Name: PhaseC
2. Value: -0.5*Mag
0.5*Mag
3. Type: Stranded
Select OK

Create the Region Object
1.

2.

Select Draw > Region
1. A Region dialog box opens up.
2. Fill in the information as follows:
Padding Data: Six
X: 400, 400
Y: 100, 100
Z: 150, 150
3. Select OK
Select OK
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5.2
Example (Magnetostatic) – Inductance Calculation
Inductance Calculation Defining Equations
Inductance in a magnetostatic simulation can be defined as
λ1 = L11 I1 + L12 I 2 + L

λ2 = L21 I1 + L22 I 2 + L
L
where λ is the flux linkage for an individual coil, and I is the current.
This inductance is the apparent inductance – it defines the ratio of flux linkage to
current in one coil.
The inductance of a coil can also be defined by the energy storage as
2
L = 2 ×W I
r r
= ∫ B ⋅ HdΩ I 2
where the energy is determined by the magnetic flux density and field intensity in
the solution space.
This energy storage calculation is what determines the inductance values in the
matrix. The on-diagonal elements (L11, L22, etc.) are determined by exciting the
coils individually and finding the energy from the B and H fields for each
individual case. The off-diagonal elements (L12, L21, L13, etc.) are determined
from a combination of the B and H fields from the individually excited cases. The
following is the exact defining equation for the inductance calculation
r r
Lij = ∫ B ⋅ H j dΩ
i

where it is assumed that one ampere is flowing through the respective coils.
For nonlinear materials, the value of the inductance obtained from these
calculations is only valid for the specific source currents. If any of the source
currents change, the characteristics of the field solution will change as well as the
inductance of each coil (less change when in a linear region, greatest change
when moving from the linear region to a saturated region).
If only linear materials are used, the value of the inductance will be valid for any
value of source currents.
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5.2
Example (Magnetostatic) – Inductance Calculation
Inductance Calculation Methodology
The inductance calculation is performed after the field solution and depends on
the values of the field solution at every point in the solution space because it
requires an energy integral in the entire solution space.
After the field solution is completed, the relative permeability values are “frozen”.
Then, one ampere is sequentially excited in each coil, and a field solution is
performed with the frozen permeabilities. With these field solutions, the energy
integral is performed and the inductance is obtained as described previously.
The inductance obtained in this manner is the inductance per turn^2 (referred to
as the nominal inductance in the software) and is the apparent inductance
(determined by the flux linkage/current operating point in the graphic below).

Incremental inductance can be obtained by performing energy perturbation
techniques (changing the source currents and finding the slope).
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5.2
Example (Magnetostatic) – Inductance Calculation
Inductance Calculation Process

Initial Setup

Adaptive Solution

Nonlinear Convergence
(Changing permeability)

Solution Convergence ?

Refine Mesh

Converged or Number of Passes

Permeability is Frozen

Inductance Matrix Solution
(Linear solution process)

Matrix Post Processing
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Example (Magnetostatic) – Inductance Calculation
Inductance Calculation Post Processing
The nominal inductances that are computed by the solver are returned in units of
Henries/turns^2. In order to return each inductance in units of Henries, the
number of turns for each coil must be specified at some point. Also, the
inductance matrix can be grouped to represent windings in series, and a factor
can be included if the winding is made up of parallel branches. These are all
considered post-processing, and they can help to return meaningful quantities.
The post processed inductances are calculated as follows:
Lij = N i N j Lij _ nom

Lgroup =

∑ ∑L

ij

i _ group j _ group

Lbranched = Lgroup b

The first step is to find the coil inductances from the nominal inductances by
multiplying by the number of turns in each coil (or number of turns squared for
self inductances).
The next step is to group the series inductances by adding up all the inductances
in the block (i.e. if conductors 1 through N are grouped, then add up the N by N
block of inductances to obtain the grouped self inductance – the same process is
followed for grouped mutual inductances).
The final step is to take into account parallel branches by dividing by the number
of branches squared. The inductance decreases with parallel branches because
of the reduced number of turns per branch.
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Example (Magnetostatic) – Inductance Calculation
Create a Solution Setup
1.

Select Maxwell > Analysis Setup > Add Solution Setup …
1. In the General tab:
1. Set Maximum Number of Passes to 10
2. Set Percent Error to 1
2. In the Solver tab:
1. Set Nonlinear Residual to 0.001
3. Select OK

The Nonlinear Residual is important in simulations with nonlinear materials that
operate outside of the linear region. Increasing the number will make the
simulation run faster, decreasing the number will force the nonlinear solver to
more precisely find the nonlinear B-H operating points within the steel (or other
nonlinear magnetic material).
It is often the case with saturated nonlinear materials that the Nonlinear Residual
will need to be reduced to obtain accurate results.
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5.2
Example (Magnetostatic) – Inductance Calculation
Create Matrix Parameters
1.

Select Maxwell > Parameters > Assign > Matrix…
Matrix…
1. In the Setup tab, check the boxes to Include all the Sources (or click on the
word Include to automatically check all the boxes).
2. In the Post Processing tab, set the turns for each source to 30
3. Select PhaseA_1, PhaseA_2, and PhaseA_3 and select Group ->
(Use Ctrl or Shift to select multiple items.)
4. Select PhaseB_1, PhaseB_2, and PhaseB_3 and select Group ->
5. Select PhaseC_1, PhaseC_2, and PhaseC_3 and select Group ->
6. Rename Group1 to PhaseA
7. Rename Group2 to PhaseB
8. Rename Group3 to PhaseC
9. Leave Branches set to 1 for each Group

This setup says that each source has 30 turns and that the sources on each leg
are connected in series (as far as the post-processing is concerned).
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5.2
Example (Magnetostatic) – Inductance Calculation
Create Matrix Parameters (continued)
2.

We will create a second Matrix Parameter to show what the settings signify.
Select Maxwell > Parameters > Assign > Matrix…
Matrix…
1. In the Setup tab, check the boxes to Include all the Sources (or click on the
word Include to automatically check all the boxes).
2. In the Post Processing tab, set the turns for each source to 15
3. Select PhaseA_1, PhaseA_2, and PhaseA_3 and select Group ->
4. Select PhaseB_1, PhaseB_2, and PhaseB_3 and select Group ->
5. Select PhaseC_1, PhaseC_2, and PhaseC_3 and select Group ->
6. Rename Group1 to PhaseA
7. Rename Group2 to PhaseB
8. Rename Group3 to PhaseC
9. Set Branches to 3 for each Group

This setup says that each source has 15 turns in 3 branches of 5 turns each (with
twice the current in each turn as for the 30 turn case) and that the sources on
each leg are connected in series (as far as the post-processing is concerned).
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5.2
Example (Magnetostatic) – Inductance Calculation
Save the Project
1.
2.
3.

Select the menu item File > Save As
From the Save As window, type in 3phase_inductor
Click on the Save button

Check the Validity of the Model
Select the menu item Maxwell > Validation Check, or click on the

icon

The problem won’t solve if there are errors (errors are denoted by a red X), but it
will solve if all the validations return a green check or a warning (warnings are
denoted by a yellow triangle, and should be noted, but can often be safely
ignored).

Analyze
Select the menu item Maxwell > Analyze, or click on the
icon
This should take about 10 minutes to solve on a standard computer (such as a
fast laptop or standard desktop), and about 5 minutes on a fast computer.
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5.2
Example (Magnetostatic) – Inductance Calculation
Inductance Matrix Solutions
Open up the matrix solution data by selecting Maxwell > Results > Solution Data
The first display that appears (by default) is the non-post processed data for
Matrix2

Check the box marked Post Processed to see the results.

Notice that the results are symmetric in both axes as we would expect.
Notice that the mutual inductances are negative. It is important to note that the
direction of the current used for the mutual inductances is determined by the
direction of the arrow for each excitation.
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5.2
Example (Magnetostatic) – Inductance Calculation
Inductance Matrix Solutions (continued)
Change to Matrix1 solutions by clicking on the pull-down menu with Matrix2.

Notice that the results change to reflect twice the turns and one-third the
branches (2^2 * 3^2 = 36 times the previous inductance value).
Remember that by increasing the turns, the current in each turn is decreased to
keep the total ampere-turns constant – this is very important for nonlinear
materials. The solutions apply only for this value of current.
If you were to compare the non-post processed results for both matrices, you
would see that these values are the same.
Change the Solution Type from Inductance to Flux Linkage to see either the Post
Processed or nominal flux linkage values.
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Results and Interpretations
These results are being obtained from a magnetostatic simulation with arbitrary
constant current inputs defined for each leg. The notation used was in terms of 3
phases, which might imply that this is an AC inductor of some sort. The modeling
of AC currents in a magnetostatic simulation can sometimes be valid for
instantaneous values (of force and inductance), but the requirements are that
eddy currents do not effect the solution (either a low frequency source or low loss
materials). The other two options available in the Maxwell software are eddy
current simulations (which allows AC sources, but does not allow nonlinear
materials), and transient simulations (which allows the study of nonlinear and AC
phenomena).
This type of magnetostatic simulation would also be valuable for an Equivalent
Circuit Extraction (again, eddy currents should be negligible) - this would require
each phase to be excited as a variable, and run as a full parametric simulation
including all phases across all possible current values (at least 5^3 variations to
see any nonlinear behavior). Notice that if you do an equivalent circuit extraction
of the inductance, the flux values automatically take into account the grouping
and other post-processing values specified in the matrix parameter.
Other magnetostatic results can be obtained from this simulation, such as force
on the Core_I object and magnetic field in the steel (is it saturating?).
Remember that this simulation uses nonlinear materials, so all of the solutions
are only valid for this specific set of excitations. If you were to change the input
currents, then you will have to solve again to see how the inductance and other
results change.
Another important note is that although we included 2 matrix parameters,
parameters, this is
not necessary to see differently postpost-processed results. You can edit the postprocessing characteristics of the matrix after having solved the problem, and the
results will adjust to reflect the changes without needing to resolve. The only
time that you would need multiple matrices is if one matrix or the other did not
include all the coils. By using two matrices, the inductance calculation was
performed twice, lengthening the simulation. The point of this example was to
show that multiple matrix parameters can be defined – not to suggest using
multiple matrix parameters.
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Example (Magnetostatic) – Inductance Calculation
Create a Symmetry Model
1.
2.
3.
4.
5.

6.

7.

8.

Right-click on MaxwellDesign1 in the project tree (this is the design name).
Choose Copy from the menu.
Right-click on 3phase_inductor in the project tree (this is the project name).
Choose Paste from the menu.
You now have a new design in your project that has the same setup as the first
design.
Remember to double-click on the design name to switch from one design to
the other!

Select all the visible objects (except the Region) by typing Ctrl + A when within
the 3D modeler window (or select them all in the object tree).
Select 3D Modeler > Boolean > Split…
Split… to split the model at the YZ plane.
1. In the Split window that appears, choose the following:
1. Split Plane : YZ
2. Keep Fragments: Positive side
3. Split Objects: Split entire selection
2. Select OK
Expect to see some errors and warnings that the sheet objects were deleted.
There are options in the Split command to keep the sheet objects when splitting
the solids, but we will not need the sheets for a symmetry simulation.
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Example (Magnetostatic) – Inductance Calculation
Create a Symmetry Model (continued)
9.

10.

11.

Select Draw > Region to edit the region object.
1. Change the padding percents as follows:
+X: 800
-X: 0
2. Select OK to accept.
The entire geometry is now on the
positive side of the YZ plane.
Adjust the visibility by going to

View > Active View Visibility…
Visibility…
12.

13.

14.

15.

16.

17.
18.

19.

In the 3D Modeler tab, find the
Region object and deselect Visibility.
Choose OK to accept.
Rotate the geometry to look at the
split plane of the core and coils.
Type f in the 3D modeler to switch to face selection mode (type o to switch back
to object selection) – face selection can also be found in Edit > Select > Faces.
Select the right-most coil faces on the YZ plane.
(Use Ctrl to select multiple items graphically.)
Select Maxwell > Excitations > Assign > Current…
Current…
In the Current Excitation dialog, enter the following:
1. Base Name: PhaseA_in
2. Value: -0.5*Mag
0.5*Mag
3. Type: Stranded
Select OK to accept the excitation.
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Create a Symmetry Model (continued)
20.

21.
22.

23.

24.

25.
26.

27.

28.
29.
30.

31.

Select the next right-most coil faces on the YZ plane.
(Use Ctrl to select multiple items graphically.)
Select Maxwell > Excitations > Assign > Current…
Current…
In the Current Excitation dialog, enter the following:
1. Base Name: PhaseA_out
2. Value: -0.5*Mag
0.5*Mag
3. Type: Stranded
4. Click Swap Direction so that the arrow
is pointing in the negative X direction.
Select OK to accept the excitation.
Continue with the next leg by selecting the next 3
coil faces on the YZ plane.
Select Maxwell > Excitations > Assign > Current…
Current…
In the Current Excitation dialog, enter the following:
1. Base Name: PhaseB_in
2. Value: Mag
3. Type: Stranded
Select OK to accept the excitation.
Now select the 3 return faces of the middle coil.
Select Maxwell > Excitations > Assign > Current…
Current…
In the Current Excitation dialog, enter the following:
1. Base Name: PhaseB_out
2. Value: Mag
3. Type: Stranded
4. Click Swap Direction so that the arrow
is pointing in the negative X direction.
Select OK to accept the excitation.
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Create a Symmetry Model (continued)
32.

33.
34.

35.

36.
37.
38.

39.

Continue to the last leg by selecting the next 3
coil faces on the YZ plane.
Select Maxwell > Excitations > Assign > Current…
Current…
In the Current Excitation dialog, enter the following:
1. Base Name: PhaseC_in
2. Value: -0.5*Mag
0.5*Mag
3. Type: Stranded
Select OK to accept the excitation.
Finish by selecting the 3 return faces of the last coil.
Select Maxwell > Excitations > Assign > Current…
Current…
In the Current Excitation dialog, enter the following:
1. Base Name: PhaseC_out
2. Value: -0.5*Mag
0.5*Mag
3. Type: Stranded
4. Click Swap Direction so that the arrow
is pointing in the negative X direction.
Select OK to accept the excitation.

Creating Matrix Parameters
Now that the excitations are redefined, the matrix has to be redefined. The
matrices were deleted when the old excitations were deleted (which were deleted
when the sheet objects were deleted during the split operation).
When matrix parameters are defined, a check will be performed for proper
conduction paths and for terminals correctly defined across a cross-section of the
conduction paths. Several errors can appear when defining a matrix, and these
often have to do with the definition of the conducting objects or the excitation.
The excitations that appear in the matrix setup, are those excitations that are
pointing into the conductor. So, for a symmetry model that requires two
excitations per conductor, only one excitation per conductor will be listed in the
matrix setup – this excitation will be the one pointing into the modeled conductor.
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Create Matrix Parameters
1.

Select Maxwell > Parameters > Assign > Matrix…
Matrix…
1. In the Setup tab, check the boxes to Include all the Sources (or click on the
word Include to automatically check all the boxes).
2. In the Post Processing tab, set the turns for each source to 30
3. Select PhaseA_in_1, PhaseA_in_2, and PhaseA_in_3 and select Group ->
(Use Ctrl or Shift to select multiple items.)
4. Select PhaseB_in_1, PhaseB_in_2, and PhaseB_in_3 and select Group ->
5. Select PhaseC_in_1, PhaseC_in_2, and PhaseC_in_3 and select Group ->
6. Rename Group1 to PhaseA
7. Rename Group2 to PhaseB
8. Rename Group3 to PhaseC
9. Leave Branches set to 1 for each Group

This setup says that each source has 30 turns and that the sources on each leg
are connected in series (as far as the post-processing is concerned).
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Example (Magnetostatic) – Inductance Calculation
Check the Validity of the Model
Select the menu item Maxwell > Validation Check, or click on the

icon

The problem won’t solve if there are errors (errors are denoted by a red X), but it
will solve if all the validations return a green check or a warning (warnings are
denoted by a yellow triangle, and should be noted, but can often be safely
ignored).

Analyze
Select the menu item Maxwell > Analyze, or click on the
icon
This should take about 5 minutes to solve on a standard computer (such as a fast
laptop or standard desktop), and about 3 minutes on a fast computer (half the
time!).

This half model runs twice as fast – taking advantage of symmetries can have an
even greater effect on larger models!
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Inductance Matrix Solutions
1.
2.

Open up the matrix solution data by selecting Maxwell > Results > Solution Data
Check the box marked Post Processed to see the results.

Notice that the results are half the value that we obtained for the full model. This
is very important to remember when using these values. The halved results are
consistent for other parameters and properties as well (i.e. torque, total energy,
etc.)
If these values are used to create an Equivalent Circuit Extraction, remember to
use a scaling factor of 2 to account for the symmetry.
3.

Change the Solution Type from Inductance to Flux Linkage.
Notice that these numbers are halved as well.
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5.3
Example (Magnetostatic) – Stranded Conductors
Stranded Conductors
This example is intended to show you how to create and analyze a
magnetostatic problem with stranded conductors for a Switched Reluctance
Motor geometry using Magnetostatic solver in the Ansoft Maxwell 3D Design
Environment.
Within the Maxwell 3D Design Environment, complete coils can be modeled
as Stranded Conductors. There are many advantages to using Stranded
Conductors when modeling coils that have multiple turns. The first obvious
advantage is that a coil with multiple wires, say 2500, can be modeled as a
single object as opposed to modeling each wire which would be
impracticable. Secondly, defining a Stranded Conductor means that the
current density will be uniform throughout the cross section of the conductor
which is physically correct for a coil with many turns.
The example that will be used to demonstrate how Stranded Conductors are
implemented in a switched Reluctance Motor. This switched reluctance
motor will have four phases and two coils per phase.
Note: There is no fundamental difference between how stranded conductors
are treated in the Eddy Current solver as compared to the Magnetostatic
Solver. When using the Eddy Current Solver and specifying Stranded for the
terminal excitation the Eddy Effect is automatically turned off.
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5.3
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Theory – Magnetostatic Solver
When using the Magnetostatic Solver, with a Stranded Current Source, the solver
assumes the following conditions:
1. The current density is uniformly distributed over the cross section of the
terminal as well as through the entire conductor.
2. The direction of the current is indicated by the arrow as seen on the
terminal. Change the direction of the current by clicking on Swap Direction
in the Current Excitation window to reverse the flow.

3.

The solver does not know how many turns are represented by the coil, thus
the value of current that is being applied represents the total ampere-turns.
For this example, the value 3570 could represent any of the following:
1. 1 amp thru 3570 turns
2. 5 amps thru 750 turns
3. 25 amps thru 150 turns
4. 3570 amps thru 1 turn
or any such combination that produces a value of 3750 ampere-turns. The
ratio of amperes to turns does not impact the field solution or the value of
inductance reported in the inductance matrix. However, this value of
inductance assumes a 1 turn coil, and must be multiplied by N2 to
determine the actual inductance of the coil. Please refer to the overview for
details of the inductance calculation.

Ansoft Maxwell 3D Field Simulator v11 User’s Guide

5.3-2
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Theory – Magnetostatic Solver (Continued)
The ampere-turn value used to define the current source is used to calculate the
current density which is the initial condition used by the solver according to the
equation:
∧

J=

Where:

I
n
S

I is the total current in ampere-turns
S
is the area of the terminal in m2
∧
n is the unit normal direction
J is the Current Density vector in A/m2

The path of the current is determined by the conduction path. Select the menu
item Maxwell > Excitations > Conduction Paths to view the conduction path, and
verify that the conduction path is correct. In this example, if any of the coils
touched the stator, then this would constitute a separate conduction path since
the material properties of the stator has a conductivity value 2e6 siemens/meter;
to solve this problem an insulation boundary will need to be applied to the coils or
stator; please refer to the overview section for details on insulation boundaries.
Although the Magnetostatic solver uses the current density vector J as the initial
condition, it does not solve for J directly as part of the output solution matrix. The
quantity that the Magnetostatic solver directly calculates is the magnetic field
intensity H. From H, the current density J in any conductor is derived by:

J =∇× H
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Ansoft Maxwell Design Environment
The following features of the Ansoft Maxwell Design Environment are used to
create the models covered in this topic
3D Solid Modeling
User Defined Primitives (UDP): Switched Reluctance Motor
Primitives:: Regular Polyhedron
Surface Operations: Section
Boolean Operations: Separate Bodies
Boundaries/Excitations
Current: Stranded
Analysis
Magnetostatic
Results
Field Calculator
Field Overlays:
Magnitude B
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Getting Started
Launching Maxwell
1.

To access Maxwell, click the Microsoft Start button, select Programs,
Programs and select
Ansoft and then Maxwell 11.

Setting Tool Options
To set the tool options:
Note: In order to follow the steps outlined in this example, verify that the
following tool options are set :
1. Select the menu item Tools > Options > Maxwell Options
2. Maxwell Options Window:
1. Click the General Options tab
Use Wizards for data entry when creating new boundaries:: 
Checked
Duplicate boundaries with geometry::  Checked
2. Click the OK button
3. Select the menu item Tools > Options > 3D Modeler Options.
Options
4. 3D Modeler Options Window:
1. Click the Operation tab
Automatically cover closed polylines::  Checked
2. Click the Drawing tab
Edit property of new primitives::  Checked
3. Click the OK button
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Opening a New Project
To open a new project:
In an Ansoft Maxwell window, click the  On the Standard toolbar, or
select the menu item File > New.
From the Project menu, select Insert Maxwell Design.

Set Solution Type
To set the solution type:
Select the menu item Maxwell > Solution Type
Solution Type Window:
Choose Magnetostatic
Click the OK button
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Creating the 3D Model
Set Model Units
To set the units:
1. Select the menu item 3D Modeler > Units
2. Set Model Units:
1. Select Units: mm
2. Click the OK button

Set Default Material
To set the default material:
1. Using the 3D Modeler Materials toolbar, choose Select
2. Select Definition Window:
1. Type steel in the Search by Name field
2. Click the OK button
3. Click on steel_1008 in the list.
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Create Rotor
To create the rotor:
1. Select the menu item Draw > User Defined Primitive > Syslib > Rmxprt >

SRMCore
From the Create User Defined Primitive dialog
1. For the value of DiaGap,
DiaGap, type: 70,
70 Click the Tab key to accept
2. For the value of DiaYoke,
DiaYoke type: 30,
30 Click the Tab key to accept
3. For the value of Length,
Length type: 65,
65 Click the Tab key to accept
4. For the value of Poles,
Poles type: 6, Click the Tab key to accept
5. For the value of ThkYoke,
ThkYoke type: 9, Click the Tab key to accept
6. For the value of Embrace,
Embrace type: 0.5,
0.5 Click the Tab key to accept
7. For the value of EndExt,
EndExt type: 0, Click the Tab key to accept
8. For the value of InfoCore,
InfoCore type: 0, Click the Tab key to accept
9. Click the OK button
To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Rotor
3. Click the OK button
To fit the view:
1. Select the menu item View > Fit All > Active View.
2.
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Create Stator and Coils:
To create the Stator and Coils
1. Select the menu item Draw > User Defined Primitive > Syslib > Rmxprt >

SRMCore
From the Create User Defined Primitive dialog
1. For the value of DiaGap,
DiaGap, type: 75,
75 Click the Tab key to accept
2. For the value of DiaYoke,
DiaYoke type: 120,
120 Click the Tab key to accept
3. For the value of Length,
Length type: 65,
65 Click the Tab key to accept
4. For the value of Poles,
Poles type: 8, Click the Tab key to accept
5. For the value of ThkYoke,
ThkYoke type: 9, Click the Tab key to accept
6. For the value of Embrace,
Embrace type: 0.5,
0.5 Click the Tab key to accept
7. For the value of EndExt,
EndExt type: 1, Click the Tab key to accept
8. For the value of InfoCore,
InfoCore type: 1, Click the Tab key to accept
9. Click the OK button
To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Stator
3. Click the OK button
To fit the view:
1. Select the menu item View > Fit All > Active View.
2.

Ungroup the Stator and Coils
To separate bodies
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
1. Select the objects named: Stator
2. Click the OK button
3. Select the menu item, 3D Modeler > Boolean > Separate Bodies

Process the Coils:
Select Coils
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
1. Select the objects named: Stator_2, Stator_3, Stator_4, Stator_5,
Stator_6, Stator_7, Stator_8
2. Click the OK button
Delete Coils
1. Select the menu item Edit > Delete
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Create Terminals
Section Coils
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
1. Select the objects named: Stator_1
2. Click the OK button
Section Object
1. Select the menu item 3D Modeler > Surface > Section
1. Section Plane: XY
2. Click the OK button
Separate Bodies
1. Select the menu item 3D Modeler > Boolean > Separate Bodies
Delete
1. Select the menu item Edit > Delete
Section Coils
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
1. Select the objects named: Section1
2. Click the OK button
Assign Excitation
1. Select the menu item Maxwell > Excitations > Assign > Current
2. Current Excitation : General
1. Name: Current1
2. Value: 3750 A
3. Type: Stranded
3. Click the OK button

Verify Duplicate Boundary Option is Set
Section To set the tool options:
1. Select the menu item Tools > Options > Maxwell Options
2. Maxwell Options Window:
1. Click the General Options tab
Duplicate boundaries with geometry::  Checked
2. Click the OK button
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Change Properties
Change Properties
1. Select the menu item Maxwell > List
2. Design List Window
1. From the list, select row: Stator_1
2. Click the Properties button
3. Properties Window
1. Name: Coil
2. Material: copper
3. Click the OK button
4. From the list, select row: Section1
5. Click the Properties button
6. Properties Window
1. Name: Terminal
2. Click the OK button
7. Click the Done button

Duplicate Coil and Terminal
To select objects
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
1. Select the objects named: Coil, Terminal
2. Click the OK button
To duplicate the objects:
1. Select the menu item, Edit > Duplicate > Around Axis
2. Duplicate Around Axis Window
1. Axis: Z
2. Angle: 45deg
3. Total Number: 8
4. Click the OK button
3. Click the OK button
Project Tree: Eight Excitations
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Stator

Coil_D2

Coil_C2
Coil_B2

Coil_A1

Coil_B1
Coil_A2
Coil_C1
Coil_D1
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Set Default Material
To set the default material:
1. Using the 3D Modeler Materials toolbar, choose vacuum

Create Region
To create the region:
1. Select the menu item Draw > Regular Polyhedron
2. Using the coordinate entry fields, enter the center position
X: 0.0,
0.0 Y: 0.0,
0.0 Z: -100.0,
100.0 Press the Enter key
3. Using the coordinate entry fields, enter the radius:
dX: 150.0 dY: 0.0,
0.0 dZ: 0.0,
0.0 Press the Enter key
4. Using the coordinate entry fields, enter the height:
dX: 0.0,
0.0 dY: 0.0,
0.0 dZ: 200.0,
200.0 Press the Enter key
Segment Number Window
Number of Segments: 12
Click the OK button
To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Region
3. Display Wireframe:
Wireframe  Checked
4. Click the OK button
To turn off the visibility:
1. Select the menu item View > Hide Selection > Active View
To fit the view:
1. Select the menu item View > Fit All > Active View.
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Analysis Setup
Creating an Analysis Setup
To create an analysis setup:
1. Select the menu item Maxwell > Analysis Setup > Add Solution Setup
2. Solution Setup Window:
1. Click the General tab::
Percent Error: 10
2. Click the Convergence tab::
Refinement Per Pass:: 10 %
3. Click the OK button

Save Project
To save the project:
1. In an Ansoft Maxwell window, select the menu item File > Save As.
2. From the Save As window, type the Filename: maxwell_ms_relmotor
3. Click the Save button

Analyze
Model Validation
To validate the model:
1. Select the menu item Maxwell > Validation Check
2. Click the Close button
Note: To view any errors or warning messages, use the Message
Manager.

Analyze
To start the solution process:
1. Select the menu item Maxwell > Analyze All
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Solution Data
To view the Solution Data:
1. Select the menu item Maxwell > Results > Solution Data
To view the Profile:
1. Click the Profile Tab.
To view the Convergence:
1. Click the Convergence Tab
Note: The default view is for convergence is Table.
Table Select
the Plot radio button to view a graphical representations of
the convergence data.
2. Click the Close button
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Field Overlays
Create Field Overlay
To create a field plot:
1. Select stator and rotor
1. Select the menu item Edit > Select > By Name
2. Press and hold the CTRL key and click on stator and rotor
2. Select the menu item Maxwell > Fields > Fields > B > Mag_B
3. In the Create Field Plot window select:
1. Solution: Setup1 : LastAdaptive
2. Quantity: Mag_B
3. In Volume: All
4. Plot on Surface Only:  Checked
5. Click the Done button
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Calculate Current
Use the field calculator to verify the total ampamp-turns flowing in the winding:
1. Select the menu item Maxwell > Fields > Calculator
2. Select Quantity: J which is a vector
3. Click the button Geometry to pull up the Geometry Window
1. Select the radio button Surface
2. From the list select: terminal
3. Click the OK button
4. Click on the Normal button to determine the current normal to the terminal
5. Click the ∫ (Integrate) button
6. Click the Eval button to evaluate the results of the integration and return the
amp-turns flowing in the winding = 3750.
7. Click the Done button to close the calculator
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Realization of an equivalent circuit extraction (ECE) of a
problem with linear movement.
The Electro Mechanical software package provided by Ansoft enables
system simulation as well as component simulation. Often, the results
of an in depth study of a magnetic component are needed in a top
level, system analysis.
With Maxwell, the results of a parametric analysis can be used to
generated an Equivalent Circuit that will be used into Simplorer. This
Equivalent Circuit is transmitted under the format of a Look up table
containing the sweep variables as well as the output variables.
This application note presents the extraction of an equivalent circuit
of a Linear Actuator. We will vary the air gap of the Armature (with the
stators) and the Input current in the Coil. The outputs will be the Force
and the inductance of the Coil. Our component in Simplorer will all 4
Terminals :
2 Electrical Terminals with the current and the EMF (the
Inductance of the Coil) as Through and Across quantities.
2 Mechanical Terminals with the Force and the air gap as
Through and Across quantities.
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Ansoft Maxwell Design Environment
The following features of the Ansoft Maxwell Design Environment are used to
create the models covered in this topic:
3D Solid Modeling
Primitives:: Box, Cylinder, Lines
Surface Operations: Section, Sweep Along Vector, Sweep along
Path
Boolean Operations: Separate Bodies, Subtract, Duplicate (Mirror)
Design Properties
Parameters: Design Parameters
Boundaries/Excitations
Current: Stranded
Boundary: Insulating
Mesh Operations
Volume:: Length Based
Executive Parameters
Force: Virtual Force
Matrix: Inductance
Output variables
From Executive Parameters
Analysis
Magnetostatic
Optimetrics Analysis
Parametric Sweep
Distributive Analysis
Results
Solutions Data
Equivalent Circuit Extraction
From Parametric:: Linear Movement
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Overview of the Study:

Getting Started
Launching Maxwell
Setting Tool Options
Opening a new project
Set Solution Type

Creating the 3D Model of a Solenoid
Set Model Units
Create the Armature
Create the Stators
Create the Coil
Create the Band
Create the Coil Terminal
Separate the Grouped Terminals
Create the Problem Region
Assign Current Source to the Terminal
Assign Boundaries Conditions
Assign Executive Parameters
Assign Mesh Operations

Solve the Nominal Problem
Create an Analysis Set up
Save the Project
Check the Validity of the Model
Analyze
Solution Data of the Nominal Problem
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Overview of the Study (Continued)
Create Parametric Analysis
Assign Problem Parameters
Create Output Variables
Create Parametric Analysis Setup

Solve the Parametric Sweep
Solution Data of the Parametric Sweep

ECE from the Parametric Analysis

Create the circuit in Simplorer
Create the Schematic sheet in Simplorer
Create the graphical Displays in Simplorer
Create a Transient Analysis
Run the Analysis
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Getting Started
Launching Maxwell
1.

To access Maxwell, click the Microsoft Start button, select Programs,
Programs and select
Ansoft and then Maxwell 11.

Setting Tool Options
To set the tool options:
Note: In order to follow the steps outlined in this example, verify that the
following tool options are set :
1. Select the menu item Tools > Options > Maxwell Options
2. Maxwell Options Window:
1. Click the General Options tab
Use Wizards for data entry when creating new boundaries:: 
Checked
Duplicate boundaries with geometry::  Checked
2. Click the OK button
3. Select the menu item Tools > Options > 3D Modeler Options.
Options
4. 3D Modeler Options Window:
1. Click the Operation tab
Automatically cover closed polylines::  Checked
2. Click the Drawing tab
Edit property of new primitives::  Checked
3. Click the OK button
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Opening a New Project
To open a new project:
1. In an Maxwell window, click the  On the Standard toolbar, or
select the menu item File > New.
2. Select the menu item Project > Insert Maxwell Design, or click
on the
icon

Set Solution Type
Select the menu item: Maxwell > Solution Type > Magnetostatic, or
right mouse click on MaxwellDesign1 and select Solution Type …

Creating the 3D Model of a solenoid
The example that will be used to demonstrate how to generate an
equivalent circuit extraction with Maxwell. Then the importation into
SIMPLORER of the circuit will be described

Set Model Units
Select the menu item 3D Modeler > Units > Select Units: in (inches)
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Create the Armature:

1.

2.

The armature is made of a box with a cylinder hole.
Create the armature . Select the Menu item Draw > Box or click on the
icon.
Using the coordinate entry field, enter the box position
X: 0.469, Y: 0.4305, Z: 0.006,
0.006 Press the Enter key
Using the coordinate entry field, enter the relative size of the box
dX:
dX: -0.938, dY:
dY: -0.861, dZ:
dZ: 0.112,
0.112 Press the Enter key
Note:
Note To create the box with the GUI, use the mouse to draw the box.

Note:
Note In the case of a typo, the modification of the coordinates can be
made within the box.
Click on the created object in the panel on the left representing the object
tree. Change its name from Box1 to Armature.
Change the Material from vacuum to Steel_1010.
Steel_1010
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Create the hole Draw > Cylinder or click on the
icon.
1. Using the coordinate entry field, enter the center of base
X: 0.0, Y: 0.0, Z: 0.012,
0.012 Press the Enter key
2. Using the coordinate entry field, enter the coordinates of a external point of
the cylinder base
X: 0.091, Y: 0.0, Z:0.0,
Z:0.0 Press the Enter key
3. Using the coordinate entry field, enter the height
X: 0.0, Y: 0.0, Z: 0.112,
0.112 Press the Enter key
Note:
Note To create the cylinder graphically, use the mouse to draw the
cylinder.

Select the objects Armature and Cylinder1 from the objects tree (maintain
the Ctrl key to select both objects).
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Select the menu item 3D Modeler > Boolean > Subtract or click on the
icon.

Make sure to have Armature in the box Blank Parts and Cylinder1 in the
box Tool Parts. Use the arrows to exchange the objects if necessary.
Change the Material from vacuum to steel_1010.
steel_1010
Change the color to purple.
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Create the Stators
The two stators are created using a polyline.
Create the polyline Draw > Line or click on the
icon.
1. Using the coordinate entry field, enter the first point of the line
X: 0.5025, Y: 0.0, Z: 0.0,
0.0 Press the Enter key
2. Using the coordinate entry field, enter the second point of the line
X: 0.5025, Y: 0.168, Z:0.0,
Z:0.0 Press the Enter key
3. Using the coordinate entry field, enter the next point of the line
X: 0.5025, Y: 0.168, Z:Z:-0.803,
0.803 Press the Enter key
4. Using the coordinate entry field, enter the next point of the line
X: 0.5025, Y: 0.324, Z:Z:-0.803,
0.803 Press the Enter key
5. Using the coordinate entry field, enter the next point of the line
X: 0.5025, Y: 0.324, Z:0.0,
Z:0.0 Press the Enter key
6. Using the coordinate entry field, enter the next point of the line
X: 0.5025, Y: 0.5, Z:0.0,
Z:0.0 Press the Enter key
7. Using the coordinate entry field, enter the next point of the line
X: 0.5025, Y: 0.5, Z:Z:-0.98,
0.98 Press the Enter key
8. Using the coordinate entry field, enter the next point of the line
X: 0.5025, Y: -0.5, Z:Z:-0.98,
0.98 Press the Enter key
9. Using the coordinate entry field, enter the next point of the line
X: 0.5025, Y: -0.5, Z:0.0,
Z:0.0 Press the Enter key
10. Using the coordinate entry field, enter the next point of the line
X: 0.5025, Y: -0.324, Z:0.0,
Z:0.0 Press the Enter key
11. Using the coordinate entry field, enter the next point of the line
X: 0.5025, Y: -0.324, Z:Z:-0.803,
0.803 Press the Enter key
12. Using the coordinate entry field, enter the next point of the line
X: 0.5025, Y: -0.168, Z:Z:-0.803,
0.803 Press the Enter key
13. Using the coordinate entry field, enter the next point of the line
X: 0.5025, Y: -0.168, Z:0.0,
Z:0.0 Press the Enter key
14. Using the coordinate entry field, enter the last point of the line
X: 0.5025, Y: 0.0, Z:0.0,
Z:0.0 Press the Enter key twice.
Change the name of the polyline from Polyline1 to base and leave the other
default parameters.
Note:
Note If you happen to have an incorrect coordinate, you can modify any entry
from the model object tree, Lines > Base > CreatePolyline.
CreatePolyline
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Create the Stators (Continued))
This base will be swept along a vector.
Select the object base from the objects tree.
Select the menu item Draw > Sweep > Along vector
1.
Using the coordinate entry field, enter the first point of the vector
X: 0.5025, Y: 0.0, Z:0.0,
Z:0.0 Press the Enter key
2.
Using the coordinate entry field, enter the last point of the vector
(Note that the following coordinates are ABSOLUTE not RELATIVE.)
X: 0.091, Y: 0.0, Z:0.0,
Z:0.0 Press the Enter key.

Leave the Draft angle to 0 deg and change Draft type to Natural.

Change the name of the object to stator. Change the Material from vacuum to steel_1010 and
change the color to dark orange.
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The second stator will be duplicated from Stator .
Select Stator from the objects tree.
Select the menu item Edit > Duplicate > Mirror or click on the
icon
1. Using the coordinate entry field, enter the anchor point of mirror plane
X: 0.0, Y: 0.0, Z:0.0,
Z:0.0 Press the Enter key
2. Using the coordinate entry field, enter the target point of vector normal to
the mirror plane
(Note that the following coordinates are ABSOLUTE not RELATIVE.)
X: -0.6, Y: 0.0, Z:0.0,
Z:0.0 Press the Enter key

After the operation, a window appears and recall the coordinates.
A new object Stator_1 has been created with the same material property and the
same color as Stator .
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Create the Coil:
The coil is created by drawing two boxes and subtracting the smaller box from the larger one..
Create the first box using Draw > Box or click on the
icon.
1.
Using the coordinate entry field in the lower right corner of the modeling window, enter the
first corner of the box
X: - 0.646, Y: - 0.264, Z: -0.803,
0.803 Press the Enter key
2.
Next, enter the change in position to define the opposite corner of the box
dX:
dX: 1.292, dY:
dY: 0.528, dZ:
dZ: 0.511,
0.511 Press the Enter key.
3.
Change the name of the box from Box1 to Coil and leave the other default parameters.
Note:
Note If you happen to have an incorrect coordinate, you can modify any entry from the
model’s history tree.
Create the second box using Draw > Box or click on the
icon.
1.
Using the coordinate entry field in the lower right corner of the modeling window, enter the
first corner of the box
X: - 0.55, Y: - 0.168, Z: -0.803,
0.803 Press the Enter key
2.
Next, enter the change in position to define the opposite corner of the box
dX:
dX: 1.1, dY:
dY: 0.336, dZ:
dZ: 0.511,
0.511 Press the Enter key.
3.
Change the name of the box from Box1 to Basecoil and leave the other default
parameters.
Subtract the boxes to create the coil using 3D Modeler > Boolean > Subtract or click on the
icon.
1.
Make sure to have Coil listed in Blank Parts and Box1 listed in Tool Parts. Use the
arrows to exchange the objects if necessary.
2.
Assign Copper as material. Change the color in blue.
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Create the Band
In our study, the Armature will be moved up and down along the Z axis. It is
always a good idea to help the mesh creation by creating an air box object
around a object that will be moved (even if the project will be performed with the
Magnetostatic solver).
Create the air object Draw > Box or click on the
icon. Use the values below
for the base coordinates and the size of the box.

Change the name of the object to Band. Also, change the Transparency from 0 to
1; this will keep the Region object displayed as a wire frame. Keep the material
as vacuum.
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Create the Coil Terminal
A coil terminal needs to be created in order to assign the current excitation.
Select Coil from the objects tree.
Select the menu item 3D Modeler > Surface > Section > YZ Plane .

Separate the Grouped Terminals
The result of the Surface > Section command, yields two terminals that are
united. Since only one terminal is needed, the other terminal needs to be
deleted, but first they need to be separated.
Select the sheet object:

Select the menu item 3D Modeler > Boolean > Separate Bodies
There are now 2 separate terminals. Delete the second terminal and rename the
remaining object to Terminal.

Ansoft Maxwell 3D Field Simulator v11 User’s Guide

5.4-15

5.4
Topic – ECE: Linear movement
Create the Problem Region
One of the main differences between Maxwell V10 and V11 is that a Background
Region is not automatically created when a project is started. A separate object
needs to be specifically created.
Create the region Draw > Region or select the

icon

The Padding determines how far will the limits of the region be from the objects.
In this case, select 100 as Padding Percentage to have plenty of room around the
solenoid.
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Assign Current Source to the Terminal
Select the coil Terminal by using your mouse or selecting from tree on the left
hand side of the GUI.
Select the menu item Maxwell > Excitations > Assign > Current
1. Change the Base Name to Current
2. Change the value to 576 Amps
3. Change the type to Stranded

Assign Boundary Conditions
We assume that no current leaks out of the coil and into the stators. However,
the stators and the coil are touching, so an insulating boundary must be applied
to the either the coil or to both stators
Select the menu item Maxwell > Excitations > Conduction Paths > Show
Conduction Paths to verify the the coil is touching the stators.
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Assign Boundary Conditions (Continued)
Select the two stators by holding down the CTRL key and using your mouse or
selecting from tree on the left hand side of the GUI.
Select the menu item Maxwell > Boundaries> Assign > Insulating. Leave the
default name Insulating1 and select OK.

Assign Executive Parameters
The force applied on the armature as well as the self inductance of the coil are
needed . These outputs will be used during the Equivalent Circuit Extraction
process.
Select the Armature from the objects tree or by using the mouse.
Select the menu item Maxwell > Parameters > Assign > Force

Select Virtual and leave the default name. Make sure the Reference is set to
Global.
Note:
Note with Maxwell 11, The Virtual and the Lorentz force are available. The
virtual force, based on the Virtual Work Principle is more general since it works
on all objects. The Lorentz force calculation works only on current carrying
conductors with permeability = 1. Also, the force computation is very mesh
dependent, so a fine mesh is advisable whenever the Force is needed.
The inductance computation leads to an Inductance Matrix (size NxN, with N the
number of selected conductors), where the M(i,i) entry corresponds to the self
inductance of the ith conductor and the M(i,j) = M(j,i) entries correspond to the
mutual inductance terms. In our case, we only have one conductor, therefore we
will only obtain the self inductance of the Coil (in a 1 by 1 matrix).
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Assign Executive Parameters (Continued)
Select the menu item Edit > Select > By Name to choose the coil.
Select the menu item Maxwell > Parameters > Assign > Matrix
Include the term current in the matrix computation (see below).

Assign Mesh Operations
As mentioned in the previous section, the Force computation is very mesh
sensitive. Therefore, to save some time computation, we will use a mesh
operation.
Select the two stators, the Band object, the Coil, the Armature by holding down
the CTRL key and using your mouse or selecting from tree on the left hand side
of the GUI. Do not select the Region.
Select the menu item Maxwell > Mesh Operations > Assign > Inside Selection >

Length Based
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Assign Mesh Operations (Continued)
The addition of 25 000 elements will be enough to achieve a reasonable
accuracy. We deselect the Restrict Length of Elements and put 25 000 as the
Maximum number of Elements.

Solve the Nominal Problem
Create an Analysis Set up
Before performing a parametric sweep on the current and the air gap, the
nominal problem needs to be solved: it is always a good idea to verify that the
problem is correctly set.
Note:
Note A solved project is required if output variables that will serve as entries in
the Parametric table have been created in the Calculator.
Calculator
Select the menu item Maxwell > Analysis Setup > Add Solution Setup.
Select General and change the Percent Error from 1.0 to 0.7. Change the
number of passes to 5. Leave the bottom of the window unchanged. This way,
the Force and the Inductance Matrix will be calculated as we expect: the default
configuration make Maxwell solve for the executive parameters after the last
adaptive pass (see next page).
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Create an Analysis Set up (Continued)
Select Convergence and change the Refinement Per Pass from 30 to 15
because we do not need to increase the size of the mesh too much after each
pass.

Save the Project
Select the menu item File > Save As
From the Save As window, type in Solenoid.
Solenoid
Click on the Save button.
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Check the Validity of the Model
Select the menu item Maxwell > Validation Check, or click on the

icon.

The problem will not solve unless each object has a check mark.

Analyze
Select the menu item Maxwell > Analyze,
icon.
Analyze or click on the
The progress bar shows the different stages of the ongoing computation. This
takes approximately 20 minutes on a 3GHz PC.

Solution Data of the nominal problem
To view the Solution Data, select the menu item Maxwell > Results > Solution
Data. You have access from this window to the inductance and to the force
computed as well as other information:
Select the Solution tab: the inductance is available by choosing Matrix1 in
the pull-down menu. In this case the inductance matrix has only one entry.
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Solution Data of the nominal problem (Continued)
Select the Solution tab: the force values are available by choosing Force1
in the pull down menu. We have access to the X,Y, and Z components of
the Force as well as its magnitude. As expected, the Z component of the
Force is much more larger than the other components.

Select the Convergence tab: the log of the different adaptive passes is
displayed with the successive sizes of the mesh.
Select the Profile tab:
tab you can find information about the CPU time, the size
of the generated data.
Select the Mesh Statistics:
Statistics all the details about the final mesh are
presented for each of the problem’s region.
Note:
Note you can calculate any quantity using the calculator of Maxwell. Select the
Menu item Maxwell > Results > Calculator or click on the
icon.
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Create Parametric Analysis
Assign Problem Parameters
Once the nominal problem has been successfully solved, some parameters need
to be declared to perform a parametric sweep. We are interested in the
inductance and the force computed in respect to the input current and the air gap
between the Armature and the Stator, therefore, we create two parameters: the
air gap and the input current. In Maxwell 11, any input can be set as parameter.
Warning:
Warning When assigning problem parameters, the solution is invalidated. The
nominal problem has to be copied if the results are needed. Also, the variables
created in the calculator that will be used in the parametric sweep must be
declared before the parameter declaration.
We begin with the current source. From the model tree on the left hand side of
the GUI, expand the Excitations title and double click on the Current entry. In the
value case, change from 576 to amp_turns.

A window pops up asking for the value of amp_turns. Leave it to 576 Amps.
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Assign Problem Parameters (Continued)
To enter the air gap parameter, expand from the objects tree the Armature entry.
Double click on CreateBox object.

Change the Z- position of the corner with the parameter armature_init.
armature_init

Set the value of armature_init as .006in + gap.
gap Set gap as 0.0in.
At any time you can access at the list of the problem parameters. Select the
menu item Maxwell > Design Properties.
Properties The window should look like:
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Create Output Variables
For a parametric analysis, we are only interested in a limited number of output
parameters. Our goal is to generate an equivalent circuit extraction, therefore we
want to have for each row the inductance and the output force. If needed,
Maxwell enables you to save the solution fields for every design of a parametric
sweep.
Select the menu item Maxwell > Results > Output Variables.
Variables From this window,
we assign output variables.
To create the output variable corresponding to the magnitude of the virtual force
(Fm)
Fm),
Fm) follow the steps below:

6- Add the
expression
and to the list
5- Name the
expression

4- Insert the
Quantity

1- Select the
Executive
parameter

2- Select the Quantity

Ansoft Maxwell 3D Field Simulator v11 User’s Guide

3- We do not need
to apply any function to
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Create Output Variables (Continued)
Proceed the same way to declare Fx, Fy, Fz the components of the Force applied
to the Armature.
We also declare the inductance as an output variable. Follow a similar procedure,
but select Matrix1 from the pull-down menu (see below). Lcc stands for the
inductance of the coil.

Finally, you should have 5 output variables declared: Fm, Fx, Fy, Fz and Lcc.
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Create Parametric Analysis
Note:
Note The module Optimetrics must be installed in order to be able to run a
parametric sweep.
Select the Menu item Maxwell > Optimetrics Analysis > Add Parametric. The
Setup Sweep Analysis pops up. We add the different variables for each
parameter that will be included in the sweep. Select Add (see Below).

From the Add/Edit Sweep window, select gap in the pull down menu. The air gap
will linearly vary from 0.0in to 0.006in with a 0.001in Step. Enter these values in
the corresponding boxes. Click Add to proceed.
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Create Parametric Analysis (Continued)
Select amp_turns from the Pull down menu. We sweep this variable with 4 single
values: -1 A, 330A, 661A and 992 A. Click on the Single Value box, enter the
actual value and click Add for the 4 different values. Do you forget to press Add
each time. Close the Window.

The Setup Sweep Analysis window has the following definitions:
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Create Parametric Analysis (Continued)
From the ‘Table’ tab, the 28 variations are displayed.
Leave ‘General’ tab of Setup Sweep Definition unchanged and select the
‘Calculations’ tab. From this tab, we will define the output variables to include in
the sweep.

5 output variables are to be included. Click 5 times to the Add button. On the first
line, from the pull down menu on the left, select Setup: Matrix1,
Matrix1 then from the pull
down menu on the right, select Lcc.
Lcc On the second line select Setup: Force1 ,
then select Fm. Repeat the procedure for the other force variables: Fx,
Fx Fy,
Fy Fz.
Fz
In the ‘Options’ tab, leave everything unchecked.
The parametric sweep is set up.
Note:
Note the number of adaptive passes, the target error and all the analysis
parameters of the nominal problem will be used. If you happen to have several
analysis setups, select the setup to use in the ‘General’ tab.
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Solve the Parametric Sweep
Right click on the ParametricSetup from the Design tree and run the analysis.

Maxwell will start an separated analysis for every row of the table. On a 3GHz
PC, this will take approximately 3hours to solve.
If you have a Distributive Analysis license, you can run the parametric sweep on
up to 10 machines per Distributive Analysis license. Use the Distributive
Analysis button in this case.
Note:
Note If you cannot click on the Distributive Analysis button, it means that the list
of machines you want to use is not correctly set. Select the menu item Tool >
Options > General Options.
Options Go to the Distributed Analysis Options tab. Make
sure you have at least two machines in the Machine for Distributed Analysis box.
The local machine (the machine where Maxwell has been running) is not included
by default. Also, for a two processor machine, you can enter the machine’s name
twice.
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Solution Data of the Parametric Sweep
Once the analysis is completed, Select the Menu item Maxwell > Optimetrics
Analysis > Optimetrics Results.

Make sure to select the correct optimetrics setup from the pull down menu, then
select the Table radio button to view the results table.
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Create Plot of Force vs. Current for each gap
To create a report:
1. Select the menu item Maxwell > Results > Create Report
2. Create Report Window::
1. Report Type: Magnetostatic
2. Display Type: Rectangular Plot
3. Click the OK button
3. Traces Window::
1. Solution: Setup1: Force
2. Click the Sweeps tab
1. Select Sweep Design and Project variable values
2. Make sure that amp_turns is selected as the primary sweep
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3.

4.

Click the Y tab
1. Category: Force
2. Quantity: Force_magnitude
3. Function: <none>
4. Click the Add Trace button
Click the Done button to view the family of curves shown below.
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ECE from the Parametric Analysis
In order to ultimately perform a system simulation in Simplorer an equivalent
magnetic model must exported from Maxwell 3D. This model contains input pins
for current and gap and outputs for force and flux linkage. The following steps
show how to create this equivalent model. (Note: if you do not intend to do a
system simulation in Simplorer, then these steps are not necessary.)
Select the menu item Maxwell > Export Equivalent Circuit > From Parametric
Solutions.
Solutions
Maxwell fills the ECE window with some parameters that correspond to the
project:
Make sure that the Model type is set to Linear Motion.
Motion
Leave the scaling factor to 1 (this factor is used for models with symmetry).
Choose the Parametric Setup corresponding to your analysis with the
according solution Setup, Matrix Setup and Force Setup.
Only the Z component of the force will be used.
Amperes-Turns have been entered in the model (we selected Stranded
Conductor):
Conductor select the corresponding radio button.

Click on Next to continue.
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ECE from the Parametric Analysis (Continued)
The next window enables you to select or deselect the entries from the
parametric tables.
Fm, Fx and Fy computations will not be used in Simplorer. From the pull-down
menu in the I/O column, select Unused.
Unused We leave the other parameters to their
default values.
Make sure that the data types are correct: gap corresponds to Position and
amp_turns corresponds to Current.
Current
Optionally, if you wish to process the data in a table form, click on Export Table
button and a text file of the parametric table will be created.

Click on Next to continue.
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ECE from the Parametric Analysis (Continued)
This window defines the Terminals of the conservative nodes in Simplorer. The
conservative nodes will have their Across and Through quantities solved by
Simplorer, ensuring the physical meaning of the simulation.
The Flux (and therefore the EMF) is the electrical Across quantity in this case.
The current is the Through quantity.
In the Mechanical domain, gap is the Across quantity whereas Force1 is the
Through quantity.

Since Maxwell has defined the correct values for the Terminals, simply accept
the suggested parameters by clicking on Finish.
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ECE from the Parametric Analysis (Continued)
Give a File name and save the output file.

Maxwell creates the SML file containing the model of the component to be used
in Simplorer. SML stands for Simplorer Modeling Language, the internal
language of Simplorer. This script file will be imported into Simplorer.
To improve visibility of the component in Simplorer, it is advised to capture the
image of the Maxwell 3D design. Select the menu item Edit > Copy To Clipboard.
Clipboard
You can paste this image in any software (like Paint, …)and save it under a bmp
format.

NOTE: Stop here is not continuing to a Simplorer simulation.
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Create the circuit in Simplorer
Note:
Note The software package Simplorer 7 must be installed in order to be able to
continue.
Open Simplorer version 7, create a project then a Schematic.
From the ModelAgent bar, Select the AddOns tab, then click on interfaces in the
folder. Right click on ECE Link and select Copy.
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Create the Component in Simplorer (Continued)
Select the tab Users (or the Project tab is some libraries have been created in the
Project). Select user and select the menu item Edit > Paste.
Paste The ECE component
has been copied to your user section. It is now possible to change the name of
the component and to modify the component symbol.

Right click after having selecting the ECE link component. Choose properties. In
the window, select the General tab and give the component name ECE Solenoid.
Solenoid
Leave the other parameters to their default values and Select OK.
Right click and select Edit Symbol. From this window, you can draw your own
symbol or import it from a bmp image (Select the menu item Draw > Insert
Bitmap).
Bitmap
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Create the Component in Simplorer (Continued)
Drag and drop the ECE Solenoid component on the sheet. Open the component
dialogue box. Click on the Load model button.

Browse your disk to recover the output file generated by Maxwell. This file has
the extension SML.

Click on OK. The model is loaded.

Ansoft Maxwell 3D Field Simulator v11 User’s Guide

5.4-41

5.4
Topic – ECE: Linear movement
Create the Component in Simplorer (Continued)
In the component dialogue box, select the Output/Display tab. In the Pin column,
4 boxes are checked: Current_N1, Current_N2, Force1_N1, Force1_N2. These
terminals correspond to the electrical and mechanical terminals we defined
during the ECE process in Maxwell. Verify that in the Show column, the Name at
Symbol is chosen to ease the wire connection on the sheet.

As additional input (non conservative node), you can specify the number of turns
in the Coil (in Maxwell, we just gave the overall value of the current) as well as
give an additional resistance corresponding to the coil in the Solenoid.
The component is ready to be used in a Simplorer project.
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Create the Schematic sheet in Simplorer

In this application, the system surrounding the actuator has an
electric part and a mechanical part.
For the electrical part, the following components have been dragged
on the sheet:
A Voltage source E1,
E1 with the following parameters:

A resistance
R1,
R1
Ansoft Maxwell 3D Field Simulator
v11 User’s Guide

with R= 215 mΩ
An inductance L1,
L1 with L= 10pH
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Create the Schematic sheet in Simplorer (Continued)
For the electrical part, the following components have been dragged on the
sheet:
A Force-meter FM1 to measure the actual force coming from the actuator
A Force Source F_initial corresponding to the initial force with F=125 N
A mass MASS that describes the mass of the plunger of the actuator:

A Limit stop LIMIT that represents a parallel damper and spring
combination:
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Create the Schematic sheet in Simplorer (Continued)
The mechanical ground and the electrical ground must be included.

Create the graphical Displays in Simplorer
We want to display the Coil Current, the Actuator Force and the Stoke for this
system.
Drag a 2D view element (from the Displays tab).

1- Click to add a quantity in
the display

2- Select ECELink1.ICurrent

Select the yellow button to add the the current of the ECE component.
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Create the graphical Displays in Simplorer
Repeat this operation with 2 new 2D view elements. Add the two following
quantities:
The force of the plunger: ECELink1.Fz_OUT
The stroke : 39.79 * MASS.S

Create a Transient Analysis
Select the menu item Simulation > Parameters
Fill the window with these parameters:
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Run the Analysis
The simulation can be started by selecting the menu item Simulation > Start
The 2D displays look like:

Coil Current
ECELink1.ICurrent [A]
80.00

50.00

0
0

2.00m

5.00m

Actuator Force
-120.00m

-100.00

-200.00
-252.00ECELink1.Fz_OUT [V]
0

2.00m

4.00m 5.00m

Stroke
39.79 * MASS.S [m]
10.00m

5.00m

0
0
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The implementation and application of Nonlinear Anisotropic
Material when using the Magnetostatic, and Transient Solvers
In v11 of Maxwell 3D a new function of Nonlinear Anisotropic Material can be
used with the Magnetostatic, and Transient Solvers for simulating soft
magnetic materials. The obvious advantage is significance because
NonNon-linear lamination is extensively used in low frequency
electromagnetic devices for having high induction but with significant
reduction of eddy current loss in the rolling direction.
NonNon-linear anisotropy is widely used magnetization, magnetic
recording, power transformers and large size electrical machines.
Oriented materials will have higher magnetic field like magnetic flux
density in special directions as users want but lower magnetic field in
other directions.
In this note a magnetostatic model as one step of magnetization will be
introduced including how to set up Non-linear lamination and Non-linear
anisotropic materials. Same set up will be used for Transient model.
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Ansoft Maxwell Design Environment
The following features of the Ansoft Maxwell Design Environment are used to
create the models covered in this topic
3D Solid Modeling
User Defined Primitives (UDP): RMxprt/SlotCore
Primitives:: Regular Polyhedron Box Cylinder
Surface Operations: Section Edge Filet
Boolean Operations: Split Separate Bodies
Boundaries/Excitations
Current: Stranded
Windings
Analysis
Magnetostatic
(Transient)
Results
Field Calculator
Group objects with Objectlist
2d plot with Create Report
Field Overlays:
Flux Density Plots
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Getting Started
Launching Maxwell
1.

To access Maxwell, click the Microsoft Start button, select Programs,
Programs and select
Ansoft and then Maxwell 11.

Setting Tool Options
To set the tool options:
Note: In order to follow the steps outlined in this example, verify that the
following tool options are set :
1. Select the menu item Tools > Options > Maxwell Options
2. Maxwell Options Window:
1. Click the General Options tab
Use Wizards for data entry when creating new boundaries:: 
Checked
Duplicate boundaries with geometry::  Checked
2. Click the OK button
3. Select the menu item Tools > Options > 3D Modeler Options.
Options
4. 3D Modeler Options Window:
1. Click the Operation tab
Automatically cover closed polylines::  Checked
2. Click the Display tab
Default transparency = 0.8
3. Click the Drawing tab
Edit property of new primitives::  Checked
4. Click the OK button
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Opening a New Project
To open a new project:
1. In an Maxwell window, click the  On the Standard toolbar, or select the
menu item File > New.
2. Select the menu item Project > Insert Maxwell Design, or click on the
icon

Set Solution Type
Select the menu item: Maxwell > Solution Type > Magnetostatic, or right mouse
click on MaxwellDesign1 and select Solution Type …

Creating the 3D Model of a magnetization model of a fourfour- poles
outout-rotor
The example that will be used to demonstrate how the anisotropic non-linear
material & non-linear lamination are implemented in a Magnetization model of a
four-poles out-rotor. The intent of this write up is not how to simulate the outrotor motors, it is rather to demonstrate how anisotropic materials are
implemented within the Magnetostatic (or Transient) solver. This magnet ring is
an non-linear anisotropic one (nonlinear in R & Z direction with low permeability
in Theta direction) and the field core is a laminated one. lamination direction is
Global X) Thus we can show how these materials can be set up for create an
four poles out-rotor.

Set Model Units
Select the menu item 3D Modeler > Units > Select Units: mm (millimeters)
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Create the problem Region
One of the main differences between Maxwell V10 and V11 is that a Background Region is
not automatically created when a project is started. A separate object needs to be specifically
created.
Create a Box region by selecting the menu item Draw > Box or click on the
icon.
1.
Using the coordinate entry field, enter the box position
X: -50, Y: -50, Z: -50,
50 Press the Enter key
2.
Then enter the opposite corner for the base rectangle with the height
X: 100.0, Y: 100.0, Z: 100.0,
100.0 Press the Enter key

Click OK to finish it. Change the name from Box1 to Region by editing the Attribute panal on
the left hand side of the interface. Keep the material as vacuum.
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Create the Field Core:
A User Defined Primitive will be used to create the Field Core

Draw > User Defined Primitive > Syslib > Rmxprt > SlotCore
Use the values given in the panel below to create the rotor

Click SlotCore1 with right of mouse in History Tree Edit >Arrange >Rotate >Y >90
degree>OK
Click on the just created object in the drawing window and in the panel on the left change its
name from SlotCore1 to FieldCore
Create material Press of nonnon-linear laminate one for FieldCore
Click Material vacuum to get in the Material Select Definition window, Pick Add Material
Material…
…
Change name Material1 to Press
Pick Type of Relative Permeability and change it from Simple to Nonlinear, Pick BH curve in
the right of it, then click Import from file…, select Press.bh for it with OK to finish it.
Pick Solid in Composition Line and Change it to Lamination
Change the Value of –Stacking Factor to 0.95 and keep the Stacking Direction as V(1) (X
direction). Pick Validate Material , the green tick will be appeared. Click OK to exit.
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Select OK in Select Definition window, Then change SlotCore1 as FieldCore, make sure the
Material is Press and the Orientation is Global.

Create the Housing and Magnet Ring of Out-rotor:
Create Housing
Draw > RegularPolyhedron then using the coordinate entry field, enter the center position
X: -15.3, Y: 0, Z: 0,
0 Press the Enter key
Then enter the height and the radio
dZ:
dZ: 24.4 for radius, Press the Enter key
dX:
dX: 30.8 for height, Press the Enter key
Number of segments = 36, OK
Change the name from RegularPolyhedron1
to Housing

Draw > RegularPolyhedron then using the coordinate entry field, enter the center position
X: -14.5, Y: 0, Z: 0,
0 Press the Enter key
Then enter the height and the radio
dZ:
dZ: 22.8 for radius, Press the Enter key
dX:
dX: 30.8 for height, Press the Enter key
Number of segments = 72, OK
Change the name from RegularPolyhedron1
to Housing1
Pick Housing and Housing1 in History Tree, Use right mouse Edit > Boolean > Subtract to
create new Housing
Draw > RegularPolyhedron then using the coordinate entry field, enter the center position
X: -15.3, Y: 0, Z: 0,
0 Press the Enter key
Then enter the height and the radio
dZ:
dZ: 3.25 for radius, Press the Enter key
dX:
dX: -1.7 for height, Press the Enter key
Number of segments = 16,
16 OK
Change the name from RegularPolyhedron1
to Housing2
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Pick Housing and Housing2 in History Tree, Use right mouse Edit > Boolean > Unit to
create new Housing

Draw > RegularPolyhedron then using the coordinate entry field, enter the center position
X: 0, Y: 0, Z: 0,
0 Press the Enter key
Then enter the height and the radio
dZ:
dZ: 2.45 for radius, Press the Enter key
dX:
dX: -20 for height, Press the Enter key
Number of segments = 16,
16 OK
Change the name from RegularPolyhedron1
to Housing3
Pick Housing and Housing3 in History Tree, Use right mouse Edit > Boolean > Substract to
create final Housing
Create material Press1 of nonnon-linear one for Housing
Click Housing in History Tree, then pick Material vacuum in it’s Attribute to get in the
Material Select Definition window, Search & pick Press
Select Clone Materials
Pick Lamination in Composition Line and Change it to Solid
Click OK to exit. Press1 will be appeared in Material Name Listing
Click OK to exit Select Definition. Make sure Press1 will be the Material of Housing
and change the color as light blue

Create Magnet Ring named as Mag
Draw > RegularPolyhedron then using the coordinate entry field, enter the center position
X: -10, Y: 0, Z: 0,
0 Press the Enter key
Then enter the height and the radio
dZ:
dZ: 22.8 for radius, Press the Enter key
dX:
dX: 20 for height, Press the Enter key
Number of segments = 72,
72 OK
Change the name from RegularPolyhedron1
to Mag
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Draw > RegularPolyhedron then using the coordinate entry field, enter the center position
X: -10, Y: 0, Z: 0,
0 Press the Enter key
Then enter the height and the radio
dZ:
dZ: 18.8 for radius, Press the Enter key
dX:
dX: 20 for height, Press the Enter key
Number of segments = 72,
72 OK
Change the name from RegularPolyhedron1
to Mag1
Pick Mag and Mag1 in History Tree, Use right mouse Edit > Boolean > Substract to create
final Mag
Create material Mag_aniso of nonnon-linear anisotropic one for Mag
Click Mag in History Tree, then pick Material vacuum in it’s Attribute to get in the Material
Material…
…
Select Definition window, Pick Add Material
Change name Material1 to mag_aniso
mag_aniso,, and Material Coord. System Cartesian to Cylindrical
Pick Type of Relative Permeability and change it from Simple to Anisotropic
Change Type of T(1,1) from Simple to Nonlinear, Click BH curve in the right of it, then click
Import from file…, select Mag.bh for it with OK to finish it.
Change Value of T(2,2) from 0 to 20
Change Type of T(3,3) from Simple to Nonlinear, Click BH curve in the right of it, then click
Import from file…, select Mag.bh for it with OK to finish it.
Click Validate Material to get green Tick Mark. OK to exit. mag_aniso will be appeared in
Material Name Listing
Click OK to exit Select Definition. Make sure mag_aniso will be the Material of Ma

Using 3d Modeler > Coordinate System >

Create > Relative CS > Rotated
Select the x axis X:0; Y:1; Z:0 Press Enter
Select the point on xy plane X:0; Y:0; Z:1
Press Enter. Then change Coord Name
From RelativeCS1 to RelativeCS0
Double click Mag in Histery Tree, Change the
Orientation Value from Global to RelativeCS0
with OK to exit.

Note: Because in Cylindrical Coordinate System, Theta direction is fixed as T(2,2), the
Global CS can’t be used for Mag directly. RelativeCS0 must be created for it.
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Create the coils
Create Coil named as coil1
Draw > Box then using the coordinate entry field, enter the box position
X: 14.2, Y: 6.2, Z: -7.8,
7.8 Press the Enter key
Then enter the length, width and height of the box
dX:
dX: -28.2; dY:
dY: 6.5; dZ:
dZ: 15.6, Press the Enter key
Box1 will be created.

Draw >Box then using the coordinate entry field, enter the box position
X: 11.2, Y: 6.2, Z: -4.8,
4.8 Press the Enter key
Then enter the length, width and height of the box
dX:
dX: -22.4; dY:
dY: 6.5; dZ:
dZ: 9.6, Press the Enter key
Box2 will be created.
Pick Box1 & Box2, Using right mouse
Edit > Boolean > Substract to create final Box1
Change the name of Box1 to Coli_1 and set
material Cupper for it
Select Coli_1 in History Tree, Using right mouse Edit > Arrange > Rotate
select X as rotating Axis with 45 degree, OK to finish it.
View > Active View Visibility to erase the tick marks for all except Coil_1 as below:

Change
in Tool Bar to
pick 4 edges of the Coil_1 as below:

Select the icon
of Fillet the selected edges
in Tool Bar and set 2 mm as Fillet Radius
After OK to finished Coil_1, change the color of
it as dark yellow.
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Using Alt Key and double click the mouse on the
the coordinate (0,0,0) to rotate the View
as YZ plane (See right)
Using 3d Modeler > Coordinate System >

Offiset,,
Create > Relative CS > Offiset
input X: 0; Y: 0.2; Z: 0.2 with Enter key
the coordinate CS1 will be created.
Pick Coil_1 in History Tree, Use right mouse
Edit > Boolean > Split and select XY plane
with OK
Pick Coil_1 in History Tree, Use right mouse
Edit > Boolean > Split and select XZ plane
with OK. The final Coil1 will be finished.
Select Global coordinate in History Tree
Pick Coil_1 in History Tree, Use right mouse

Edit > Duplicate > Around Axis
Select X Axis with Angle 90 & Total Number 4
All 4 coils will be finished
Pick all Coil_1- 4 in History Tree, Use right
mouse Edit > Surface > Section and select YZ
plane with OK
Pick all Section1- 4 in History Tree, Use right mouse Edit > Boolean > Separate Bodies
Pick Section1_1,2_1,3_1,4_1, then Click Delete Key.
Now the whole model will be as below:

Housing

Coils

Mag
FieldCore
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Assign Current Source to the Terminals
Select Coil Terminals Section1 & Section3 by using holding down the CTRL key
and using your mouse or selecting from tree on the left hand side of the GUI
Select the menu item Maxwell > Excitations > Assign > Current
1. Change the Base Name to Current13
2. Change the value to 4000 Amps
3. Change the type to Stranded
Select Coil Terminals Section2 &
Section4
Select the menu item Maxwell >

Excitations > Assign > Current
1.
2.
3.
4.

Change the Name to Current24
Change the value to 4000 Amps
Change the type to Stranded
Pick Swap Direction

The project tree now shows 4 separate Excitations:
Any one of them can be selected to check the
directions of the Excitation Current.
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Theory of the Nonlinear Anisotropic Material for soft
magnetic materials
Basic ideas for new nonlinear anisotropic materials:
The cross effects of the magnetic field in the different principle directions
are decoupled by introducing an equivalent magnetic field magnitude in
each principle direction based on an anisotropic characterization of the
energy density .
Only B-H curves in the principal directions of the materials – two curves in
2D or three curves in 3D – need to be measured
The anisotropic behavior of laminations with either isotropic or anisotropic
steel is also considered.
Proposed approach
Since applying the same value of H in different principle directions will
cause different level of magnetic saturations, the approach refers all
components of H to each principle direction by referring factor k to
determine the saturation in that direction
 H x = H 2 + (k H ) 2 + (k k H ) 2
x
xy y
xz µ z z
 e
 y
2
2
2
 H e = (k yx H x ) + H y + (k yz k µ z H z )
 z
2
2
2
 H e = (k zx H x ) + (k zy H y ) + (k µ z H z )


where
is introduced to consider lamination effects and kxy is determined
by magnetic energy density w in x and y principle directions, kxy = wx /wy,
and similarly to other k’s.
The permeability for each principle direction is obtained in terms of the
equivalent magnitude He in that direction. For example, for axis x:
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1

The Modeling Sequence will be as follows:

Reference:
[1] D. Lin, P. Zhou, Z. Badics, W. N. Fu, Q. M. Chen and Z. J. Cendes, “A
A New Nonlinear
Anisotropic Model for Soft Magnetic Materials”
Materials” , CSY0084 of COMPUMAG’
COMPUMAG’2005
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Create an Analysis Setup
Select the menu item Maxwell > Analysis Setup > Add Solution Setup
Select General and change the Percent Error from 1 to 5
Select Convergence and change the Refinement Per Pass from 30 to 20
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Save the Project
Select the menu item File > Save As
From the Save As window, type in GST16
Click on the Save button

Check the Validity of the Model
Select the menu item Maxwell > Validation Check, or click on the

icon

The problem won’t solve unless each object has a check mark.

Analyze
Select the menu item Maxwell > Analyze,
Analyze or click on the
The Analysis will be start as below:
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Solution Data
To view the Solution Data, select the menu item Maxwell > Results >

Solution Data
Here you can view the Profile and the Convergence. Note:: The
default view is for convergence is Table.
Table Select the Plot radio button
to view a graphical representations of the convergence data.
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Plot Flux Density on Cross-section YZ of Mag
To plot the flux density on YZ cut-plane of the magnetic, select the Global YZ of
Planes in History Tree by clicking on it, and move the mouse to 3d Modeler
Window then right mouse click and select Fields > B > B _Vector, in Create Field
Plot Window select B_Vector in “Quantity” and Mag in “In Volume”, Press Done.
Done
The field plot is a little misleading since it show different colors across the YZ
plane, but the legend displays the exact value for the full color spectrum. To
change the scale, double click on the legend and then select Scale.
Scale Select the
radio button Use Limits and set the Min to 0.0001,
0.0001 the Max to 0.8,
0.8 click on Apply
Then select Marker/Arrow,
Marker/Arrow in Arrow options Change the Type as Umbrella and
move Size Arrow to largest, click on Apply.
Then select Plots,
Plots in Vector plot Select Uniform and move the Spacing size to
smallest, set Min. as 0.7 and Max. as 3, click on Apply.
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The plot of the flux density on YZ cut plane of the Mag will be as below:

Note: Please note that if the Mag is not set up as anisotropic one (i.e. uniform
Nonlinear one) the B field between two magnetic poles will be very large in the
theta directions, which will be not as good as user wanted.
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Plot Flux Density Bmag on Cross-section YZ of Mag, FieldCore &
Housing
To plot the Field on more than one objects, the group function is needed. Pick
Mag,
Mag, FieldCore & Housing in History Tree, then 3D Modeler/List/Create/Object
Modeler/List/Create/Object
List, then click OK to create Objectlist1

Select the Global YZ of Planes in History Tree and move the mouse to 3d
Modeler Window then right mouse click and select Fields > B > Mag_B,
Mag_B, pick
Objectlist1 in “In Volume” then press Done
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The plot of the mag_B on YZ cut plane of the Mag, FieldCore & Housing will be
as below:

User may double click on the legend and change Scale to see the detail field
distributions
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Plot Flux Density B_radial on an arc of the Mag
To see the detail distribution near the inner surface of the Mag, the 2d plot on
a cut-line will be needed.
Create a cut-line of arc
Draw > Arc > 3 Points and select Yes for Question below:

using the coordinate entry field, Enter first endpoint
X: 0, Y: 19.0, Z: 0,
0 Press the Enter key
Then enter arc intercept (middle point)
X: 0, Y: 0, Z: 19,
19 Press the Enter key
Enter second endpoint
X: 0, Y: -19.0, Z: 0,
0 Press the Enter key twice.

Press OK to create Polyline1.
Polyline1
Create B_radial in Calculator
Select the Global YZ of Planes in History Tree and move the mouse to
3d Modeler Window then right mouse click and select Maxwell >Fields

> Calculator
Function > Scalar Z > OK
Function > Scalar Y > OK
Trig > ATan2 >Push [ATan2(Z,Y) = ATan(Z/Y)]
Trig > Sin > Exch > Trig > Cos
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Quantity > B > Scal?
Scal? > Scalar Y > * >Exch
>Exch
Quantity > B > Scal?
Scal? > Scalar Z > * > + ,the Br for arc is ready.

Pick Add and type the Name as B_radial , pick Ok to finish it.
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In Maxwell V11 all 2d plot will be created with Create Report

Maxwell > Result >Create Report > OK

Select Polyline1 in Geometry, pick B_radial in Quantity, click Add Trace
press Done, the result curve on cutline will be se below:
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The application of Symmetry Boundaries
There are many advantages to using Symmetry Boundaries when modeling.
Meshes ca be decreased greatly by using Symmetry Boundaries when you
model the shape of an analytical object . As a result, the saving of the
calculation resource and shortening analytical time become possible.
In this note, the model of very simple transformer will be analyzed using
Magentstatic solver. At this time, the model size is reduced by using the
Symmetry boundaries
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Ansoft Maxwell Design Environment
The following features of the Ansoft Maxwell Design Environment are used to
create the models covered in this topic
3D Solid Modeling
Primitives: Line, Rectangle, Box
Surface Operations: Section, Sweep Along Path
Boolean Operations: Subtract, Separate Bodies, Split,
Duplicate (Mirror)
Boundaries/Excitations
Current: Stranded
Symmetry
Analysis
Magnetostatic
Results
Solution Data
Field Overlays:
Flux Density Plots
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Getting Started
Launching Maxwell
1.

To access Maxwell, click the Microsoft Start button, select Programs, and select
Ansoft and then Maxwell 11.

Setting Tool Options
To set the tool options:
Note: In order to follow the steps outlined in this example, verify that the
following tool options are set :
1. Select the menu item Tools > Options > Maxwell Options
2. Maxwell Options Window:
1. Click the General Options tab
Use Wizards for data entry when creating new boundaries: 
Checked
Duplicate boundaries with geometry:  Checked
2. Click the OK button
3. Select the menu item Tools > Options > 3D Modeler Options.
4. 3D Modeler Options Window:
1. Click the Operation tab
Automatically cover closed polylines:  Checked
2. Click the Display tab
Default transparency = 0.8
3. Click the Drawing tab
Edit property of new primitives:  Checked
4. Click the OK button
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Opening a New Project
To open a new project:
1. In an Maxwell window, click the  On the Standard toolbar, or select the
menu item File > New.
2. Select the menu item Project > Insert Maxwell Design, or click on the
icon.
Select the new design and change the name to full.

Set Solution Type
Select the menu item: Maxwell > Solution Type > Magnetostatic, or right
mouse click on MaxwellDesign1 and select Solution Type …

Creating the 3D Model of a Symmetry model of a Trans
The example that will be used to demonstrate how the Symmetry boundaries is
implemented in a Magnetization model of a Transformer. The intent of this write
up is not how to simulate the Transformer, it is rather to demonstrate how
Symmetry boundaries is implemented within the Magnetostatic solver. A very
simple transformer that rolls the winding of coil_in and coil_out in core is used.

Set Model Units
Select the menu item 3D Modeler > Units >
Select Units: mm (millimeters)
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Create the problem Region
One of the main differences between Maxwell V10 and V11 is that a Background Region is
not automatically created when a project is started. A separate object needs to be specifically
created.
Create a Box region by selecting the menu item Draw > Box or click on the
icon.
1.
Using the coordinate entry field, enter the box position
X: -75, Y: -75, Z: -75, Press the Enter key
2.
Then enter the opposite corner for the base rectangle with the height
X: 150, Y: 150, Z: 150, Press the Enter key

Click OK to finish it. Change the name from Box1 to region by editing the Attribute panal on
the left hand side of the interface. Keep the material as vacuum.
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Create the core
D Modeler > Grid Plane > YZ then change the grid plane to YZ.
Draw > Rectangle then make a rectangle.
1.
Input the coordinate of start point in the coordinates input
scene in the lower right of the screen
X: 5, Y: -25, Z: -25 Press the Enter key.
2.
Input the coordinates of opposite corner.
dY: 50, dZ: 40, Press the Enter key.
3.
Change the object name and color.
Name: core, Color: blue
Draw > Rectangle then make a rectangle.
1.
Input the coordinate of start point in the coordinates input
scene in the lower right of the screen
X: 5, Y: -15, Z: -10 Press the Enter key.
2.
Input the coordinates of opposite corner.
dY: 10, dZ: -20, Press the Enter key.
3.
Change the object name and color.
Name: slot1, Color: blue
Select slot1 and Edit > Duplicate > Mirror then make the copy of slot1.
1.
Input the coordinate of start point in the coordinates input
scene in the lower right of the screen
X: 0, Y: 0, Z: 0 Press the Enter key.
2.
Input the direction where the copy object will be made.
X: 0, dY: 1, dZ: 0, Press the Enter key.
Select core, slot1, and slot1_1 in this order while pushing the Ctrl key. 3D Modeler >
Boolean > Subtract
Select core and Draw > Sweep > Along Vector
1.
Input the coordinate of start point in the coordinates input
scene in the lower right of the screen.
X: 0, Y: 0, Z: 0 Press the Enter key.
2.
Input the direction to sweep.
X: -10, dY: 0, dZ: 0, Press the Enter key.
3.
Select Draft angle: 0, Draft type: Round
The material of core is ferrite.
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Create the coil_in
Draw > Box then make a box.
1.
Input the coordinate of start point in the coordinates input
scene in the lower right of the screen
X: -9, Y: -9, Z: -9 Press the Enter key.
2.
Input the coordinates of opposite corner.
dX: 18, dY: 18, dZ: 18, Press the Enter key.
3.
Change the object name and color.
Name: coil_in, Material: copper, Color: red
Draw > Box then make a box.
1.
Input the coordinate of start point in the coordinates input
scene in the lower right of the screen
X: -6, Y: -6, Z: -9 Press the Enter key.
2.
Input the coordinates of opposite corner.
dX: 12, dY: 12, dZ: 18, Press the Enter key.
3.
Change the object name and color.
Name: coil_in_
Select coil_in and coil_in_ in this order while pushing the Ctrl key.
3D Modeler > Boolean > Subtract

Create coil_out
Draw > Rectangle then make a rectangle.
1.
Input the coordinate of start point in the coordinates input
scene in the lower right of the screen
X: 0, Y: 10, Z: -9 Press the Enter key.
2.
Input the coordinates of opposite corner.
dY: 4, dZ: 18, Press the Enter key.
3.
Change the object name and color.
Name: coil_out, Color: green
Draw > Line then make the path to sweep coil_out
1.
Input the following coordinates in the coordinates input
scene in the lower right of the screen
In the last point, push Enter key twice
X: 10, Y: 10, Z: 9
X: -10, Y: 10, Z: 9
X: -10, Y: -10, Z: 9
X: 10, Y: -10, Z: 9
2.
Change the name to coil_out_path
3.
Dlete CoverLines of coil_out_path using History window
Select coil_out and coil_out_path while pushing the Ctrl key.
3Draw > Sweep > Along Path
Angle of twist: 0deg
Draft Angle: 0deg
Draft Type: Round
The maerial of coil_out is copper.
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Create Coil Terminal
Make the terminal for coil_in and coil_out to pass a current.
1.
Select coil_in and coil_out while pushing the Ctrl key
3D Modeler > Surface > Section
Section Plane: YZ
2.
Select Section1, Section2 that are made now.
3D Modeler > Boolean > Separate Bodies
3.
Delete sections on a minus side of Y axis of each coil
as shown in a right figure.
4.
Change each name to term_in, term_out.

term_in
Assign Current Source to the Terminals
term_in
1.
Select term_in
2.
Maxwell > Excitations > Assign > Current
Name: Cur_in
Value: 100 A
Type: Stranded
Click Swap Direction

term_out

term_out
1.
Select term_out
2.
Maxwell > Excitations > Assign > Current
Name: Cur_out
Value: 50 A
Type: Stranded
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Create an Analysis Setup
Select the menu item Maxwell > Analysis Setup > Add Solution Setup
Select General and change the Percent Error to 1
Select Convergence and change the Refinement Per Pass from 30 to 15
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Save the Project
Select the menu item File > Save As
From the Save As window, type in 03_Symm
Click on the Save button

Check the Validity of the Model
Select the menu item Maxwell > Validation Check

The problem won’t solve unless each object has a check mark.

Analyze
Select the menu item Maxwell > Analyze,
Analyze or click on the
The Analysis will be start as below:
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Solution Data
To view the Solution Data, select the menu item Maxwell > Results > Solution Data
Here you can view the Profile and the Convergence. Note: The default view is for
convergence is Table. Select the Plot radio button to view a graphical representations of the
convergence data.

You can view mesh information clicking Mesh Statistics Tab.
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Plot Flux Density Vector on CrossCross-section YZ
To plot the flux density on YZ cut-plane of the magnetic, select the Global YZ of Planes in
History Tree by clicking on it, and move the mouse to 3d Modeler Window then right mouse
click and select Fields > B > B _Vector, in Create Field Plot Window select B_Vector in
“Quantity” and All in “In Volume”, Press Done.
Done
The field plot is a little misleading since it show different colors across the YZ plane, but the
legend displays the exact value for the full color spectrum. To change the scale, double click
on the legend and then select Scale.
Scale Select the radio button Use Limits and set the Min to 0,
the Max to 2, click on Apply
Then select Marker/Arrow,
Marker/Arrow in Arrow options Change the Type as Umbrella and move Size
Arrow to the third from left , click on Apply.
Then select Plots,
Plots in Vector plot Select Uniform and move the Spacing size to smallest,
smallest set
Min. as 1.5 and Max. as 3, click on Apply.

Plot Flux Density Magnitude on CrossCross-section YZ
To plot the flux density on YZ cut-plane of the magnetic, select the Global YZ of Planes in
History Tree by clicking on it, and move the mouse to 3d Modeler Window then right mouse
click and select Fields > B > Mag_B, in Create Field Plot Window select Mag_B in “Quantity”
and All in “In Volume”, Press Done.
Done
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The plot of the flux density Vector and Magnitude on YZ cut plane will be as below:
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Create 1/8 model using Symmetry boundaries
Copy of design
1.
Select full design in the project manager window
Edit > Copy
2.
Select 03_Symm project in the project manager
window
Edit > Paste
3.
Change the name of new design from full_1to 1_8

Divide the model
Divide by XY plane
1.
Edit > Select All
2.
3D Modeler > Boolean > Split
Split Plane: XY
Keep fragments: Positive side
Split objects: Split entire selection
Divide by YZ plane
1.
Edit > Select All
2.
3D Modeler > Boolean > Split
Split Plane: YZ
Keep fragments: Positive side
Split objects: Split entire selection
Divide by XZ plane
1.
Edit > Select All
2.
3D Modeler > Boolean > Split
Split Plane: XZ
Keep fragments: Positive side
Split objects: Split entire selection
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Assign Current Source to the Terminals
Edit > Select > Faces then change the selection mode of object.
coil_in
1.
Select the face of coil_in which touches YZ plane
2.
Maxwell > Excitations > Assign > Current
Name: Cur_in_in
Value: 50 A
Type: Stranded
3.
Select the face of coil_in which touches
XZ plane
4.
Maxwell > Excitations > Assign > Current
Name: Cur_in_out
Value: 50 A
Type: Stranded
Click Swap Direction
coil_out
1.
Select the face of coil_out which touches YZ plane
2.
Maxwell > Excitations > Assign > Current
Name: Cur_out_out
Value: 25 A
Type: Stranded
3.
Select the face of coil_out which touches
XZ plane
4.
Maxwell > Excitations > Assign > Current
Name: Cur_out_in
Value: in A
Type: Stranded
Click Swap Direction

Note: The current value of coil_in was 100A and coil_out was 50A in full model. The
sectional area of the coil is 1/2 in 1/8 models because it is divided by XY plane.
Therefore, the current value becomes 1/2, too.

Ansoft Maxwell 3D Field Simulator v11 User’
User’s Guide

5.6-15

5.6
Example (Magnetostatic) – Symmetry Boundaries

Setup boundaries
Select the face of region which touch XY plane.
Maxwell > Boundaries > Assign > Symmetry
Name: Symmetry1
Symmetry: Even (Flux Normal)

Note: The surface of boundary area (region) is analyzed as a natural boundary
condition (Flux is the horizontal compared with respect). Because Flux becomes the
horizontal for the YZ plane and the XZ plane in this model, the Symmetry
boundaries is not necessary.
Check the Validity of the Model
Select the menu item

Maxwell > Validation Check

Analyze
Select the menu item Maxwell > Analyze,
Analyze or click on the
The Analysis will be start as below:
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Solution Data
To view the Solution Data, select the menu item Maxwell > Results > Solution Data
Here you can view the Profile and the Convergence. Note: The default view is for
convergence is Table. Select the Plot radio button to view a graphical representations of the
convergence data.

You can view mesh information clicking Mesh Statistics Tab.

In the full model, the number of mesh was 2216, now it becomes 372 meshes in 1/8 models.
That means the number of mesh become about 1/6. Moreover, analytical accuracy is almost
same because it is specified by Energy Error.
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The plot of the flux density Vector and Magnitude on YZ cut plane will be as below:

The result is almost same as that of full model
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Magnetization
Permanent Magnet Magnetization
Each object can have the coordinate system that is independent and is
arbitrary in Maxwell v11. The magnetization setting can be done in an
arbitrary direction for using this coordinate system.
Moreover, because it is also possible to do the magnetization setting by
using the equation and the numeric character data, the user can do a variety
of magnetization settings.
This chapter introduces the magnetization setting as shown in the figure
below as an example of an easy toroidal magnet.
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Magnetization
Ansoft Maxwell Design Environment
The following features of the Ansoft Maxwell Design Environment are used to
create the models covered in this topic
3D Solid Modeling
Primitives: Regular Polyhedron Box
Coordinate System: Relative CS
Boolean Operations: Subtract
Analysis
Magnetostatic
Field Overlays:
B Vector Plots B Magnitude Plots
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Getting Started
Launching Maxwell
1.

To access Maxwell, click the Microsoft Start button, select Programs, and select
Ansoft and then Maxwell 11.

Setting Tool Options
To set the tool options:
Note: In order to follow the steps outlined in this example, verify that the
following tool options are set :
1. Select the menu item Tools > Options > Maxwell Options
2. Maxwell Options Window:
1. Click the General Options tab
Use Wizards for data entry when creating new boundaries: 
Checked
Duplicate boundaries with geometry:  Checked
2. Click the OK button
3. Select the menu item Tools > Options > 3D Modeler Options.
4. 3D Modeler Options Window:
1. Click the Operation tab
Automatically cover closed polylines:  Checked
2. Click the Display tab
Default transparency = 0.8
3. Click the Drawing tab
Edit property of new primitives:  Checked
4. Click the OK button
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Magnetization
Opening a New Project
To open a new project:
1. In an Maxwell window, click the  On the
Standard toolbar, or select the menu item
File > New.
2. Select the menu item
Project > Insert Maxwell Design,
or click on the
icon

Set Solution Type
Select the menu item: Maxwell > Solution Type > Magnetostatic, or right
mouse click on MaxwellDesign1 and select Solution Type …

Change Design name
Right-click MaxwellDesign1 at the project manager window , change the
Design Name to Ring01.
Ring01

Set Model Units
Select the menu item 3D Modeler > Units > Select Units: mm
(millimeters)

Saving of project
Select the menu item File > Save as
Enter the folder name that you want to save and change the Project name
:Magnet.
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Magnetization
Example Coordinate system of object and setting for each axis
In this example, it is introduced the magnetization of using Coordinate system of
object and setting for each axis. Material : Mag01 and Mag02 is newly made in this
Example.
Create the problem Region
One of the main differences between Maxwell V10 and V11 is that a
Background Region is not automatically created when a project is started. A
separate object needs to be specifically created.
Create a Box region by selecting the menu item Draw > Box or click on the
icon.
1. Using the coordinate entry field, enter the box position
X: -200, Y: -200, Z: -200 Press the Enter key
2. Then enter the opposite corner for the base rectangle with the height
dX: 400, dY: 400, dZ: 400, Press the Enter key

Click OK to finish it. Change the name from Box1 to Region by editing the
Attribute panel on the left hand side of the interface. Keep the material as
vacuum.
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Create Ring01_1
Draw > RegularPolyhedron then using the coordinate entry field, enter
the center position
X: 0, Y: 0, Z: -4, Press the Enter key
Then enter the height and the radio
dX:40 for radius, Press the Enter key
dZ: 8 for height, Press the Enter key
Number of segments = 36, OK
Change the name and color from RegularPolyhedron1 to Ring01_1
and blue

Draw > RegularPolyhedron then using the coordinate entry field, enter
the center position
X: 0, Y: 0, Z: -4, Press the Enter key
Then enter the height and the radio
dX:30 for radius, Press the Enter key
dZ: 8 for height, Press the Enter key
Number of segments = 36, OK
Change the name from RegularPolyhedron1 to Hole

Select Ring01_1 and Hole in History Tree, Use right mouse Edit >
Boolean > Subtract to create new Ring01_1
Ansoft Maxwell 3D Field Simulator v11 User’
User’s Guide

5.7-6

5.7
Example (Magnetostatic) – Permanent Magnet
Magnetization
Create new material Mag01
Click Ring01_1, then pick Material Vacuum in it’s Attribute to get in
the Material Select Definition window.
Select Add Material
Change properties as follows.
Material Name Mag01
Material Coordinate System Cylindrical
Magnitude -837000
R Component 1
Click OK to exit. Mag01 will be appeared in Material Name Listing
Click OK to exit Select Definition.
Definition Make sure Mag01 will be the
Material of Ring01_1

Note Please note that Orientation of Ring01_1 is Global. It will be
radially magnetized from (0,0,0) by this setting.
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Create Ring01_2
Create new coordinate system for Ring01_2
3D Modeler > Coordinate System > Create > Relative CS > Offset
then using the coordinate entry field, enter the origin position
X: 120, Y: -50, Z: 0, Press the Enter key
Select Coordinate Systems > RelativeCS1 in History Tree, change the
name from RelativeCS1 to RelativeCS_Mag01_2 in Property window.
3D Modeler > Coordinate System > Set Working then select Global

Select Ring01_1 in History Tree, Use right mouse Edit > Duplicate >
Along Line to create Ring01_2
Then enter the start point, end point,
the number of duplicated objects
X: 0, Y: 0, Z: 0 for start point,
Press the Enter key
dX:120, dY: 0, dZ: 0 for end point,
Press the Enter key
Total Number 2 for the number
of duplicated objects,
Press the Enter key
Select Ring01_1_1 in History Tree, change the name from
Ring01_1_1 to Ring01_2
Ring01_2 and Orientation from Global to
RelativeCS_Mag01_2.
RelativeCS_Mag01_2

Note Please note that Orientation of Ring01_2
Ring01_2 is
RelativeCS_Mag01_2 . It is radially magnetized from (0,0,0) of
RelativeCS_Mag01_2 by this setting.
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Magnetization
Create Ring02_1 and Ring02_2
Create new coordinate system for Ring02_2
3D Modeler > Coordinate System > Create > Relative CS > Both
then using the coordinate entry field, enter the origin position, X axis,
and the point of XY plane.
X: 120, Y: 120, Z: 0 for origin, Press the Enter key
X: 1, Y: 0, Z: 0 for X axis, Press the Enter key
X: 0, Y: 0, Z: -1 for the point of XY plane, Press the Enter key
Select RelativeCS1 in History Tree, change the name from
RelativeCS1 to RelativeCS_Mag02
RelativeCS_Mag02_2 in Property window.
3D Modeler > Coordinate System > Set Working then select Global
Select Ring01_1 and Ring01_2 in History Tree, Use right mouse
Edit > Duplicate > Along Line to create Ring02_1 and Ring02_2
Then enter the start point, end point, the number of duplicated objects
X: 0, Y: 0, Z: 0 for start point, Press the Enter key
dX:0, dY: 120, dZ: 0 for end point, Press the Enter key
Total Number 2 for the number of duplicated objects, Press the
Enter key
Select Ring01_1_1 in History Tree, change the name from
Ring01_1_1 to Ring02
Ring02_1.
Select Ring01_1_2
Ring01_1_2 in History Tree, change the name from
Ring01_1_2
Ring01_1_2 to Ring02
Ring02_2 and Orientation from Global to
RelativeCS_Mag02
RelativeCS_Mag02_2.
_2
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Magnetization
Create new material Mag02
Click Ring02_1 and Ring02_2, then pick Material Mag01 in it’s
Attribute to get in the Material Select Definition window.
Select Clone Material
Change properties as follow.
Material Name Mag02
Material Coordinate System Cylindrical
Magnitude -837000
R Component 0
Z Component 1
Click OK to exit. Mag02 will be appeared in Material Name Listing
Click OK to exit Select Definition.
Definition Make sure Mag01 will be the
Material of Ring02_1 and Ring02_2

Note Please note that Orientation of Ring02
Ring02_1 is Global. It is
magnetized in parallel to Z axis of Global.
Note Please note that Orientation of Ring02
Ring02_2 is RelativeCS_Mag02
RelativeCS_Mag02_2.
It is magnetized in parallel to Z axis of RelativeCS_Mag02
RelativeCS_Mag02_2.
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Magnetization
Create an Analysis Setup
Select the menu item Maxwell > Analysis Setup > Add Solution Setup
Select General and change the Percent Error from 1 to 3
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Magnetization
Check the Validity of the Model
Select the menu item Maxwell > Validation Check.

The problem won’t solve unless each object has a check mark.

Analyze
Select the menu item Maxwell > Analyze.
The Analysis will be start as below:
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Magnetization
Solution Data
To view the Solution Data, select the menu item Maxwell > Results > Solution

Data
Here you can view the Profile and the Convergence. Note:: The default view
is for convergence is Table.
Table Select the Plot radio button to view a graphical
representations of the convergence data.

Mesh information can be confirmed by clicking the Mesh Statistics tab.
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Magnetization
Plot Flux Density
To plot the flux density on Ring01_1 Ring01_2 Ring02_1 Ring02_2 of the
magnetic, select the Ring01_1 Ring01_2 Ring02_1 Ring02_2 in History Tree
by clicking on it, and move the mouse to 3D Modeler Window then right
mouse click and select Fields > B > B_Vector, in Create Field Plot Window
select B_Vestor in “Quantity” and All in “In Volume”, and Check Plot Surface
Only ,Press Done.
Done
The field plot is a little misleading since it show different colors, but the legend
displays the exact value for the full color spectrum. To change the scale,
double click on the legend and then select Scale.
Scale Select the radio button Use
Limits and set the Min to 0, the Max to 1, click on Apply
Then select Marker/Arrow,
Marker/Arrow in Arrow options Change the Type as Cylinder ,
move Size Arrow to he third from
the left , remove the check of Map
Size and click on Apply.
Then select Plots,
Plots in Vector plot
Select Uniform and move the
Spacing size to smallest, set Min.
as 3 and Max. as 10,
10 click on Apply.
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Magnetization
Each object has been magnetized in a different direction. Thus, when the
coordinate system of the object is different, it is possible to magnetize it in a
different direction even by the same material characteristic.

Ring01_1

Ring02_1

Ring01_2

Ring02_2
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Magnetization
Example2 Magnetization using the equation
In this example, it is introduced the magnetization using the equation.
Material : Mag03 is newly made in this example.
Design copy
Select Ring01 design in project window, use right mouse
Copy,
Copy select Magnet project in project window, use right mouse Paste to
create Ring2 design.
Correction of object
Select Ring01_2 Ring02_1 Ring02_2 ,Press the Del key.
Open the history of Ring01_1 in history tree, double click
CreateRegularPolyhedron
Change to
Center Position 0,0,-20
Start Position 40,0,-20
Height 40

In addition, double click Subtract > Hole > CreateRegularPolyhedron
in the history.
Change to
Center Position 0,0,-20
Start Position 30,0,-20
Height 40

Double click Ring01_1 in history tree, change the name from Ring01_1
to Ring03
Click Material Mag01 and make new Material:Mag03 as follows.
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Example (Magnetostatic) – Permanent Magnet
Magnetization
Create new material Mag03
Select Clone Material
Change properties as follow.
Material Name Mag03
Magnitude -837000 * pwl_periodic(
pwl_periodic( $mg_skew1,4 * (Phi * 180 / PI - 45
*(Z / 40 mm)))
Because the Add Dataset window is displayed, data is input as follows.
Click OK to exit.

Click OK to exit. Mag03 will be appeared in Material Name Listing
Click OK to exit Select Definition.
Definition Make sure Mag03 will be the Material
of Ring03
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Magnetization
Note About the skew magnetization
The function used this case defines the magnetization of the direction
of Phi with $mg_skew1. Moreover, to apply the skew, magnetic data is
rotated according to Z axis coordinates.
Magnetization

0 position

Number of Poles

-837999 * pwl_periodic( $mg_skew1, 4* (Phi*180/PI - 45 *((Z- $CoreOrigin / 2 mm)))

Magnetization wave form

Skew angle[deg]

Length of magnet

The magnetization wave form is defined at one cycle of 0 - 360deg.
$CoreOrigin is Z axis value that becomes 0deg of the magnetization
wave form by the Phi=0 degree.
The unit is meter.

Skew angle

$Height
$CoreOrigin
X : Phi = 0
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Magnetization
Create an Analysis Setup
There is already Setup1 because it copied from the Ring01 design. Analyze
this design by the untouched setting.

Check the Validity of the Model
Select the menu item Maxwell > Validation Check.

To change the sign of the magnetization, attention is displayed. Ignore it
because it intentionally sets it this time.
The problem won’t solve unless each object has a check mark.

Analyze
Select the menu item Maxwell > Analyze.
The Analysis will be start as below:
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Magnetization
Plot Flux Density
Double click Field Overlays > B > B_Vector in Project window.
Because the set up information made by Ring01 design remains, it is possible
to display easily.

Select the Ring03
Ring03 in History Tree by clicking on it, and move the mouse to 3D
Modeler Window then right mouse click and select Fields > B > Mag_B, in
Create Field Plot Window select Mag_B in “Quantity” and All in “In Volume”,
and Check Plot Surface Only ,Press Done.
Done

The magnetic induction changes into the direction of Phi, and the skew
magnetization.
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Topic – Master/Slave Boundaries
Assigning Master/Slave Boundary Conditions
Boundary Conditions
Boundary conditions enable you to control the characteristics of planes,
faces, or interfaces between objects. Boundary conditions are important to
understand and are fundamental to solution of Maxwell’s equations.
Master/Slave
Master and slave boundaries enable you to model planes of periodicity
where the H-field (E-field for Electrostatic Solver) at every point on the slave
boundary surface is forced to match the H-field of every corresponding point
on the master boundary surface. The transformation used to map the H-field
from the master to the slave is determined by specifying a coordinate system
on both the master and slave boundaries.
Considerations
Some considerations for Master/Slave boundaries:
They can only be assigned to planar surfaces.
The geometry of the surface on one boundary must match the
geometry on the surface of the other boundary.
Why They are Important
When used properly, Master/Slave boundary conditions can be successfully
utilized to reduce the model complexity.
The model complexity usually is directly tied to the solution time and
computer resources so it is a competitive advantage to utilize them
whenever possible.
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Ansoft Maxwell Design Environment
The following features of the Ansoft Maxwell Design Environment are used to
create the models covered in this topic
3D Solid Modeling
User Defined Primitives (UDP): SRMCore
Surface Operations: Section
Boolean Operations: Separate Bodies
Boundaries/Excitations
Current: Stranded
Boundaries: Master/Slave
Analysis
Magnetostatic
Field Overlays:
H Vector
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Getting Started
Launching Maxwell
To access Maxwell, click the Microsoft Start button, select Programs,
Programs and select
Ansoft and then Maxwell 11. Or double click the

icon on the desktop.

Setting Tool Options
To set the tool options:
Note: In order to follow the steps outlined in this example, verify that the
following tool options are set :
1. Select the menu item Tools > Options > Maxwell Options
2. Maxwell Options Window:
1. Click the General Options tab
Use Wizards for data entry when creating new boundaries:: 
Checked
Duplicate boundaries with geometry::  Checked
2. Click the OK button
3. Select the menu item Tools > Options > 3D Modeler Options.
Options
4. 3D Modeler Options Window:
1. Click the Operation tab
Automatically cover closed polylines::  Checked
2. Click the Drawing tab
Edit property of new primitives::  Checked
3. Click the OK button

Ansoft Maxwell 3D Field Simulator v11 User’s Guide

5.8-3

5.8
Topic – Master/Slave Boundaries
Opening a New Project
To open a new project:
1.
In an Maxwell window, click the  On the Standard toolbar, or select the menu item File >
New.
2.
Select the menu item Project > Insert Maxwell Design, or click on the
icon.
3.
Save the project with name “Master_Slave” to your own folder. Change the name of the
design from “MaxwellDesign1” to “Full_Model_1”.

Set Solution Type
Select the menu item: Maxwell > Solution Type > Magnetostatic, or right mouse click on
Full_Model_1 and select Solution Type.

Creating the 3D Model
The example that will be used to demonstrate how to assign Master/Slave boundary conditions
does not represent any real-world product. The intent of this write up is rather to demonstrate how
Master/Slave boundary conditions are implemented.

Set Model Units
Select the menu item 3D Modeler > Units > Select Units: mm (millimeters)
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There will be four designs in this example, as shown below. The
objective is to demonstrate how to assign Master/Slave boundary
conditions and how they can help reduce model complexity and
hence solution time.

Design1: Full_Model_1

Design2: Full_Model_2

Design3: Quarter_Model_1, Slave=Master

Design4: Quarter_Model_2, Slave=-Master

Slave=Master

Master
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Create Stator and Coils:
Coils
oils
A User Defined Primitive will be used to create the Stator and C

Draw > User Defined Primitive > Syslib > Rmxprt > SRMCore
Use the values given in the panel below to create the Stator and Coils

Click on the just created object in the drawing window and in the panel on
the left change its name from SRMCore1 to Stator.
Change the Material from vacuum to nickel.
nickel
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The stator and coils were created as one entity and they need to be
separated.
1. Click on the Stator-Coil group so that they are selected
2. Select the menu item 3D Modeler > Boolean > Separate Bodies, the
result will be a single stator and four coils.
As was done with the Stator, change the name, materials, and color for the
Coils. The material property for the Stator will be nickel, and the material
property for the Coils will be copper. The name and color for each object is
given below.

Coil2

Coil1

Stator
Coil3
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To fit the view:
Select the menu item View > Fit All > Active View, or press the CTRL+D key

Create Coil Terminals
Coil terminals need to be created in order to assign the current excitation
Holding the Control key, click on the four coils so that they are selected, or select
them from the History tree on the left of the 3D Modeler window
Select the menu item 3D Modeler > Surface > Section > XY Plane , or right click

> Surface > Section > XY Plane.
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Separate the Grouped Sections
The result of the Surface > Section command, yields two terminals for each coil
that are united. Since only one terminal per coil is needed, half of these
terminals need to be deleted, but first they need to be separated.
Select all of the sheet objects:

Select the menu item 3D Modeler > Boolean > Separate Bodies or right click >
Edit > Boolean > Separate Bodies
There are now 8 separate terminals. Delete half of them so that each coil has
one terminal.
One Section for each Coil

Make sure the section numbers correspond to coil
numbers correctly
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Assign Current Source to the Terminals
Select all four coil sections by holding down the CTRL key and using your
mouse or selecting from tree on the left hand side of the GUI
Select the menu item Maxwell > Excitations > Assign > Current or right click >

Assign Excitations > Current
1.
2.
3.

Change the Base Name to Current
Change the value to 100 Amps
Change the type to Stranded
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The project tree now shows four separate Excitations:
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Create the Problem Region
One of the main differences between Maxwell V10 and V11 is that a Background
Region is not automatically created when a project is started. A separate object
needs to be specifically created.
To create a rectangular region simply select Draw > Region, or click the
icon
from standard toolbar. The size of this rectangular region is based on dimensions
of the existing objects. Change Padding Percentage to 100.

Click View > Fit All > All Views.
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Create an Analysis Setup
Select the menu item Maxwell > Analysis Setup > Add Solution Setup or right
click on the Analysis in the project window > Add Solution Setup
Select General and change the setting as follows
Select Convergence and change the setting as follows
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Save the Project
Select the menu item File > Save As
From the Save As window, type in Master_Slave
Click on the Save button

Check the Validity of the Model
Select the menu item Maxwell > Validation Check, or click on the

icon

The problem won’t solve unless each object has a check mark.

Analyze
Select the menu item Maxwell > Analyze,
Analyze or click on the
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Solution Data
To view the Solution Data, select the menu item Maxwell > Results >

Solution Data
Here you can view the Profile and the Convergence.
Note: The default view for convergence is Table.
Table Select the Plot
radio button to view a graphical representations of the convergence
data.
Note: You don’t have to wait for the solution to be done to do this.
You can do this while the simulation is running, all information will
update automatically after each pass is done.
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Plot H-Field Vector on X-Y Plane
To plot the H-field vector on the X-Y plane, click Planes > Global: XY from the
history tree window, then right click on Field Overlays > Fields > H > H_Vector >
Done in the project window.
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The following H-field vector plot will appear, which is the result of the current
excitation on the left side.

If the plot is not as nice as you may want to see, you can double click the legend
bar, then change various settings under Color map/Scale/Marker/Arrow/Plot tabs.
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Create Design2: Full_Model_2
Click on Full_Model_1 in the Project Tree and then right mouse click and select
Copy
Click on the project name Master_Slave,
Master_Slave right click and select Paste, a new
design called Full_Model_2 has been created

Modify Current Excitation
Click on Excitations > Current_2 in the Project window, you will see a
MaxwellTab window under Project window, change from Point out of terminal to
Point into terminal in the Direction row.
Do the same for Current_4.
Current_4 The purpose is to change the current excitation as
shown in the graph above.
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Right click on Setup1 of Analysis,
Analysis select Analyze.
Double click on Field Overlays > H > H_Vector1. You can see the vector plot is
updating automatically after each pass.
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The following H-field vector plot will appear, which is the result of the current
excitation on the left side.

If the plot is not as nice as you may want to see, you can double click the legend
bar, then change various settings under Color map/Scale/Marker/Arrow/Plot tabs.
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Create Quarter Symmetry Geometry
So far we’ve been working with full geometry. Often it is useful to use symmetry
in order to reduce the problem size and thus increase the solution time. In this
section, we’ll show how to create the symmetric model and how to assign
Master/Slave boundary conditions.

Copy the Existing Design
Select the design Full_Model_1,
Full_Model_1 and right mouse click and select Copy.
Copy
Click on project name Master_Slave,
Master_Slave and right mouse click and select Paste;
Paste this
will create a third design called Full_Model_3.
Full_Model_3 Change its name to
Quarter_Model_1.
Quarter_Model_1 Double click on this design to make it active.

Modify the Geometry to Create Quarter Symmetry
Make all of the objects visible and then select them. Next select the menu item
3D Modeler > Boolean > Split and choose
Split Plane > YZ
Keep Fragments > Positive Side
Split Objects > Split Objects Crossing Split Plane
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The resulting geometry, Project window and History Tree window should look like
this:

Ansoft Maxwell 3D Field Simulator v11 User’s Guide

5.8-24

5.8
Topic – Master/Slave Boundaries
Assigning Master/Slave Boundary Conditions
Click on Objects > Vacuum > Region > CreateRegion in the History Tree window,
you will see the following information window:

Change Padding Percentage of –X and –Y to be 0. The geometry has become
this:
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Spin the model so that you can see the face on the XZ plane. Like this:

Click on Object from the Standard toolbar, select Face.
Face Now we are ready to
select faces instead of objects.
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Click on the face on the XZ plane

Right click on Boundaries > Assign > Master…
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The following window pops up, select New Vector…
Vector….

Draw a straight line along Z direction starting from the left-most vertex, ending at
the top-left corner of the box. Master boundary has been assigned, as shown in
the following. Click OK.
OK
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Spin the model so that you can see the face in the YZ plane, like this:

Select the face on the YZ plane, right click on Boundaries > Assign > Slave.
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Select Master1 for Master Boundary,
Boundary New Vector for U Vector,
Vector then draw the
same straight line along the Z direction. Select Hs=Hm
Hs=Hm for Relation.
Relation The Slave
Boundary has been assigned, as shown below. Click OK.
OK

Click on Boundaries > Master1 and Slave1,
Slave1 you should see these:
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Right click on Analysis > Setup1,
Setup1 select Analyze.
Analyze
Select Region,
Region Hide it for the view.
Double click Field Overlays > Field > H > H_Vector1.
H_Vector1 You will see the following
vector plot. This is a quarter view of design Quarter_Model_1.
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Create a New Design and Assign Different Master/Slave
Boundary Conditions
Select the design Quarter_Model_1,
Quarter_Model_1 and right mouse click and select Copy.
Copy
Click on project name Master_Slave,
Master_Slave and right mouse click and select Paste;
Paste this
will create a fourth design called Quarter_Model_2.
Quarter_Model_2 Double click on this design to
make it active.
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Modify the Slave Boundary
Double click Boundaries > Slave1,
Slave1 the following window pops up. Change
Relation to Hs=Hs=-Hm.
Hm
Right click Analysis > Setup1 > Analyze.
Analyze
Double click Field Overlays > Field > H > H_Vector_1.
H_Vector_1 You will see the H vector
plot like this.
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Topic Summary

Slave=Master

Master
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Chapter 6.0
Chapter 6.0 – Eddy Current Examples
6.1 – Asymmetrical Conductor with a Hole
6.2 – Radiation Boundary
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6.1
Example (Eddy Current) – Asymmetrical Conductor
The Asymmetrical Conductor with a Hole
This example is intended to show you how to create and analyze an
Asymmetrical Conductor with a Hole using the Eddy Current solver in the Ansoft
Maxwell 3D Design Environment.

Coil (Copper)

Stock (Aluminum)
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Getting Started
Launching Ansoft Maxwell
1.

To access Ansoft Maxwell, click the Microsoft Start button, select Programs,
Programs and
select the Ansoft > Maxwell 11 program group. Maxwell 11.

Setting Tool Options
To set the tool options:
Note: In order to follow the steps outlined in this example, verify that the
following tool options are set :
1. Select the menu item Tools > Options > Maxwell Options
2. Maxwell Options Window:
1. Click the General Options tab
Use Wizards for data entry when creating new boundaries:: 
Checked
Duplicate boundaries with geometry::  Checked
2. Click the OK button
3. Select the menu item Tools > Options > 3D Modeler Options.
Options
4. 3D Modeler Options Window:
1. Click the Operation tab
Automatically cover closed polylines::  Checked
2. Click the Drawing tab
Edit property of new primitives::  Checked
3. Click the OK button
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Opening a New Project
To open a new project:
In an Ansoft Maxwell window, click the  On the Standard toolbar, or
select the menu item File > New.
From the Project menu, select Insert Maxwell Design.

Set Solution Type
To set the solution type:
Select the menu item Maxwell > Solution Type
Solution Type Window:
Choose Eddy Current
Click the OK button
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Creating the 3D Model
Set Model Units
To set the units:
1. Select the menu item 3D Modeler > Units
2. Set Model Units:
1. Select Units: mm
2. Click the OK button

Set Default Material
To set the default material:
1. Using the 3D Modeler Materials toolbar, choose Select
2. Select Definition Window:
1. Type aluminum in the Search by Name field
2. Click the OK button
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Create Stock
To create the stock:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
X: 0.0,
0.0 Y: 0.0,
0.0 Z: 0.0,
0.0 Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the box:
dX: 294.0,
294.0 dY: 294.0,
294.0 dZ: 19.0,
19.0 Press the Enter key
To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: stock
3. Click the OK button
To fit the view:
1. Select the menu item View > Fit All > Active View.

Create Hole in Stock
To create the hole:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
X: 18.0,
18.0 Y: 18.0,
18.0 Z: 0.0,
0.0 Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the box:
dX: 126.0,
126.0 dY: 126.0,
126.0 dZ: 19.0,
19.0 Press the Enter key
To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: hole
3. Click the OK button
To select the objects:
1. Select the menu item Edit > Select All
To complete the stock:
1. Select the menu item 3D Modeler > Boolean > Subtract
2. Subtract Window
Blank Parts: stock
Tool Parts: hole
Click the OK button
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Set Default Material
1.
2.

Using the 3D Modeler Materials toolbar, choose Select
Select Definition Window:
1. Type copper in the Search by Name field
2. Click the OK button

Create Coil (Hole)
To create coil:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
X: 119.0,
119.0 Y: 25.0,
25.0 Z: 49.0,
49.0 Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the box:
dX: 150.0,
150.0 dY: 150.0,
150.0 dZ: 100.0,
100.0 Press the Enter key
To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: coil_hole
3. Click the OK button
To create the filets:
1. Select the menu item Edit > Select > Edges.
2. Using the mouse graphically select the 4 z-directed edges. Hold down the
CTRL key to make multiple selections.
3. Select the menu item 3D Modeler > Fillet
4. Fillet Properties
1. Fillet Radius: 25mm
2. Setback Distance: 0mm
3. Click the OK button

Select 4 Edges
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Create Coil
To create coil:
1. Select the menu item Draw > Box
2. Using the coordinate entry fields, enter the box position
X: 94.0,
94.0 Y: 0.0,
0.0 Z: 49.0,
49.0 Press the Enter key
3. Using the coordinate entry fields, enter the opposite corner of the box:
dX: 200.0,
200.0 dY: 200.0,
200.0 dZ: 100.0,
100.0 Press the Enter key
To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: coil
3. Click the OK button
To create the filets:
1. Select the menu item Edit > Select > Edges.
2. Using the mouse graphically select the 4 z-directed edges. Hold down the
CTRL key to make multiple selections.
3. Select the menu item 3D Modeler > Fillet
4. Fillet Properties
1. Fillet Radius: 50mm
2. Setback Distance: 0mm
3. Click the OK button
To select the object for subtract
1. Select the menu item Edit > Select > Objects
2. Select the menu item Edit > Select > By Name
3. Select Object Dialog,
1. Select the objects named: coil, coil_hole
2. Click the OK button
To complete the coil:
1. Select the menu item 3D Modeler > Boolean > Subtract
2. Subtract Window
Blank Parts: coil
Tool Parts: coil_hole
Click the OK button
To fit the view:
1. Select the menu item View > Fit All > Active View.
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Create Offset Coordinate System
To create an offset Coordinate System:
1. Select the menu item 3D Modeler > Coordinate System > Create >

Relative CS > Offset
2.

Using the coordinate entry fields, enter the origin
X: 200.0,
200.0 Y: 100.0,
100.0 Z: 0.0,
0.0 Press the Enter key

Create Excitation
Object Selection
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
1. Select the objects named: coil
2. Click the OK button
Section Object
1. Select the menu item 3D Modeler > Surface > Section
1. Section Plane: XZ
2. Click the OK button
Separate Bodies
1. Select the menu item 3D Modeler > Boolean > Separate Bodies
Assign Excitation
1. Select the menu item Maxwell > Excitations > Assign > Current
2. Current Excitation : General
1. Name: Current1
2. Value: 2742 A
3. Type: Stranded
Note: The current flow should be clockwise when viewing the coil
from above. Use the Swap Direction button to change the direction.
3. Click the OK button
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Set Eddy Effect
To set the eddy effect for the stock object
1. Select the menu item Maxwell > Excitations > Set Eddy Effects
2. Set Eddy Effect,
1. Check the settings as shown
2. Click the OK button

Show Conduction Path
Show Conduction Path
1. Select the menu item Maxwell > Excitations > Conduction Paths > Show
Conduction Paths
2. From the Conduction Path Visualization dialog, select the rows to visualize
the conduction path in on the 3D Model.
3. Click the Close button

Define a Region
To define a Region:
1. Select the menu item Draw > Region
1. Padding Date: One
2. Padding Percentage: 300
3. Click the OK button
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Create a dummy object
As a post-processing results we are interested to calculate the flux density on a line with the
following end points: [0.0; 72.0; 34.0] and [288.0; 72.0; 34.0]. In order to get as accurate results as
possible, the mesh around the line has to be fine enough. It is generally a good practice to create
dummy objects around regions of interest so that the mesh quality can be better controlled in
those regions. For this particular problem we create a box around the line of interest.
To create a dummy object:
1.
Be sure that the global coordinate system is active by
clicking on it in the history tree
2.
Select the menu item Draw > Box
3.
Using the coordinate entry fields, enter the box position
X: -3.0,
3.0 Y: 68.0,
68.0 Z: 30.0,
30.0 Press the Enter key
4.
Using the coordinate entry fields, enter the opposite corner of the box:
X: 297.0,
297.0 Y: 76.0,
76.0 Z: 38.0,
38.0 Press the Enter key
(Note that the coordinates of the opposite corner are absolute values and that the
size of the box will be 300 x 8 x 8mm.)
To set the name:
1.
Select the Attribute tab from the Properties window.
2.
For the Value of Name type: dummy
3.
Click the OK button

Analysis Setup
Creating an Analysis Setup
To create an analysis setup:
1.
Select the menu item Maxwell > Analysis Setup > Add Solution Setup
2.
Solution Setup Window:
1.
Click the General tab::
Percent Error: 2
2.
Click the Convergence tab::
Refinement Per Pass:: 50 %
3.
Click the Solver tab::
Adaptive Frequency:: 200 Hz
4.
Click the OK button

Save Project
To save the project:
1.
In an Ansoft Maxwell window, select the menu item File > Save As.
2.
From the Save As window, type the Filename: maxwell_
maxwell_asymcond
3.
Click the Save button
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Assign and apply mesh operations
Select the dummy object.
Select the menu item Maxwell > Mesh Operations > Assign > On Selection >
Length Based.
Based
Deselect Restrict Length of Elements check box
Select Restrict the Number of Elements check box and change the
Maximum Number of Elements to be 1000.
Select the menu item Maxwell > Analysis Setup > Apply Mesh Operations

Analyze
Model Validation
To validate the model:
1. Select the menu item Maxwell > Validation Check
2. Click the Close button
Note: To view any errors or warning messages, use the Message
Manager.

Analyze
To start the solution process:
1. Select the menu item Maxwell > Analyze All
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Create Reports
Create zz-component of BB-Field (real part) vs. Distance plot on a line
To create a line:
1.
Make sure that the Global Coordinate System is selected:
3D Modeler > Coordinate System > Set Working CS
2.
Select the menu item Draw > Line
3.
When the dialog appears asking to create a non-model object, click the Yes button.
4.
Select the menu item Draw > Line
5.
Using the coordinate entry fields, enter the vertex point:
X: 0.0,
0.0 Y: 72.0,
72.0 Z: 34.0,
34.0 Press the Enter key
6.
Using the coordinate entry fields, enter the vertex point:
X: 288.0,
288.0 Y: 72.0,
72.0 Z: 34.0,
34.0 Press the Enter key
7.
Using the mouse, right-click and select Done
To set the name:
1.
Select the Attribute tab from the Properties window.
2.
For the Value of Name type: FieldLine
3.
Click the OK button
To calculate real part of the zz-component of BB-field (use the fields calculator)
1.
Select the menu item Maxwell > Fields > Calculator
2.
Select Quantity: B
3.
Select Vector:
Vector Scal?
Scal? > Scalar Z
4.
Select General: Complex > Real
5.
Click the Smooth button

6.

7.
8.
9.

10.

(The flux density will be displayed by default in the units of Tesla [T]. If you wish to see the
results in Gaussian units perform steps 6 and 7, otherwise jump to step 8.
Click the Number Button
1.
Type: Scalar
2.
Value: 10000
3.
Click the OK button
Click the * button
Click the Add button
Named Expression
1.
Name: Bz_real
2.
Click the OK button
Click the Done button
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Create Report
Select the menu item Maxwell > Results > Create Report
Create Report Window::
Report Type: Fields
Display Type: Rectangular
Click the OK button
Traces Window::
Solution: Setup1: LastAdaptive
Geometry: FieldLine
Click the Y tab
Category: Calculator Expressions
Quantity: Bz_real
Bz_real
Function: <none>
Click the Add Trace button
Click the Done button
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Field Overlays
Create Field Overlay
To select an object
Select the menu item Edit > Select > By Name
Select Object Dialog,
Select the objects named: stock
Click the OK button
To create a field plot:
1. Select the menu item Maxwell > Fields > Fields > J > Mag_J
2. Create Field Plot Window
1. Solution: Setup1 : LastAdaptive
2. Quantity: Mag_J
3. In Volume: All
4. Plot on Surface Only:  Checked
5. Click the Done button
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Create Field Overlay
To select an object
Select the menu item Edit > Select > By Name
Select Object Dialog,
Select the objects named: stock
Click the OK button
To create a field plot:
1. Select the menu item Maxwell > Fields > Fields > J > Vector_J
2. Create Field Plot Window
1. Solution: Setup1 : LastAdaptive
2. Quantity: Vector_J
3. In Volume: All
4. Plot on Surface Only:  Checked
5. Click the Done button
To modify a Magnitude field plot:
1. Select the menu item Maxwell > Fields > Modify Plot Attributes
2. Select Plot Folder Window:
1. Select: J
2. Click the OK button
3. J Window:
1. Click the Plots tab
1. Plot: Vector_J1
2. Vector Plot
3. Set the Spacing slider to the minimum
2. Click the Marker/Arrow tab
1. Arrow Options
2. Map Size:  Unchecked
3. Arrow Tail:  Unchecked
4. Use the slider bar to adjust the
size
2. Click the Close button

Ansoft Maxwell 3D Field Simulator v11 User’s Guide

6.1-15

6.2
Example (Eddy Current) –- Radiation Boundary
The implementation and application of a Radiation Boundary
in the Eddy Current Solver
Radiation Boundaries are used when one wants to simulate the free
emission of fields into space. The main distinction of this boundary from all
other boundary conditions is that the radiation boundary does not enforce
any restrictions on the field behavior. This is used specifically to model
unbounded eddy currents and propagating waves without reflection. This
boundary has several specific uses which will be discussed in detail in this
document.
Note that Maxwell3D is a low-frequency simulator, so it is not recommended
to model standard antennas and wave propagation with this tool. Maxwell is
ideal for near-field simulations for the investigation of interactions between
low-frequency inductors and RFID applications.
The example that will be used to demonstrate how Radiation Boundaries are
implemented is a Magnetic Dipole. The intent of this write up is not how to
simulate a dipole antenna, it is rather to demonstrate how Radiation
Boundaries are implemented within the Eddy Current solver.
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Ansoft Maxwell Design Environment
The following features of the Ansoft Maxwell Design Environment are used to
create the models covered in this topic
3D Solid Modeling
Primitives:: Torus
Sphere
Surface Operations: Section
Boolean Operations: Separate Bodies
Boundaries/Excitations
Current: Solid
Radiation Boundary
Symmetry Boundary
Eddy Effects
Analysis
Eddy Current
Results
Fields Calculator: Named Expression
Field Overlays:
Field Plots
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Getting Started
Launching Maxwell
1.

To access Maxwell, click the Microsoft Start button, select Programs,
Programs and select
Ansoft and then Maxwell 11.

Setting Tool Options
To set the tool options:
Note: In order to follow the steps outlined in this example, verify that the
following tool options are set :
1. Select the menu item Tools > Options > Maxwell Options
2. Maxwell Options Window:
1. Click the General Options tab
Use Wizards for data entry when creating new boundaries:: 
Checked
Duplicate boundaries with geometry::  Checked
2. Click the OK button
3. Select the menu item Tools > Options > 3D Modeler Options.
Options
4. 3D Modeler Options Window:
1. Click the Operation tab
Automatically cover closed polylines::  Checked
2. Click the Drawing tab
Edit property of new primitives::  Checked
3. Click the OK button
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Opening a New Project
To open a new project:
1. In an Maxwell window, click the  On the Standard toolbar, or select
the menu item File > New.
2. Select the menu item Project > Insert Maxwell Design, or click on the
icon

Set Solution Type
Select the menu item: Maxwell > Solution Type > Eddy Current, or right
mouse click on MaxwellDesign1 and select Solution Type …

Set Model Units
Select the menu item 3D Modeler > Units > Select Units: m (meters)
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Create the Dipole Ring
1.

2.

Select Draw > Torus to start the drawing procedure:
1. Enter 0, 0, 0 as the center point of the torus
2. Enter 0.0095, 0, 0 as the inner radius
3. Enter 0.001, 0, 0 as the outer radius
A Properties dialog appears:
1. In the Command Tab it should be as follows:
1. Center: 0, 0, 0
2. Axis: Z
3. Minor Radius: 0.0005m
4. Major Radius: 0.01m
2. In the Attribute Tab make the following changes:
1. Name: Ring
2. Material: copper
1. Select vacuum in the Material Value area
2. Type copper to select copper from the Material list
3. Select OK
3. Select OK
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Create the Bounding Region
1.

2.

3.

Select Draw > Sphere to start the drawing procedure:
1. Enter 0, 0, 0 as the center point of the sphere
2. Enter 0.06, 0, 0 as the radius of the sphere
A Properties dialog appears:
1. In the Attribute Tab make the following changes:
1. Name: Region
2. Transparent: 0.8
2. Select OK
Check that the Material of the Region object is vacuum by selecting the Region
object from the history tree. The Material shown in the Properties window should
be vacuum.
vacuum
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Create a Surface for Current Excitation
1.
2.

3.
4.

5.
6.

Select the Ring object from the history tree
Select 3D Modeler > Surface > Section…
Section…
1. Select YZ and then OK
2. This creates a new sheet object with two separate parts
Select the new sheet object
Select 3D Modeler > Boolean > Separate Bodies
This creates two separate sheet objects from the one previous object
Select and Delete the sheet that lies along the negative Y axis
Select and Rename the remaining sheet as Current

Assign a Current Excitation
1.
2.

Select the sheet named Current
Select Maxwell > Excitations > Assign > Current …
1. Input 1.414 as the Value of the current. Note that in the eddy current
solver, peak current is always specified instead of RMS.
2. Keep Solid selected
3. Select OK

Assign Eddy Effects
1.

Select Maxwell > Excitations > Set Eddy Effects …
1. Note that conductors will be high-lighted in blue, and eddy effects can only
be assigned to conductors.
2. Keep both Eddy Effect and Displacement Current set for Ring
3. Set Displacement Current for Region
4. Select OK
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Radiation Boundary Overview
The radiation boundary is only available in the Eddy Current solver – it is only
applicable for frequency domain solutions.
The radiation boundary should be used in conjunction with displacement current
in the background object – implying that the fields in the background can
propagate to the edge of the model. This means that if displacement currents are
simulated in the background, then a radiation boundary should be used on the
outside surface of the background.
A radiation boundary is used to simulate an open problem that allows waves to
radiate infinitely far into space, such as antenna designs. Maxwell3D absorbs the
wave at the radiation boundary, essentially ballooning the boundary infinitely far
away from the structure.
A radiation surface does not have to be spherical, but it must be exposed to the
background, convex with regard to the radiation source, and located at least a
quarter wavelength from the radiating source. In some cases the radiation
boundary may be located closer than one-quarter wavelength, such as portions
of the radiation boundary where little radiated energy is expected.
Remember that Maxwell3D is a near-field simulator, so the dimension of
components should be much smaller than the wavelength (i.e. lambda/10)
The wavelength at 1.5GHz is 0.2m. Therefore, our 0.06m radius sphere is
exactly one quarter wavelength from the ring. In order to make the boundary
placement more automated, we can use variables and equations to define the
size of the bounding object.
Make the size of the sphere a function of speed of light “c0”
c0” and frequency
1. Expand Region in the history tree
2. Select CreateSphere
3. Change the radius to lambda/4 + 0.01m
4. Add Variable lambda defined by c0/frequ
Click the OK button
5. Add Variable frequ defined by 1.5GHz
Click the OK button
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Assign the Radiation Boundary
1.

2.
3.

Type f to enter face selection mode or change the
selection mode to Face in the toolbar buttons
Select the face of the Region
Select Maxwell > Boundaries > Assign > Radiation …
Select OK
This assigns a radiation boundary to the outside of the sphere, allowing the
waves to propagate outside of the sphere. If no radiation boundary is assigned,
the interactions of the components may be correct, but the fields near the
boundaries will certainly be incorrect. The Poynting vector on the outer surface is
a clear indicator of this, which we will explore later.

Assign a Surface Approximation
1.
2.

Select the Ring object
Select Maxwell > Mesh Operations > Assign > Surface Approximation …
1. Choose Set maximum normal deviation (angle) and keep it at 15 deg
2. Choose Set aspect ratio and keep it at 10
3. Select OK

Maximum surface deviation (length)
is the difference between the shortest
and longest edge of a triangle on a
true surface. This encourages
equilateral triangles on the surface.



Maximum Surface Normal Deviation
(degrees) which allows you to limit
the maximum angle between normal
vectors to adjacent tetrahedrons
which break up a true surface. This
can force more tetrahedron to break
up a curved true surface like a
cylinder.



Maximum Aspect Ratio is the ratio
between the largest and shortest
edges of triangles on a given face. A
ratio = 1 would attempt to create
equilateral triangles.
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Create Outer Surface
One important part of creating a geometry is to consider the results needed in the
post-processor. We will wish to use the outer surface of the sphere to compute
the radiated power and the radiation resistance. Therefore, we will need to
create a surface to integrate over that defines precisely the area that we need.
1.
2.
3.
4.

5.

Type f to enable face-selection mode
Select the outer face of the sphere Region
Select 3D Modeler > Surface > Create Object From Face
A sheet object called ObjectFromFace1 appears in the history tree (expand the
Sheets category if this is not visible)
Change the name of the new sheet object
1. Double-click on ObjectFromFace1 in the history tree
2. Change the name from ObjectFromFace1 to Outside

Add Matrix Parameter
1.

Select Maxwell > Parameters > Assign > Matrix …
1. The program will check conduction paths before proceeding.
2. The Matrix window appears, allowing selection of excitations for use in
automatic inductance and impedance calculations.
3. Check the box next to Current to include the ring in the inductance
calculations.
4. Select OK
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Create a Solution Setup
1.

Select Maxwell > Analysis Setup > Add Solution Setup …
1. In the General tab:
1. Set Maximum Number of Passes to 5
2. Set Percent Error to 10
2. In the Solver tab:
1. Set Adaptive Frequency to 1.5 GHz
3. Select OK
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Save the Project
1.
2.
3.

Select the menu item File > Save As
From the Save As window, type in Dipole_Antenna
Click on the Save button

Check the Validity of the Model
Select the menu item Maxwell > Validation Check, or click on the

icon

The problem won’t solve unless each object has a check mark.

Analyze
NOTE: This problem will solve, but it probably will not converge within 5 passes.
This will be discussed more later. To proceed you do not need a fully converged
simulation – a rough solution will work fine (only 3 or 4 passes are necessary).
Select the menu item Maxwell > Analyze, or click on the
This should take about 10-20 minutes to solve
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Create Named Calculator Expression
We will create a Poynting vector expression in the calculator that is accessible as
a field plot and for power calculations. The expression will be:

{

r 1
r r∗
P = Re E × H
2
1.

}

Open the calculator by selecting Maxwell > Fields > Calculator …
1. The fields calculator window appears.
2. Select Quantity > E to add the complex E field to the stack
3. Select Quantity > H to add the complex H field to the stack
4. Select Complex > Conj to obtain the complex conjugate of H
5. Select Cross to obtain the cross product of E and H*
6. Select Complex > Real to obtain the real part of the complex field
7. Select Number…
Number… and enter 0.5 for the value. Select OK
8. Select * to multiply the vector field by 0.5

Number
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Create Named Calculator Expression (Continued)
1.

Select Add…
Add… (above the calculator stack) to add the top entry of the stack to
the list of named expressions.
Type Poynting and select OK

2.

Select Done to exit the calculator
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Plot the Power flow from the Dipole
1.
2.
3.

4.

Type f to enter face selection mode
Select the outside face of the Region
Select Maxwell > Fields > Fields > Named Expression …
1. Select Poynting from the list
2. Select OK
Select Done
A plot similar to the following should
appear, with strong fields near theta=90°.
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Calculate the Radiation Resistance
The radiation resistance of an antenna is determined by the following formula:
P
Rr = 2av
I rms
Where the radiated Power is defined as the integral of the Poynting vector over
the surface S (outer surface of the region).
r r
1
Pav = ∫∫ Re E × H * dS
2 S

(

)

Since the rms current is 1 A (the peak current is defined as 1.414 A), the
radiation resistance is simply the result of this integral.
The sequence of computing the resistance is as follows:
Select Maxwell > Fields > Calculator to enter the fields calculator
Select Poynting from the list of Named Expressions
Select Copy to stack to add this quantity to the stack
Select Geometry…
Geometry…
Select Surface,
Surface then Outside
Select OK to add the geometry to the stack
Select Normal to take the normal component of the Poynting vector
Select
(integrate)
Select Eval
The result should be about 2.2 W or 2.2 ohms.
According to the literature, the radiation resistance of a Magnetic Dipole with no
thickness is:

Rrad _ air = 20π 2 β 4 a 4
where β is the wave number and a is the radius of the loop
This equation results in 1.923 ohms for a radius of 0.01m and a wavelength of
0.2m.
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View the Impedance Matrix
1.

Now, view the results of the impedance matrix:
1. Select Maxwell > Results > Solution Data
2. Change the solution type to R,L to see resistance and inductance.
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PART 2: Create a 1/16th Section Model
1.

Copy the design by right clicking on MaxwellDesign1 and selecting Copy

2.

Paste the design by right clicking on Dipole_Antenna and selecting Paste

3.

Rename MaxwellDesign1 to Full_Ring
1. Right click on MaxwellDesign1 and select Rename
Rename MaxwellDesign2 to One16th_Ring

4.

5.
6.
7.

8.

Double-click on One16th_Ring in order to make this the active design
Select all objects by typing ctrl + a while in the 3D Modeler
Select 3D Modeler > Boolean > Split …
1. Keep XY,
XY Positive Side,
Side and Split entire selection selected
2. Select OK
With all objects still selected, Split all objects again.
1. Change split plane to YZ,
YZ and split objects to
Split objects crossing split plane
2. Keep Positive Side selected
3. Select OK
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Create a 1/16th Section Model (Continued)
9.

10.
11.

12.

Create a rotated Coordinate system:
1. Select 3D Modeler > Coordinate System > Create > Relative CS > Rotated
1. Select 0.01, 0.01, 0 for the x-axis
2. Select -0.01, 0.01, 0 for the y-axis
Select all objects again by typing ctrl + a
Select 3D Modeler > Boolean > Split …
1. Choose XZ for the split plane, Positive side for the fragments, and Split
objects crossing split plane for the split objects
2. Select OK

Now the geometry is all set and only a couple changes are required to the
boundaries/sources.
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Create a Symmetry Boundary
Only one symmetry boundary is required even though three surfaces define
distinct symmetries. The two surfaces perpendicular to the ring have a symmetry
that is accounted for by the default boundary condition of Zero Tangential H Field
– i.e. this is a special case of symmetry, where the symmetric tangential fields are
zero. The surface that lies in the plane of the ring has a Flux Normal symmetry,
so we need to define this separately.
1.
2.
3.
4.

Select the face of the region that lies in the XY plane (type f to select faces)
Select Maxwell > Boundaries > Assign > Symmetry …
Choose Even (Flux Normal) to define this as a Flux Normal symmetry
Select OK
The squared pattern (seen below) appears when the boundary is selected, and
indicates on which surfaces the boundary is defined.
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Adjust the Current Excitation
In the last simulation, the current excitation was internal to the simulation. That
is, the conduction path formed a loop and the current excitation defined the
current throughout the entire loop. The one current excitation that remains in this
one sixteenth model lies on the edge of the simulation, and the conduction path
does not form a loop. Therefore, this current excitation is considered an external
excitation, and it defines how the current flows out of the model. We need a
second external current excitation to define how the current flows into the model.
Also, the conduction path was split in half, so half the current is needed in the
excitations to define the same current density – this will be dealt with now.
1.
2.

3.
4.

5.
6.

Go to Edit > Select > and make sure that Faces is selected (has a checkmark)
Select Edit > Select > By Name …
1. Select Ring and the half-circle face that does not contain the Current sheet
2. Select OK

Select 3D Modeler > Surface > Create Object From Face
Rename the object by double clicking ObjectFromFace1 and entering Current2
as the new name. Then select OK.
OK
Select the sheet Current2
Select Maxwell > Excitations > Assign > Current …
1. Enter 0.707 A for the value
2. Select OK
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Adjust the Current Excitation (Continued)
6.

7.
8.
9.

In the Project Manager, expand Excitations and double-click Current1
1. Change the value from 1.414 A to 0.707 A
2. Select OK
In the Project Manager, select Current1 and note the direction of the arrow
Select Current2 and note the direction of this arrow
These arrows should be on opposite ends of the copper segment, and they
should be in the same direction (choose Swap Direction in the excitation
definition window if both current excitations are not in the same direction).
Current1

Current2

Adjust the Matrix Parameter
1.

2.

In the Project Manager, expand the Parameters category in the One16th_Ring
design
Double-click on Matrix1
1. Check the box next to Current2
2. Select OK
The excitations available to the Matrix are only those excitations that define the
current entering the conduction path. The Current1 excitation defines current
exiting the conduction path, and so is not available to the matrix. Current1 can
be made available by swapping the direction of both current excitations. This
switches which excitation defines the current entering and exiting the conduction
path.
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Save the Project
Select the menu item File > Save

Check the Validity of the Model
Select the menu item Maxwell > Validation Check, or click on the
The problem won’t solve unless each object has a check mark.

icon

Analyze
Select the menu item Maxwell > Analyze, or click on the
icon
This should take 1 minute or less to solve, and it may or may not converge in 5
passes.

Plot Power Flow
In the Project Manager, expand Field Overlays and NamedExpr to find Poynting1
Double click on Poyntning1 to refresh the plot
The plot should look similar to the following
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Calculate the Radiation Resistance
1.
2.
3.
4.

5.
6.
7.

Select Maxwell > Fields > Calculator to enter the fields calculator
Select Poynting from the list of Named Expressions
Select Copy to stack to add this quantity to the stack
Select Geometry…
Geometry…
1. Select Surface,
Surface then Outside
2. Select OK to add the geometry to the stack
Select Normal to take the normal component of the Poynting vector
Select
(integrate)
Select Eval
The result should be about 0.138 W or 0.138 ohms – which is one-sixteenth of
2.2.

Find the Impedance of this Antenna
The impedance (both resistive and reactive) of the antenna (as seen from the
current source) is computed automatically through the inclusion of the excitation
in the matrix calculation.
These results computed at the end of the simulation and are reported in the
solution data.
Select Maxwell > Results > Solution Data …
The results are reported both as Re{Z}, Im{Z}, and as R, L. The Inductive
Coupling Coefficient is related to mutual inductance with multiple conductors, so
this is not relevant now.
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Chapter 7.0
Chapter 7.0 – Transient Examples
7.1 – Switched Reluctance Motor (Stranded Conductors)
7.2 – Rotational Motion
7.3 – Translational Motion
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7.1
Example (Transient) – Stranded Conductors
Stranded Conductors
This example is intended to show you how to create and analyze a transient
problem on a Switched Reluctance Motor geometry using the Transient
solver in the Ansoft Maxwell 3D Design Environment.
Within the Maxwell 3D Design Environment, solid coils can be modeled as
Stranded Conductors. There are many advantages to using Stranded
Conductors when modeling coils that have multiple turns. The first obvious
advantage is that a coil with multiple wires, say 2500, can be modeled as a
single object as opposed to modeling each wire which would be
impracticable. Defining a Stranded Conductor means that the current
density will be uniform throughout the cross section of the conductor.
The example that will be used to demonstrate how Stranded Conductors are
implemented is a switched Reluctance Motor. This switched reluctance
motor will have four phases and two coils per phase, thus we can show how
independent coils can be grouped to create windings.
Magnetostatic:
Magnetostatic: See Example 5.3 for setup instructions for this design.
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Theory – Transient Solver
When creating Windings in the Transient solver, it is assumed that all of the coils
used to make up that winding are connected in series.
When creating a Winding and using voltage sources, the Winding Panel asks for
the Initial Current, Resistance, Inductance,
Inductance and Voltage.
Voltage
Initial Current:
Current This is an initial condition used by the solver
Resistance:
Resistance This is the DC resistance of the total winding; for the Phase_A
winding, this is the resistance of Coil_A1 and Coil_A2 in series.
Inductance:
Inductance This is any extra inductance that is not modeled that needs to
be added. For example, and additional line inductance or source
inductance.
Voltage:
Voltage This is the source voltage which can be a constant, function, or
piecewise linear curve.
A sketch of the Phase_A Winding circuit is:
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Theory – Transient Solver (Continued)
If the Winding was defined as a Current Source instead of a Voltage Source,
Source the
only additional field to modify is the initial current. The circuit would look like this:

The DC Resistance and Extra Inductance is not needed since this is a
current source and its value is guaranteed regardless of any value for the
DC Resistance or Extra Inductance.
The third option for the Winding setup is External.
External This means that there is an
external circuit that is made up of arbitrary components. Please refer to the
Topic paper on External Circuits for the details on how this is implemented.
Please note that if the two coils that make up the Phase_A winding were
connected in parallel instead of series, then two separate Windings would need
to be created.
In regards to the current density, the Transient solver treats stranded conductors
the same as in the Magnetostatic solver; that is, the current density is uniform
across the terminal and the solver calculates the magnetic field intensity H
directly and the current density vector J indirectly.
There are two options when defining the type of winding: Solid or Stranded.
Stranded This
write up is for Stranded Windings only. For a full description of how Solid
windings are implemented, please refer to the Topic paper Solid Conductors.
Conductors
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Ansoft Maxwell Design Environment
The following features of the Ansoft Maxwell Design Environment are used to
create the models covered in this topic
3D Solid Modeling
User Defined Primitives (UDP): Switched Reluctance Motor
Primitives:: Regular Polyhedron
Surface Operations: Section
Boolean Operations: Separate Bodies
Boundaries/Excitations
Current: Stranded
Analysis
Transient
Results
Field Calculator
Field Overlays:
Magnitude B
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Getting Started
Launching Maxwell
1.

To access Maxwell, click the Microsoft Start button, select Programs,
Programs and select
Ansoft and then Maxwell 11.

Setting Tool Options
To set the tool options:
Note: In order to follow the steps outlined in this example, verify that the
following tool options are set :
1. Select the menu item Tools > Options > Maxwell Options
2. Maxwell Options Window:
1. Click the General Options tab
Use Wizards for data entry when creating new boundaries:: 
Checked
Duplicate boundaries with geometry::  Checked
2. Click the OK button
3. Select the menu item Tools > Options > 3D Modeler Options.
Options
4. 3D Modeler Options Window:
1. Click the Operation tab
Automatically cover closed polylines::  Checked
2. Click the Drawing tab
Edit property of new primitives::  Checked
3. Click the OK button
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Opening a New Project
To open a new project:
In an Ansoft Maxwell window, click the  On the Standard toolbar, or
select the menu item File > New.
From the Project menu, select Insert Maxwell Design.

Set Solution Type
To set the solution type:
Select the menu item Maxwell > Solution Type
Solution Type Window:
Choose Transient
Click the OK button
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Creating the 3D Model
Set Model Units
To set the units:
1. Select the menu item 3D Modeler > Units
2. Set Model Units:
1. Select Units: mm
2. Click the OK button

Set Default Material
To set the default material:
1. Using the 3D Modeler Materials toolbar, choose Select
2. Select Definition Window:
1. Type iron in the Search by Name field
2. Click the OK button
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Create Rotor
To create the rotor:
1. Select the menu item Draw > User Defined Primitive > Syslib > Rmxprt >

SRMCore
From the Create User Defined Primitive dialog
1. For the value of DiaGap,
DiaGap, type: 70,
70 Click the Tab key to accept
2. For the value of DiaYoke,
DiaYoke type: 30,
30 Click the Tab key to accept
3. For the value of Length,
Length type: 65,
65 Click the Tab key to accept
4. For the value of Poles,
Poles type: 6, Click the Tab key to accept
5. For the value of ThkYoke,
ThkYoke type: 9, Click the Tab key to accept
6. For the value of Embrace,
Embrace type: 0.5,
0.5 Click the Tab key to accept
7. For the value of EndExt,
EndExt type: 0, Click the Tab key to accept
8. For the value of InfoCore,
InfoCore type: 0, Click the Tab key to accept
9. Click the OK button
To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Rotor
3. Click the OK button
To fit the view:
1. Select the menu item View > Fit All > Active View.
2.
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Create Stator and Coils:
To create the Stator and Coils
1. Select the menu item Draw > User Defined Primitive > Syslib > Rmxprt >

SRMCore
From the Create User Defined Primitive dialog
1. For the value of DiaGap,
DiaGap, type: 75,
75 Click the Tab key to accept
2. For the value of DiaYoke,
DiaYoke type: 120,
120 Click the Tab key to accept
3. For the value of Length,
Length type: 65,
65 Click the Tab key to accept
4. For the value of Poles,
Poles type: 8, Click the Tab key to accept
5. For the value of ThkYoke,
ThkYoke type: 9, Click the Tab key to accept
6. For the value of Embrace,
Embrace type: 0.5,
0.5 Click the Tab key to accept
7. For the value of EndExt,
EndExt type: 1, Click the Tab key to accept
8. For the value of InfoCore,
InfoCore type: 1, Click the Tab key to accept
9. Click the OK button
To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Stator
3. Click the OK button
To fit the view:
1. Select the menu item View > Fit All > Active View.
2.

Ungroup the Stator and Coils
To separate bodies
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
1. Select the objects named: Stator
2. Click the OK button
3. Select the menu item, 3D Modeler > Boolean > Separate Bodies

Process the Coils:
Select Coils
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
1. Select the objects named: Stator_2, Stator_3, Stator_4, Stator_5,
Stator_6, Stator_7, Stator_8
2. Click the OK button
Delete Coils
1. Select the menu item Edit > Delete
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Create Terminals
Section Coils
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
1. Select the objects named: Stator_1
2. Click the OK button
Section Object
1. Select the menu item Edit > Surface > Section
1. Section Plane: XY
2. Click the OK button
Separate Bodies
1. Select the menu item Edit > Boolean > Separate Bodies
Delete
1. Select the menu item Edit > Delete
Section Coils
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
1. Select the objects named: Section1
2. Click the OK button
Assign Excitation
1. Select the menu item Maxwell > Excitations > Assign > Coil Terminals
2. Coil Terminal Excitation : General
1. Name: CoilTerminal1
2. Number of Conductors: 150
3. Click the OK button

Verify Duplicate Boundary Option is Set
Section To set the tool options:
1. Select the menu item Maxwell > Options > Maxwell Options
2. Maxwell Options Window:
1. Click the General tab
Duplicate boundaries with geometry::  Checked
2. Click the OK button
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Change Properties
Change Properties
1. Select the menu item Maxwell > List
2. Design List Window
1. From the list, select row: Stator_1
2. Click the Properties button
3. Properties Window
1. Name: Coil
2. Material: copper
3. Click the OK button
4. From the list, select row: Section1
5. Click the Properties button
6. Properties Window
1. Name: Terminal
2. Click the OK button
7. Click the Done button

Duplicate Coil and Terminal
To select objects
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
1. Select the objects named: Coil, Terminal
2. Click the OK button
To duplicate the objects:
1. Select the menu item, Edit > Duplicate > Around Axis
2. Duplicate Around Axis Window
1. Axis: Z
2. Angle: 45deg
3. Total Number: 8
4. Click the OK button
3. Click the OK button
Project Tree: Eight Excitations
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Add Windings
To add windings
1. Select the menu item Maxwell > Excitations > Add Winding
2. Winding Window
1. Name: Winding1
2. Type: Voltage
3. Stranded
4. Resistance: 2.5 ohm
5. Voltage: 120 V
6. Click the OK button
3. Repeat these steps three more times to add: Winding2, Winding3,
Winding4

Assign Terminals to Windings
To select windings
1. Expand the Project tree to display the Excitations
2. Using the mouse, right-click on Winding1 and select Add Terminals
3. Add Terminal Window
1. From the list, select: CoilTerminal1, CoilTerminal5
2. Click the OK button
4. Repeat these steps for:
Winding2
CoilTerminal2
CoilTerminal6
Winding3
CoilTerminal3
CoilTerminal7
Winding2
CoilTerminal4
CoilTerminal8
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Set Default Material
To set the default material:
1. Using the 3D Modeler Materials toolbar, choose vacuum

Create Region
To create the region:
1. Select the menu item Draw > Regular Polyhedron
2. Using the coordinate entry fields, enter the center position
X: 0.0,
0.0 Y: 0.0,
0.0 Z: -100.0,
100.0 Press the Enter key
3. Using the coordinate entry fields, enter the radius:
dX: 150.0 dY: 0.0,
0.0 dZ: 0.0,
0.0 Press the Enter key
4. Using the coordinate entry fields, enter the height:
dX: 0.0,
0.0 dY: 0.0,
0.0 dZ: 200.0,
200.0 Press the Enter key
Segment Number Window
Number of Segments: 12
Click the OK button
To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Region
3. Display Wireframe:
Wireframe  Checked
4. Click the OK button
To turn off the visibility:
1. Select the menu item View > Hide Selection > Active View
To fit the view:
1. Select the menu item View > Fit All > Active View.
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Create Mesh
Note: The transient solver does not use automatic adaptive meshing.
Select Coils
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
1. Select the objects named: Coil, Coil_1, Coil_2, Coil_3, Coil_4,
Coil_5, Coil_6, Coil_7
2. Click the OK button
To create a mesh:
1. Select the menu item Maxwell > Mesh Operations > Assign > On Selection

> Length Based
Element Length Based Assignment Window
1. Name: Coils
2. Restrict Length of Elements:  Unchecked
3. Restrict Number of Elements: Checked
4. Maximum Number of Elements: 16000 (2000/tets per coil)
5. Click the OK button
Select Rotor and Stator
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
1. Select the objects named: Rotor, Stator
2. Click the OK button
To create a mesh:
1. Select the menu item Maxwell > Mesh Operations > Assign > On Selection
2.

> Length Based
2.

Element Length Based Assignment Window
1. Name: Rotor_Stator
2. Restrict Length of Elements:  Unchecked
3. Restrict Number of Elements: Checked
4. Maximum Number of Elements: 4000 (2000/tets per object)
5. Click the OK button
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Analysis Setup
Creating an Analysis Setup
To create an analysis setup:
1. Select the menu item Maxwell > Analysis Setup > Add Solution Setup
2. Solution Setup Window:
1. Click the General tab::
Stop time: 0.05s
Time step: 0.002s
2. Click the OK button

Save Project
To save the project:
1. In an Ansoft Maxwell window, select the menu item File > Save As.
2. From the Save As window, type the Filename: maxwell_trans_relmotor
3. Click the Save button

Analyze
Model Validation
To validate the model:
1. Select the menu item Maxwell > Validation Check
2. Click the Close button
Note: To view any errors or warning messages, use the Message
Manager.

Analyze
To start the solution process:
1. Select the menu item Maxwell > Analyze All
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Create Quick Report
To create a report:
1. Select the menu item Maxwell > Results > Create Quick Report
2. Quick Report Window::
1. Select: Current
2. Click the OK button
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Calculate Current
To use the field calculator
1. Select the menu item Maxwell > Fields > Calculator
2. Select Quantity: J
3. Select Vector:
Vector Scal?
Scal? > Scalar Z
4. Click the button Geometry
5. Geometry Window
1. Select the radio button Surface
2. From the list select: Section1
3. Click the OK button
6. Click the ∫ (Integrate) button
7. Click the Number Button
1. Type: Scalar
2. Value: 150 (Number of Conductors)
3. Click the OK button
8. Click the / button
9. Click the Eval button
10. Click the Done button to close the calculator
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Create Quarter Symmetry Geometry
So far we have been working with full geometry. Often it is useful to use
symmetry in order to reduce the problem size and thus decrease the solution
time. In this section, we’ll show how to create the symmetric model and its
impact on stranded conductors.

Copy the Existing Design
Select the previous design, Stranded_TR,
Stranded_TR and right mouse click and select Copy.
Copy
Click on project name, Stranded_Conductors,
Stranded_Conductors and right mouse click and select
Paste;
Paste this will create a second design called Stranded_TR1.
Stranded_TR1 Change its name
to Stranded_TR_Symm for Transient wit symmetry. Double click on this design
to make it active.

Rotate the Geometry to Create Quarter Symmetry
Before splitting the model to create a ¼ model, all of the objects need to be
rotated. Make all of the objects visible and then select them. Next choose the
menu item Edit > Arrange > Rotate and choose 22.5 degrees about Z.

Next select only the rotor and choose the menu item Edit > Arrange > Rotate
and choose 7.5 degrees about Z. Now the objects are rotated so that they can
be properly cut on the symmetry planes.
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Modify the Geometry to Create Quarter Symmetry
Make all of the objects visible and then select them. Next select the menu item
3D Modeler > Boolean > Split and choose
Split Plane > YZ
Keep Fragments > Positive Side
Split Objects > Split Entire Selection
Note: By selecting Split Entire Selection instead of Split Objects Crossing Split
Plane, all objects in negative X direction are automatically deleted, even if
they are not cut.
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Select all of the objects and then select the menu item 3D Modeler > Boolean >
Split and choose:
Split Plane > XY
Keep Fragments > Positive Side
Split Objects > Split Entire Selection

The resulting geometry should look like this. Select View > Rotate to spin the
view so that the ends of the coils are exposed and the faces can be selected.
Select View > Zoom to enlarge the view.
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Redefining the Terminals
When the entire coil is not being modeled and the coil cuts the surface of the
solution boundary (called Region in this example), terminals need to be defined
that are coincident with the Coil and the Region.
Hide the region under View > Active View > Visibility
Select the menu item Edit > Select > Faces and click on the right face of
Coil_A2 that is coincident with the Region.
Select the menu item 3D Modeler > Surface > Create Object from Face
Change the name from ObjectFromFace1 to Terminal_A2_1 to represent
the number 1Terminal on Coil A2

Repeat this for the other coils, creating terminals from the faces the touch
the boundary as shown below.

Terminal_A2_2
Terminal_D1_1

Terminal_A2_1
Terminal_B2_2
Terminal_D1_2

Terminal_B2_1
Terminal_C2_2

Terminal_C1_1

Terminal_C1_2
Terminal_C2_1
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Assign Terminals as Excitation Coil Terminals
Select the Terminals just created.
Select the menu item Maxwell > Excitations > Assign > Coil Terminal.
Assign the Number of Conductors to 150
Note:
Note The number of conductors for this fractional model is 150 which is
the same as for the full model. The cross-section of the winding has not
been reduced and so the objects modeled still have 150 conductors.
Change the name of the Excitations to match the actual terminal. Select
CoilTerminal_1 and in Properties Window change the name to
CoilTerminal_A2_1. Make sure that the terminal is going into the Coil_A2 along
the Z direction.
Repeat this for all of the other Coil Terminals, making sure that each coil has one
terminal that has the direction along +Z and the other terminal along –Z.
The terminals for the A Coil should look like this:

CoilTerminal_A2_1

CoilTerminal_A2_2

Repeat this for all five coils
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Assign the Coil Terminals to the Windings
The new Coil Terminals need to be assigned to the existing Windings
Click on Winding_1 Winding and then right mouse click and select Add
Terminals.
Terminals Choose Terminal_A2_1 and Terminal_A2_2.

Repeat this for the other four Windings
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Create a Mesh
As before, we will need to create a manual mesh.
First, delete any previous mesh operations under the Mesh Operations tree.
Select the coils. Select the menu item Maxwell > Mesh Operations > Assign >
On Selection > Length Based.
Based
Change the Name to Coils
Deselect Restrict Length of Elements check box
Select Restrict the Number of Elements check box and change the
Maximum Number of Elements to be 4000. This is ¼ of the value that was
used for the full model
Select the Rotor and Stator. Right mouse click and select Assign Mesh
Operation > On Selection > Length Based
Change the Name to Rotor_Stator
Deselect Restrict Length of Elements check box
Select Restrict the Number of Elements check box and change the
Maximum Number of Elements to be 1000. Again, this is ¼ of the value
that was used for the full model
Select the menu item Maxwell > Analysis Setup > Apply Mesh Operations

Set Symmetry Factor
Under Stranded_TR_Symm, select Model from the project tree. Right mouse
click and select Set Symmetry Multiplier and use a value of 4.

Check the Validity of the Model
Select the menu item Maxwell > Validation Check, or click on the
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Analyze
Select the menu item Maxwell > Analyze,
Analyze or click on the

icon

Results
Click on Results > Current Quick Report 1 to view the plot of the Winding Current

As before, the four phase windings converge to the same DC value, 48 amps.
Calculate the total current across the terminal
Select the menu item Maxwell > Fields > Calculator and perform the following:
1. Time > 0.05 sec
2. Quantity > J
3. Scal? > ScalarZ
4. Geometry > Surface > Terminal_A1_1
5.
, the integral symbol
6. Number > Scalar > 150, this is the conductor number
7. /, the divide symbol
8. Eval, which stands for evaluate
9. The value displayed is 47.98 amp.
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Half Coils
Note: If the cross section of the coil is cut in half, then the number of conductors
is half. An example for a simple coil is shown below:

H = 20mm
H = 10mm

Modeling the Full Coil:
Conductor Number = 150
Symmetry Multiplier = 1
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Rotational Cylindrical Motion using the Transient Solver
Transient Solver in Maxwell allows to be combined with motion. This motion
can be translational, rotational cylindrical or rotational non-cylindrical (relaytype motion). This example shows on a simple geometry how to set-up
rotational cylindrical motion project in a Transient Solver. It teaches how to
set-up a band for rotational cylindrical motion, create and post process timedependent field variables and create an animation. It shows how to utilize
the periodicity of the configuration to reduce the size of the problem.
The geometry consists of a cylindrical 4-pole radially magnetized NdFeB
magnet with sinusoidal distribution of magnetization. The magnet rotates
with a constant speed of 360 degrees per second around its axis. There is a
Hall Sensor at certain distance from the magnet. The goal is to model a timedependent magnetic field created by rotating magnet and follow the
magnitude of this field by employing the Hall sensor. The role of the sensor
is to calculate the average flux density passing through the sensor.
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Ansoft Maxwell Design Environment
The following features of the Ansoft Maxwell Design Environment are used to
create the models covered in this topic
3D Solid Modeling
Primitives:: Regular Polyhedron, Rectangle
Boolean Operations: Split
Sweep Operations: Around Axis
Model: Band for rotational cylindrical motion
Boundaries/Excitations
Matching boundaries (Master/Slave)
Natural outer boundary
Material properties
Edit material (4(4-pole NdFeB radially magnetized magnet with
sinusoidal distribution of magnetization)
Analysis
Transient
Results
Fields Calculator
Rectangular Plot
Field Overlays:
Flux Density Vector Plots
Flux Density Vector Animation
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Getting Started
Launching Maxwell
1.

To access Maxwell, click the Microsoft Start button, select Programs,
Programs and select
Ansoft and then Maxwell 11.

Setting Tool Options
To set the tool options:
Note: In order to follow the steps outlined in this example, verify that the
following tool options are set :
1. Select the menu item Tools > Options > Maxwell Options
2. Maxwell Options Window:
1. Click the General Options tab
Use Wizards for data entry when creating new boundaries:: 
Checked
Duplicate boundaries with geometry::  Checked
2. Click the OK button
3. Select the menu item Tools > Options > 3D Modeler Options.
Options
4. 3D Modeler Options Window:
1. Click the Operation tab
Automatically cover closed polylines::  Checked
2. Click the Drawing tab
Edit property of new primitives::  Checked
3. Click the OK button
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Opening a New Project
To open a new project:
1. In an Maxwell window, click the  On the Standard toolbar, or select
the menu item File > New.
2. Select the menu item Project > Insert Maxwell Design, or click on the
icon

Set Solution Type
Select the menu item: Maxwell > Solution Type > Transient or right mouse
click on MaxwellDesign1 and select Solution Type …

Set Model Units
Select the menu item 3D Modeler > Units > Select Units: mm (millimeters)
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Create Magnet
Outer Radius: 7 mm; Inner Radius: 5 mm; Height: 2 mm
There are 2 possibilities how to create the magnet:
1.
Create 2 cylinders with respective outer and inner radii and subtract them
2.
Create a rectangle and sweep it around axis:

3D Modeler > Drawing Plane > XZ
Draw > Rectangle
Using the coordinate entry field, enter the first corner of the rectangle
X: 5.0, Y: 0.0, Z: -1.0,
1.0 Press the Enter key
Using the coordinate entry field, enter the opposite corner of the rectangle
X: 7.0, Y: 0.0, Z: 1.0,
1.0 Press the Enter key
(Note here that the entries for the position are in ABSOLUTE values.)
Select Rectangle 1:
icon and choose
Edit > Select > By Name – Rectangle 1 or click on the
Rectangle 1.
Draw > Sweep > Around Axis – choose z as sweep axis and 360 degrees as Angle
of sweep

Click on the Attribute Tab and change the name from Rectangle 1 to Magnet
Change the Color to Blue
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Create Hall Sensor
A Hall Sensor is a square sheet (0.8x0.8 mm) located 1 mm from the outer radius
of the magnet and rotated 45 degrees from the x-axis:

3D Modeler > Drawing Plane > YZ
Draw > Rectangle
Using the coordinate entry field, enter the first corner of the
rectangle
X: 8.0, Y: -0.4, Z: -0.4,
0.4 Press the Enter key
Using the coordinate entry field, enter the opposite corner of the
rectangle
dX:
dX: 0.0, dY:
dY: 0.8, dZ:
dZ: 0.8,
0.8 Press the Enter key
Click on the Attribute Tab and change the name from Rectangle 1 to
Sensor
Change the Color to Red

Edit > Arrange > Rotate
Axis: z; Angle: 45 deg

Create Band
In a Transient Solver, Band is an object that contains all rotating objects. In it is a
way how to tell Maxwell which objects are steady and which are moving. In this
example there is one moving (rotating) object: Magnet. For rotational cylindrical
type of motion Band is usually a cylinder. It should be a solid cylinder, not a
hollow cylinder. For translational type of motion Band cannot be a true surface
object (cylinder). It must be a faceted object, such as Regular Polyhedron.

3D Modeler > Drawing Plane > XY
Draw > Cylinder
Using the coordinate entry field, enter the center of base:
X: 0.0, Y: 0.0, Z: -6.0,
6.0 Press the Enter key
Using the coordinate entry field, enter the radius:
dX:
dX: 7.3, dY:
dY: 0.0, dZ:
dZ: 0.0,
0.0 Press the Enter key
Using the coordinate entry field, enter the height:
dX:
dX: 0.0, dY:
dY: 0.0, dZ:
dZ: 12.0,
12.0 Press the Enter key
Click on the Attribute Tab and change the name from Cylinder 1 to Band
Transparent: 0.6
Change the Color to Brown
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Create Outer Boundary (Region)
All objects in the model must be enclosed in one object the boundary of which
serves as outer boundary. This object is called Region and can be created using
Draw > Region command. Using this command a box with prescribed dimensions
is created. In this example we wish that the Region is of cylindrical shape.
Therefore, an additional cylinder far enough from all other objects will be created.
This cylinder will serve as Region. The field is by default tangential to the outer
boundary of such an object.

Draw > Cylinder
Using the coordinate entry field, enter the center of base:
X: 0.0, Y: 0.0, Z: -8.0,
8.0 Press the Enter key
Using the coordinate entry field, enter the radius:
dX:
dX: 16, dY:
dY: 0.0, dZ:
dZ: 0.0,
0.0 Press the Enter key
Using the coordinate entry field, enter the height:
dX:
dX: 0.0, dY:
dY: 0.0, dZ:
dZ: 16.0,
16.0 Press the Enter key
Click on the Attribute Tab and change the name from Cylinder 1 to Region
Check the box Display Wireframe
Change the Color to Light Blue
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Define and assign material properties
The only object that needs material definition and assignment is Magnet. All other
objects are vacuum by default.
To define a new NdFeB30 4-pole magnet material with sinusoidal distribution of
magnetization:

Tools > Edit Configured Libraries > Materials

Select NdFeB30 and click on View/Edit Materials (start typing NdFeB into
the Search by Name window for faster selection)
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Specify the following:
Material Name: magnet_material
Material Coordinate System Type: Cylindrical
(The magnet is radially magnetized so it is advantageous to use the
cylindrical coordinate system. The direction of magnetization is
determined by Unit Vector. For the cylindrical coordinate system the
components of Unit Vector are R, Phi and Z, standing for radial,
circumferential and z- directions. The values of R, Phi and Z are 1,
0, 0 by default. For this example they do not have to be changed,
because the magnet is radially magnetized.)
Magnetic Coercivity – Magnitude: -838000*cos(2*Phi)
(Phi is a default symbol for an angle in the cylindrical coordinate
system. In order to get 4-pole magnet the argument in cos is
multiplied by two.)
Click on Validate Material to check the settings (green check mark
indicates that everything is all right).
Using the coordinate entry field, enter the height:
Press the OK key
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To assign a newly created magnet_material to object Magnet:
Select Magnet:
Edit > Select > By Name – select Magnet and press OK key
Assign material:
3D Modeler > Assign Material – select magnet_material and press
OK key

Define Band and Motion Setup
Select Band:

Edit > Select > By Name – select Band and press OK key
Assign Band:
Maxwell > Model > Motion Setup > Assign Band

Select Type Tab and specify Rotate radio button
Select Mechanical Tab and specify Angular Velocity: 360 deg_per_s
(The magnet rotates at constant speed of 360 degrees per second – 1
revolution per second)
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Create an Analysis Setup
Select the menu item Maxwell > Analysis Setup > Add Solution Setup
General Tab: Stop time: 1 s; Time step: 0.05 s
(We will analyze one revolution. Since the speed is 360 degrees per second, to
analyze one revolution, we have to solve 1 s in time. We will discretize the time
domain into 20 time steps, meaning that the time step will be 0.05 s.)
Save Fields Tab: Type: Linear Step;
Step Start: 0; Stop: 1; Step Size: 0.05 and click
on Add to List >>.
>> Finally press OK key.
(The field solution will be saved at the specified time instants.)
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Save the Project
Select the menu item File > Save As
From the Save As window, type in rotational_motion
Click on the Save button

Check the Validity of the Model
Select the menu item Maxwell > Validation Check, or click on the

icon

The problem won’t solve unless each object has a check mark. We can see that
at the moment there are 2 warnings. From the Message Window we can read:
1. Warning: Eddy effect settings may need revisiting due to the recent
changes in the design.
In This example we are not interested to compute eddy currents. We have
to make sure that the objects that are made from conducting material
(Magnet) are not assigned for eddy current computation.

Maxwell > Excitations > Set Eddy Effects …
Make sure that the box next to Magnet is unchecked
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2.

Warning: Currently no mesh operations or data link have been created for
the setup(s): Setup1. The initial mesh will be used. The initial mesh is
usually not fine enough to achieve an accurate solution.
This warning reminds us that we are using the Transient Solver in which
there is not adaptive refinement of the mesh as in Magnetostatic or Eddy
Current Solvers. This means that the mesh once created will be used
throughout all the time steps. Sliding Band technology enables that the
mesh is not recreated even if rotational cylindrical motion is involved. A fine
enough mesh has to be manually created before solving any transient
problem with motion.
To refine the mesh by assigning the mesh operations:
Select Magnet:
Edit > Select > By Name – select Magnet and press OK key
Assign mesh operations:

Maxwell> Mesh Operations > Assign > Inside Selection >
Length Based…
Based…
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Name: magnet
Uncheck Resctrict Length of Elements
Check Resctrict the Number of Elements
Specify 1000 for Maximum Number of Elements
Repeat the same procedure for Region (8000)
Since a cylinder is a true (curved) surface object, we will use Surface
Approximation in order to create a good mesh for this rotational motion
problem:
Select Band:
Edit > Select > By Name – select Magnet and press OK key
Assign mesh operations:

Maxwell> Mesh Operations > Assign > Surface
Approximation
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Name: band
Maximum Surface Deviation: Ignore
Maximum Surface Normal Deviation: 3 deg
Maximum Aspect Ratio: 5
Performing the Validity Check again gives the green check marks for all the
objects. The project is ready to be analyzed.

Analyze
Select the menu item Maxwell > Analyze,
Analyze or click on the
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Solution Data
To view the Solution Data, select the menu item Maxwell > Results > Solution

Data
Here you can view the Solution (if any, e.g. force) , Profile and the Mesh
Statistics.

Plot Flux Density Vector on XY plane at time 0 s
To plot the flux density at specified time instant:

View > Set Solution Context

For Time specify 0 s.
s
Select XY plane: From the history tree window expand Planes and select
Global: XY plane
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Maxwell > Fields > Fields > B > B_vector

Specify B_vector as Quantity and All as In Volume
Press the Done key
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To set the viewing direction to the view of XY plane from the bottom:

View > Modify Attributes > Orientation …
Specify Bottom as Viewing Direction
Click on Apply key and Close key

Shortcut to Set the viewing direction to the view of XY plane from the
bottom:
Press and hold Alt key
Double-click with the left mouse button on the central bottom region
of 3D Modeler Window
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Modify the attributes of the vector plot:

Maxwell > Fields > Modify Plot Attributes …
Select the specific plot (B)
Or
Double-click on the Plot Legend

Plot Hall Sensor Flux Density as a function of time
To define a function Bsensor characterizing the average flux density through the
surface of Sensor (use Fields Calculator):
Calculator

Maxwell > Fields > Calculator …
1.
2.
3.
4.
5.
6.
7.
8.
9.

Input > Quantity > B
Input > Geometry > Surface > Sensor
Vector > Normal
Undo
Scalar > Integrate (the integral symbol)
Input > Number > Scalar, Value 1
Input > Geometry > Surface > Sensor
Scalar > Integrate (the integral symbol)
General > Divide (forward slash)
The final line in the Calculator register should look like this:

10.

Add > Named Expression > Name: Bsensor > OK

11.

Click on Done key
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To plot the defined function Bsensor as a function of time:

Maxwell > Results > Create Report
Specify: Report Type: Fields;
Fields Display Type: Rectangular Plot

In the Traces Window specify from the Y Tab:
Category: Calculator Expressions
Quantity: Bsensor
Function: none
Click on Add Trace key and Done key
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Create an Animation of Flux Density Vector Plot
Select already created plot of Flux Density Vector
At the Project Manager Window expand Field Overlays and B
Double-click on B_vector1 to brink this vector plot back to view
Right-click on B_vector1
Select Animate
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In Setup Animation Window and Swept Variable Tab:
Swept Variable: Time
Select Values: Holding down the Shift key select all the values
Press the OK key
To start and stop the animation, to control the speed of the animation and to
export the animation use the buttons on the Animation Panel:
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Utilize periodicity to reduce the size of the problem
It is always advisable to utilize possible symmetries present in the model in order
to reduce the size of the problem and in turn to reduce the computation time. The
geometry of the problem studied in this section is obviously symmetrical. It is a 4pole geometry where one pole pitch can be identified as the smallest symmetry
sector. The field pattern repeats itself every pole pitch, which in this case is 90
degrees (see plot on page 5-1.16). To be precise there is so called negative
periodicity present in the field pattern because the field along the x-axis is exactly
the same as the field along the y-axis but with the opposite direction. The
negative periodicity boundary conditions can be set-up in Maxwell using Master
and Slave boundaries.
In the Project Manager Window select the previous design, full_geometry,
full_geometry and
right mouse click and select Copy.
Copy
Click on project name, rotational_motion,
rotational_motion and right mouse click and select Paste;
Paste
this will create a second design called rotational_motion1.
rotational_motion1 Change its name to
quarter_geometry.
quarter_geometry. Double click on this design to make it active.
To create a 90 degrees geometry:
Select Magnet,
Magnet Band and Region
Edit > Select > By Name – select Magnet, Band and Region; OK
Split the selected object at xz-plane:
xz

3D Modeler > Boolean > Split
Select xz-plane;
Keep fragments: Positive side;
xz
side Split entire selection

OK
Split the selected object at yz-plane:
yz

3D Modeler > Boolean > Split
Select yz-plane;
Keep fragments: Positive side;
yz
side Split entire selection
OK
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To assign negative periodicity boundary conditions:
Press F on the keyboard in order to select Face Selection Mode
Using the mouse select the face of the Region at the xz-plane
xz

To assign Master boundary:

Maxwell > Boundaries > Assign > Master
U vector: New Vector
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Now define the beginning and the end of the U vector:
Using the coordinate entry field, enter the first corner of the rectangle
X: 0.0, Y: 0.0, Z: 0.0,
0.0 Press the Enter key
Using the coordinate entry field, enter the opposite corner of the rectangle
dX:
dX: 12.0, dY:
dY: 0.0, dZ:
dZ: 0.0,
0.0 Press the Enter key

V vector: check Reverse Direction

Using the mouse select the face of the Region at the yz-plane
yz
To assign Slave boundary:

Maxwell > Boundaries > Assign > Slave
U vector: New Vector
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Using the mouse select the face of the Region at the yz-plane
yz
To assign Slave boundary:

Maxwell > Boundaries > Assign > Slave
U vector: New Vector
Now define the beginning and the end of the U vector:
Using the coordinate entry field, enter the first corner of the
rectangle
X: 0.0, Y: 0.0, Z: 0.0,
0.0 Press the Enter key
Using the coordinate entry field, enter the opposite corner of
the rectangle
dX:
dX: 0.0, dY:
dY: 12.0, dZ:
dZ: 0.0,
0.0 Press the Enter key
V vector: check Reverse Direction
Relation: Hs = - Hm (negative periodicity)
OK
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We can now reassign the number of required elements in different objects
(magnet, region):
In the Project Manager Window expand Mesh Operations
Left-click to select magnet
Reduce the number of maximum elements from 1000 to 250
Repeat the same for region (8000 to 2000)
2000
The surface approximation setting for the band remains unchanged.
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Since only one quarter of a geometry is considered, the energy, torque and force
computed will be will be one quarter of the value computed with the full geometry.
In order to change that, we have to set Symmetry Multiplier to 4:

Maxwell > Model > Set Symmetry Multiplier…
Multiplier…
Type 4 and OK

Analyze
Select the menu item Maxwell > Analyze.

Results
In the Project Manager Window expand Results and double-click on XY Plot 1
and view the results of Sensor Flux Density plot versus time. This plot should be
very similar to the one already created for the full geometry.
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Translational Motion using the Transient Solver
Transient Solver in Maxwell allows to be combined with motion. This motion
can be translational, rotational cylindrical or rotational non-cylindrical (relaytype motion). This example shows on a simple geometry how to set-up a
translational motion project using the Transient Solver of Maxwell.
The geometry consists of a cylindrical NdFeB magnet with uniform
distribution of magnetization in the axial direction (z-direction). The magnet
moves through a copper hollow cylindrical structure (coil) with a constant
speed of 1 mm per second. As the magnet moves the eddy currents are
induced and flow in the copper structure. The goal is to model a timedependent magnetic field created by moving magnet and determine the eddy
currents in the copper structure.
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Ansoft Maxwell Design Environment
The following features of the Ansoft Maxwell Design Environment are used to
create the models covered in this topic
3D Solid Modeling
Primitives:: Regular Polyhedron, Rectangle
Boolean Operations: Split
Sweep Operations: Around Axis
Model: Band for translational motion
Boundaries/Excitations
Natural outer boundary
Material properties
Edit material (NdFeB
(NdFeB axially magnetized magnet with uniform
distribution of magnetization)
Analysis
Transient
Results
Fields Calculator
Rectangular Plot
Field Overlays:
Current Density Vector Plots
Current Density Vector Animation
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Getting Started
Launching Maxwell
1.

To access Maxwell, click the Microsoft Start button, select Programs,
Programs and select
Ansoft and then Maxwell 11.

Setting Tool Options
To set the tool options:
Note: In order to follow the steps outlined in this example, verify that the
following tool options are set :
1. Select the menu item Tools > Options > Maxwell Options
2. Maxwell Options Window:
1. Click the General Options tab
Use Wizards for data entry when creating new boundaries:: 
Checked
Duplicate boundaries with geometry::  Checked
2. Click the OK button
3. Select the menu item Tools > Options > 3D Modeler Options.
Options
4. 3D Modeler Options Window:
1. Click the Operation tab
Automatically cover closed polylines::  Checked
2. Click the Drawing tab
Edit property of new primitives::  Checked
3. Click the OK button
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Opening a New Project
To open a new project:
1. In an Maxwell window, click the  On the Standard toolbar, or select
the menu item File > New.
2. Select the menu item Project > Insert Maxwell Design, or click on the
icon

To rename the design: Right-click on MaxwellDesign1 and select Rename;
Rename
change the name from MaxwellDesign1 to moving_magnet

Set Solution Type
Select the menu item: Maxwell > Solution Type and specify Transient or
right mouse click on MaxwellDesign1 and select Solution Type and specify
Transient

Set Model Units
Select the menu item 3D Modeler > Units > Select Units: cm (centimeters)
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Create Magnet
Regular Polyhedron with Outer Radius: 1.3 cm and Height: 2 cm positioned 1 cm below XY plane:

3D Modeler > Drawing Plane > XY
Draw > Regular Polyhedron
Using the coordinate entry field, enter the center of the base of the regular
polyhedron
X: 0.0, Y: 0.0, Z: -1.0,
1.0 Press the Enter key
Using the coordinate entry field, enter the radius
dX:
dX: 0.0, dY:
dY: 1.3, dZ:
dZ: -1.0,
1.0 Press the Enter key
Using the coordinate entry field, enter the height
dX:
dX: 0.0, dY:
dY: 0.0, dZ:
dZ: 2.0,
2.0 Press the Enter key
Number of Segments: 36
Click on the Attribute Tab and change the name from Regular Polyhedron 1 to
Magnet
Change the Color to Blue

Create Coil and Coil Terminal
Outer Radius: 2.5 cm; Inner Radius: 1.5 cm; Height: 5 cm
Create a rectangle in XZ plane and sweep it around z-axis

3D Modeler > Drawing Plane > XZ
Draw > Rectangle
Using the coordinate entry field, enter the first corner of the rectangle
X: 0.0, Y: 1.5, Z: -2.5,
2.5 Press the Enter key
Using the coordinate entry field, enter the opposite corner of the rectangle
dX:
dX: 0.0, dY:
dY: 1.0, dZ:
dZ: 5.0,
5.0 Press the Enter key
Click on the Attribute Tab and change the name from Rectangle 1 to CoilTerminal
Select CoilTerminal and Edit > Copy Edit > Paste (a copy CoilTerminal1 will be
created)
Edit > Select > By Name – CoilTerminal 1
Draw > Sweep > Around Axis – choose z as sweep axis and 360 degrees as Angle
of sweep
Click on the Attribute Tab and change the name from CoilTerminal 1 to Coil
Change the Color to Yellow
Transparent: 0.7
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Create Band
In Transient Solver, Band is an object that contains all moving objects. In other
words it is a way how to tell Maxwell which objects are steady and which are
moving. In this example there is one moving (translating) object: Magnet.
Magnet For
translational type of motion Band cannot be a true surface object (cylinder). It
must be a faceted object, such as Regular Polyhedron:

3D Modeler > Drawing Plane > XY
Draw > Regular Polyhedron
Using the coordinate entry field, enter the center of base:
X: 0.0, Y: 0.0, Z: -6.0,
6.0 Press the Enter key
Using the coordinate entry field, enter the radius:
dX:
dX: 0.0, dY:
dY: 1.4, dZ:
dZ: -6.0,
6.0 Press the Enter key
Using the coordinate entry field, enter the height:
dX:
dX: 0.0, dY:
dY: 0.0, dZ:
dZ: 12.0,
12.0 Press the Enter key
Number of Segments: 36
Click on the Attribute Tab and change the name from Cylinder 1 to Band
Transparent: 0.7
Change the Color to Brown

Create Outer Boundary (Region)
Draw > Region: Padding Data: One;
One Padding Percentage: 50; OK
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Define and assign material properties
Magnet and Coil need material assignment. All other objects are vacuum by
default.
To define a new NdFeB35 magnet material with uniform distribution of
magnetization in the axial (positive z) direction:

Tools > Edit Configured Libraries > Materials

Select NdFeB35 and click on View/Edit Materials (start typing NdFeB into
the Search by Name window for faster selection)
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Specify the following:
Material Name: magnet_material
Material Coordinate System Type: Cartesian
The direction of magnetization is determined by Unit Vector. For the
Cartesian coordinate system the components of Unit Vector are X, Y
and Z. The values of X, Y and Z are 1, 0, 0 by default. For this
example they have to be changed, because the magnet is
magnetized in positive z-direction:
X: 0; Y: 0; Z: 1
Click on Validate Material to check the settings (green check mark
indicates that everything is all right); OK
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To assign a newly created magnet_material to object Magnet:
Magnet
Select Magnet:
Magnet
Edit > Select > By Name – select Magnet and press OK key
Assign material:
3D Modeler > Assign Material – select magnet_material and press OK key
To assign material copper to object Coil:
Coil
Select Coil:
Coil
Edit > Select > By Name – select Coil and press OK key
Assign material:
3D Modeler > Assign Material – select copper and press OK key

Define Band and Motion Setup
Select Band:
Band

Edit > Select > By Name – select Band and press OK key
Assign Band:

Maxwell > Model > Motion Setup > Assign Band

Select Type Tab and specify Translate radio button.
Select Data Tab and specify: Initial Position: -4 cm; Translate Limit: Negative: -4 cm;
cm
Positive: 4 cm
Select Mechanical Tab and specify Angular Velocity: 1 cm_per_s
(The magnet moves at constant speed of 1 cm per second in the positive z direction.)
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Create an Analysis Setup
Select the menu item Maxwell > Analysis Setup > Add Solution Setup
General Tab: Stop time: 8 s;
s Time step: 0.25 s
Save Fields Tab: Type: Linear Step;
Step Start: 0; Stop: 8; Step Size: 0.5 and click on
Add to List >>.
>> Finally press OK key.
(The field solution will be saved at the specified time instants.)
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Save the Project
Select the menu item File > Save As
From the Save As window, type in translational_motion
Click on the Save button

Check the Validity of the Model
Select the menu item Maxwell > Validation Check, or click on the

icon

The problem will not solve unless each item has a check mark. We can see that
at the moment there are 2 warnings. From the Message Window we can read:
1. Warning: Eddy effect settings may need revisiting due to the recent
changes in the design.
In this example we are particularly interested to compute eddy currents
induced in the solid copper coil. We have to make sure that the objects Coil
is assigned for eddy current computation:

Maxwell > Excitations > Set Eddy Effects
Make sure that the box next to Coil is checked and all other boxes
are unchecked (Magnet
Magnet is unchecked)
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2.

Warning: Currently no mesh operations or data link have been created for
the setup(s): Setup1. The initial mesh will be used. The initial mesh is
usually not fine enough to achieve an accurate solution.
For demonstration purposes in this particular example we are interested to
see the induced eddy currents at the cross section of the coil. Let us
therefore refine the cross section by assigning appropriate mesh
operations:
To refine the mesh by assigning the mesh operations:
Select CoilTerminal:
CoilTerminal
Edit > Select > By Name – select CoilTerminal and press OK
Assign mesh operations:

Maxwell> Mesh Operations > Assign > Inside Selection >
Length Based…
Based…
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Name: Lenght1
Uncheck Resctrict Length of Elements
Check Resctrict the Number of Elements
Specify 5000 for Maximum Number of Elements
Performing the Validity Check again gives the green check marks for all the
objects. The project is ready to be analyzed.

Analyze
Select the menu item Maxwell > Analyze,
Analyze or click on the
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Solution Data
To view the Solution Data, select the menu item Maxwell > Results > Solution

Data
Here you can view the Solution (if any, e.g. force) , Profile and the Mesh
Statistics.

Plot Current Density Magnitude across the Coil Terminal at time
2.5 s
To plot the flux density at specified time instant:

View > Set Solution Context

For Time specify 2.5 s.
s
Select CoilTerminal

Maxwell > Fields > Fields > J > mag_J
Press the Done key
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Plot Induced Current through the coil as a function of time
To define a function It characterizing the current through the surface of
CoilTerminal (use Fields Calculator):
Calculator

Maxwell > Fields > Calculator …
1.
2.
3.
4.
5.
6.

Input > Quantity > J
Input > Geometry > Surface > CoilTerminal
Vector > Normal
Scalar > Integrate (the integral symbol)
Add > Named Expression > Name: It > OK
Click on Done key

To plot the defined function It as a function of time:

Maxwell > Results > Create Report
Specify: Report Type: Fields;
Fields Display Type: Rectangular Plot
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In the Traces Window specify from the Y Tab:
Category: Calculator Expressions
Quantity: It
Function: none
Click on Add Trace key and Done key
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The generated trace is continuous without any discrete symbols showing where
the calculated points are. In order to show the trace with the discrete calculated
pints, the current 2D report has to be modified:
Select the trace you want to modify:
Point the mouse pointer on the trace and left-click or left-click on the area in
the rectangle in the upper right corner specifying the trace you want to
modify. The selected trace changes its color.

Report2D > Properties
Select a Line Style Tab
Check Show Symbol
on all Traces
Symbol Drawing Every
1 Data Points
OK
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Note that the points appear every 0.5s, even though the specified time step was
0.25s. The reason for this is that the quantity It is a field associated quantity. The
field associated quantities are computed as post-processing quantities from the
saved field solution, which in our case is every 0.5s.

Create an Animation of Current Density Magnitude Plot
Select already created plot of Current Density
At the Project Manager Window expand Field Overlays and J
Double-click on Mag_J1 to brink this plot back to view
Right-click on Mag_J1
Select Animate and Click on New…
New…
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In Setup Animation Window and Swept Variable Tab:
Swept Variable: Time
Select Values: Holding down the Shift key select all the values
Press the OK key
To start and stop the animation, to control the speed of the animation and to
export the animation use the buttons on the Animation Panel:
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8.1 –
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Chapter 9.0
Chapter 9.0 – Basic Exercises
9.1 – Electrostatic
9.2 – DC Conduction
9.3 – Magnetostatic
9.4 – Parametric
9.5 – Transient
9.6 – Transient with Circuit Editor
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9.1
Basic Exercises – Electrostatic Solver

Introduction on the Electrostatic Solver
This note introduces the Electro Static solver based on some simple examples.
This solver is meant to solve the static electric field without current flowing in
conductors (conductors are in electrostatic equilibrium). The conductors are
considered perfect such that there is no electric field inside conductors.

Capacitance of a Cylindrical Capacitor
Suppose we have a long coaxial line. We want to know what is the electric field
distribution based on the potential (or the charges) that are applied on each
conductor. We also want to determine the capacitance.

Draw the Model
Click on the menu item Project > Insert MaxwellDesign
Click on the menu item Maxwell > Solution Type
Select Electric
Select the radio button Electrostatic
Click on the menu item Draw > Cylinder or click on the
icon
For center position, enter 0;0;0;0;- 4 mm
For radius, enter 0.6 mm
For height, enter 25 mm
Change the name to Inner
Change the material to copper
Change the color and transparency level at your convenience.
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Create a cylinder
For center position, enter 0; 0 ;;- 4 mm
For radius, enter 1.2 mm
For height, enter 25 mm
Change the name to Outer
Change the material to copper
Change the color and transparency level at your convenience.
Create a third cylinder
For center position, enter 0; 0; - 4mm
For radius, enter 1. mm
For height, enter 25 mm
Change the name to Air
Assign material to vacuum
Change the color and transparency level at your convenience.
Subtract Air from Outer
Select Air and Outer
3D Modeler > Boolean > Subtract
Blank Parts: Outer;
Outer Tool Parts: Air
Select the menu item Draw > Region
For the padding data, choose 6
For the Padding Percentage, enter +/- 300 for X and Y, 0 for +/- Z

Assign Excitation
Based on the assumptions that the conductors are in electrostatic equilibrium, we
assign voltage potential on the object itself (and not on the surface of the object
line in the other solvers).
Select the object Inner,
Inner select the menu item Maxwell > Excitations > Assign >
Voltage.
Voltage As an alternative, once the object is selected, you can right click and
select Assign Excitations > Voltage.
Voltage
For the voltage, enter -1kV
Select the object Outer,
Outer select the menu item Maxwell > Excitations > Assign >
Voltage.
Voltage
For the voltage, enter 1kV
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Assign Executive Parameter
in addition to the field, we are interested by the Capacitance value as well
as the force applied to the inner armature.
Select the menu item Maxwell > Parameters > Assign > Matrix
Include Voltage1 and Voltage2 in the capacitance computation
Select the object Inner
Select the menu item Maxwell > Parameters > Assign > Force
Choose the virtual force

Create Analysis Setup
Select the menu item Maxwell > Analysis Setup > Add Solution Setup
For the Percent Error,
Error enter 5%
For the Refinement per Pass (Convergence tab), put 50%

Solve the Problem
Select Setup1 from under Analysis in the project tree, right mouse click and
select Analyze

Plot the electric field
From the modeler history tree, select the plane Global:XY.
Global:XY
On the 3D modeler window, right click and select Fields > E_Vector
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Get the capacitance value
From the Project window, right click on Setup1. From the context menu,
select the entry Solutions
From the pull down menu, select Matrix1

In our problem, we only have two conductors, therefore the capacitance
values are symmetrical.
From the pull down menu, select Force1.
Force1 It gives you the force applied to
the inner object.
The analytical value of the capacitance per meter for an infinite long coaxial
wire is given by the following formula:
C = 2πε
2 0 / ln(b/a) (a and b being the inside and outside diameters)
The analytical value would is therefore 1.089e1.089e-10 F/m (a =0.6mm, b=1mm)
In our project, then length of the conductor is 25 mm, therefore the total
capacitance is 2.722 pF.
pF We obtain a good agreement with the obtained
result.
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Capacitance of a planar capacitor
In this example we illustrate how to simulate a simple planar capacitor made of
two parallel plates

Draw the model
Click on the menu item Project > Insert MaxwellDesign
Name the design Plate
Click on the menu item Maxwell > Solution Type
Select Electric
Select the radio button Electrostatic
Select the menu item Draw > Box to create a plate
For the first position corner, enter 0;0;0 mm
For the Xsize, enter 25 mm
For the Ysize, enter 25mm
For the Zsize, enter 2mm
For the material property, enter pec (perfect conductor)
Name the first box DownPlate
It is not needed to draw the plate; it is possible in this case just to apply a voltage
to the surface of the region.
Select the menu item Draw > Box to create a plate
For the first position corner, enter 0;0;3 mm
For the Xsize, enter 25 mm
For the Ysize, enter 25mm
For the Zsize, enter 2mm
Name the box UpPlate
Create Region with 0% Padding Percentage. By doing this all the fringing is
neglected.

Assign Excitation
Select the object UpPlate,
UpPlate select the menu item Maxwell > Excitations > Assign >
Voltage. As an alternative, once the object is selected, you can right click and
Voltage
select Assign Excitations > Voltage.
Voltage
For the voltage, enter 0V
Select the upper face of the box Region,
Region select the menu item Maxwell >
Excitations > Assign > Voltage.
Voltage
For the voltage, enter 1V
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Assign Executive Parameter
Select the menu item Maxwell > Parameters > Assign > Matrix
Include Voltage1 and Voltage2 in the capacitance computation

Create Analysis Setup
Select the menu item Maxwell > Analysis Setup > Add Solution Setup
For the Percent Error,
Error enter 1%
For the Refinement per Pass (Convergence tab), put 50%

Solve the Problem
Select Setup1 from under Analysis in the project tree, right mouse click and
select Analyze. The problem is really easy, therefore the solution is
obtained almost immediately.

Get the capacitance value
From the Project window, right click on Setup1. From the pull down menu,
select Matrix1
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Get the capacitance value (Continued)
The analytical value of the capacitance for two parallel plates is given by:
C = ε0 A/ d (A is the area of the plate and d is the thickness of the di
electrics)
A = 625e-6 m2
d = 1e-3 m
ε0 = 8.854e-12 F/m
Using the above formula, we obtain 5.53 pF.
pF. This value matches the value
obtain using the finite elements
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Capacitance of a planar capacitor with perturbation
Here we look at the consequence for the capacitance value when a conductive
object is placed in the dielectrics region. We will use the previous design
geometry to start with

Draw the model
Click on the previous design Plate.
Plate Right Mouse click and select Copy

Click on the project name, Right Mouse click and select Paste

Based on this design, we draw a metal copper object. Select the menu item
Draw> Box
For the base point, enter 10;10;2.4 mm
For the Xsize, enter 5 mm
For the Ysize, enter 5mm
For the Zsize, enter 0.2mm
For the material property, enter pec (perfect conductor)
Name this object SmallPlate
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Modify Analysis Setup
We want to lower the error percentage since we have included the small
piece of metal.
From the project manager winder, double click on setup1 (under the
Analysis folder name).
For the Percent Error,
Error enter 0.1%
For the Refinement per Pass (Convergence tab), put 50%

Solve the Problem
Select Setup1 from under Analysis in the project tree, right mouse click and
select Analyze. .

Get the capacitance value
From the Project window, right click on Setup1. From the pull down menu,
select Matrix1
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Get the capacitance value (Continued)
We obtain quite a similar capacitance than without the SmallPlate object.
Actually, when a conductor is surrounding by insulator, Maxwell does not
compute any voltage on it. In other words, the SmallPlate object will not
have any charge on it, the capacitance value is not affected.
This illustrates the fact that in this case, a dedicated excitation boundary
needs to be used, the floating boundary.

Assign Excitation (2nd round)
Select the object SmallPlate,
SmallPlate right click and select Assign Excitations >
Floating.
Floating
There is not charge on this plate, so enter 0 Coulomb.

Solve the Problem
Select Setup1 from under Analysis in the project tree, right mouse click and
select Analyze. .

Get the capacitance value
From the Project window, right click on Setup1. From the pull down menu,
select Matrix1. We obtain now the good capacitance value..
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Introduction on the DCconduction Solver
This note introduces the DC conduction solver. Only conductors are considered
in the process.

Parallel Plates with Non-uniform media

In this example, we want to determine the DC resistance between two plates with
a non-uniform media made of ferrite and sea water. We do not need to draw the
plates; we just need to draw the two media regions.

Draw the Model
Click on the menu item Project > Insert MaxwellDesign
Name the design Plates
Click on the menu item Maxwell > Solution Type
Select Electric
Select the radio button DCconduction
Select the menu item Draw > Box to create the first region
For the first position corner, enter 0;0;0 mm
For the Xsize, enter 4 mm
For the Ysize, enter 4mm
For the Zsize, enter 0.5mm
For the material property, enter ferrite Name the first box Solid
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Draw the Model (Continued)
Select the menu item Draw > Box to create the second region
For the first position corner, enter 0;0;0.5 mm
For the Xsize, enter 4 mm
For the Ysize, enter 4mm
For the Zsize, enter 1mm
For the material property, enter water_sea
Name the first box Liquid

Assign Excitation
We apply the voltage to the plates. We did not draw the plates, because we can
apply a voltage to the top and bottom part of the regions.
Select the top face of the liquid object and select the menu item Maxwell >
Excitations > Assign > Voltage
For the voltage, enter 10V
Select the bottom face of the solid object and select the menu item Maxwell >
Excitations > Assign > Voltage
For the voltage, enter -10V
10V

Create Analysis Setup
Select the menu item Maxwell > Analysis Setup > Add Solution Setup.
Leave the default parameters

Solve the Problem
Select Setup1 from under Analysis in the project tree, right mouse click and
select Analyze
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Compute the DC Resistance
The DC resistance is not directly computed by Maxwell3D. However, we
already know the applied voltage. We need the DC current that flows
through the media. The current is obtained by taking the integral of Z
component of J on a cross-section of the region. To define any cross
section, we define a local coordinate system, and use the planes defined
by this local CS
Let’s define a local coordinate system. Select the menu item 3D Modeler >
Coordinate System > Create > Relative CS > Offset.
Offset
Enter 0 mm, 0mm, 1mm for the position of the origin. The CS is
called by default RelativeCS1.
Select the menu item Maxwell > Fields > Calculator.
Calculator The field calculator is
a tool that can compute any quantities using geometric entities and fields.
The total current going through the media is the integral of the current
density J on the plane XY of the local CS.
Select Quantity > J
Select Scalar > ScalarZ
Select Geometry > Surface > RelativeCS1:XY,
RelativeCS1:XY then click OK
Select the Integral symbol
Click on Eval
The total current appears, closed to -6.37e6.37e-3 A.
A The value is very low; it
makes sense because the conductivity of medium is very low. The negative
sign is just a matter of sign convention due to the CS orientation.
The DC resistance is given by R = Voltage / Current. The difference of
potential between the two plates is 20 V. We obtain R = 3140 Ohm
The analytical value of the resistance is given by the following formula:
R = σ2h1 + σ1h2 / ( σ1σ2A) where σ1, σ2 are the conductivity of the
two medium, h1,h2 the thickness of the two medium and A the
surface of the plates.
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Compute the DC Resistance (Continued)
Here, σ1 = 1e1e-2 Siemens/m,
Siemens/m h1= 0.5e0.5e-3 m (ferrite); σ2 = 4 Siemens/m,
Siemens/m h2 =
1e1e-3 mm (sea water) ; A = 16e16e-6 m2. This gives
R = 3140.62 Ohm
The two values are very similar.

DC current flow in conductors
In this example, we illustrate the capability of the DC current solver to reconstruct
the current paths flowing in different conductors

Draw the Model
Click on the menu item Project > Insert MaxwellDesign
Name the design Conductors
Click on the menu item Maxwell > Solution Type
Select Electric
Select the radio button DCconduction
Select the menu item Draw > Box to create the first conductor
For the first position corner, enter 1 ;;-0.6 ;0 mm
For the Xsize, enter 1 mm
For the Ysize, enter 0.2 mm
For the Zsize, enter 0.2 mm
For the material property, enter copper Name the first box Conductor
Select the object conductor,
conductor then select the menu item Edit > Duplicate > Along
Line
Enter 0;0;0 mm for the first point of the vector
Enter 0 ;0.4;0 mm for the second point of the vector
For the total number, enter 4
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Draw the Model (Continued)
Select the menu item Draw > Box
For the first position corner, enter 0.8 ;;-1 ;0 mm
For the Xsize, enter 0.2 mm
For the Ysize, enter 2.2 mm
For the Zsize, enter 0.2 mm
For the material property, enter copper Name the box Conductor_4
Select the menu item Draw > Box
For the first position corner, enter 0.8 ;;-0.4 ;0 mm
For the Xsize, enter -1.2 mm
For the Ysize, enter -0.2 mm
For the Zsize, enter 0.2 mm
For the material property, enter copper Name the box Conductor_5
Select the object Conductor_5 and select the menu item Edit > Duplicate > Mirror
For the anchor point on the mirror plane, enter 0;0;0 mm
For the target point, enter 0;1;0 mm
Select the menu item Draw > Box
For the first position corner, enter -0.4 ,0.6 ,0 mm
For the Xsize, enter -0.4 mm
For the Ysize, enter -1.2 mm
For the Zsize, enter 0.2 mm
For the material property, enter copper Name the last box Conductor_sink
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Assign Excitation
Switch the Selection mode to face by clicking on f
Select the out faces of the objects Conductor,
Conductor Conductor_1,
Conductor_1 Conductor_2,
Conductor_2
Conductor_3,
Conductor_3 Conductor_4 as shown on the picture:

Right mouse click and from the context menu select Assign Excitation > Current
Enter 1 A as the current value
Maxwell creates 6 current excitations of 1A,
1A each for every faces selected. The
default current orientation is the current going inside the objects, so we do not
need to swap any current direction.
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Assign Excitation (Continued)
We need to define a current sink. It ensures that the total current flowing through
the outside surface of a conduction path is exactly zero. A current sink can be
any collection of surfaces.
Select the two faces of the Conductor_sink object as shown below

Right mouse click and from the context menu select Assign Excitation > Sink

Assign Mesh Operations
Select all the objects, right mouse click and select Assign Mesh Operations >
Inside Selection > Length Based
Unselect the radio button Restrict length of elements
Select the radio button Restrict the number of elements
Enter 10,000 for the maximum number of elements
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Create Analysis Setup
Select the menu item Maxwell > Analysis Setup > Add Solution Setup.
Leave the default parameters

Solve the Problem
Select Setup1 from under Analysis in the project tree, right mouse click and
select Analyze

Plot the Current
Select all the objects, right mouse click and select Fields > J_Vector.
J_Vector The
3D plot of the current vectors appears. It is possible to change the
parameters of the plots:
On the Scale tab, check the radio button Use Limits and enter 0 and
90000000 as Min and Max
On the Marker/Arrow, uncheck the Map size radio button, then
adjust the Size of the arrows
You should get a similar plot.
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Torque calculation in Magnetostatic Solver
This exercise will discuss how to set up a torque calculation in the Magnetostatic
Solver.

Problem Description
As shown in the following graph, the current in the coil generates a magnetic
field pointing upward. The permanent magnet in the middle is magnetized along
X-axis, hence there is a torque generated along Z-axis.

Magnetic Field Generated by Coil

Coil
Current
N

Permanent Magnet

S
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Draw the Coil
Open up Maxwell 3D V11
Click on the menu item Project > Insert Maxwell Design
Click on the menu item Maxwell > Solution Type > Magnetostatic
Click on the menu item Draw > Regular Polygon
X,Y, Z: 0,5,0, Enter
DX, DY, DZ: 0.5,0,0, Enter
Number of Segments: 12
Change its name from Polygon1 to Coil
Select the Coil and click on the menu item Draw > Sweep > Around Axis
Change its material to: copper
Change its color and transparency if desired

Draw the Permanent Magnet
Click on the menu item Draw > Box
X, Y, Z: -3,3,-0.5,0.5,-0.5, Enter
DX, DY, DZ: 6,1,1, Enter
Change its name to: Magnet
Change its material to: NdFe35
Change its color and transparency if desired
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Make sure the magnetization of the magnet is assigned along X-axis

Create Section
Select Coil and then click on the menu item 3D Modeler > Surface > Section:
Section Plane: XY
Two sheets are create and to separate them click on 3D Modeler > Boolean
> Separate Bodies
Select Section1_1 and click on the menu item Edit > Delete
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Select Section1 and change its color if necessary
Click on File > Save:
Save
Magnetostatic_Force.mxwl for Basic Exercise Magnetostatic Force
calculation
Click on the menu item Draw > Region:
Region
Padding Percentage: 100
Select Region and click on the menu item View > Hide Selection > All views.

Assign Excitation
Select the Section1 and click on the menu item Maxwell > Excitations >
Assign > Current:
Name: Current1
Value: 100
Type:: Stranded

Assign Torque Calculation
Select the object Magnet and right click on the project tree item Parameters
> Assign > Torque:
Name: Torque1
Type: Virtual
Axis: Global::Z,
Global::Z, Positive
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Rotate the Coil
Select object Coil and sheet Section1,
Section1 right click, then Edit > Arrange >
Rotate

Create Analysis Setup
Click on Maxwell > Analysis Setup > Add Solution Setup
Maximum Number of Passes: 15
Refinement per Pass: 30
Click on OK

Solve the Problem
Select Setup1 from under Analysis in the project tree, right mouse click and
select Analyze
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View Calculated Torque Result
Click on menu item Maxwell > Results > Solution Data.
Data
Click on Solution tab, you will see the calculated torque, it is updated
automatically after each pass.

This concludes the Basic Exercise for Magnetostatic Torque
Calculation.
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Parametric study using a coil and iron slug.
A Magnetostatic problem will be used to demonstrate the setup of a
parametric solution using Optimetrics. The coil current and the dimensional
length of an iron slug will be varied and the force on the slug will be
observed.

Click on the menu item Project > Insert Maxwell Design
Click on the menu item Maxwell > Solution Type > Magnetostatic

Draw the Coil
The user will draw two concentric cylinders and perform a “Boolean subtract”
to create the coil.
Draw the first cylinder. Click on the menu item Draw > Regular Polyhedron
Arbitrarily select a center of base (origin), a radius, and a height using
the mouse. Then, assign a number of segments. When finished, the
Properties window will appear.
Edit the values as shown in the panel below to create the first cylinder.
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The user will create a second cylinder using copy and paste.
Select the first cylinder, “RegularPolyhedron1” from the Design Tree.

Copy and Paste the Polyhedron by using the Edit > Copy and Edit > Paste.
In the Design Tree, double click on “RegularPolyhedron2” and edit the
values given in the Properties window below.

The user will finish the creation of the coil by performing a Boolean subtract of
the two polyhedron.
Select the both polyhedrons from the Design Tree by holding the Ctrl key
and clicking on both objects.

Perform the Boolean subtract.
3D Modeler > Boolean > Subtract
Blank Park: Polyhedron1
Tool Park: Polyhedron2
Select the polyhedron object in the Design Tree and double click it to edit it’s
properties.
Name: Coil
Material: Select copper from the material database.
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Draw the iron Slug.
The user will draw the iron slug using a Box.
Click on the Menu item: Draw > Box
Arbitrarily select a Box position (origin), the opposite corner of the base
rectangle, and a height using the mouse. When finished, the Properties
window will appear.
Edit the values as shown in the Property window below to create the box.
Note that SlugHeight is entered as a variable for the ZSize of the box.
When prompted, define the value of SlugHeight as “1mm.”

Note: By defining a variable name (SlugHeight) it becomes a design
variable. The design variables are accessible in the Property window by
clicking on the design name in the Project Manager. Or, by clicking:
Maxwell > Design Properties . . .
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Double click on the newly created Box1 to bring up the property window.

Edit the name of the Slug and assign the Material as iron.
Name: Slug
Material: Select iron from the material database.
Note: The material properties for iron has a linear permeability. This means that
no non-linear BH curve is being used in this example.

Create a Problem Region
Create a problem region that surrounds the coil and slug.
3D Modeler > Region
Assign a padding percentage as 200, as shown below and select OK.
OK
The user may edit the padding percentages in the Properties window as desired.
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Assign the Excitation.
Select the Coil from the Design Tree.

Section the coil to create a sheet cross section.
3D Modeler > Surface > Section.
Section
Select the YZ radial button.
button
Separate the section into two objects.
3D Modeler > Boolean > Separate Bodies
Delete the unnecessary section, “Section1_1” by selecting it in the Design Tree
and pressing the Delete key.
Select Section1 and assign an excitation in the project manager window.

Click on the Menu item Maxwell > Excitations > Assign > Current
Assign a variable called AmpTurns as shown below.
Select a Stranded Winding.
Winding

Define the value of AmpTurns as 100 in the Add Variable window.
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Assign a Force Parameter Calculation
Select the Slug from the Design Tree.
Assign a force in the project manager window.
Click on the Menu item Maxwell > Parameters > Assign > Force.
Select the Virtual Force as shown below.

Create and solve a nominal problem
Click on the Menu item Maxwell > Analysis > Add Solution Setup . . .
Change the default Minimum Number of Passes to 5 to speed up the solution.
Select Force1 to be displayed in the Convergence, as shown below. Click OK.
OK
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Run the nominal solution.
In the Project Manager window, right click on Setup1 and select Analyze.
During or after the solution is complete, inspect the Convergence and
Force results by viewing the appropriate Tab in the Solution window.
In the Project Manager Window, right click on Setup1 and select
Convergence.
Your results should look similar to those shown below.

Plot a field result.
Select the Global: YZ plane from in the Design Tree under Planes.

Plot the B-Field on this plane.
Click on the Menu item Maxwell > Fields > Fields > B > Mag_B.
Mag_B
Click Done in the next window.
To view the fields inside the slug, expand Field Overlays in the
Project Manager and click on Mag_B1.
Mag_B1
Your result should show about 0.2 Tesla in the Center of the Slug
which is well within the linear region of the BH curve for most steels.
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Create a Parametric solution
Click on the Menu item Maxwell > Optimetrics > Add Parametric . . .
Click Add. . . in the Setup Sweep Analysis window to define the parameters to be
swept in the analysis.
Select the SlugHeight variable for definition, and assign Start =1, Stop =2, and
Step = 0.2,
0.2 and click the Add >> button.
Similarly, select the AmpTuns variable for definition and assign a Start =100,
Stop =200, and Step = 50, and click the Add >> button.
Click OK..
OK

Cick on the Table tab to inspect the combination of solutions that have been
created. There should be 18 solutions since we defined 6 variations of
SlugHeight and 3 variations of AmpTurns.
Next, select the Calculations tab to define which outputs will be calculated for
each parametric solution.
Click the Add button to add a calculation.
Click Edit Calculation . . . to select the output calculation.
Select : Category: Force,
Force
Quantity: Force_magnitude
Insert Quantity Into Expression
Name: type
MagForceSlug
t
click Add
The Edit Calculation window should appear as follows:
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Click Done
The Calculation MagForceSlug should appear in in the Calculation tab
In the Options Tab, click both boxes for Save Fields And Mesh,
Mesh and Copy
Geometrically Equivalent Meshes.
Meshes
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Solve the Parametric problem
In the Project Manager window, under Optimetrics,
Optimetrics, right click on
ParametricSetup1, and select Analyze.

Note: the solving criteria is taken from the nominal problem, Setup1 . Each
parametric solution will re-mesh if the geometry has changed or the energy
error criteria is not met as defined in Setup1.
Setup1
View the solution progress:
In the Project Manager window, right click on ParametricSetup1, and select
View Analysis Result . . .
Click the Table button to view all the results in tablature form.
The full parametric solution should take about 5 minutes depending on the
speed of the machine.
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Graph the Force vs. AmpTurns vs. SlugHeight
Right Click on Results in the Project Manager, and select Create Report.
Choose the Report Type and Display Type as shown below.
Click OK.

Define the values to be plotted on the y-axis. Select the Y tab,
Select Output Variables in the Category window.
Select MagForceSlug in the Quantity Window.
Click Add Trace.
Trace
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Click on the Sweeps tab.
Select the first trace in the top of the window by clicking on “1”..
Check the Sweep Design and Project variable value button.
Click on Apply to All Selected Traces.
Traces
Click Done.
Done

The graph should appear as shown below.
The graph may be edited by double clicking on the legend, axis, or trace.
Right click on the table and select Export to File to save the data as a text file
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Create a Table of SlugHeight, Force, and AmpTurns
Right Click on Results in the Project Manager, and select Create
Report.
Choose the Report Type and Display Type as shown below.
Click OK.
OK

Define the values to be listed in the Table. Select the Y tab,
Select OutputVariables in the Category window
Select MagForceSlug in the Quantity window.
Click on Add Trace
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Click on the Sweeps tab.
Select the first trace in the top of the window by clicking on “1”..
Check the Sweep Design and Project variable value button.
Click on Apply to All Selected Traces.
Traces
Click Done.
Done

The table should appear as shown below.
Right click on the table and select Transpose to transpose the table matrix, or
right click on the table and select Export to File to save the data as a text file.
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Inductor using transient source
This exercise will discuss how to use transient sources as the excitation for
an inductor coil.

Draw the Inductor
Click on the menu item Project > Insert Maxwell Design
Click on the menu item Maxwell > Solution Type > Transient
Click on the menu item Draw > Regular Polyhedron
Center: 0,0,0
Start Position: 2.0, 2.0, 0
Height: 20.0
Number of Segments: 24
Change its name to: Core
Change its material to: ferrite
Change its color if desired
Select the Core and click on the menu item Edit > Copy
Click on the menu item Edit > Paste, the new objects name is Core1
In the object tree click on Core1 and then click on CreateRegularPolyhedron

In the Properties window change the following:
Name: Coil
Material: Copper
Start Position: 3.0, 3.0, 0
Change its color
Select Core and Coil and the click on 3D Modeler > Boolean > Subtract:
Blank Part: Coil
Tool Part: Core
Clone objects before subtracting:  checked
Select the Coil and then click on the menu item 3D Modeler > Surface >
Section:
Section Plane: YZ
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Two sheets are create and to separate them click on 3D Modeler > Boolean
> Separate Bodies
Select Section1_1 and click on the menu item Edit > Delete
Select Section1 and in the properties window change the following:
Name: Terminal
Change its color
Click on the menu item Draw > Region:
Region
Padding Percentage: 500
Change the name of the design to:
BE_Trans.mxwl for Basic Exercise Transient

Assign Excitation
Select the Terminal and click on the menu item Maxwell > Excitations >
Assign > Coil Terminal:
Name: Coil_Terminal
Number of Conductors: 150
Click on the menu item Maxwell > Excitations > Add Winding
Name: Winding_A
Type: Voltage
Stranded:  Checked
Initial Current: 0.0 amps
Resistance:: 25 ohm
Inductance: 0 H
Voltage: 0 V ... This will be changed later
Select Winding_A from the project tree under Excitation and right mouse
click and select Add Terminals:
Terminals
Select: Coil_Terminal
The project tree should look like this:
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Create the Excitation
The excitation for this problem will be a voltage source with a 1KHz triangular
wave superimposed on a 50 Hz sine wave that has a 50 volt DC offset.
Click on the menu item Maxwell > Design Datasets and then Add a new dataset
Name: DSet_A
Coordinates:
X1 = 0
Y1 = 0
X2 = 250e-6
Y2 = 1
X3 = 750e-6
Y3 = -1
X4 = 1e-3
Y4 = 0
Select Winding_A from the Project Tree and right mouse click and select
Properties and type in the following:
Voltage: 50 + 25*sin(2*PI*50*Time) + 5*pwl_periodic(DSet_A, Time)
The first term is a 50 V DC offset
The second term is a 25 Vp-p, 50 Hz sine wave
The third term is a 5 Vp-p, 1 KHz triangular wave

Apply Mesh Operations
The transient solver does not use the automatic adaptive meshing process, so a
manual mesh needs to be created
Select the Core and click on the menu item Maxwell > Mesh Operations > Assign
> On Selection > Length Based.
Based
Restrict Length Of Elements: Uncheck
Restrict Number of Elements:  Check
Maximum Number of Elements: 1000
Select the Coil and click on the menu item Maxwell > Mesh Operations > Assign
> On Selection > Length Based.
Based
Restrict Length Of Elements: Uncheck
Restrict Number of Elements:  Check
Maximum Number of Elements: 1000

Create Analysis Setup
Click on Maxwell > Analysis Setup > Add Solution Setup
Stop Time: 20 ms
Time Step: 50 us
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Solve the Problem
Select Setup1 from under Analysis in the project tree, right mouse click and
select Analyze

Save the Design
Click on File > Save to save the design and results

Plot the Voltage and Current
Click on Maxwell > Results > Create Quick Report and select Input Voltage.
Voltage
Click on Maxwell > Results > Create Quick Report and select Current

This concludes the Basic Example for Transient Sources
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Inductor using transient source with external circuits
This exercise will discuss how to link a transient source generated by an
external circuit to an inductor coil.

Draw the Inductor
Click on the menu item Project > Insert Maxwell Design
Click on the menu item Maxwell > Solution Type > Transient
Click on the menu item Draw > Regular Polyhedron
Center: 0,0,0
Start Position: 2.0, 2.0, 0
Height: 20.0
Number of Segments: 24
Change its name to: Core
Change its material to: ferrite
Change its color if desired
Select the Core and click on the menu item Edit > Copy
Click on the menu item Edit > Paste, the new objects name is Core1
In the object tree click on Core1 and then click on CreateRegularPolyhedron

In the Properties window change the following:
Name: Coil
Material: Copper
Start Position: 3.0, 3.0, 0
Change its color
Select Core and Coil and the click on 3D Modeler > Boolean > Subtract:
Blank Part: Coil
Tool Part: Core
Clone objects before subtracting:  checked
Select the Coil and then click on the menu item 3D Modeler > Surface >
Section:
Section Plane: YZ
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Two sheets are create and to separate them click on 3D Modeler > Boolean
> Separate Bodies
Select Section1_1 and click on the menu item Edit > Delete
Select Section1 and in the properties window change the following:
Name: Terminal
Change its color
Click on the menu item Draw > Region:
Region
Padding Percentage: 500
Change the name of the design to:
BE_Trans_Ckt.mxwl for Basic Exercise Transient with Circuits

Assign Excitation
Select the Terminal and click on the menu item Maxwell > Excitations >
Assign > Coil Terminal:
Name: Coil_Terminal
Number of Conductors: 150
Click on the menu item Maxwell > Excitations > Add Winding
Name: Winding_A
Type: External
Stranded:  Checked
Initial Current: 0.0 amps
Select Winding_A from the project tree under Excitation and right mouse
click and select Add Terminals:
Terminals
Select: Coil_Terminal
The project tree should look like this:
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Create an External Circuit
To access Maxwell Circuit Editor, click the Microsoft Start button, select
Programs > Ansoft > Maxwell 11> Maxwell Circuit Editor
Select the Components tab and choose Maxwell Circuit Elements >
Dedicated Elements > Winding and drag this component onto the sheet

In the properties window change the following:
Name: Winding_A
Note:
Note This name has to be exactly the same name as using the Winding
definition described in the previous section “Assign Excitation”
Excitation”
Select Sources > VSin drag this component onto the sheet:
VA: 100 volts
VFreq: 60 Hz
Select Source > VSin drag this component onto the sheet:
VA: 10 volts
VFreq: 1000 Hz
Select Passive Elements > Res and drag this component onto the sheet:
R: 25 ohms
Connect all of the elements together with wires and add a ground
Select Probes > Voltmeter and place it between the two voltage sources and
ground
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The circuit should look like this:

Click on Maxwell Circuit > Export Netlist:
Netlist
File Name: Inductor_Circuit.sph
Click on Edit > Save As:
As
BE_Circuit.amcp for Basic Exercise Circuit

Link the circuit file to the Maxwell project
In the Maxwell BE_Trans_Ckt.mxwl project click on the menu item Maxwell >
Circuit.
Excitations > External Circuits > Edit External Circuit
Import Circuit: Inductor_Circuit.sph
The Edit External Circuit Panel should look like this:
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Apply Mesh Operations
The transient solver does not use the automatic adaptive meshing process,
so a manual mesh needs to be created
Select the Core and click on the menu item Maxwell > Mesh Operations >
Assign > On Selection > Length Based.
Based
Restrict Length Of Elements: Uncheck
Restrict Number of Elements:  Check
Maximum Number of Elements: 1000
Select the Coil and click on the menu item Maxwell > Mesh Operations >
Assign > On Selection > Length Based.
Based
Restrict Length Of Elements: Uncheck
Restrict Number of Elements:  Check
Maximum Number of Elements: 1000

Create Analysis Setup
Click on Maxwell > Analysis Setup > Add Solution Setup
Stop Time: 20 ms
Time Step: 50 us
Click on OK

Solve the Problem
Select Setup1 from under Analysis in the project tree, right mouse click and
select Analyze

Save the Design
Click on File > Save to save the design and results
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Plot the Voltage and Current
Click on Maxwell > Results > Create Quick Report and select Node Voltage.
Voltage
Click on Maxwell > Results > Create Quick Report and select Current

This concludes the Basic Example for Transient Sources
Using External Circuits
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Maxwell is a high-performance interactive software
package that uses finite element analysis (FEA) to solve
three-dimensional (3D) electric, magnetostatic, eddy
current, and transient problems.
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Maxwell solves the electromagnetic field problems by solving Maxwell's
equations in a finite region of space with appropriate boundary conditions and
— when necessary — with user-specified initial conditions in order to obtain a
solution with guaranteed uniqueness.

Electric 3D fields:
Electrostatic 3D fields in dielectrics
Electric 3D fields in conductors
A combination of the first two with conduction solutions being used as
boundary conditions for an electrostatic problem.

Magnetostatic 3D fields
Eddy current 3D fields
Transient 3D fields
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FEM and adaptive meshing
In order to obtain the set of
algebraic equations to be solved,
the geometry of the problem is
discretized automatically into
tetrahedral elements.
All the model solids are meshed
automatically by the mesher.
The assembly of all tetrahedra is
referred to as the finite element
mesh of the model or simply the
mesh.

Ansoft Maxwell 3D Field Simulator v11 – Training Seminar

Start
Field Solution

Generate
Initial Mesh

Compute
Fields

Perform
Error Analysis

Has
Stopping
Criteria been
met?

Refine
Mesh

No

Yes

Stop
Field Solution

P1-3

Presentation

Overview

1

GUI - Desktop
The complex functionality
built into the Maxwell 3D
solvers is accessed through
the main user interface
(called the desktop).
Problem can be setup in a
fairly arbitrary order (rather
than following the steps in a
precise order as was
required
in
previous
versions of Maxwell).
A new “validation check”
has been added to insure
that all required steps are
completed
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ACIS solid modeling kernel
The underlying solid modeling technology used by Ansoft products is
provided by ACIS geometric modeler. ACIS version 14 is presently
used.
Users can create directly models using primitives and operations on
primitives.
In addition, users can import models saved in a variety of formats (sm2
.gds .sm3 .sat .step .iges .dwg .sld .geo .stl)
When users import models into Ansoft products, translators are
invoked that convert the models to an ACIS native format (sat format).
Exports directly .sat, .dxf, .sm3, .sm2, .step, .iges
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Supported platforms

Windows (2000 Professional, XP Professional, XP
Professional x64 Edition, Server 2003)
Windows Sun Solaris
Red Hat Enterprise Linux v3
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System requirements (Windows)
32-Bit System Requirements
Minimum System Requirements:
Pentium-based processor: 500 MHz
Hard Drive Space (for Maxwell software): 200 MB
RAM: 512 MB
Recommended Minimum Configuration (for Optimal
Performance):
Pentium-based processor: 2 GHz
Hard Drive Space (for Maxwell software and temporary files): 500
MB
RAM: 2 GB
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Maxwell 3D
3D field solver
Solves for the fields in an arbitrary volume
Core (Steel_1008)

Coil (120 Conductors, Copper)
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Starting Maxwell
Click the Microsoft Start button, select Programs,
Programs and select the Ansoft >

Maxwell 11 > Maxwell 11
Or Double click on the Maxwell 11 icon on the Windows Desktop

Adding a Design
When you first start Maxwell a new project will be automatically added to
the Project Tree.
To insert a Maxwell Design to the project, select the menu item Project >

Insert Maxwell Design

Toolbar:
Insert Maxwell Design

Insert RMxprt Design
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Ansoft Desktop
Menu
bar
Toolbars

3D Modeler
Window
Project
Manager
with project
tree

Progress
Window
Message
Manager

Status
bar
Coordinate Entry Fields
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Ansoft Desktop – Project Manager
Multiple Designs per Project
Multiple Projects per Desktop
Integrated Optimetrics Setup (requires license for analysis)
Project Manager Window

Project
Design

Design Setup

Design Automation
•Parametric
•Optimization
•Sensitivity
•Statistical
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Ansoft Desktop – 3D Modeler
3D Modeler Window

Graphics
area

Model

Edge

Vertex
3D Modeler
design tree
(history)

Coordinate System (CS)
Plane
Context menu
(right mouse
click on 3D
modeler
window)

Origin

Face
Model
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Set Solution Type
To set the solution type:
1. Select the menu item Maxwell > Solution Type
2. Solution Type Window:
1. Choose Magnetostatic
2. Click the OK button
To edit notes: Maxwell > Edit Notes

Maxwell - Solution Types
Magnetostatic
Static magnetic fields, forces, torques, and inductances caused by DC currents, static
external magnetic fields, and permanent magnets. Linear or nonlinear materials.
Eddy Current
Sinusoidally-varying magnetic fields, forces, torques, and impedances caused by AC currents
and oscillating external magnetic fields. Linear materials only. Full wave solver considers
displacement currents. Induced fields such as skin and proximity effects considered.
Transient
Transient magnetic fields caused by time-varying or moving electrical sources and permanent
magnets. Linear or nonlinear materials. Induced fields such as skin and proximity effects
considered. Sources can be DC, sinusoidal, or transient voltages or currents. Can use
external schematic circuit.
Electrostatic
Static electric fields, forces, torques, and capacitances caused by voltage distributions and
charges. Linear materials only.
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Set Model Units
To set the units:
1. Select the menu item 3D Modeler > Units
2. Set Model Units:
1. Select Units: mm
2. Click the OK button

Set Default Material
To set the default material:
1. Using the 3D Modeler Materials toolbar, choose Select
2. Select Definition Window:
1. Type steel_1008 in the Search by Name field
2. Click the OK button
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3D Modeler – Create a Primitive
Point 1

Point 1
Grid Plane

Note: Point 1 and Point 2
are drawn in the grid
plane, while Point 3 is
drawn in the 3rd direction

Point 3

Base Rectangle

Point 2
Point 2

Coordinate Entry Fields

Point 3
The Coordinate Entry fields allow equations to be entered for position values.
Examples: 2*5, 2+6+8, 2*cos(10*(pi/180)).
Variables are not allowed in the Coordinate Entry Field
Note:
Note Trig functions are in radians
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3D Modeler – Object Properties
Commands
(dimensions
and history)

In History Tree:
Attributes
Commands

Attributes
(properties
of the object)
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3D Modeler – Attributes

Solve Inside – if unchecked
meshes but no solution inside
(like the old exclude feature in
material manager)
Model – if unchecked, the object is
totally ignored outside of modeler with
no mesh and no solution
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Set Grid Plane
To set the Grid Plane:
Select the menu item 3D Modeler > Grid Plane > XY

Create Core
To create the coax pin:
1. Select the menu item Draw > Cylinder
2. Using the coordinate entry fields, enter the center position
X:: 0.0,
0.0 Y:: 0.0,
0.0 Z:: -3.0, Press the Enter key
4.

Using the coordinate entry fields, enter the radius of the cylinder
dX:: 0.0,
0.0 dY:: 2.0,
2.0 dZ:: 0.0
0 0, Press the Enter key

5.

Using the coordinate entry fields, enter the height of the cylinder
dX:: 0.0,
0.0 dY:: 0.0 dZ:: 10.0,
10.0 Press the Enter key

Continued on Next Page
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Create Core (Continued)
To Parameterize the Height
1. Select the Command tab from the Properties window
2. Height: H
3. Press the Tab key
4. Add Variable Window
1. Value: 10mm
2. Click the OK button
To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Core
To set the material:
1. Select the Attribute tab from the Properties window
2. Click on the button in Material value: set to steel_1008
To set the color:
1. Select the Attribute tab from the Properties window.
2. Click the Edit button
To set the transparency:
1. Select the Attribute tab from the Properties window.
2. Click the OK button
To finish editing the object properties
1. Click the OK button
To fit the view:
1. Select the menu item View > Fit All > Active View
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3D Modeler - Views
View > Modify Attributes >
Orientation – Predefined/Custom View Angles
Lighting – Control angle, intensity, and color of light
Projection – Control camera and perspective
Background Color – Control color of 3D Modeler background
View > Active View Visibility - Controls the display of: 3D Modeler
Objects, Color Keys, Boundaries, Excitations, Field Plots

View > Options – Stereo Mode, Drag Optimization, Color Key Defaults,
Default Rotation

View > Render > Wire Frame or Smooth Shaded (Default)
View > Coordinate System > Hide or Small (Large)
View > Grid Setting – Controls the grid display
Toolbar: Toggle Grid Visibility
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Changing the View
Toolbar
Rotate Around
Current Axis

Zoom In/Out

Fit Selected

Predefined View Angles

Pan

Top
Fit All
Rotate Around
Rotate Around Screen Center
Model Center

Dynamic Zoom

Context Menu

Right

Left

Bottom

Shortcuts
Since changing the view is a frequently used operation, some useful shortcut keys exist. Press the
appropriate keys and drag the mouse with the left button pressed:
ALT + Drag – Rotate
In addition, there are 9 pre-defined view angles that can be selected by holding the ALT key and
double clicking on the locations shown on the next page.
Shift + Drag - Pan
ALT + Shift + Drag – Dynamic Zoom
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Set Default Material
To set the default material:
1. Using the 3D Modeler Materials toolbar, choose Select
2. Select Definition Window:
1. Type copper in the Search by Name field
2. Click the OK button

Create Coil
To create the coil for the current to flow:
1. Select the menu item Draw > Cylinder
2. Using the coordinate entry fields, enter the center position
X:: 0.0,
0.0 Y:: 0.0,
0.0 Z:: 0.0, Press the Enter key
4. Using the coordinate entry fields, enter the radius of the cylinder
dX:: 0.0,
0.0 dY:: 4.0,
4.0 dZ:: 0.0
0 0, Press the Enter key
5. Using the coordinate entry fields, enter the height of the cylinder
dX:: 0.0,
0.0 dY:: 0.0 dZ:: 4.0,
4.0 Press the Enter key
To set the name:
1. Select the Attribute tab from the Properties window.
2. For the Value of Name type: Coil
3. Click the OK button
To fit the view:
1. Select the menu item View > Fit All > Active View
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Overlapping Objects
About Overlapping Objects
When the volume of a 3D object occupies the same space as two or more objects you will receive an overlap
error during the validation process. This occurs because the solver can not determine which material
properties to apply in the area of overlap. To correct this problem, Boolean operations can be used to
subtract one object from the other or the overlapping object can be split into smaller pieces that are
completely enclosed within the volume of another object. When an object is completely enclosed there will
be no overlap errors. In this case, the material of the interior object is used in the area of overlap.

Complete the Coil
To select the objects Core and Coil:
1. Select the menu item Edit > Select All
To complete the Coil:
1. Select the menu item 3D Modeler > Boolean > Subtract
2. Subtract Window
Blank Parts: Coil
Tool Parts: Core
Clone tool objects before subtract:  Checked
Click the OK button
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Create Excitation
Object Selection
1. Select the menu item Edit > Select > By Name
2. Select Object Dialog,
1. Select the objects named: Coil
2. Click the OK button
Section Object
1. Select the menu item 3D Modeler > Surface > Section
1. Section Plane: YZ
2. Click the OK button
Separate Bodies
1. Select the menu item 3D Modeler > Boolean > Separate Bodies
2. Delete the extra sheet which is not needed
Assign Excitation
1. Select the menu item Maxwell > Excitations > Assign > Current
2. Current Excitation : General
1. Name: Current1
2. Value: 120 A
3. Type: Stranded
3. Click the OK button
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Show Conduction Path
Show Conduction Path
1. Select the menu item Maxwell > Excitations > Conduction Path > Show Conduction Path
2. From the Conduction Path Visualization dialog, select the row1 to visualize the conduction path in on the 3D
Model.
3. Click the Close button

Fix Conduction Path
To solve this isolation problem an insulating boundary condition will be used.
1.

2.
3.

4.

Select the outer face of the core by typing f on the keyboard and
select the outer face of the core.
Select the menu item Maxwell > Boundaries > Assign > Insulating
Insulating Boundary
1. Name: Insulating1
2. Click the OK button
Follow the instructions from above to redisplay the Conduction Path
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Define a Region
Before solving a project a region has to be defined. A region is basically an outermost object that contains all other
objects. The region can be defined by a special object in Draw
Draw-->Region. This special region object will be resized
automatically if your model changes size.
A ratio in percents has to be entered that specifies how much distance should be left from the model.
To define a Region:
1. Select the menu item Draw > Region
1. Padding Data: One
2. Padding Percentage: 200
3. Click the OK button

Note: Since there will be considerable fringing
in this device, a padding percentage of at least
2 times, or 200% is recommended
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Maxwell - Solution Setup
Creating an Analysis Setup

Add Solution Setup

To create an analysis setup:
1. Select the menu item Maxwell > Analysis Setup > Add Solution Setup
2. Solution Setup Window:
1. Click the General tab::
Maximum Number of Passes:: 10
Percent Error:: 1
2. Click the OK button
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Save Project
To save the project:
1. In an Ansoft Maxwell window, select the menu item File > Save As.
2. From the Save As window, type the Filename: maxwell_coil
3. Click the Save button

Analyze
Model Validation
To validate the model:
1. Select the menu item Maxwell> Validation Check
2. Click the Close button
Note: To view any errors or warning messages, use the Message Manager.

Analyze
To start the solution process:
1. Select the menu item Maxwell > Analyze All

Validate
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View detailed information about the progress
In the Project Tree click on AnalysisAnalysis->Setup1 with the right mouse button und select Profile
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Field Overlays
To create a field plot:
1. Select the Global XZ Plane
1. Using the Model Tree, expand Planes
2. Select Global:XZ
2. Select the menu item Maxwell > Fields > Fields > B > Mag_B
3. Create Field Plot Window
1. Solution: Setup1 : LastAdaptive
2. Quantity: Mag_B
3. In Volume: All
4. Click the Done button
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Field Overlays
scale:
ale:
To create a second field plot of same quantity, but different sc
1. Select the Global XZ Plane
1. Using the Model Tree, expand Planes
2. Select Global:XZ
2. Select the menu item Maxwell > Fields > Fields > B > Mag_B
3. Create Field Plot Window
1. Specify Folder: B1
2. Solution: Setup1 : LastAdaptive
3. Quantity: Mag_B
4. In Volume: All
5. Click the Done button
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To modify a Magnitude field plot:
1. Select the menu item Maxwell > Fields > Modify Plot Attributes
2. Select Plot Folder Window:
1. Select: B
2. Click the OK button
3. B-Field Window:
1. Click the Scale tab
1. Scale: Log
2. Click the Close button
4. Hide the plots by clicking in the project tree and unchecking Plot Visibility

Mesh Overlay
To select the objects Core and Coil:
1. Select the menu item Edit > Select > By Name
2. Press and hold the CTRL key and select Core and Coil from the list
3. Click the OK button
To create a mesh plot:
1. Select the menu item Maxwell > Fields > Plot Mesh
2. Create Mesh Window::
1. Click the Done button
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Plot the zz-component of B Field along the line
1.
2.
3.

Create a line
Calculate the z-component of B using the Calculator tool
Create report – plot the desired graph
To create a line
1. Select the menu item Draw > Line. The following window opens:

2.
3.
4.

5.

Answer YES to create a non model object and not to destroy the solution.
Place the cursor at the top face of the core and let the cursor snap to the center.
Click the left mouse button and hold the z button on the keyboard while moving the cursor up. Left click at
some distance from the core and double click left to end the line.
Leave the values in the upcoming dialog box and close the dialog by pressing OK.
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To bring up the Calculator tool
1. Select the menu item Maxwell
Maxwell-->Fields
>Fields-->Calculator
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To calculate the zz-component of B field
1. In the Input Column select the Quantity B
2. In the Vector Column select the ScalarZ
component
3. In the General Column select Smooth
4. Press the Add button in the upper
part of the calculator and enter a name that
describes the calculation
- enter Bz for B field in z-direction
5. Click Done to close the calculator
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To create report (plot the desired graph)
1. Select the menu item Maxwell
Maxwell-->Result
>Result-->Create Report
2. Enter Fields and Rectangular Plot and click the OK button
3. Select the following: Geometry – Polyline1; Category – Calculator Expressions; Quantity – Bz
4. Press the Add Trace to copy your selection to the upper part of the window and click on the Done button
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To save drawing Window or a plot to clipboard
1. Select the menu item Edit
Edit-->Copy to Clipboard as Image
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File Structure
Everything regarding the project is stored in an ascii file
File: <project_name>.mxwl
<project_name>.mxwl
Double click from Windows Explorer will open and
launch Maxwell v11
Results and Mesh are stored in a folder named
<project_name>.mxwlresults
<project_name>.mxwlresults
Lock file: <project_name>.lock.mxwl
<project_name>.lock.mxwl
Created when a project is opened
Auto Save File: <project_name>.mxwl.auto
<project_name>.mxwl.auto
When recovering, software only checks date
If an error occurred when saving the auto file, the
date will be newer then the original
Look at file size (provided in recover dialog)
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Scripts
Default Script recorded in v11
Visual Basic Script

Remote Solve (Windows Only)
Tools > Options > General Options > Analysis Options
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The Process
Design

Solution Type
2. Boundaries

1. Parametric Model
Geometry/Materials
2. Excitations
3 Mesh
Operations

2. Analysis Setup
Solution Setup
Frequency Sweep

Mesh
Refinement

Analyze

Solve

4. Results
2D Reports
Fields

NO

Converged

2. Solve Loop
YES
Update
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Note:
 Edit Copy/Paste is a dumb copy for only dimensions and
materials, but not the history
 Edit > Duplicate clones objects include dimensions,
materials and the creation history with all variables

Draw – Primitives
3D Modeler – Settings and Boolean Operations
Edit – Copy/Paste, Arrange, Duplicate
Maxwell – Boundaries, Excitations, Mesh Operations, Analysis Setup, Results
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3D Modeler – Model Tree
Select menu item 3D Modeler > Group by Material

Material

Object

Object Command History

Grouped by Material
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3D Modeler – Commands
Parametric Technology
Dynamic Edits - Change Dimensions
Add Variables
Project Variables (Global) or Design Variables (Local)
Animate Geometry
Include Units – Default Unit is meters
Supports mixed Units
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3D Modeler – Primitives
2D Draw Objects
The following 2D Draw objects are available:
Line, Spline, Arc, Equation Based Curve,
Rectangle, Ellipse, Circle, Regular
Polygon,
Equation Based Surface
3D Draw Objects
The following 3D Draw objects are available:
Box, Cylinder, Regular Polyhedron
Cone, Sphere, Torus, Helix, Spiral, Bond
Wire
True Surfaces
Circles, Cylinders, Spheres, etc are represented
as true surfaces. In versions prior to release 11
these primitives would be represented as faceted
objects. If you wish to use the faceted primitives,
select the Regular Polyhedron or Regular
Polygon.

Toolbar: 2D Objects

Toolbar: 3D Objects
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3D Modeler – Boolean Operations/Transformations
3D Modeler > Boolean >
Unite – combine multiple primitives
Unite disjoint objects (Separate
Separate Bodies to separate)
Subtract – remove part of a primitive from another
Intersect–
Intersect keep only the parts of primitives that overlap
Split – break primitives into multiple parts along a plane (XY, YZ, XZ)
Split Crossing Objects – splits objects along a plane (XY, YZ, XZ) only where they intersect
Separate Bodies – separates objects which are united but not physically connected into individual
objects
Toolbar: Boolean

3D Modeler > Surfaces > Move Faces – Resize or Reposition an objects face along a normal or vector.
Edit > Arrange >
Move – Translates the structure along a vector
Rotate – Rotates the shape around a coordinate axis by an angle
Mirror – Mirrors the shape around a specified plane
Offset – Performs a uniform scale in x, y, and z.
Toolbar: Arrange

Edit > Duplicate >
Along Line – Create multiple copies of an object along a vector
Around Axis – Create multiple copies of an object rotated by a fixed angle around the x, y, or z axis
Mirror - Mirrors the shape around a specified plane and creates a duplicate
Toolbar: Duplicate

Edit > Scale – Allows non-uniform scaling in the x, y, or z direction
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3D Modeler - Selection
Selection Types
Object (Default)
Face
Edge
Vertex

Selection Modes
All Objects
All Visible Object
By Name

Highlight Selection Dynamically – By default, moving the mouse pointer over an object will dynamically
highlight the object for selection. To select the object simply click the left mouse button.
Multiple Object Selection – Hold the CTRL key down to graphically select multiple objects
Next Behind – To select an object located behind another object, select the front object, press the b key to get
the next behind. Note: The mouse pointer must be located such that the next behind object is under the
mouse pointer.
To Disable: Select the menu item Tools > Options > 3D Modeler Options
From the Display Tab,
Tab uncheck Highlight selection dynamically

Selected

Dynamically Highlighted
(Only frame of object)
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3D Modeler – Moving Around

Step 1: Start Point

Step 2: Hold X key (to only allow motion in Xdirection) and select vertex point

Edge Center Snap

Toolbar: Snap Mode

Step 3: CTRL+Enter Keys (sets a temporary
local reference)
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3D Modeler – Coordinate Systems
Can be Parameterized
Working Coordinate System
Currently selected CS. This can be a local or global CS
Global CS
The default fixed coordinate system
Relative CS
User defined local coordinate system.
Offset
Rotated
Toolbar: Coordinate System
Both
Face CS (setting available to automatically switch to face coordinate system in the 3D Modeler Options)

Step 1: Select Face

Step 2: Select Origin

Cone created with Face CS

Step 3: Set X-Axis

New Working CS
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Measure
3D Modeler > Measure >
Position – Points and Distance
Length – Edge Length
Area – Surface Area
Volume – Object Volume

Position Points
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Options – General
Tools > Options > General Options > Project Options
Temp Directory – Location used during solution process
Make sure it is at least 512MB free disk.

Options - Maxwell
Tools > Options > Maxwell Options > Solver
Set Number of Processors = 2 for 1 dual-core processor or
two single-core processors. Requires additional license
Default Process Priority – set the simulation priority from
Critical
(highest) to Idle (lowest)
Desired RAM Limit – determines when solver will use hard
disk off core (leave it unchecked for auto-detect)
Maximum RAM Limit – determines when swapping will
occur with hard drive (leave it unchecked for auto-detect)
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Converting Older Maxwell Projects (pre-Maxwell v11) to Maxwell v11
From Maxwell v10.0,
v10.0
1. Select the menu item File > Open
2. Open dialog
1. Files of Type: Ansoft Legacy EM Projects (.cls
(.cls)
cls)
2. Browse to the existing project and select the .cls file
3. Click the Open button
What is Converted?
Converts Entire Model: Geometry, Materials, Boundaries,
Sources and Setup

Solutions, Optimetrics projects and Macros are not converted
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Break
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Material Setup - Libraries
3-Tier library structure
System (global) level – predefined from Ansoft and ships with new upgrades, users cannot
modify this
User Library – to be shared among several users at a company (can be encrypted)
Personal libraries - to be used only by single user (can be encrypted)
Add a new material: Tools > Edit Configured Libraries > Materials
New Interface for Materials Setting shared with RMxprt
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Click “Add Material …”. The Material is only available in Project
To add a material in the user or personal library: click on “Export Library” and save it in the desire
library.
In the main project window, click on Tools > Configured Libraries. Locate the library to have the
material available for all the projects.
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Materials Setup - Editing
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Material Setup – BH curve
Lamination model to account for stacking factor (modifies permeability, not conductivity)
Robust BH curve entry – can delete points Create the Object
To export BH curve for use in future, right-mouse-click on curve and select Export to File…
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Material Setup - Permanent Magnets:
Create the Object
Create a Face Coordinate System (Face CS)
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Enter the Materials Library and choose the Desire Material
Permanent Magnet Orientation refers by default to the global CS. To change the reference CS for orientation,
open the property window and change the CS reference
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In the Material Window, you can assign orientation
The Orientation can be described in Cartesian, Cylindrical, Spherical
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Material setup - Anisotropic Material Properties
ε1, µ1, and σ1 are tensors in the X direction.
ε2, µ2, and σ2 are tensors in the Y direction.
ε3, µ3, and σ3 are tensors in the Z direction.
Anisotropic permeability definitions can be either LINEAR or NONLINEAR.
NONLINEAR

Electrostatic &
Eddy Current

ε1 0 0 
[ε ] =  0 ε 2 0 ,
 0 0 ε 3 

Ansoft Maxwell 3D Field Simulator v11 – Training Seminar

Magnetostatic,
Eddy Current, &
Transient

 µ1
[µ ] =  0
 0

0

µ2
0

0
0 ,

µ3 

Eddy Current, &
Transient

σ 1 0 0 
[σ ] =  0 σ 2 0 
 0 0 σ 3 
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Electric Boundary Conditions
Boundary Type

E-Field Behavior

Used to model…
model…

Default
Boundary
Conditions
(Natural and
Neumann)

Field behaves as follows:
Natural boundaries — The normal component of D
changes by the amount of surface charge density. No
special conditions are imposed.
Neumann boundaries — E is tangential to the boundary.
Flux cannot cross a Neumann boundary.

Ordinary E-field behavior
on boundaries. Object
interfaces are initially set
to natural boundaries;
outer boundaries are
initially set to Neumann
boundaries.

Symmetry

Field behaves as follows:
Even Symmetry (Flux Tangential) — E is tangential to the
boundary; its normal components are zero.
Odd Symmetry (Flux Normal) — E is normal to the
boundary; its tangential components are zero.

Planes of geometric and
electrical symmetry.

Matching
(Master and
Slave)

The E-field on the slave boundary is forced to match the
magnitude and direction (or the negative of the direction) of
the E-field on the master boundary.

Planes of symmetry in
periodic structures where
E is oblique to the
boundary.

Note: No Balloon Boundary available
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Electric Sources

Source

Type of Excitation

Floating
Conductor

Used to model conductors at unknown potentials.

Voltage

The DC voltage on a surface or object.

Charge

The total charge on a surface or object (either a conductor or
dielectric).

Charge Density

The charge density in an object.

Note: DC conduction solution (voltage) can also be used as input for an electric
field solution
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Magnetostatic Boundaries
Boundary Type

H-Field Behavior

Used to model…
model…

Default
Boundary
Conditions
(Natural and
Neumann)

Field behaves as follows:
Natural boundaries — H is continuous across the
boundary.
Neumann boundaries — H is tangential to the boundary
and flux cannot cross it.

Ordinary field behavior. Initially,
object interfaces are natural
boundaries; outer boundaries and
excluded objects are Neumann
boundaries.

Magnetic Field
(H-Field)

The tangential components of H are set to pre-defined
values. Flux is perpendicular.

External magnetic fields.

Symmetry

Field behaves as follows:
Odd Symmetry (Flux Tangential) — H is tangential to the
boundary; its normal components are zero.
Even Symmetry (Flux Normal) — H is normal to the
boundary; its tangential components are zero.

Planes of geometric and
magnetic symmetry.

Insulating

Same as Neumann, except that current cannot cross the
boundary.

Thin, perfectly insulating sheets
between touching conductors.

Matching
(Master and
Slave)

The H-field on the slave boundary is forced to match the
magnitude and direction (or the negative of the direction) of
the H-field on the master boundary.

Planes of symmetry in periodic
structures where H is oblique to
the boundary.

Note: No Balloon Boundary available
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Magnetostatic Sources

Source

Type of Excitation

Voltage

The DC voltage on a surface or object.

Voltage Drop

The voltage drop across a sheet object.

Current

The total current in a conductor.

Current Density

The current density in a conductor.

Current Density Terminal

The terminal source current.

Notes:
Current and H-field are RMS (or DC) values
Current sources require one or more 2D sheet objects (terminal)
Permanent Magnets can also be a source
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Eddy-current boundaries
Boundary Type

H-Field Behavior

Used to model…
model…

Default
Boundary
Conditions
(Natural and
Neumann)

Field behaves as follows:
Natural boundaries — H is continuous across the boundary.
Neumann boundaries — H is tangential to the boundary and
flux cannot cross it.

Ordinary field behavior. Initially,
object interfaces are natural
boundaries; outer boundaries and
excluded objects are Neumann
boundaries.

Magnetic Field
(H-Field)

The tangential components of H are set to pre-defined values.
Flux is perpendicular.

External AC magnetic fields.

Symmetry

Field behaves as follows:
Odd Symmetry (Flux Tangential) — H is tangential to the
boundary; its normal components are zero.
Even Symmetry (Flux Normal) — H is normal to the boundary;
its tangential components are zero.

Planes of geometric and magnetic
symmetry.

Impedance

Includes the effect of induced currents beyond the boundary
surface.

Conductors with very small skin
depths.

Insulating

Same as Neumann, except that current cannot cross the
boundary.

Thin, perfectly insulating sheets
between touching conductors.

Radiation

No restrictions on the field behavior.

Unbounded eddy currents.

Matching
(Master and
Slave)

The H-field on the slave boundary is forced to match the
magnitude and direction (or the negative of the direction) of the
H-field on the master boundary.

Planes of symmetry in periodic
structures where H is oblique to the
boundary.

Note: Radiation (Balloon) Boundary available
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Eddy-current Sources

Source

Type of Excitation

Current

The total current in a conductor.

Current Density

The current density in a conductor.

Current Density Terminal

The current density terminals in a conductor.

Notes:
Current and H-field are Peak (Not RMS) values
Current sources requires a 2D sheet objects (terminal) which lie in the cross-section of the conductor
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Setup Boundaries/Sources
Select Object (for solid sources and current terminals)
Select Face (for insulating boundaries)
Select item Maxwell > Excitations > Assign for sources
Select item Maxwell > Boundaries > Assign for boundary conditions
Turn on eddy or displacement current calculation in eddy current solver for materials of interest: Maxwell >

Excitations > Set Eddy Effects …
Stranded coil option available in Magnetostatic and Eddy Current solvers
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View conduction paths by selecting: Maxwell > Excitations > Conduction Paths > Show Conduction Paths
Assign insulating boundaries on faces between touching conductors if necessary
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Magnetostatic and Electric Solution Setup
Start the menu of solution setup by: Maxwell > Analysis Setup > Add Solution Setup …
For Magnetostatic solver on Solver tab, suggest setting nonlinear residual = 0.001. On default tab choose Save
Defaults to set this value for all future projects.
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Magnetostatic Setup
For Magnetostatic solver on Solver tab, suggest setting nonlinear residual = 0.001.
On default tab choose Save Defaults to set this value for all future projects.
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Eddy Current Solution Setup
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Transient Solution Setup
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Transient Sources
Coil Terminal - used to define one or more model windings
Winding With Current - stranded and solid conductor
Winding With Voltage - stranded and solid conductor
Winding With External Circuit Connection - stranded and solid conductor
In addition, permanent magnets serve as sources of magnetic fields
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To define a winding for a Transient Source
1.

2.
3.

Define the terminal(s): Maxwell > Excitations > Assign > Coil Terminal
1. Select the planar surface(s) as appropriate for the model
2. Assign the coil terminal excitation by specifying the orientation of the current with respect
to the terminal (current in or current out, graphically represented by an arrow).
3. Specify the actual number of conductors (turns) intersecting the chosen planar surface
(coil terminal), regardless of the symmetry (if any) of the problem.
Add a new winding: Maxwell > Excitations > Add Winding
Specify the coil terminal(s) that belong to the winding: Right-click the winding in the property
window and select Add Terminals
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Transient Motion
Translational motion (motion along a user specified, linear direction).
Rotational motion (non-cylindrical such as the pivoting rotation around an axis encountered in the armature of a
relay).
Rotational motion (cylindrical, such as the type of rotation encountered in an electric machine type of application).

Ex: Pivoting Rotation
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Band
Regardless of the particular type of motion involved, all types of motion applications require a band object that must
contain the moving part(s).
If there are multiple moving objects, all of the moving parts must be included in one all-inclusive object — this is
because they all must be moving as one rigid body, with a single force acting on the assembly.
Regardless of the type of motion, the user must create a mesh density capable of capturing the physical effects
characteristic for the specific application, such as field gradients, skin and proximity effects, etc.

Translational and non-cylindrical rotation types of motion:
The band object can touch the symmetry plane if any exists.
The moving object cannot touch a stationary object during motion (the gap between the moving object and the band
can never become zero during analysis).
The band cannot have true surface faces; all faces must be segmented (for example created with the regular
polyhedron primitive).
The band object cannot separate the stationary part into unconnected sub-regions.
Hollow objects cannot be used for band objects.

For the cylindrical type of rotational motion applications:
Always use a facetted (regular polyhedron) type of cylindrical object or a wedge object if symmetry is used. The
angular aperture of each facet depends on the problem; however, an opening of 2-3 degrees per facet is usually
sufficient.
Hollow cylinders cannot be used for band objects.
The band object can separate the stationary part into unconnected sub-regions (a rotor sandwiched between two
stators is allowed).
Non-cylindrical band objects are allowed.
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Motion Setup
To assign a band: Maxwell > Model > Motion Setup > Assign Band
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Manual Mesh Refinement
To assign Mesh operations to Objects:
1. Select the Menu item: Maxwell > Mesh Operations > Assign
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Element length based refinement: Maxwell > Mesh Operations > Assign > On Selection > Length Based
Skin Depth based refinement: Maxwell > Mesh Operations > Assign > On Selection > Skin Depth B
Based
ased
Note: Adaptive Meshing will not refine these elements in this case
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Manual Mesh Refinement
To de-feature the mesh:
1. Specify the maximum dimension to be used in
the mesh under: Mesh Operations > Assign > On
Selection > Model Resolution
2. Improves mesh quality and reduces mesh size for
complex models
3. Increases the mesh speed
4. Reduces the load on the solver with reductions in
mesh size
For true surfaces, perform faceting control on a faceby-face basis select: Mesh operation > Assign >
Surface approximation and specify one or more
settings:

Maximum surface deviation (length) which is the
difference between the shortest and longest edge
of a triangle on the true surface. This
encourages equilateral triangles on the surface.

Maximum Surface Normal Deviation (degrees)
which allows you to limit the maximum angle
between normal vectors to adjacent tetrahedrons
which break up a true surface. This can force
more tetrahedron to break up a curved true
surface like a cylinder.

Maximum Aspect Ratio is the ratio between the
largest and shortest edges of triangles on a given
face. A ratio = 1 would attempt to create
equilateral triangles.
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Manual mesh creation
To create the initial mesh: Click Maxwell > Analysis Setup > Apply Mesh Operations
To refine the mesh without solving
1. Define mesh operations as previously discussed
2. Click Maxwell > Analysis Setup > Apply Mesh Operations

If a mesh has been previously generated, Maxwell refines it using the defined mesh operations.
If an initial mesh has not been generated, Maxwell generates it and applies the mesh operations to the initial mesh.
If the defined mesh operations have been previously applied to the selected face or object, the current mesh is not
altered.
Hint: When modifying an existing mesh operation, you should revert to initial mesh and then re-apply mesh
operations.
To view mesh information: Click Maxwell > Results > Solution Data and click on the tab Mesh Statistics
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Mesh Display
1.
2.

Select an object
Select the menu item Maxwell > Fields > Plot Mesh
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Post Processing
Two Methods of Post Processing Solutions:
Viewing Plots
Manipulating Field Quantities in Calculator

Six Types of Plots:
1. Contour plots (scalars): equipotential lines, ...
2. Shade plots (scalars): Bmag, Hmag, Jmag, …
3. Scatter plots (scalars): Bmag, Hmag, Jmag, Voltage
4. Arrow plots (vectors): B vector, H vector, …
5. Line plots (scalars): magnitude vs. distance along a predefined line
6. Animation Plots
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Contour plot
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Shade plot (tone)
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Shade plot (fringe with outline)
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Arrow plot
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Line plot
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Multiple windows and multiple plots
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Animation plot
Animate across different surfaces or with
different phase angles (eddy solver)
Export to .gif or .avi format
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Fields Calculator
To bring up the Fields Calculator tool
1.
Select the menu item MaxwellMaxwell->Fields>Fields->Calculator
Typical quantities to analyze:
1.
Flux through a surface
2.
Current Flow through a surface
3.
Tangential Component of E-field along a line
4.
Average Magnitude of B-field in a core
5.
Total Energy in an object
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Fields Calculator – Export Command
Exports the field quantity in the top register to a file, mapping it to a grid of points. Use this command to save field
quantities in a format that can be read by other modeling or post-processing software packages. Two options are
available:
1.
Grid points from file: Maps the field quantity to a customized grid of points. Before using this command, you
must create a file containing the points.
2.
Calculate grid points: Maps the field quantity to a three-dimensional Cartesian grid. You specify the
dimensions and spacing of the grid in the x, y, and z directions.
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Export to Grid
Vector data <Ex,Ey,Ez>
Min: [0 0 0]
Max: [2 2 2]
Spacing: [1 1 1]
Space delimited ASCII file saved in
project subdirectory
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Vector data "<Ex,Ey,Ez>"
Grid Output Min: [0 0 0] Max: [2 2 2] Grid Size: [1 1 1]
0 0 0 -71.7231 -8.07776 128.093
0 0 1 -71.3982 -1.40917 102.578
0 0 2 -65.76 -0.0539669 77.9481
0 1 0 -259.719 27.5038 117.572
0 1 1 -248.088 16.9825 93.4889
0 1 2 -236.457 6.46131 69.4059
0 2 0 -447.716 159.007 -8.6193
0 2 1 -436.085 -262.567 82.9676
0 2 2 -424.454 -236.811 58.8847
1 0 0 -8.91719 -241.276 120.392
1 0 1 -8.08368 -234.063 94.9798
1 0 2 -7.25016 -226.85 69.5673
1 1 0 -271.099 -160.493 129.203
1 1 1 -235.472 -189.125 109.571
1 1 2 -229.834 -187.77 84.9415
1 2 0 -459.095 -8.55376 2.12527
1 2 1 -447.464 -433.556 94.5987
1 2 2 -435.833 -407.8 70.5158
2 0 0 101.079 -433.897 -18.5698
2 0 1 -327.865 -426.684 95.8133
2 0 2 -290.824 -419.471 70.4008
2 1 0 -72.2234 -422.674 -9.77604
2 1 1 -495.898 -415.461 103.026
2 1 2 -458.857 -408.248 77.6138
2 2 0 -470.474 -176.115 12.8698
2 2 1 -613.582 -347.994 83.2228
2 2 2 -590.326 -339.279 63.86
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Getting Help
If you have any questions while you are using Ansoft Maxwell you can find answers in several ways:
Ansoft Maxwell Online Help provides assistance while you are working.
To get help about a specific, active dialog box, click the Help button in the dialog box or press the F1
key.
Select the menu item Help > Contents to access the online help system.
Tooltips
Tooltip are available to provide information about tools on the toolbars or dialog boxes. When you
hold the pointer over a tool for a brief time, a tooltip appears to display the name of the tool.
As you move the pointer over a tool or click a menu item, the Status Bar at the bottom of the Ansoft
Maxwell window provides a brief description of the function of the tool or menu item.
The Ansoft Maxwell Getting Started guide provides detailed information about using Maxwell to create
and solve 3D EM projects.
Ansoft Technical Support
To contact Ansoft technical support staff in your geographical area, please log on to the Ansoft
corporate website, www.ansoft.com and select Contact.
Contact
Your Ansoft sales engineer may also be contacted in order to obtain this information.

Visiting the Ansoft Web Site
If your computer is connected to the Internet, you can visit the Ansoft Web site to learn more about the Ansoft
company and products.
From the Ansoft Desktop
Select the menu item Help > Ansoft Corporate Website to access the Online Technical Support (OTS)
system.
From your Internet browser
Visit www.ansoft.com
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WebUpdate
This new feature allows you to update any existing Ansoft software from the WebUpdate window. This feature
automatically scans your system to find any Ansoft software, and then allows you to download any updates if they
are available.
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For Technical Support
The following link will direct you to the Ansoft Support Page. The Ansoft Support Pages provide additional
documentation, training, and application notes. Web Site: http://www.ansoft.com/support.cfm

Application Support for North America
The names and numbers in this list may change without notice
Technical Support:
9-4 EST:
Pittsburgh, PA
(412) 261-3200 x0 – Ask for Technical Support
Burlington, MA
(781) 229-8900 x0 – Ask for Technical Support
9-4 PST:
San Jose, CA
(408) 261-9095 x0 – Ask for Technical Support
Portland, OR
(503) 906-7944 or (503) 906-7947
El Segundo, CA
(310) 426-2287 – Ask for Technical Support
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